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COPYRIGHT NOTICE 
This manual is a publication of Maple Systems, Inc., and is provided for use by its customers only. The 
contents of the manual are copyrighted by Maple Systems, Inc.; reproduction in whole or in part, for use 
other than in support of Maple Systems equipment, is prohibited without the specific written permission of 
Maple Systems. 

The Watlow edition of this manual is based with permission on Maple Systems part number 1010-1015 Rev. 
10 

The copyright of EZwarePlus and its related software belongs to Weintek Labs, Inc. 

WARRANTY 
Warranty Statements are included with each unit at the time of purchase and is available at 
www.MapleSystems.com 

TECHNICAL SUPPORT 
This manual is designed to provide the necessary information for trouble-free installation and operation of 
your new HMI. However, if you need assistance, please contact Maple Systems: 

• Phone: (507) 494-5656 (7 a.m. and 5 p.m. Central Time. Ask for an applications engineer.) 
• Email: wintechsupport@watlow.com   
• Web:  http://www.watlow.com 

Regarding Watlow Part Numbers 
When you purchased your Operator Interface Terminal and accessories from Watlow, you ordered and 
received them under Watlow part numbers. The parts are also labeled with Maple Systems’ part numbers 
and are referred to by those part numbers throughout this manual and other support documents. The table 
below correlates the Watlow and Maple Systems part numbers. 

Watlow P/N Maple P/N Description 
Silver Series EM HMI5000 Family of Maple Systems operator interfaces offered by Watlow 

TS00-0043-EM00 HMI5043L 4.3 in. (480 x 272) color TFT LCD touch screen; two-tone, light gray 
bezel; USB host; two serial ports and Ethernet 

TS00-0043-EM0B HMI5043LB 4.3 in. (480 x 272) color TFT LCD touch screen; two-tone, dark gray 
bezel; USB host; two serial ports and Ethernet 

TS00-0070-EM00 HMI5070L 7 in. (800 x 480) color TFT LCD touch screen; two-tone, light gray bezel; 
USB host; two serial ports and Ethernet 

TS00-0070-EM0B HMI5070LB 7 in. (800 x 480) color TFT LCD touch screen; two-tone, dark gray 
bezel; USB host; two serial ports and Ethernet 

TS00-0100-EM00 HMI5100L 10 in. (800 x 480) color TFT LCD touch screen; two-tone, light gray 
bezel; USB host; two serial ports and Ethernet 

 

mailto:wintechsupport@watlow.com
http://www.watlow.com/
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Chapter 1 – Introduction 

Welcome 
Welcome to the Maple Systems HMI5000 Series Human Machine Interfaces (HMIs). Using graphic HMIs 
has never been easier. This powerful family of graphic HMIs connects to programmable logic controllers 
(PLCs) to provide the human-machine interface in industrial applications. The HMI5000 Series have several 
features not found in other graphic HMIs. This manual explains the programming and operation of the 
HMI5000 Series HMIs and how to implement the many available features using the EZwarePlus 
Configuration Software. 

EZwarePlus Support 

HMI Models Supported 
For the latest list of HMI5000 Series models supported by EZwarePlus, please visit our website at 
www.maplesystems.com. 

PLCs Supported 
For the latest list of PLCs and controllers supported by the HMI5000 Series touchscreens, please visit our 
website. 

About Your Documentation 
Watlow and Maple Systems provides many resources to allow you to get the most out of your HMI5000 
Series touchscreen. 

• This EZwarePlus Programming Manual (shipped with EZwarePlus as a PDF file) describes the general 
operation and features of the HMI5000P/L/RMI Series using EZwarePlus configuration software. 

• Using Watlow Products with the Silver Series EM manual addendum contains specific instructions and 
examples on communicating with and creating interfaces for Watlow controllers. 

• HMI5000P/L/RMI Installation Guides (shipped with the HMI) provide information on installing, powering, 
and connecting the HMI5000P/L Series to a PLC/Controller. 

•  Controller Information Sheets provide important information specific to each supported protocol (available 
on our website). 

•  EZwarePlus Online Help covers the operation of EZwarePlus. Help is always available by clicking Help 
Topics from the Help menu in EZwarePlus, or press F1 from any dialog. 

For more information, please visit the Support Center section on our website at 
http://www.maplesystems.com/support.htm. The Support Center provides links to manuals, FAQs, technical 
notes, training videos, sample projects, controller information sheets, and controller cables. 

Conventions 
When using EZwarePlus, there are usually several ways to perform a task. For example, if you want to copy 
a graphics object, you can: 

•  Click the Copy command on the Edit menu. 

•  Click the Copy button on the Standard toolbar. 

•  Press the CTRL + C keys on your computer. 

http://www.maplesystems.com/
http://www.maplesystems.com/
http://www.maplesystems.com/support.htm


Chapter 1 – Introduction   8 

 

EZwarePlus Programming Manual   8 

   

Icon Meaning 

 Identifies a procedure. 

 Indicates a reference to additional information. 

 Indicates an important note. 

 

In most cases, we will describe each method when the task is first discussed. The menu method is then 
used whenever the task is used in later procedures. Other conventions used in this manual are listed in the 
table on the following page. 

 

Convention Meaning 

Bold 
Characters that you must type exactly as they appear or identifying text in program 
fields and commands. For example, if you are directed to type a:\setup, you 
should type all the bold characters exactly as they are printed. 

Italic 
Placeholders for information you must provide. For example, if you are directed to 
type filename, you should type the actual name for a file instead of the word 
shown in italic type. Italics are also used to indicate a glossary term. 

ALL CAPITALS Directory names, file names, key names, and acronyms  

KEY1+KEY2 A plus sign (+) between key names means to press and hold down the first key 
while you press the second key. 

Click Refers to clicking the primary mouse button (usually the left mouse button) once. 

Double-click Refers to quickly clicking the primary mouse button (usually the left mouse button) 
twice. 

Right-click Refers to clicking the secondary mouse button (usually the right mouse button) 
once. Right-clicking usually opens shortcut menus. 

 

The following table identifies symbols and margin icons. 

 

 

 

 

 

What You Need 
The following items are needed to configure and operate your HMI. 

 

Configuration Software EZwarePlus 

Configuration Cable1 
7431-0104 (Ethernet Crossover cable for Ethernet-equipped models) 
7431-0115 (USB download cable for USB Client-equipped models)  
7431-0119 (USB download cable for HMI5070P later models) 

Personal Computer2 User Provided 

Power Cable 6030-0009  2-conductor 18 AWG, shielded, no connectors 

24VDC Power Supply User Provided (or available from Maple Systems) 

PLC User Provided 
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Controller Information 
Sheet 

Maple Systems provides Controller Information Sheets which contain important 
information specific to each PLC. Please locate the sheet that corresponds to 
your PLC in the Support Center section on our website. 

Communication Cable   
(HMI to PLC) Refer to our web site (www.maplesystems.com) for a list of available cables. 

 
1Allows you to connect the HMI directly to a PC Ethernet port or to a USB port to download/upload projects 
into the HMI. 
2Computer requirements include a Pentium 1.7 GHz or higher processor, 512 MB RAM, 200 MB available 
Hard Disk Space, SVGA or higher resolution monitor, Keyboard and Mouse, available Ethernet port, USB 
2.0 port for downloading project (depending on model), at least one RS232 port for online simulation, 
Windows XP, Vista, Windows 7, or Windows 8 operating system. 

HMI Basics 
Human Machine Interfaces (HMIs) provide much more versatility than traditional mechanical control panels. 
An HMI allows a plant floor operator to monitor current conditions of a control system and, if necessary, to 
initiate a change in the operation of the system. HMIs connect to programmable logic controllers (PLCs) 
typically through the PLC’s serial communications port. The HMI can be programmed to monitor and change 
current values stored in the data memory of the PLC. 

A graphics-based HMI can display text characters of varying fonts and sizes and graphics shapes such as 
icons, bitmaps, or pictures. Using pictures instead of words or characters often greatly simplifies the 
operation of the HMI, making it much more intuitive to use. For example switches can be created on a 
graphical touchscreen that appear only when needed. Now let us define some terms that are used 
throughout the EZwarePlus Programming Manual and Help files. 

Projects 
The HMI has two basic segments of internal memory. The code memory contains the information required 
by the HMI that controls how it operates such as the features supported and how it communicates to a PLC. 
The HMI programmer does not have the ability to change code memory. The project memory pertains to all 
the window screens created and any other features that the HMI programmer can create using the 
EZwarePlus configuration software. Therefore, the term project is used to designate the file that is sent to 
the HMI from the EZwarePlus software. 

 

Backing Up Projects 

We recommend that you frequently back up your projects to another folder or an  
external or network drive. In addition, when you have completed a project, archive  
it by running the compression utility (Tools > Compress/Uncompress), which bundles  
the project file with the libraries that are associated with the project. This allows the  
project to be opened on another computer and retain all the shapes and pictures that  
are linked to the project. Refer to the Help menu for more information  
(Help > Help Topics > Contents > How Do I…Backup a Project?). 

 

The HMI also has internal memory that can be used by the programmer for temporary or permanent storage 
of data. 

http://www.maplesystems.com/


Chapter 1 – Introduction   10 

 

EZwarePlus Programming Manual   10 

   

Register Memory Description 

LW (0-8999) Local Words: Non-retentive memory available for program 
(Resets to zero when power is cycled on the HMI) 

LW (9000 and 
above) Reserved Local Words (System tags): Used for various system functions 

RW (0-524287) Recipe Words: Retentive memory available for storing recipe data 
(Stored in flash memory) 

RW_A (0-65535) Recipe Word Annex: Reserves an additional 64K of memory for recipes 
(Stored in flash memory) 

RWI (0-65535) Recipe Word Index: Uses the offset supplied by LW9000 

PLW (0-5) Private Local Words (RMI5010 only): Used by the cMT Viewer for local storage of data 

RECIPE Access recipe items configured on the Recipe tab of the System Parameters window 
(Stored in flash memory) 

EM (0-9) Extended Memory: Access additional memory on a connected USB flash drive or SD 
card 

Discrete Memory Description 

LB (0-8999) Local Bits: Non-retentive memory available for program 
(Resets to zero when power is cycled on the HMI) 

LB (9000 and 
above) Reserved Local Bits (System tags): Used for various system functions 

LW_Bit Access individual bits within Local Words (LW) 

RW_Bit Access individual bits within Recipe Words (RW) 
(Stored in flash memory) 

RBI Recipe Bit Index: Uses the offset supplied by LW9000 

PLB Private Local Bits (RMI5010 only): Used by the cMT Viewer for local storage of data 

PLW_Bit Access individual bits within Private Local Words (PW) (RMI5010 only) 

 

Objects 
An object is any ‘thing’ that performs an action while the HMI is communicating to the PLC. In order to get 
the HMI to ‘do anything’, you must program the HMI with objects. Objects perform actions such as display 
text or graphics, write a value to a PLC register, or display an alarm. Objects most often are graphics shapes 
that are to be displayed on the HMI screen. For example, a Text Object is used to display text on the HMI. 
But objects are also used to configure the HMI to perform some action. For example, a PLC Control Object 
tells the HMI to continuously monitor a PLC register that is used by the PLC to request a new window. Some 
objects can display a graphics shape on the HMI screen and perform some action. For example, a Toggle 
Switch Object creates a graphic object on the HMI that, when pressed, activates a bit in the PLC. 
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Graphics Object 
A Graphics Object is any text, icon, or picture that can be displayed on the HMI. Graphics objects are further 
defined by how they are composed or created. A Text Object is a graphics object that displays text on the 
HMI screen. A Bitmap Object is a graphics object that displays a bitmap on the HMI screen. Bitmaps are 
files stored in the HMI to display pictures. A Shape Object is a graphics object that displays a shape on the 
HMI screen. Shapes are also files stored in the HMI to display pictures. Shapes differ from bitmaps in that 
shapes are stored using a vector-based file format whereas bitmaps use a pixel-based file format. Each 
format has its advantages and disadvantages. For example, vector-based graphics can be resized without 
losing resolution, whereas bitmap graphics lose resolution as they are magnified. Finally, a Group Object is 
the most complex type of graphics object. It is a combination of other objects. Briefly, a group object consists 
of one or more objects that are ‘grouped’ together and stored as one object. A good example is a keypad, 
which is really a combination of several keys each designed to perform a specific task. When grouped 
together, a keypad can be stored as a group object for use in other projects or windows. 

Windows 
A window is a screen that can be displayed on the HMI. Windows can be full-sized to completely cover the 
HMI display or partially sized. Any partially sized window is usually referred to as a popup window. Windows 
can appear on the HMI display by a request from the PLC or by a press from the touchscreen. Windows can 
be configured to any size. Once a window is displayed, it can be moved around the HMI display or removed 
from the display. Windows can even overlap each other. Each window can display graphics objects and 
there is no limit to the number of graphics objects that can be placed on each window. The HMI5000P/L 
Series is capable of storing up to 1999 windows, but the actual limit is determined by the total amount of 
memory used for the application. 

What is an HMI5000 Series? 
The HMI5000 Series by Maple Systems are graphic operator interfaces designed to connect to PLCs in an 
industrial environment. The displays are covered with analog resistive touchscreens designed for harsh 
industrial environments. The touchscreens use the latest in touchscreen technology enabling the HMI 
programmer to create switches that are very fine in resolution. Unlike many other touchscreen HMIs on the 
market, the HMI5000 Series are not limited to a fixed number of cells in which switches can be created. The 
project can contain as many objects of varying sizes and shapes as desired, limited only by the total amount 
of memory available for the project. 

LED indicators are provided on the face of the HMIs to provide instant feedback to the HMI operator of the 
current operating condition of the HMI. 

Models: HMI5121XL, HMI5150XL, HMI5070P(v2) 

LED Indicator Purpose 

PWR LED (amber)  Indicates if power is applied to the HMI 

CPU LED (green)  Blinks when reading/writing to flash memory 

COM LED (blue)  Indicates communications activity on serial port only 
(Does not indicate network activity) 

 

All other models: (some models have PWR LED only; some models have no LEDs) 

LED Indicator Purpose 

PWR LED (amber)  Indicates if power is applied to the HMI 

CPU LED (green)  Indicates if the HMI is operating correctly 
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COM LED (blue or red)  Indicates communications activity on serial or Ethernet port  
 

The HMI5000 Series have two serial ports, which provide a connection to a PLC using RS-232, RS-485; 
CANbus communications, and an Ethernet connection for PLC communication and project upload and 
download. Some models also have a USB port for project upload and download. 

The RMI5001 and RMI5010 have three serial ports (on a single DE9P connector), which provide a 
connection to a PLC using RS-232 and RS-485 communications, and an Ethernet connection for PLC 
communication and project upload and download. 

• The RMI5001 is a DIN-rail mounted unit designed to display information on an HDMI-compatible 
monitor. 

• The RMI5010 is a DIN-rail mounted unit designed to display information wirelessly (optional wireless 
access point required) on an iPad or Android device, or by a hardwired RMI5090 touch panel. The 
RMI5010 also has a second, separate Ethernet port. 

 

  The L-Series and RMI-Series do not support CANbus. 

   Some EZware objects have different configuration options when used with the RMI5010.  This is to take 
advantage of the ‘pinch and zoom’ functionality of tablet devices. 

 

The HMI5000 Series are powered using +24VDC. A reset switch is provided on the back of some models to 
reinitialize the HMI if an operational failure occurs. The HMI5000 Series is designed for industrial 
environments and carries a NEMA4/IP65 rating as well as CE compliance for noise immunity and emissions. 
The RMI5000 series carry the CE rating for noise and immunity, but are designed to be installed inside an 
enclosure. 

List of Features 
The next chapter will guide you through the creation of your first project. Before you proceed, you may wish 
to read this brief list of some of the features offered in the EZwarePlus programming software.  Please refer 
to the EZwarePlus Help section for details of the objects listed. 

 Bit Lamp Creates a graphic object to reflect the current status of a PLC bit. 

 Word Lamp Creates a graphics object to reflect the current state of a multi-state PLC 
data register. 

 
Set Bit Creates a touchscreen graphics object that represents a two-state switch. 

When pressed it sets/resets a PLC bit. 

 Set Word Creates a touchscreen graphic object that represents a multi-state switch. 
When pressed it can place a constant value in a PLC register or jog the value. 

 
Toggle Switch 

Creates a touchscreen graphic object that represents a two-state switch 
changing state (picture) based upon a PLC bit. When pressed, it can control 
that bit or a different PLC bit. 

 
Multi-State 
Switch Creates a multi-state touchscreen graphic object that changes state (picture) 

according to the value in a PLC data register. When pressed, it sends a 
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value(s) to the same or a different PLC register. 

 
Option List 

Displays a list of text items with the selected item being determined by the 
value in a register. Optionally, selecting an item can write the 
corresponding value to a register. 

 
Slider Object Creates a touchscreen graphic object that changes a register value 

according to the position of a slider switch. 

 Function Key 
Creates a touchscreen graphic object that changes windows, inputs data 
as part of a keypad, executes a macro, or prints the screen to a USB flash 
drive or printer. 

 Combo Button Creates a touchscreen graphic object that allows multiple actions to be 
triggered with a single touch. 

 Numeric 
Displays a number stored in a PLC register. The number can be changed 
using a numeric keypad.  The Read and Write addresses can be the 
same or different. 

 
ASCII 

Displays ASCII characters stored in a PLC register. Characters can be 
changed using an alphanumeric keypad. The Read and Write addresses 
can be the same or different. 

 QR Code Displays ASCII characters stored in a PLC register as a QR code. 

 
Indirect 
Window Displays any Window based on the value in a PLC word address. 

 Direct Window Displays a specified Window based on a bit in a PLC register. 

 Moving Shape 
Creates a multi-state graphic object, which changes state (picture) based 
on a PLC register value, and position based on X- and Y-coordinates from 
PLC registers. 

 Animation 
Creates a multi-state graphic object, which changes state (picture) based 
on a PLC register value, and pre-defined position based on a PLC register 
value. 

 Flow Block Creates animation along a fixed path.  The speed of the animation can be 
set from a PLC register. 

 Date/Time Displays the Date and Time as text, in one of several formats. 

 Media Player Displays a video file from a connected USB flash drive or SD card. 

 
Video In 

Input and play video on the HMI from an external source.  The 
HMI5121P/5150P support NTSC composite video.  These units and the 
HMI5070P, 5121XL/5150XL/5097XL/5097NXL/5097DXL, and RMI5001 
also support USB Web Cam video. 
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 Bar Graph Creates a bar graph with alarm monitoring. 

 Meter Display Creates an analog-face meter with built-in legend and scaling. 

 Pie Chart Displays the data stored in a series of register as a pie chart. 

 
Data Block 

Display Displays the data stored in a series of registers as a line graph. 

 XY Plot Creates an XY Plot of data stored in a series of registers. On the RMI5090 
and tablet devices, ‘pinch and zoom’ is supported. 

 
Recipe View Displays recipe data in a tabular format. 

 
Picture View Displays images stored on the HMI or an attached SD or USB storage 

device. 

 
Data Sampling Stores data for trending and archiving. 

 Trend Display 
Creates a trend graph. Monitors data in single or multiple PLC registers  
and plots the data on a time graph. On the RMI5090 and tablet devices, 
‘pinch and zoom’ is supported. 

 
Circular Trend 

Display 

Creates a circular trend graph. Monitors data in single or multiple PLC 
registers and plots the data on a circular graph where the circumference 
represents time and the radius represents the range of data. 

 
History Data 

Display Displays historical data in a tabular format. 

 
Event (Alarm) 

Log Contains the data for detecting alarm conditions. 

 Alarm Bar Displays alarms detected by the Alarm (Event) Log Object on a single 
horizontal scrolling line. 

 Alarm Display Display alarms detected by the Alarm (Event) Log Object in a table format. 

 
Event Display Displays messages detected in the Alarm (Event) Log and can 

acknowledge the message(s). 

 
Data Transfer 

(Trigger-based) 
Transfers data to the specified PLC registers based on a touch or PLC bit 
status. 

 Backup Copies recipe, event, or historical data to one of the USB flash drives or to 
a PC connected via Ethernet. 

 
Timer Controls an internal bit or PLC bit based on a timer; supports five different 

configurations. 
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 PLC Control 
Configures the HMI to monitor PLC data registers to display full window 
screens, execute a data transfer, control the backlight, play a sound, 
execute a macro, or print a screen. 

 
Data Transfer 
(Time-based) Transfers data to the specified PLC registers on a timed basis. 

 
System 

Message Customizes the content of system-generated messages. 

 
Scheduler Performs an action based upon a time schedule. 

 Operation Log Records entries and keystrokes. 

 File Browser Lists the files in a selected folder. Some objects can use the File Browser 
to select a file. 

 
Recipe 

Import/Export 
Allows recipe data from a Recipe Database table to be imported/exported 
using Comma-separated Variable (CSV) files. 

 Drawing Tools Includes Line, Arbitrary Line, Link Line, Arc, Ellipse/Circle, Pie, Rectangle, 
Polygon, Scale, Text, Picture, and Shape. 
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Chapter 2 – HMI Local Setup 

Factory Configuration 
Each HMI arrives from the factory with a demo project file that illustrates some of the most popular features 
of the HMI. For a first time user, it is worthwhile to navigate through the screens in the demo project and 
become familiar with the features and capabilities of the HMI and EZwarePlus. Refer to the EZwarePlus 
Help file for more information about the features and operation of the HMI and EZwarePlus.  

Some HMIs also have a black reset push button and a four-position DIP switch located through an access 
hole on the back of the enclosure. The reset switch can be used to reinitialize the HMI if the HMI 
malfunctions. DIP switch 1 puts the HMI into Touch Calibration mode. For normal operation, all of the DIP 
switches should be set to the OFF position. 

This chapter describes how to use the HMI5000 Series’ local setup options. The local setup allows 
touchscreen calibration, transferring projects to and from the HMI, configuring the HMI’s IP settings, 
passwords, time and date, screen brightness, as well as managing the storage of recipe and history files. 
Additionally, memory and other system information can be viewed. 

  Local Setup on the RMI5010 is done online from a web browser. See the RMI5010/RMI5090 Quick 
Start Guide. 

Calibrating the Touchscreen 
The touchscreen of the HMI is fully calibrated before it leaves the factory so there is no need to adjust it. 
However, over time the touchscreen may need to be recalibrated. 

To calibrate the touchscreen: 
1. Turn DIP switch 1 ON. For units without DIP switches, open the System Toolbar and touch the 

Calibration icon (see “Getting into Local Setup” below). 
2. Cycle power to the HMI (or press the reset button next to the DIP switches). 
3. After the HMI displays a crosshair cursor, you are prompted to touch the cursor in each of the four 

corners and in the center position. Touch each corner for approximately one second. 

System reset: 
Units with DIP switches will present the option to restore the system settings password to the default setting 
(111111). If you choose Yes, a dialog box will inform you that the project will be erased in the HMI. You 
must type Yes and click OK to complete the operation. When you next download a project, check the 
Firmware and Font files checkboxes in the Download dialog.  

If you choose No or allow the option to timeout, the HMI will resume initializing and run the project. 

   On most models, touchscreen calibration can also be started by pressing on the screen as the unit 
boots up. 
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Getting into Local Setup 
Access the local setup menu by touching the arrow in the lower right-hand corner of the HMI screen. The 
following Toolbar will pop up (the actual appearance may vary depending on the model): 

 

 

 

 

   The Touchscreen Calibration icon is present only on units without DIP switches.  

 

Changing the System Settings 
To change the system settings on the HMI: 

1. Open the System Settings Toolbar as described above, and click the System Settings icon. 

  The System Setting Toolbar can be hidden to make it inaccessible to the operator. 
 
• When DIP switch 2 is set ON, the System Settings Toolbar is disabled. Cycle power for the setting to 
take effect. 
• For the RMI Series, set DIP switch 1 ON to disable the System Settings Toolbar. 
• The System Settings Toolbar can be disabled in the project that is downloaded to the HMI by selecting 
the “Hide system setting bar” option in the System Parameters > System Setting tab. 
• The System Settings Toolbar can be disabled with a system bit in the HMI. When LB-9020 is ON, the 
toolbar is enabled and when LB-9020 is OFF, the toolbar is disabled. 

2. A dialog will be displayed requesting the Local password. The default password is 111111. 

  You may have to move windows around a bit to gain access to the virtual keyboard. You may also 
have to click inside the password field again. 

3. Once the correct password has been entered, the System Settings dialog is displayed. For all tabs, 
the Previous, Next, Cancel, Apply, and OK buttons are available. 

Previous Move to the Previous tab 

Next Move to the Next tab 

Cancel Close the System Settings dialog without saving any changes. 

Apply Save the current settings without closing the System Settings dialog. 
OK Save the current settings and close the System Settings dialog. 

 

4. Click on the Network tab to configure network settings. The Network dialog is displayed. 

 

 

System info 
 

Small keyboard 
 

Large keyboard 
 

System settings 
 

Touchscreen calibration 
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Single Ethernet Port Models      Dual Ethernet Port Models 

    

5. The Network tab allows configuration of the IP settings. The default setting is Obtain an IP Address 
Automatically. Use this setting if the HMI will obtain an IP address from a DHCP server. If 
connected to a DHCP server, this dialog will display the IP settings obtained by the HMI. The IP 
fields are disabled and are not editable. 

6. If using a static IP address, use the IP Address get from below option. The IP fields are enabled. 
Enter the appropriate settings for your network. 

7. Click the Next button or the Time/Date tab to configure time/date settings. The time/date dialog is 
displayed. 

 

8. Configure appropriate time and date settings. 
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9. Click the Next button or the Security tab to display the security settings dialog. Here, you can select 
your system passwords.  

 

10. Configure your password settings. 

 

11. The new password must be entered, and then entered again to confirm. As the password is entered 
into the confirm field, an indicator will show if the two passwords match. 
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12. Click the Next button or the History tab to display the History dialog. This is where data stored in 
the HMI can be cleared.  

 

 

 

 

 

 

 

 

 

 

 This will not clear data stored on an SD card or USB flash drive. 

13. Click the Next button or the HMI name tab to give the HMI a unique name. This name can be used 
to address the HMI for downloading over Ethernet. 

 

14. Click the Next button or the OS setting tab to access the Upgrade OS option and the Portrait 
Mode settings (for models with the Portrait feature). 
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Upgrade OS: Click this button to upgrade the Operating System in the HMI from a USB flash drive 
or SD card. Contact Maple Systems Technical Support for instructions on how to perform this 
procedure. 

 
Portrait Mode: Select the orientation of how the project is displayed on the HMI. Landscape mode 
or Portrait mode can be selected when a project is created in EZwarePlus. If Landscape mode is 
selected, choose 0 degrees or 180 degrees. If Portrait mode is selected, choose 90 degrees or 270 
degrees. 
 
  Once a project is created, the Portrait/Landscape Display mode selected cannot be changed. 

15. Click the Next button or the VNC server setting tab to enable remote access using VNC (Virtual 
Network Computing). VNC makes it possible to view and interact with an HMI from another 
computer or mobile device with network access to the HMI (via LAN or Internet). 

In order to access an HMI over a VNC connection, you must install a VNC client application on a PC or 
mobile device (e.g., smartphone or tablet).  

  Maple Systems does not provide a VNC viewer application. There are many VNC applications available 
on the internet. 

WARNING: The VNC remote connection allows full-access control of the HMI over a network. Any capability 
accessible through the touchscreen interface is accessible remotely. If the HMI is connected to a controller, 
it is possible for an operator to activate machinery through the VNC connection. If activating the VNC 
connection, have safety measures in place to prevent accidents. 

  System bit LB-12088 can be used to enable VNC monitor mode (when ON). This disables remote control 
of the HMI and allows only monitoring data. 
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Click Start VNC single-connection to enable the VNC server and allow only one connection at a time. 

Click Start VNC multi-connection to enable the VNC server and allow multiple simultaneous connections.  
While there is no limit to the number of connections, more connections will degrade HMI performance. 

Click Stop VNC… to disable VNC and disconnect any currently-connected users.  

  When VNC is started, the Start buttons are disabled. 
  When VNC is stopped, the Stop button is disabled. 

Click the VNC login password to enter the password used to login to the HMI with a remote VNC viewer. 
The default password is 111111. 

Click Apply and then click OK to save the settings and exit the System Settings window. 

  The VNC server option in the System Parameters > System Settings tab will override the VNC login 
password in the HMI when Password from project is checked. 

  When connecting to an HMI remotely through a router, use port forwarding to direct the VNC connection 
to the HMI.  
Use TCP port 5900 for a stand-alone VNC viewer.  
Use TCP port 5800 (or port 80) for web-browser or Java VNC viewers. 

  When using a web browser or Java VNC viewers, the security settings in Java will affect the VNC 
connection. If the VNC connection cannot be made: 

1. Open Windows Control Panel and select Java to open the Java Control Panel.  
2. Click the Security tab and click Edit Site List. Enter the IP address of the HMI in the Exception 

Site List (for example, http://192.168.1.211). 

 

http://192.168.1.211/
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System tags for VNC control: 

LB-12088: enable VNC monitor mode (when ON); enables monitor mode only 
LB-12089: VNC password free (when ON); disables password requirement for VNC client to log in 
LB-12090: indicates when a VNC client has connected to the HMI 
LB-12091: disable auto-logout function when a VNC client has connected to the HMI (when ON) 
LB-12092: enable VNC server (ON), disable VNC server (OFF) 
LB-12093: VNC connection mode (single connection OFF, multi-connection ON) 
LW-9530 (8 words): VNC server password 

16. Click the Next button or the Misc 1 tab to display the Backlight dialog. The Brightness control 
adjusts the brightness of the HMI’s backlight. Use the mouse or touchscreen to roll the wheel. 
Rolling to the left decreases the brightness, rolling to the right increases the brightness. 

  System tags “Backlight Up (LB9040),” “Backlight Down (LB9041),” and “Backlight Index 
(LW9040)” can be used to adjust the brightness at runtime (range 0-31). 
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The Popup download window option allows you to turn on or off whether the Download dialog 
window appears on the screen when a USB flash drive is connected to the USB port on the HMI. 
The Restart after download/upload option causes the HMI to reboot after a download or upload 
from a USB flash drive or SD card, when selected. 

17. Click the Next button or the Misc 2 tab to display the Hide mouse cursor option. This hides the 
mouse cursor on the HMI screen when the HMI first starts up. 

• The mouse cursor can be disabled in the project that is downloaded to the HMI by selecting the 
“Hide mouse cursor” option in the System Parameters > System Setting tab. 
• The mouse cursor can be disabled with a system bit in the HMI. When LB-9018 is ON, the mouse 
cursor is disabled and when LB-9018 is OFF, the mouse cursor is enabled. 
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• The Modify HMI ports option allows you to customize the TCP port used for uploading and 
downloading to the HMI (default TCP port 20248) and to customize the FTP port used for accessing 
the HMI as an FTP server (default FTP port 21). 

 

 

 

 

 

 

 

18. Click the Next button or the EasyAccess 2.0 tab to display the EasyAccess 2.0 setup options. 

 
  As of this writing, EasyAccess 2.0 is not supported.  

Viewing System Information 
 To view system information: 

1. Open the System Setup Toolbar as described above, and click the System Information icon . 
A dialog will be displayed with two tabs. 

2. Click on the Network tab to display the current IP settings. 

 

3. Click on the Version tab to display the current firmware information. 
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Changing or Restoring the HMI Settings by USB or SD 
There may be times when it is necessary to change or update the settings in an HMI, when the IP address 
or password of the HMI is unknown. EZwarePlus provides a tool to create a system settings file, and transfer 
that file to the HMI. 

Note: The HMI must have OS version 20131106 or later. 

The following settings can be changed with the System Setting Editor: 

  The HMI password is not required when the file is loaded into the HMI, but 
the proper HMI password must be supplied in the editor’s Current local password field. 

 

Password 

 

Local, Upload, Download, Upload History 

General HMI Name, Backlight Brightness, Time Offset (Time Zone Adjustment), 
Portrait Mode (0, 90, 180, 270 degree rotation) 

Network Use DHCP, IP Address, Subnet Mask, Gateway, DNS 

Clear History Recipe, Data Log, Event Log, Operation Log 

VNC Server Enable, Stop VNC, Stop VNC, Start VNC Single Connection, Start VNC Multiple 
Connection 

Download Popup Download Window, Restart After Download/Upload  
(recommend leaving these checked) 

 

To open the System Settings Editor, use the Tools menu in EZwarePlus: 
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Once all the settings are made, click the Export button to save the data to a file.  Then, from the 
EZwarePlus Tools menu, select Build Data for USB Disk or SD Card Download. 

 

1. Select the drive corresponding to the SD or USB device.  Note that the Save folder must be the root 
level of the SD or USB device (in this case, the root level of the F: drive). 

2. Check the Use system setting box, and select the file exported above. 

3. Click the Build button to create the required data structure on the SD or USB device. 
 
  In this example, the Use user-defined startup screen option is checked, but that is not   
required for configuring the System Settings. 
 
EZwarePlus will also create folders with the data for the project currently open in EZwarePlus. 
Therefore, it is recommended that a very simple project be created in EZware prior to building the 
USB/SD data. 

4. Insert the SD or USB device into the HMI. The following dialog will appear after a few seconds. 

 

 
5. Click the Load System Setting button. The HMI will transfer the system settings from the SD/USB 

device. 

  The HMI will also load the project from the SD/USB device, overwriting the project currently present on 
the HMI. This is done to protect any intellectual property in the project currently residing on the HMI.

 If Local Bit LB-9063 is set in the HMI 
project, this dialog will not appear. 
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Chapter 3 – Connect the HMI to the PLC or Controller 
 
The Graphic HMI can be configured to connect to many PLCs from many different manufacturers. Because 
each PLC is unique, the information needed to establish a particular connection is not included in this 
manual. All of the information needed to connect to any specific PLC is contained in a Controller Information 
Sheet (CIS) available for download from the Support Center at www.maplesystems.com. The first step in 
establishing a PLC connection is to review the information in the CIS. 

The HMI5000 Series of HMIs can connect to one, two, or more PLC/controllers. This is accomplished via 
one or two 9-pin D-sub serial communications connectors (Port A and Port B) and one Ethernet port. Each 
PLC/Controller has its own wiring requirements. Maple Systems offers HMI-to-PLC/Controller 
communication cables for most PLC/Controllers that are tested for high reliability. The HMI5000 Series has 
three software controlled communications ports (COM1, COM2, and COM3 or CANbus depending on the 
model) located on one or two physical connectors, designated as Port A and Port B.  

  Some models do not support CANbus. 

Each software controlled communications port can only be selected for one communication type. Once a 
communication type is selected for one of these software controlled ports, that port cannot be used for 
another communication type. Each of these communication ports has between one and three 
communication types. COM1 can be RS232, RS485 4-Wire, or RS485 2-Wire. COM3 is either RS232 or 
RS485 2-Wire. The CANbus port is strictly for CANbus connections using the CANopen protocol. The RMI-
series also support RS485 2-Wire and 4-Wire on COM2. 

COM1 cables are readily available for purchase from Maple Systems. COM3 and CANbus cables are 
custom-made according to wiring diagrams that can be found on Maple Systems' web site. Connecting 
multiple PLCs and controllers may require a splitter. 

 The RMI5090 does not connect directly to a PLC. Please refer to the RMI5090 Installation Guide for more 
information. 

 Refer to the “Installation Guide” for the specific model that you are working with for pinout information on 
the serial COM ports. 

Connecting to multiple ports on the same connector 
Maple Systems HMI5000P/L/RMI family of HMIs is capable of connecting to multiple PLC/controllers. If you 
choose to take advantage of this feature, a splitter will be needed to break out the pins for each port. Refer 
to the pin definitions above. 

Connecting multiple PLC/controllers serially using daisy chaining 
The RS485 4-wire and RS485 2-wire communications ports of the HMI5000P/L/RMI family support multi-
drop connections. A daisy-chain connection is made from the HMI to the first PLC/controller, and then from 
the first PLC/controller to the second and so on (see following page). The network may need biasing 
resistors – refer to the PLC/controller documentation for more information. 

 

 

 

 

 

http://www.maplesystems.com/
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Connecting one or more PLC/controllers via Ethernet 
The HMI5000 Series have a single RJ45 Ethernet connector configured for 10BaseT and 100BaseT 
operation. This port is used for communicating with a PC for configuration purposes as well as 
communicating with supported Ethernet PLCs and protocols. 

The connector is wired just like the RJ45 Ethernet connector on a PC. The Ethernet connection to a 
PLC/controller will vary with each PLC/controller. Some will require a straight-through connection, while 
others require a crossover connection. See Maple Systems' website for cable drawings of Ethernet cables. 

To connect a single PLC/controller to an HMI: 
1. Attach one end of the Ethernet cable to the RJ45 connector on the HMI. 
2. Attach the other end to the RJ45 connector on the PLC/controller. 

A router or switch is required to connect multiple PLCs/controllers to a single HMI. In general, standard 
straight-through type cables can be used when connecting to a PLC/controller through a router or switch. 
Some routers and switches may be auto-sensing. In this case, either type of cable may be used. 

Troubleshooting 
The HMI must be connected to a PLC/controller in order for the project to run correctly in the HMI. If there is 
a problem with communications between the HMI and PLC/controller, the “PLC no response” message 
(window 5) will appear on the screen and objects addressing PLC registers will not appear on the screen.  

Communication issues can be caused by several things, but the most common are: 

• Hardware – the physical wiring could be incorrectly connected or physically damaged, or the 
network hardware could be improperly set up.  

• Addressing – there could be misprints or accidents in the addressing of data registers from either 
the HMI or PLC resulting in misplaced information.  

• Traffic - the length of the data connections as well as the volume of data traffic on the connection 
can lead to issues analogous to a traffic jam. Removing all but one variable with a confirmed 
address eliminates addressing and traffic errors and allows the user to confirm the hardware is 
functional.  

Here are some things to check: 

1. Make sure you have selected the correct communication protocol (driver) for the PLC you are using 
in the System Parameters (Edit > System Parameters > Device Properties). 

 The demo version of EZwarePlus will not download the driver to the HMI and will automatically 
generate a “PLC no response” error message. Make sure you are running EZwarePlus from the 
EZPlus folder and not the EZPlusDemo folder. 

2. Make sure the communication settings in the HMI (Edit > System Parameters > Device Properties) 
match the communication settings in the PLC (for example, Baud rate, Parity, Data bits, Stop bits, IP 
address, etc.). 

3. Make sure the Runtime file has been downloaded at least once with the project file (Tools > 
Download) to ensure that the project is compatible with the HMI’s operating system. 

4. Make sure the communication cable is wired correctly for your application. Double-check the cable 
wiring and test for continuity, as well as for any shorts between adjacent pins. Refer to the Controller 
Cable Assembly drawings on our website for specific cabling information for your PLC/controller. 
(http://www.maplesystems.com/cables1023.htm). 

5. Check the address formatting for objects that are reading from or writing to registers in the PLC. If 
the objects cannot access specific registers in the PLC, they will not appear on the screen and the 

http://www.maplesystems.com/cables1023.htm
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“PLC no response” message will appear on the screen. Refer to the Controller Information Sheet for 
your particular PLC/controller for specific information about accessible registers in the PLC memory 
and the correct addressing format for the various registers. 
(http://www.maplesystems.com/products/prodbycon-bot.htm) 

  To resolve communication issues, it is often helpful to create a new project with only one 
Numeric object on the screen assigned to a known register address in the PLC. This will reduce the 
number of variables that may be causing the communication error.  

 

 

 

  

http://www.maplesystems.com/products/prodbycon-bot.htm
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Chapter 4 – Creating a Sample Project 
 

Often the best way to learn about new software is to jump right in and begin using it. This chapter will step 
you through the process of creating a sample project that can be downloaded to your HMI. In this sample 
project, we will create a bar graph with a tank shape that will represent the level of the fluid in the tank, and 
create a pump with a pipeline connected to the tank to indicate when the pump is operating to increase or 
decrease the level in the tank. 

Starting EZwarePlus 
Before you can create a sample project, you must start the configuration software. The EZwarePlus software 
has two main applications: 

• EZwarePlus – used to create the project downloaded to the HMI. 
• Utility Manager – used to launch various applications and utilities including EZwarePlus. 

To start Utility Manager and EZwarePlus: 
1. From the Windows Task Bar, click the Start button, select All Programs > Maple Systems > 

EZwarePlus > Utility Manager. 
2. On the Utility Manager dialog box, click EZwarePlus. 
3. The EZwarePlus dialog box appears. Click New and then OK.  
4. Select the HMI model that you intend to use with your project. We will use the HMI5070L for this 

example. Select Landscape display mode (you can select Portrait as an option), and select the Use 
template checkbox to open the project with the default template for your selected model. 

 
  Once a project is created, the Portrait/Landscape Display mode selected cannot be changed. 
Make sure the corresponding orientation is selected in the HMI’s System Settings > OS setting tab 
(choose 0 or 180 degrees for Landscape mode; choose 90 or 270 degrees for Portrait mode). 
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5. Click OK. The System Parameter Settings window opens next. For now, we will not add any more 
devices to the Device List and we will use the default settings in the System Parameters. Click OK 
to accept the settings.  

 

  Refer to the Help menu “How Do I… Set Up a PLC or Controller in EZwarePlus?” to configure 
the devices in the Device List. You may also jump ahead to “Chapter 6 – Using EZwarePlus” 
(System Parameter Settings). 
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Creating a Bargraph 
Window 10 is the default initial screen that EZwarePlus uses when a project is opened. Let’s create Window 
11 to place the bar graph, and use a Function Key to change windows from window 10 to window 11. 

To create Window 11: 
There are two ways to create a window: 

• Method 1, using the Window Tree Bar: 

 

The Window Tree Bar is a window-management tool normally located on the left side of the main 
EZwarePlus window. 

  If the Tree Bar is not visible, click the View menu and select Window Tree. (See on next page) 

 

Right-click on 11, and select New. 

 

 

 

 

 

 

 

 

The Window Tree Bar has two modes, Window Preview and Object 
List.  If the mode is set to Window Preview, click the drop-down and 
change it to Object List. 
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• Method 2, using the Open Window dialog: 

1. From the Window menu, click Open Window. The Open Window dialog box appears. 

 

 

2. Click New… The Select Window Style dialog box appears. 

 

 

3. Click Base Window. 

Method 1 and Method 2 both display the Window Settings dialog box. 
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1. Type “Bargraph” in the Name field. The number 11 should already be in the Window No. field. 

2. Click the box for the Background color. The color palette box opens. Click on the white color box in 
the lower-right corner. The color box will reflect the color that you have selected. 

3. Click OK. If Method 1 was used, the new window will open.  If Method 2 was used, highlight 
Window 11: Bargraph in the Open Window list, then click the Open button. Window 11 now 
appears on your work area. 

Now let’s create a function key to open Window 11 from the initial screen, Window 10. 

To create a Function Key: 
1. Click on Window 10 in the Windows Object List to open Window 10. 

2. In the top menu bar in EZwarePlus, click Objects > Button > Function Key (or select the Function 
Key icon in the Object 1 Toolbar). 

3. In the Function Key Properties General tab, select Change full-screen window and select 11. 
Bargraph in the Window no.: box. 
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4. Click the Shape tab and select the Use Shape checkbox. Click the Shape Library button to open 
the Shape Manager window. Click the New Library button (red box in the image below), browse to 
the arrow1.plb file, and click Open. 
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5. Select shape number 7 and click OK. The Function Key Object’s Shape tab now shows a preview of 
how the function key will appear on the screen. Click OK. 

 

6. On the main screen of EZwarePlus you will see a white rectangle outline that is attached to your 
cursor in the work area. This represents the Function Key just created. Click to place the Function 
Key in the middle of Window 10. You can click and drag on the handles around the Function Key 
Object to resize it. 

 

7. In the top menu bar in EZwarePlus, click Draw > Text (or select the Text Tool icon in the Draw 
Toolbar). In the New Text Object properties window, select Arial in the Font box and 16 pt in the 
Size box. Click the Color box and the color palette box opens. Click on the white color box in the 
lower-right corner. The color box will reflect the color that you have selected. 
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8. In the Content box at the bottom of the properties window, type To next window and click OK. 

 

9. On the main screen of EZwarePlus you will see a white rectangle outline that is attached to your 
cursor in the work area. Click to place the text just below the function key in the middle of 
Window10. You can click and drag it to center it beneath the function key. 

 

Now let’s create a bar graph on Window 11. We will use the bar graph to indicate the level of a tank. We will 
create pushbuttons to increase or decrease the level of the tank by turning a pump on and off. 

To open Window 11, double-click on Window 11 in the Windows Tree Bar on the left side of the EZwarePlus 
screen. Alternatively, select Window > Open Window and double-click Window 11 in the list. 
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To create a Bar graph: 
1. In the top menu bar in EZwarePlus, click Objects > Bar Graph (or select the Bargraph icon in the 

Object 2 Toolbar). 
 

2. In the Bar Graph Properties General tab, select LW0 for the Read address. Leave the numeric 
format set to the default 16-bit unsigned. 

 

3. Click the Outline tab. In the Attribute section, select the following: 
Type: Normal 
Direction: Up 
Min: 0 (the register value represented when the bar graph is minimum) 
Max: 100 (the register value represented when the bar graph is maximum) 
Bar width ratio (%): 30 
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4. In the Bar color/style section, click the Transparent checkbox. Leave the Bar and Bar style colors 
at their default blue. 
 

5. Leave the Target indicator Enable box unchecked. 
 
 

6. In the Alarm indicators section, select the following: 
Low limit: 25  
High limit: 85 
Low color: yellow (the bar graph color is yellow when the register value is below 25) 
High color: red (the bar graph color is red when the register value is above 85) 
 

7. Click the Shape tab. Leave the Use shape checkbox unchecked and click the Use picture 
checkbox. 



Chapter 4 – Creating a Sample Project  41 

 

EZwarePlus Programming Manual   41 

   

 

8. Click the Picture Library… button and click the New Library button (red box in the image below). 
Locate tank.flb in the Library folder. Select it and click Open to add it to the list. Select picture 
number 16 and click OK. This is the picture that will appear over the bar graph on the screen. 
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9. Click OK to accept the properties settings. On the main screen of EZwarePlus you will see a white 
rectangle outline that is attached to your cursor in the work area. Click to place the Bargraph Object 
in the middle of Window 11. You can click and drag it to adjust its position once you have placed it 
on the window. 

 

Next we will create a pushbutton to raise the level of the tank and another one to lower the level of the tank. 
This will use the Set Word Object to increment and decrement the value in LW0, the register that the bar 
graph is monitoring. 

To create a Set Word: 
1. In the top menu bar in EZwarePlus, click Objects > Button > Set Word (or select the Set Word icon 

in the Object 1 Toolbar). 

2. In the Set Word Object’s Properties General tab, you can enter a description of the object such as 
“Tank Level Up.” Select LW for the Device Type and 0 for the Write address. Leave the numeric 
format set to the default 16-bit unsigned. 
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3. In the Attribute section, select the following: 
Set Style: Press and hold increment (JOG++)  
(this will cause the value in the register to increase while the button is pressed) 
Inc. value: 1 
Upper limit: 100 
JOG delay: 0.5 second(s) 
JOG speed: 0.1 second(s) 

4. Click the Shape tab. Click the Use Shape checkbox and click the New Library button (red box in 
the image below). Select the arrow1 library. Select shape number 6 and click OK. 

 

5. A preview of the selected shape appears in the properties window.  
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6. Click OK and place the Set Word Object below the bargraph on Window 11 in EZwarePlus. You can 
click and drag it to adjust its position once you have placed it on the window. 

7. Click on the screen to deselect the Set Word Object, then double-click on it to reopen the properties 
(or right-click on it and select Attribute) and click the Profile tab (the Profile tab is not available 
when creating a new object). Set the Width and Height to 60 (pixels). 

 

8. Click OK to accept the new profile settings. 

 

9. Now we will create another Set Word Object to lower the level of the tank. Select the Set Word 
Object that we just created and copy it (Edit > Copy or Ctrl+C on the keyboard).  
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10. Paste the Set Word Object to the window (Edit > Paste or Ctrl+V) and drag it next to the other Set 
Word Object.  

 

11. Click on the screen to deselect it then double-click on the new Set Word Object to open the 
Properties window (or right-click on it and select Attribute). 

 

12. In the Set Word Object’s Properties General tab, you can enter a description of the object such as 
Tank Level Down. Select LW and 0 for the Write address. Leave the numeric format set to the 
default 16-bit unsigned. 
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13. In the Attribute section, select the following: 
Set Style: Press and hold decrement (JOG--)  
     (this will cause the value in the register to decrease while the button is pressed) 
Dec. value: 1 
Bottom limit: 0 
JOG delay: 0.5 second(s) 
JOG speed: 0.1 second(s) 
 

14. Click the Shape tab. Click the Shape Library… button. Select the Arrows 1 library. Select shape 
number 8 and click OK. 

 

15. Click OK to accept the properties settings. 

 

Next we will create a Bit Lamp Object to represent a pump and another to represent a pipe connecting the 
pump to the tank. 
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To create a Bit Lamp: 
1. In the top menu bar in EZwarePlus, click Objects > Lamp > Bit Lamp (or select the Bit Lamp icon 

in the Object 1 Toolbar). 

2. In the Bit Lamp Object’s Properties General tab, you can enter a description of the object such as 
Pump. Select LB and 0 for the Read address. 

 

3. In the Blinking section, select None for the Mode. 
Leave Hide picture/shape of no corresponding picture for current state unchecked. 

4. Click the Shape tab and check the Use Picture checkbox (uncheck the Use Shape checkbox if it is 
selected). 

5. Click the Picture Library… button and select Pumps1 in the Library list. If it does not appear in the 
Library list, click the New Library button and locate Pumps1.flb in the Library folder. Select it and 
click Open to add it to the list.  
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6. Select shape number 5. Notice that it has four states associated with it. We will use the first two 
states, grey and green. Click OK and a preview of the pump will appear in the Properties window. 

 

7. Click OK and place the Bit Lamp Object to the left of the tank. You can click and drag it to adjust its 
position once you have placed it on the window. 

8. Click on the screen to deselect the Bit Lamp Object, then double-click on it to reopen the properties 
(or right-click on it and select Attribute) and click the Profile tab. Set the Width and Height to 75 
(pixels). 

9. Click OK to accept the new Profile properties. 
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10. Copy and paste the Bit Lamp Object (pump) to the same window and open the Properties window. 
Leave the read address set to LB-0 and set the Blinking Mode to Alternating image on state 1 
(Blinking time: 0.5 seconds). 

11. Click the Shape tab. Click the Picture Library… button and select the Pipes Blue library (use the 
New Library button if it doesn’t appear in the Library list). Select picture number 1 and click OK. 

 

12. Click the Profile tab and set the Width to 100 and the Height to 25 (pixels). 

13. Click OK to accept the properties. Click to place the Bit Lamp Object between the pump and the 
tank. You can click and drag it to adjust its position once you have placed it on the window. 

 

Now we will create a Set Bit Object to turn the pump and pipe on and off whenever the Up or Down Arrows 
(Set Word Objects) are pressed. 
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To create a Set Bit: 
1. In the top menu bar in EZwarePlus, click Objects > Button > Set Bit (or select the Set Bit icon in 

the Object 1 Toolbar). 

2. In the Set Bit Object’s Properties General tab, you can enter a description of the object such as 
Pump On. Select LB for the Device Type and 0 for the Write address. Select Momentary for the Set 
Style.  Leave Write after button is released unchecked. 

 
3. Click the Shape tab and deselect the Use Shape checkbox. This will make the Set Bit invisible on 

the screen. 
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4. Click OK and place the Set Bit Object on the window. It will appear as a square frame. Click on the 
screen to deselect it then double-click on it to reopen the properties (or right-click on it and select 
Attribute). Click the Profile tab and set the Width and Height to 65 (pixels). Click OK to accept the 
new Profile settings. 

5. Move the Set Bit Object over the Arrow Up button. 

6. Copy and paste the Set Bit Object and place the second one over the Arrow Down button. When the 
Up or Down buttons are pressed, the pump and pipe will change states to indicate that they are on.  

 

Finishing Up 
There are still a few more steps to finish your first project. In this section, you will: 

• save the project onto your computer hard drive 
• compile the project into a format that can be understood by the HMI 
• run the offline simulator to test the project 
• download the project to the HMI 
• verify that the HMI operates as expected 
• exit the EZwarePlus software 

Saving your first project 
1. From the File menu, click Save As. The Save As dialog box appears. 
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2. Use the drop-down menus to locate the project folder in EZwarePlus. 

3. In the File name text box, type Sample_Project.emtp. 

4. Click Save. The file is saved onto your computer hard drive and the main screen of EZwarePlus 
reappears. 

Compiling your first project 
1. From the Tools menu, click Compile. The Compiling dialog box appears. 

 

2. Click the Compile button. EZwarePlus will compile your project and display error results. 

3. If no errors occur, click Close. The main screen of EZwarePlus reappears. If errors have occurred, 
repeat the steps in the “Creating a Sample Project” section. 

Simulating your first project 
1. Click Tools in the top menu bar and select Off-line Simulation (Ctrl+T) or click the Off-line 

Simulation icon in the Project Toolbar. The Simulation Window will appear on the screen. 
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2. Click the arrow button to go to the next window. 

 

3. Click and hold the arrow UP button to fill the tank. The pump turns green and the pipe starts blinking. 
The bar graph is yellow when the tank begins to fill and turns blue when it fills more than 25%. 

 

4. When the tank fills above 85% the bar graph turns red.  

 

5. Click and hold the arrow DOWN button to lower the tank level. 
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6. Right-click in the simulation window and select Exit simulation. 
 

Downloading your first project 
First, connect a +24 VDC power supply to the HMI. Refer to the HMI5000P/L/RMI Installation Guide for 
more information.  

In order to download your project, you must first connect the HMI to your computer. There are three 
methods of downloading to the HMI; Ethernet, USB configuration cable, or USB flash drive/SD card. 

Ethernet 
Ethernet Crossover Configuration Cable: P/N 7431-0104 

It is necessary to determine the IP Address of the HMI. By default, the HMI is configured to get a dynamic IP 
address from a DHCP server. This setting can be changed. To determine or change the HMI’s IP address: 

1. Connect the HMI to your computer using an Ethernet crossover cable (7431-0104). 

2. Touch the arrow in the lower right corner of the HMI screen. A menu bar will appear. Touch the gear 
icon on the menu bar. 

3. Enter the System Settings password (default password is 111111). 

4. On the Network tab of the System Settings dialog, the HMI’s IP address will be shown. If set for 
Obtain an IP Address Automatically, the HMI’s current IP setup information is displayed but is not 
changeable. To change the IP address, select IP Address Get From Below and enter the data. 

5. Once the IP Address has been established, the project can be downloaded. Select Tools > 
Download from the EZwarePlus menu (or click the Download icon). 

6. Enter the HMI’s IP address (or optionally the HMI name). The default download password is 
111111.  
Note: The computer’s Ethernet port IP address should have the same Subnet Mask as the HMI’s IP 
address, usually 255.255.255.0. Therefore, the first three octets of the IP address should be the 
same for both devices. 

7. Make sure that the Ethernet, Firmware, and Reboot HMI After Download boxes are checked. 

8. Click the Download button. If the HMI is properly connected to the PC, the status box on the 
download dialog will update with messages indicating the progress of the transfer. The HMI itself will 
also display messages reflecting its status. 

9. When the download is complete, the HMI will restart and will begin running your project. Click the 
Exit button on the Download dialog. 

USB Cable 
USB Configuration Cable: P/N 7431-0115 (HMI5070Pv2: 7431-0119) 

1. Make sure the USB driver has been installed on your computer. See the Help menu “How Do 
I…Install the Maple Systems USB Driver” for more information. 

2. Connect the HMI to your computer using the USB configuration cable  
(PN 7431-0115; HMI5070Pv2: 7431-0119).  

3. Select Tools > Download from the EZwarePlus menu (or click the Download icon). 
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4. Make sure that the USB, Firmware, and Reboot HMI After Download boxes are checked. 

5. Click the Download button. If the HMI is properly connected to the PC, the status box on the 
download dialog will update with messages indicating the progress of the transfer. The HMI itself will 
also display messages reflecting its status. 

6. When the download is complete, the HMI will restart and begin running your project. Click the Exit 
button on the Download dialog. 

Note: When connecting two powered devices, a difference in potential can exist between the ground 
reference on each device. If there is a large difference in ground potential (voltage), making a connection via 
a USB cable can complete a ground loop that may damage the HMI and PC. The connectors on the Maple 
Systems USB Configuration Cable (P/N 7431-0115; 7431-0119) are electrically isolated to prevent a 
potentially damaging ground loop, and we recommend using this cable to connect the HMI to the PC. Maple 
Systems cannot be held responsible for any damage to the HMI, PLC, or PC due to improper wiring. Please refer to 
the HMI5000 Series Installation Guide for proper wiring instructions. 

USB Flash Drive/SD Card 
USB Flash Drive: Up to 8 GB 
SD Card: Up to 32 GB (FAT 32) 

Projects can be uploaded from and downloaded to an HMI from a USB flash drive or SD card.  
• See Appendix C for information on downloading a project to the HMI from a USB drive or SD card. 
• See Appendix D for information on uploading a project from the HMI to a USB drive or SD card. 

CONGRATULATIONS! You have completed your first EZwarePlus project. Select File > Exit to close EZwarePlus. 

 

Managing Fonts and Libraries in EZwarePlus 
Downloading a Compiled Project File and Fonts to an HMI 
When you compile a project (Tools > Compile), the fonts used in the project are copied into the EZPlus > 
Font folder. The fonts are renamed with the filename of the project (i.e., project$0.ttf, project$1.ttf, 
project$2.ttf, etc.). These are the font files that are downloaded to the HMI along with the compiled project. 

 

This works when you download a project with the same computer that created the project. However, if you 
transfer a project to another computer, you must be aware of the fonts and libraries associated with the 
project to ensure that the project is successfully downloaded to the HMI with the correct fonts, shapes, and 
pictures. 
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The Font Management option (Edit menu > Font Management) provides a method of copying the font files 
used in the project to a specified location or to replace a font used in the project with another one. See 
“Chapter 6 – Using EZwarePlus > EZwarePlus Features > Edit Menu > Font Management” for more 
information. 

Uploading a Compiled Project File to a PC 
When you upload a file (Tools > Upload) the compiled application is transferred from the HMI to your PC. 
Enter the IP address of the target HMI to upload, enter (or browse to) a folder to hold the project and click 
the upload button at the bottom of the window. Once this process is completed, the compiled file 
(project.exob) will be placed in the folder chosen for the Project Location.  

To convert this file into a development file, use the Decompile function (Tools > Decompile). Browse to the 
project.exob file; the project file name (for the .emtp file) will be auto generated. Click on the decompile 
button on this dialog. If you receive a password error, verify you have the correct decompile password 
entered in the EXOB password field. 

Transferring a Project File to Another Computer 
When transferring a project (*.emtp file) to another computer (computer 1 to computer 2), verify that 
computer 2 has all of the fonts and libraries used in the project. When you open the project on another 
computer, EZwarePlus will let you know if there is a missing library file with a warning message that says, 
“Cannot find the library below. Replace or unattach it?” If you select Unattach, the objects associated with 
the missing libraries will have no shape or picture and will become “invisible” on the screen. 

Make sure the text appears correctly in each screen. If not, there may be a missing font. Compile the project 
on computer 2 to load the fonts into the EZPlus > Font folder so they can be downloaded to the HMI. 

Transferring a Compiled Project File to Another Computer 
When transferring a compiled project (*.exob file) to another computer (computer 1 to computer 2), you may 
not be able to download the *.exob file directly to an HMI and have it appear correctly because the fonts have 
not been loaded into the EZPlus > Font folder on computer 2. Either copy the fonts from the EZPlus > Font 
folder on computer 1 to computer 2, or decompile the project on computer 2, open the *.emtp file in 
EZwarePlus, and recompile the project to load the fonts into the EZPlus > Font folder. Once again, make sure 
the text appears correctly in each screen (if not, verify that computer 2 has all of the fonts used in the project). 

  When a compiled project is decompiled, new Shape and Picture library files are created and copied to 
the EZPlus > Library folder with the filename of the project (i.e., project_0.plb and project_0.flb). These 
libraries are associated with the *.emtp project file after decompiling it from a *.exob file. 

Decompiling a Project Created on Another Computer 
When decompiling a *.exob file, the fonts are not extracted from the *.exob file (this includes decompiling a 
project that has been uploaded from an HMI using Utility Manager). After decompiling, you must open the 
*.emtp file in EZwarePlus and recompile the project to load the fonts into the EZPlus > Font folder. Once 
again, make sure the text appears correctly in each screen (if not, verify the computer has all of the fonts 
used in the project). 

Compressing and Uncompressing a Project 
When compressing a project (Tools > Compress/Uncompress), the associated library files are included in the 
compressed file (*.ecmp), but the fonts are not. When uncompressing a project, the Shape and Picture libraries 
are copied into the EZPlus > Library folder. However, in order to load the fonts into the EZPlus > Font folder (if 
they are not already there), you must open the *.emtp file and compile the project. Once again, make sure the 
text appears correctly in each screen (if not, verify the computer has all of the fonts used in the project). 

  Using the Compress utility is a good way to archive your projects once they are completed. Backup the 
font files along with your compressed project to complete the archive.  
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Uploading and Downloading Using USB Flash Drive or SD Card 
When uploading a project using a USB flash drive or SD card, the fonts are uploaded from the HMI and 
stored in the font folder in the mt8000ie (or emt3000) folder (mt8000ie > pub > font). Connecting the USB 
flash drive to another HMI to download the project will also download the fonts. 

Compile a project before using the “Build Data for USB Disk or CF Card Download” in order to include the 
fonts from the EZPlus > Font folder, which are downloaded to the HMI along with the project. 

  If the fonts are not available in the EZPlus > Font folder when downloading a project, the project is 
downloaded to the HMI without the fonts, and default fonts are used. There is no error message to warn that 
the fonts are not available.

Chapter 5 – Simulator Mode 
As you saw from creating the sample project in the last chapter, downloading any changes you make to the 
HMI can take time. To decrease the amount of time required to download a project to the HMI, you can 
uncheck the Firmware option on the EZwarePlus download dialog after you have downloaded it once. 

A better way of testing changes made to a project is to use the computer to simulate the operation of the 
HMI. 

This chapter shows you how to dramatically save time when creating and testing a project by putting the 
computer into Simulation Mode. In Simulation Mode, the computer displays a screen that simulates what is 
seen when the HMI executes the project file. You can use the mouse on your computer to simulate the 
operation of the touchscreen on the HMI. Rather than waiting for the download to test each change you 
make to your project, you can now instantly switch to Simulation Mode to see if your project is working as 
expected. 

You can enter Simulation Mode from EZwarePlus or from the Utility Manager. 

The Simulation Screen 
All modes of simulation use the same screen.  

 

For our example, we are showing the sample project as it would appear after the “To next window” function 
key has been pressed. When the Simulation Mode screen first appears, it will always show the startup 
screen of the project. You can test any objects you have created which require touchscreen input by clicking 
on them. In this example, clicking on the increment key simulates the key as it is pressed on the 
touchscreen. Simulation Mode always uses the compiled version of the project that you have created (the 
*.xob file). Therefore, you must save and compile any changes you make to the project before you can 
simulate it. 

Simulating the HMI is done in on-line or off-line mode. 
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On-line simulation is most useful when a project is near completion and you need to test the interaction of 
the project with the PLC. It is also very convenient when making minor changes to a project because these 
changes can be instantly checked for operation. 

Off-line simulation does not require any connection to the HMI. Because of this, off-line simulation is most 
often used when starting a project. You can quickly test new ideas and create preliminary screens without 
the HMI. 

Off-line simulation is also great for demonstrating the operation of the HMI and becoming familiar with the 
operation of the HMI before it is installed. If you want to simulate the interaction with a PLC when off-line, it 
can be done by creating additional windows on the HMI which allow PLC data input. 

  Right-click on the simulator screen and select “Screenshot” to generate a bitmap image of the currently 
open window. The BMP file is saved in the “screenshot” folder in the EZPlus folder 
(C:\MapleSystems\EZPlus\screenshot). 

To use off-line simulation mode from EZwarePlus: 
1. If the project has been modified since the last time it was saved and compiled, or if it has not yet 

been compiled, it must be saved and compiled before the simulator can start. 

2. Select Tools > Off-line Simulation from the top menu bar (or click the Off-line Simulation icon in 

the Project toolbar ). 

3. The Simulation Mode screen will appear. 

4. To end off-line simulation, right-click in the simulation screen and click Exit simulation, or click the 
red “X” button in the upper-right corner of the simulator. 

Simulation mode can also be started from the Utility Manager. Utility Manager requires only the compiled 
project file (*.xob). This can be useful in situations in which you want to demonstrate changes made to a 
project for a client without giving him access to your project file. It also allows you to rapidly switch from 
simulating one project to another without having to open, save, and compile each project. 

To use off-line simulation mode from Utility Manager 
1. Start the Utility Manager software. 

2. Select the Design tab. 

3. Click Simulation. The Open Project box appears.  Click the folder icon, and browse to the exob file 
to run simulation on. 

4. Click the Off-line Simulation button. 

5. Click Open. The simulation screen will appear. 

6. To end off-line simulation, right click in the simulation screen and click Exit. 

To use on-line simulation mode from EZwarePlus 
Online simulation requires a direct connection between the PC and the controller. It is not necessary to have 
the HMI connected. 

The HMI’s COM1 RS232 connection is wired the same as a standard PC 9-pin serial connector. Therefore, 
the standard Maple Systems’ COM1 RS232 cable for the selected PLC/controller can be used with online 
simulation. Connect the cable end marked "HMI" to the PC’s serial port, and connect the other end to the 
PLC/controller. 
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1. If the project has been modified since the last time it was saved and compiled, or if it has not yet 
been compiled, it must be saved and compiled before the simulator can start. 

2. Select Tools > On-line Simulation from the top menu bar (or click the On-line Simulation icon in 

the Project toolbar ). 

3. The Simulation Mode screen will appear. 

4. To end on-line simulation, right-click in the simulation screen and click Exit simulation. 

To use on-line simulation mode from Utility Manager 
1. Start the Utility Manager software. 

2. Select the Design tab. 

3. Click Simulation. The Open Project box appears.  Click the folder icon, and browse to the exob file 
to run simulation on. 

4. Click the On-line Simulation button. 

5. Click Open. The simulation screen will appear. 

6. To end off-line simulation, right click in the simulation screen and click Exit. 

 The above method will work with a standard PC serial COM port, regardless of the COM number 
assigned to the PC serial port. EZwarePlus supports RS232 communication on ports COM1 – 
COM9. COM2 and COM4 and higher are intended for use with online simulation only, since the 
HMI5000 itself supports RS232 communication on COM1 on all models, and also COM3 on some 
models. 

 If simulating with RS422 or RS485 communication, the PC will require some mechanism to support 
RS422/485. A communication card can be installed in the PC, a USB communications module can 
be used, or an external RS232-to-RS485 converter can be used. In any case, a standard Maple 
Systems cable may not work. 

If simulating a project using Ethernet communications, the IP settings of the PC are used by the simulator.  
An Ethernet cable between the PC and the PLC/controller is needed.   Consult the PLC/controller 
documentation for details. 

To use EasySimulator 
Online or offline simulation can be initiated without having to open EZwarePlus or Utility Manager by using 
EasySimulator. EasySimulator is located in the same folder as EZwarePlus and Utility Manager 
(C:\MapleSystems\EZPlus\EasySimulator.exe). If you have installed the EZwarePlus Downloader, it is 
located at C:\MapleSystems\EZPlusUtil\EasySimulator.exe. 

When EasySimulator starts, it reads the file “XOB_POS.def,” which is also located in the same folder as 
EasySimulator. This definition file determines whether to run offline or online simulation, the location of the 
com.exe and gui.exe files, and the location and name of the *.xob file to simulate. The following are the 
default settings for the XOB_POS.def file: 

// mode – 0: offline, 1: online 
“0” 

// directory containing com.exe and gui.exe 
“c:\MapleSystems\EZPlusUtil” 
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// xob file 
“c:\MapleSystems\EZPlusUtil\HMI5121PDemo.xob” 

Edit the XOB_POS.def file in a text editor such as Notepad. 

Now that you are familiar with using simulation mode, the next chapter guides you through the fundamental 
operation of three primary segments of the EZwarePlus configuration software. 
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Chapter 6 – Using EZwarePlus 

Overview 
The EZwarePlus software is composed of a number of separate applications that are accessible from the 
EZPlus folder, including EZwarePlus, Utility Manager, and EasyConverter. EZwarePlus is the application 
software used to create a project file. Utility Manager is a utility application that is used to launch the various 
applications and utilities that are included with EZware. EasyConverter changes certain binary files created 
by the HMI into text files. 

By the end of this chapter, you should be quite familiar with the operation of EZwarePlus and Utility Manager 
and be able to maneuver around the EZwarePlus programming software easily. 

 EZwarePlus includes extensive online help. From any dialog box within the software, click on the 
HELP button, or press the computer's F1 key. 

 Projects created in EasyBuilder-5000 can be opened in EZwarePlus. The System Parameters 
window will open on the Model tab so you can reassign the project to an HMI5000P/L/RMI model. If 
the screen size of the selected HMI5000P/L/RMI model is different from the original project, the 
Resize pop-up windows/objects dialog will open with options for resizing objects in the project. 
EasyBuilder-5000 projects use the file extensions mtp and xob, EZwarePlus projects use the file 
extensions emtp and exob (or cmtp and cxob for the RMI5010). 

 Projects created in EasyBuilder-500 should be converted to EasyBuilder-5000 first using the 
Translate HMI500 Project selection under the Tools menu, then opened in EZwarePlus. 

The Utility Manager 
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The Utility Manager is a launching pad for a number of EZware applications. Open the Utility Manager by 
clicking on the Windows Start menu on your computer and selecting “All Programs > Maple Systems > 
EZwarePlus > Utility Manager.” Alternately, navigate to the EZPlus folder (C:\MapleSystems\EZPlus) and 
double-click on UtilityManagerEX.exe. 

When the Run tab is selected at the bottom, clicking a ‘heart’ icon will add the corresponding application to 
the Favorites bar at the bottom of the window. When the Edit tab is selected, clicking the red ‘–‘ icon on an 
item in the Favorites bar removes the application from the Favorites bar. 

The applications are divided into groups. Not all applications are available for all HMI families. 

Select Model (IMPORTANT!) 

• In the upper-left corner of Utility Manager, select the family of models for the HMI that you are using 
(HMI5000P Series, HMI5000L Series, HMI5000XL Series, RMI5001 Series, RMI5010 Series). 

Design 

• EZwarePlus: Opens EZwarePlus. Create projects for the HMI 
• EasyAddressViewer: Examine supported addresses and devices for the PLC and controller 

communications drivers provided with EZwarePlus. 
• Simulation: Run a compiled EZwarePlus project without transferring to an HMI (see “Chapter 5 – 

Simulator Mode”). 

Analysis & Testing 

• EasyDiagnoser: Connect to an HMI via Ethernet, and monitor/debug communications to an HMI (see 
Chapter 18 – EasyDiagnoser and Easy Watch). 

• EasyWatch: Monitors data in the PLC and HMI over Ethernet, displayed in a spreadsheet-style 
arrangement (see “Chapter 18 – EasyDiagnoser and Easy Watch”). 

• Reboot: Reboot the HMI connected to the PC by Ethernet or USB. 
• Pass-Through: Allows PC applications to communicate to the PLC through the HMI. 

Publish 

• Download: Transfer a compiled EZwarePlus project, as well as firmware, startup screen image, 
recipe, and data log files to the HMI. 

• Upload: Transfer a compiled EZwarePlus project, as well as recipe, data log files, event log files and 
operation log files from the HMI. 

• Build Download Data for SD/USB Disk: Build a directory structure containing project data on an SD 
or USB device for direct transfer to the HMI. 

Maintenance 

• EasyPrinter/Backup Server: Runs on a PC so that data can be sent to the PC from the HMI over an 
Ethernet connection. 

• Administrator Tools: Put user account and email data on an SD or USB device for direct transfer to 
an HMI. 

• EasyAccess 1.0: Allow remote access to the HMI from anywhere that has internet access. 
• Data/Event Log Information: Display information about the size and quantity of Data and Event log 

files on the HMI. 
• cMT Viewer (RMI5010 Series only): Connect to an RMI5010 from the PC and view the project 

running in the RMI5010. Please refer to the “RMI5010/5090 Quick-Start Guide” for more information. 
• RMI5090 Upgrade (RMI5010 Series only): Used to upgrade the OS and runtime firmware on an 

RMI5090. 
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Data Conversion 

• Recipe Database Editor: Edit a recipe database without modifying the HMI project itself. 
• EasyConverter: Convert binary data and event log files to CSV format. 

Recipe Editor: Edit recipe data stored in RW and RW_A memory, as well as data stored in Extended 
Memory.Many of the applications launched by the Utility Manager are self-contained and have their own 
documentation. Some of the applications are discussed below. 

Utilities 

EasyAddressViewer  
(Design) 

Starts the Easy Address Viewer application for viewing the device types and memory ranges for the selected 
communications driver. 

Simulation  
(Design) 

On-line Simulation 

Opens a compiled project (*.exob) in on-line simulator mode. 

Off-line Simulation 

Opens a compiled project (*.exob) in off-line simulator mode. 

  See “Chapter 5 – Simulator Mode” for more information. 

EasyDiagnoser  
(Analysis & Testing) 

Opens the EasyDiagnoser utility, which connects to the HMI over Ethernet and monitors the read/write 
commands between the HMI and the PLC and helps resolve communication errors. See “Chapter 18 – 
EasyDiagnoser and Easy Watch” for more information. 

EasyWatch  
(Analysis & Testing) 

Opens the EasyWatch utility, which connects to the HMI over Ethernet and provides a method of displaying 
and editing PLC and HMI registers in a spreadsheet-style view. It also can be used to trigger existing macros 
in an HMI. See “Chapter 18 – EasyDiagnoser and Easy Watch” for more information. 

Pass-Through  
(Analysis & Testing) 

The pass-through mode allows serial communications from the PC to the PLC, through the HMI. This can 
eliminate the need to disconnect the PLC from the HMI when it is necessary to configure the HMI or PLC. 

  Pass-through mode is only available on HMIs with an Ethernet port. An Ethernet connection from the PC 
to the HMI is required to initiate pass-through mode, even when using serial pass-through mode. 
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To use the serial pass-through mode: 

 

1. Select COM port. In the serial pass-through mode, data coming in on one serial port on the HMI is 
re-transmitted out another serial port to the PLC. 

2. HMI/IP: Specify the IP Address of the HMI that is to be used in pass-through mode and click Get 
HMI Communication Parameters to read the current communication settings for the HMI (if the 
HMI is connected directly to the PC’s Ethernet port, you must use a crossover Ethernet cable). 

3. HMI work mode: Indicates the current mode of the HMI. After the communication parameters have 
been received, the mode will be either Normal (HMI set to communicate with PLC) or Pass-through 
(HMI is in pass-through mode). 

4. Source COM Port (PC -> HMI): Set COM settings for the HMI COM port that will be connected to 
the PC. 

5. Destination COM Port (HMI -> PLC): Set COM settings for the HMI COM port that will be 
connected to the PLC. 

6. Click Start Pass-through to begin pass-through communication and Stop Pass-through to end. 
Click Exit to exit pass-through mode. 
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 When the HMI is in serial pass-through mode, the HMI may suspend communications with the PLC and 
the application in the HMI may not run, depending on the PLC and PLC programming software used. 

To use the Ethernet pass-through mode: 

 

In the Ethernet pass-through mode, the HMI acts as an Ethernet-to-Serial bridge. A virtual COM port driver is 
installed on the PC (in this example, COM4), which provides the connection between EZwarePlus (or the 
PLC programming software) and the Ethernet port connected to the HMI. The virtual COM port uses the next 
available port on the PC.  

1. Click Install to install the virtual COM port driver. The Virtual COM Port (PC <-> PLC) indicates the 
virtual COM port used on the PC.  

 
 To change to another port, use the COM ports section of Device Manager on the PC. 

2. PLC Connection Port (HMI <-> PLC): 
For most PLCs, set the mode to Normal.  Some Siemens PLCs will use MPI ISOTCP; 
Enter the IP address of the HMI; 
Select the TCP Port to use.  This must the same setting as the Pass-Through Port Number set in the 



Chapter 6 – Using EZwarePlus  66 

 

EZwarePlus Programming Manual   66 

   

EZwarePlus project, on the Model tab of the System Parameters dialog; 
Set the COM port on the HMI connected to the PLC. 

3. Click Apply to accept the settings. 

4. Click Stop Pass-through to end. 

5. Click Uninstall to uninstall the virtual COM port driver on the PC. 

 The HMI must be powered and connected to the PC or Windows will not recognize the virtual port as an 
available serial port. 

System tags for pass-through mode: 

LW-9901: pass-through source COM port (1-3 = COM1-COM3) 
LW-9902: pass-through destination COM port (1-3 = COM1-COM3) 
LW-9903: pass-through control (0=normal, 1=pause, 2=stop communications between HMI and  
  PLC when executing pass-through) 
 

Download  
(Publish) 

Sends a compiled project file stored on the computer to the HMI. The download window also gives you the 
option of downloading firmware files, recipe files, data log files, and a startup screen graphic. 

 

When downloading to an HMI for the first time, select the Firmware checkbox and the Project checkbox. 
Click on the Browse button to the right of the Project checkbox and navigate to where the EXOB project file 
is located. Select it and click Open. 
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Select the connection method for downloading to the HMI, Ethernet or USB cable.  

When Ethernet is selected, enter the IP address of the HMI in the IP address field.  

  The HMI and the computer must be on the same subnet. If connecting the HMI directly to the computer, 
an Ethernet crossover cable may be required. 

Selecting any of the “Reset” options will erase the selected file-type when the project is downloaded. 

The Port No. Setting button provides a way to select a different TCP port than the default 20248. 

The download Password must match the download Password in the HMI’s System Settings (Security tab). 
The default password is 111111. 

  When downloading a project to an HMI, the fonts are downloaded along with the project file. The fonts 
are stored in the fonts folder in the EZPlus (or EZPlusUtil) folder when the project is compiled. If the project 
was not compiled on the same computer that is being used to download the EXOB file, it may be necessary 
to copy the font files from the computer where the project was compiled to the computer where the project is 
being downloaded. The font file naming format is: <Project name>$n.ttf, where n is a sequential number 
beginning at 0.1, 2, 3, etc.. 

Upload  
(Publish) 

Receives a compiled project file from the HMI to be stored on the computer. 

The upload window also gives you the option of uploading recipe files, operation log files, data log files, 
event log files, and extended memory files. 
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When uploading a project from an HMI, select the Project checkbox. Click on the Browse button to the right 
of the Project checkbox and navigate to where you want to save the EXOB project file. Enter the name of 
the project in the “File name” field at the bottom and click Open. 

Select the connection method for uploading to the computer, Ethernet or USB cable.  

When Ethernet is selected, enter the IP address of the HMI in the IP address field.  

  The HMI and the computer must be on the same subnet. If connecting the HMI directly to the computer, 
an Ethernet crossover cable may be required. 

The Port No. Setting button provides a way to select a different TCP port than the default 20248. 

The upload Password must match the upload Password in the HMI’s System Settings (Security tab). The 
default password is 111111. 

Once the EXOB file is uploaded from the HMI, use the Decompile option under the Tools menu in 
EZwarePlus to create the EMTP project file, which can be opened in EZwarePlus. 

Build Download Data for SD/USB Disk  
(Publish) 

 

Data can be downloaded to the HMI5000 Series using an SD card and USB flash drive. The Build 
Download Data function builds the data files to do this. 

(Not supported in the RMI5010.) 

To build download data for SD card or USB flash drive: 

1. Start Utility Manager. 

2. Click Build Download Data for SD/USB Disk… The Utility Manager dialog appears. 
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3. Insert SD card or USB flash drive into PC. Note the drive that represents the SD/USB device. 

4. Click Browse... next to Select the folder to save download data: to select the drive that 
represents the SD/USB device. 

5. Check the boxes that will be the sources for your data and browse to the appropriate file for that 
source. Click Build. 

  The L Series do not support SD cards. 

EasyPrinter/Backup Server 
(Maintenance tab) 

The Easy Printer button starts the EasyPrinter application. The EasyPrinter application runs as a server on 
the pc, and allows screen images from the HMI to be printed via a printer connected to the pc running the 
EasyPrinter application.  Additionally, the HMI Backup object can be used to send certain data to the PC 
running EasyPrinter. 

 

The printer is set up on the Printer/Backup Server tab in the EZwarePlus Systems Parameters (not available 
for the RMI5010). Select the Use Remote Printer/Backup Server checkbox to enable remote screen printing 
and backup of data log file (*.dtl). 

File Menu 

Enable Output: Enable the printer. If not enabled, nothing will be sent to the printer. 
Exit: Terminates the EasyPrinter utility. If EasyPrinter is terminated, the HMI cannot send data to the 
printer or receive backup data. 

Edit Menu 

Edit: Edit the selected print job. 
Delete: Delete the selected print job. 
Select All: Select all print jobs. 
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View Menu 

The Jobs area is always displayed and indicates the source of the data, the operation being performed, and 
the status of the job. 

Properties Bar: Displays the properties of the selected print job. 
Preview Bar: Displays an image of the data being sent to the printer. 
Download Bar: Displays the status of the data being transferred from the HMI, not the status of the 
data being sent to the printer. 
Logger Bar: Displays the status of the EasyPrinter utility. 

Options Menu  

Toolbars: Provides the option of turning on and off the Standard toolbar and the View toolbar. 
Status bar: Provides the option of turning on and off the Status bar at the bottom of the EasyPrinter 
window. 
Settings: The Settings window is used to configure the operation of EasyPrinter. 
 The Output must be disabled before the Settings option is enabled. 

General 

 

Port Number of the Server Socket: Specify the IP Port number to use. This must match the Port 
setting on the Printer Server tab in the EZwarePlus System Parameters dialog. 

User Name: Specify a User Name. This must match the User Name setting on the Printer Server 
tab in the EZwarePlus System Parameters dialog. 

Password: Specify a Password. This must match the Password setting on the Printer Server tab in 
the EZwarePlus System Parameters dialog. 
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Naming Convention for HMI Folder (when writing files): Select Use IP address to create a folder 
named with the IP address of the HMI. Select Use HMI name to create a folder using the HMI name 
assigned in the Data Sampling Object’s Folder name, which is used to save history data files. The 
folder name is stored in LW9032-LW9039. 

Prefix: Optional prefix to append to the folder name defined above. For example, if Use IP address 
is selected for the naming convention, the IP address of the HMI is 192.168.1.211, and IP_ is 
entered in the Prefix box, the folder will be named IP_192.168.1.211. 

Minimize to System Tray: If checked, the minimized EasyPrinter utility will appear in the System 
Tray. If unchecked, the utility will be minimized to the Task Bar. 

Detailed Message: If checked, detailed messages will be written to the Logger window. If 
unchecked, general messages will be written to the Logger window. 

Hardcopy 

 

Print Out To: When checked, specifies the printer or device to send the data to. The drop-down list 
will be populated with devices available on the PC. 

Save to files in: When checked, saves a *.bmp file of the screen print to the designated folder on 
the computer. 
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Backup 

 

Backup files in: Specifies the location on the computer to save the data file. 

When target file has existed: When Overwrite it is checked, the existing file will be overwritten by 
the new file. When Append.BAK to the file name is checked, the existing file will have .BAK 
appended to the filename so it will be preserved. 

Convert Batch File: When enabled, defines the path to the definition file used to convert the data 
file to CSV file format (C:\MapleSystems\EZPlus\convert2csv.def is the default). 

Administrator Tools 
(Maintenance) 

The Administrator Tools allow some security and email settings to be saved to a USB flash drive and loaded 
into an HMI during runtime. See Chapter 14 – Administrator Tools for more information. 

EasyAccess 1.0 
(Maintenance) 

Opens the EasyAccess (v1.0) window, which provides a method of connecting to the HMI remotely over the 
internet. Unlike VNC, EasyAccess transfers only data (no images), resulting in much faster communication 
between the EasyAccess client running on a PC and the HMI. The EasyAccess client can run the same 
project that is running in the HMI, or a different project. The project in the EasyAccess client runs 
independently from the project in the HMI. See Technical Note 5082 “Using EasyAccess” for more 
information. 
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Data/Event Log Information 
(Maintenance) 

 

The Data/Event Log Information window is used to read the data log files and event log files in the HMI and 
provides a listing of the files stored in HMI memory. If connecting over Ethernet, enter the IP address of the 
HMI and click Open. The Data/Event Log File Information window will pop up showing a list of the data log 
files and event log files in the HMI. 
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Recipe Database Editor 
(Data Conversion) 

The Recipe Database Editor is used to modify an existing recipe.db file and add or delete records within a 
recipe. See Adding and Editing Data in a Recipe in the Recipe Database Editor in Chapter 16 – 
Recipes for more information. 

Easy Converter  
Data Conversion 

The EasyConverter application is used to view data log files (*.dtl) and event log files (*.evt) that are created 
by the HMI during operation. Data log files are files the HMI creates when capturing data using the Data 
Sampling object. Event log files are history files the HMI creates when using the Event (Alarm) Log object. 
Both files are in binary format to minimize the amount of file space required. 

To view these files with a computer, you must use the EasyConverter application. In addition, EasyConverter 
can take a data or event log file and convert it into a CSV (Comma Separated Value) file that can be easily 
imported into other applications such as Microsoft Excel.  

• For more information on how to do data logging, see “Chapter 12 – Data Sampling and Trend 
Displays.” 

• For more information on how to use Event Log files, see “Chapter 13 – Capturing Alarms and 
Events” section “Monitoring Alarms with the Event (Alarm) Log.” 

• For information on uploading history files from the HMI, see “Appendix D – Uploading a Project to 
the HMI from a USB Drive or SD Card.” 

• For information on accessing history files in the HMI from the FTP server, see “Appendix F – 
Accessing the FTP server in an HMI.” 

To start the EasyConverter Application   

1. Click the EasyConverter button in the Utility Manager Data Conversion window or click the 
EasyConverter icon in the Project Toolbar. The EasyConverter application appears. 

 

2. Click File > Open to display the Open dialog box. Search for the data log file (*.dtl) or event log file 
(*.evt) that you wish to view, then click the Open button. 

Please Note: 
These files are captured by the HMI and stored in internal HMI memory, an attached SD card, or USB flash 
drive. You must copy these files into your computer before using the EasyConverter utility. If you are running 
a project that is capturing data log or event log files using the Offline Simulator, the EZwarePlus application 
automatically creates new folders on your computer and creates the files 
(C:\MapleSystems\EZPlus\HMI_memory). 
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Data log files are stored in a folder using the name that you assigned in the Data Sampling Object attribute 
box (e.g., C:\MapleSystems\EZPlus\HMI_memory\data log\History Data1\20100618.dtl) 

Event log files are stored in an event log folder (e.g., C:\MapleSystems\EZPlus\event log\EL_20100625.evt). 

Viewing an Event Log File (*.evt) 

1. From the EasyConverter application, click File… Open and locate the Event Log file (*.evt). 

 

 

2. “Event”: This column indicates the following: 0 = Event triggered; 1 = Event acknowledged; 2 = 
Event returns to normal. 
“Category”: Indicates the event category. 
“Date”: Indicates the date of the event (YYYY/MM/DD). 
“Time”: Indicates the time of the event (HH:MM:SS) 
“Message”: Indicates the Event/Alarm message. 

 This is read only – the EasyConverter application does not allow any edits. 

Viewing a Data Log File (*.dtl) 

1. From the EasyConverter application, click File…Open and locate  
the Data Log file (*.dtl). As the file is loaded,  
the following popup window appears: 
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Sampling Data Information: This shows the type and number of data samples contained in the data 
file. You can select the number of digits after the decimal point to display and whether or not millisecond 
information is displayed. 

2. In addition, there is a scaling option that can apply linear scaling to the data before it is displayed.  
For this example, we have elected to use the linear scaling formula on Data No 1 to convert the raw 
data (which is measuring temperature in °F) to °C. 

 

3. Also, the raw data collected for Data 4 is a floating point number calculated to three decimal places. 
However, we are only concerned with a two decimal accuracy, so we change the ‘Digits’ field from 3 
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to 2. If we want to use these same changes on other files, click the Save Setting… button to save 
the changes as a conversion file (*.lgs). When opening other data log files, we can apply the same 
changes by clicking on the Load Setting… button and selecting the proper conversion file. 

4. Click OK to continue. The data log file is shown: 

 

5. The data shown includes the Date (YYYY/MM/DD), Time (HH:MM:SS), Milliseconds, and the actual 
data for each register sampled. In our example, notice that the value for Data 1 has been converted 
to °C and the value for Data 4 has two decimal places instead of three. 

 This is read only – the EasyConverter application does not allow any edits. 

Saving a Data/Event Log File as a CSV or XLS file  

After opening a Data/Event Log file in EasyConverter, you can easily save the file as a CSV or XLS file. 

1. Click File > Save As… or click the Save As icon. The Save As dialog opens. 

2. Click the Save as type: drop-down box and select either Text files (*.csv) or Excel files (*.xls).  
By default, the new file is saved in the same folder as the original file, but you can navigate to a 
different folder by clicking the Save in box at the top. 

Exporting a Data/Event Log File as an XLS file to Excel  

After opening a Data/Event Log file in EasyConverter, you can export the file as a XLS file and open it 
directly in Microsoft Excel.  
 Microsoft Excel is required to convert the file when exporting to Excel. 

1. Click File > Export to Excel or click on the Excel icon. 

2. Microsoft Excel opens and you should see the data in a spreadsheet format. Simply click File…Save 
As to save the file. 
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Converting Multiple Files  

EasyConverter also has a feature that allows you to select multiple Data/Event Log files and save them to 
one XLS file.  

1. Click File > Multi-File or click on the Multi-File icon. 

 
2. Click Add File… then select which Data/Event Log files you wish to combine. 

3. Enable Setting file: Check this box to select a conversion (*.lgs) file that performs a linear scaling 
conversion or decimal point conversion on the selected files. 

4. Combine to a file: Check this box to combine the files and save them into an Excel spreadsheet. 

Click the browse button  to select the location and filename where you want to save the 
combined XLS file. Click OK to save the file. 

Recipe/Extended Memory Editor  
Data Conversion 

The Recipe/Extended Memory Editor is an application that allows you to create, view, and modify recipe 
(*.rcp) files and Extended Memory (*.emi) files. You can also use this editor to import/export recipe and 
extended memory files to CSV formatted files, which can then be shared by other applications. 

 EZwarePlus has a new way of implementing recipes in addition to the method described here. With the 
new implementation, recipe data is stored in a database file and can be edited in the Database Editor or 
directly on the HMI screen. See “Chapter 16 – Recipes” for more information. 

To create a new Recipe/Extended Memory file: 

From the Utility Manager application, click Recipe/Extended Memory Editor: 
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1. Click File > New. The following dialog box appears: 

 

2. Address range (unit: word): Use this area to select the total number of RW (recipe word) registers 
or EMx (Extended Memory) registers that are used for the recipe or extended memory file. In the 
example above, RW0 thru RW100 will be used. 

3. Select your data format: Use this area to enter how each data register element is interpreted by the 
HMI. The data collected and stored in recipe/extended memory files is in binary format and does not 
contain any information about how each data should be interpreted by the HMI (for example, is the 
data in 16-bit signed integer format or BCD?). Therefore, the data format is used to define how each 
data element is formatted (i.e., Signed vs. Unsigned, 16-bit vs. 32-bit, Float, String, etc.). 

a. Add: Click to add a new data register format. The following dialog box appears: 
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In the Data Type dialog box you can enter a description of the Data Type and select which format that the 
HMI will use to interpret the data. 

 For String format, you must enter the total number of 16-bit register words used for the character string. 

b. Delete: If you wish to delete an item from the list, highlight a data element and click Delete 
to remove from list.  

c. Clear All: Click to erase entire list of data elements. 
d. Modify: Highlight a data element and click Modify to revise the name of the data element or 

format. 

2. Select your data format: Use to select or create a data format template that can be used for other 
recipes or extended memory files. In the example above, the data elements configured in the Data 
format list have been saved to a template called ‘Example’. Click OK. 

3. A table of data elements appears that shows the recipe or extended memory table. 

 

4. This table has several columns with headers: 

a. ID: This is the ID number for each record. 
b. ADDRESS: This is the starting RW address or EMx address for each record. 
c. Data headers: These are the descriptions used for each data element created in the step 

above. 

5. Edit the table by clicking on each data element field and entering the preset value. Please note that 
you are only allowed to enter data according to the format defined for each data element. 

6. Here is an example of a completed table: 

 

7. Click File > Save with the following options: 
a. Save file as *.rcp for recipes. 
b. Save file as *.emi for extended memory files.  

 You must use file names which correspond to the ten extended memory areas 
preconfigured in the HMI (ex. em0.emi, em1.emi, …, em9.emi). 

c. Save file as *.csv to open the file in applications such as Microsoft Excel. 
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8. Once the file is saved, you can copy the recipe file to your HMI by: 
a. Procedure 1-- Downloading the file using the Utility Manager: 

i. With the computer connected to your HMI, click Download. 
ii. On the Download dialog box, check the RW enable box, then select the recipe file.  

 

 

b. Procedure 2 -- Downloading using a SD card or USB Flash Drive: 
i. Attach an SD card or USB Flash Drive to your computer. 
ii. In Utility Manager, click Build Download Data for SD/USB Disk button. 

 

iii. Select the folder to save download data. Enter the SD card or USB Flash drive 
location.  

iv. Check the Recipe (RW) enable box, then select the recipe file. 
v. Click the Build button. A folder called ‘mt8000’ is created on the root directory of 

your drive.  
vi. Remove the SD or USB drive and connect it to your HMI. 
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EZwarePlus Features 
This section guides you in a basic understanding of the features and capabilities that EZwarePlus has to 
offer, from an overview of all the objects available in the software to enter and display data, to setting up the 
system parameters and selecting the target PLC. This information will be useful for understanding more 
advanced features explained in later chapters. 

 

EZwarePlus Development Window 

Objects Summary 
EZwarePlus includes several active graphics objects that are used to represent data that is stored in the PLC 
or internal memory of the HMI. The data represented can be single bit coils, 16-bit, or 32-bit registers. The 
data can be represented as numbers, ASCII characters, or as graphic shapes or bitmap images. This section 
provides a summary of all the objects available in EZwarePlus. Most of these objects are accessible by 
clicking Objects in the top menu in EZwarePlus, or by clicking on its icon in one of the toolbars. 

Refer to the Help file (Help > Help Topics > Using EZware > Parts List) for more information relating to 
each object. 

Bit Lamp  

The Bit Lamp Object is used as an indicator to represent the ON or OFF status of a bit or coil in the PLC, or 
a bit in the HMI local memory (LB). If the bit is cleared (0, False), the State 0 Shape of the Bit Lamp will be 
displayed. If the bit is set (1, True), the State 1 Shape of the Bit Lamp will be displayed. The Bit Lamp can 
also blink in various ways. 

Word Lamp  

The Word Lamp Object is used as an indicator to represent the value in a PLC register, or the value in a 
register in the HMI local memory (LW). Creates a graphics object to reflect the current state of a multi-state 
PLC data register. It can display a different shape or picture depending on the value in the register. If the 
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value is 0, the first shape is displayed, if the value is 1, the second shape is displayed, etc. A Word Lamp 
can display up to 256 different shapes and text strings, corresponding to register values of 0 – 255. 

There are four modes of operation available for the Word Lamp. 

Value: The state of the Word Lamp is displayed according to the value in the Read address. The Offset 
field will cause the Word Lamp to display the state according to the value in the Read address + the Offset. 
For example, if the Read address contains a value of 3 and the Offset is set to 4, the Word Lamp will display 
state 7 (4 + 3 = 7). 

LSB: Displays the state represented by the least significant bit in the binary word. 

Decimal Binary Displayed state 

0 0000 State 0 is displayed. All the bits are 0. 

1 0001 State 1 is displayed. The least significant active bit is 1. 

2 0010 State 2 is displayed. The least significant active bit is 2. 

3 0011 State 1 is displayed. The least significant active bit is 1. 

4 0100 State 3 is displayed. The least significant active bit is 3. 

5 0101 State 1 is displayed. The least significant active bit is 1. 

6 0110 State 2 is displayed. The least significant active bit is 2. 

7 0111 State 1 is displayed. The least significant active bit is 1. 

8 1000 State 4 is displayed. The least significant active bit is 4. 

 
 The LSB mode does not work with 32-bit Float data format. 

Bit combination: The state of the Word Lamp is displayed according to discrete bits rather than the value in 
a PLC or HMI register. One to four bits are used, depending on the number of states selected (1-16). The 
selected bits can be non-consecutive. 

PLC 1 = least significant bit (LSB) 
PLC 2 = next significant bit 
PLC 3 = next significant bit 
PLC 4 = most significant bit (MSB) 
The binary value represented by the PLC bits selected determines the state of the Word Lamp. 

PLC 4 PLC 3 PLC 2 PLC 1 State 
0 0 0 0 0 
0 0 0 1 1 
0 0 1 0 2 
0 0 1 1 3 
0 1 0 0 4 
0 1 0 1 5 
0 1 1 0 6 
0 1 1 1 7 
1 0 0 0 8 
…and so forth. 
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Change state by time: The state of the Word Lamp increments automatically at the interval specified by the 
Time interval. After the last state (up to 96 states), the Word Lamp returns to state 0 and repeats. 

Set Bit  

The Set Bit Object is used as a button to toggle ON or OFF the state of a bit or coil in the PLC, or a bit in the 
HMI local memory (LB). There are a number of different options (Set Styles) available to operate the button 
including touch (On, Off, Toggle, Momentary), window open or closed, and backlight on or off. 

Set Word  

The Set Word Object is used as a button to change the value in a PLC register, or the value in a register in 
the HMI local memory (LW). There are a number of different options (Set Styles) available to operate the 
button including touch (Write a constant value, increment or decrement), window open or closed, backlight 
on or off, and periodic bounce or jog. 

Toggle Switch  

The Toggle Switch Object is a combination of the Bit Lamp and Set Bit objects. It is used as a button to 
toggle ON or OFF the state of a bit or coil (specified by the Write Address), and as an indicator to represent 
the ON or OFF status of a bit or coil (specified by the Read Address) in a PLC register or HMI local memory. 
It can be configured with various Switch Styles including Set On , Set Off, Toggle, or Momentary. 

Multi-State Switch  

The Multi-State Switch Object is a combination of the Word Lamp and Set Word objects. It is used as a 
button to change the value of a register (specified by the Write Address), and as an indicator to represent the 
value in a register (specified by the Read Address). A Multi-State Switch can display up to 256 different 
shapes and text strings, corresponding to register values of 0 – 255. 

Option List  

The Option List Object provides a way to display a list of names corresponding to values in a register 
(Monitor address). The Source of item data selection determines how the Option List operates.  If Recipes 
are used, the Option List can contain the names of the recipes. 

Predefine: The Option List displays a list of items where the item displayed or selected (configured on the 
Mapping tab) is determined by the value in a register. Optionally, selecting an item from the list can write its 
corresponding value to a register.  

Dates of historical data: When data sampling (Data Sampling Object) or Alarms (Alarm/Event Log) are 
employed, the Option List can be used to list the dates corresponding to Historical data/event files for 
displaying in a Historical Trend Display, History Data Display, or History Event Display. 

Item address: Custom text for the Option List can be stored in registers and changed or updated during 
runtime. 
Control register: Set to 1 to update the item list. 
Control register + 1: Determines the number of items in the list. 
Item address: The starting address for the item list contents (ASCII or UNICODE). 

User account: When “Enhanced Security Mode” is enabled in the System Parameters > Security tab, the 
Option List can display the user names in the drop-down list. With the Monitor address pointing to the 
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Control Address + 2 (Index of accounts register) configured for the Enhanced Security, you can select the 
user name to login from the Option List and the corresponding value will be written to the Index register. 

Slider Object  

The Slider Object is used as a control to change the value in a PLC register, or the value in a register in the 
HMI local memory (LW), based on the position of the slide control. Low and High limits can be configured 
based on constant values or on PLC/HMI register values, and the resolution of the slide control can be 
adjusted to accommodate the range of values in the register. The position of the Slider will change if the 
register value is changed by some other device. 

Function Key  

The Function Key Object is used to change windows, popup a window, return to a previous window, close a 
window, or input data as part of a keypad. It can also be used to execute a macro or print the screen to a 
USB flash drive, SD card, or printer. 

Combo Button  

This button can be configured to perform multiple functions in sequential order and display the state of a bit 
or word as a Bit Lamp or a Word Lamp. Available actions are Set Bit, Set Word, Change Window, Execute 
Macro, and Delay (50ms to 500ms). Up to 20 actions can be selected. 

  The Change Window function can only be executed once by the Combo Button and it must be the last 
action performed. 

  The Delay action can only be executed once by the Combo Button. 

Numeric  

The Numeric Object is used to display the current value in a register and to optionally change the value in 
the register using a popup numeric keypad or external keyboard (iPad or smartphone keyboard for the 
RMI5010). The value can be displayed as BCD, Hex, Binary, or Decimal (signed or unsigned). The Numeric 
Object has the option to read and write to different registers, to set a notification bit when a value is entered, 
and to set a notification bit on an invalid (out-of-range) entry. 

ASCII  

The ASCII Object is used to display the value in one or more registers as text (ASCII characters or Unicode 
characters) and to optionally change the value in the register using a popup ASCII (alphanumeric) keypad or 
external keyboard (iPad or smartphone keyboard for the RMI5010). Up to 64 registers can be written to and 
displayed. 

QR Code  

The QR Code object converts ASCII characters in a series of registers (up to 1024 registers) into a QR Code 
that displays on the HMI screen. The code can then be read by a scanning device (e.g., a mobile phone) to 
display text or go to a website. 
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Correction level: The QR Code object has error correction capability to restore damaged data. Four 
correction levels are available, with each one adding additional amounts of backup data based on the 
amount of damage the QR code is expected to suffer as a result of the image being obscured or unclear. As 
the error correction level increases, the number of rows and columns in the QR code increases to store the 
original data plus the backup codewords. 

Choose Level L for up to 7% damage (25 x 25 array) 
Choose Level M for up to 15% damage (26 x 26 array) 
Choose Level Q for up to 25% damage (28 x 28 array) 
Choose Level H for up to 30% damage (29 x 29 array) (recommended for industrial environments) 

Color: Use this color bar to select the display color of the QR Code on the HMI screen. 

Read address: Select the first address of the block of registers that contain the ASCII data for the QR Code 
(up to 1024 words). Click the Settings button next to the PLC name to open the Address window. Select the 
number of words that contain the ASCII data. 

 

Indirect Window  

The Indirect Window Object is used to display a window based on the value in a register (specified by the 
Read Address). The window whose number appears in the register is displayed within the frame of the 
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Indirect Window. The Indirect Window Object should be the same size as the window(s) that are being 
displayed. If the Indirect Window is too small, some information may not display properly.  Indirect Windows 
can be displayed with or without a Title Bar.  Using a Title Bar allows the window to be moved around the 
screen.  Indirect Windows can also optionally auto-size based on the size of the window being displayed, 
and optionally use an offset value. 

The window is displayed as long as the value in the register contains the window number. Set the value to 
zero (or to a window number that hasn’t been created) to clear the Indirect Window. 

Direct Window  

The Direct Window Object is used to display a window based on the state of a bit in a register (specified by 
the Read Address). The window being displayed is selected in the Attributes section of the Direct Window 
Object’s Properties and appears within the frame of the Direct Window. The Direct Window Object should be 
the same size as the window being displayed. If the Direct Window is too small, some information may not 
display properly.  Direct Windows can be displayed with or without a Title Bar.  Using a Title Bar allows the 
window to be moved around the screen. 

Toggle the bit to turn the window on and off (the window can be triggered to display with bit ON or OFF). 

Moving Shape  

The Moving Shape Object is used to move a shape or picture on the screen based on values in consecutive 
registers (specified by the Read Address). The value in the Read Address register determines the state of 
the object and can be used to change its appearance. The value in the next consecutive register(s) 
determines the position of the part (relative to the object’s initial position, in pixels). The position can be 
defined by X values, Y values, and XY values, where the Read Address + 1 = the X or Y position (for X axis 
only or Y axis only modes), or the Read Address + 1 = the X position and Read Address +2 = Y position (for 
X & Y axis mode). These addresses define the position relative to the upper-left corner of the shape. The 
Min/Max XY values in the Moving Shape object’s properties define the total area within which the object is 
allowed to move, regardless of the values in the controlling registers. 

Animation  

The Animation Object is used to move a shape or picture on the screen based on values in consecutive 
registers (specified by the Read Address). The value in the Read Address register determines the state of 
the object and can be used to change its appearance. The value in the next consecutive register (Read 
Address + 1) determines the preselected position of the part. 

When the Animation Object is selected, the cursor changes to a crosshair (+). Left-click the mouse on each 
location where the object will appear. When all locations have been defined, right-click the mouse to finish 
drawing the object. There must be at least three positions defined. The first location is represented by a 0 in 
the register, the second location by a 1 in the register, and so on. 

Flow Block  

Creates animation along a fixed path to represent flow in a pipe or other transportation line. The speed and 
direction of the animation can be preset or controlled from a PLC register (range of -25 to +25). 

Date/Time  

Displays the HMI Date and Time as text, in one of several formats 



Chapter 6 – Using EZwarePlus  88 

 

EZwarePlus Programming Manual   88 

   

Media Player  

The Media Player Object is used to play a media file on the HMI screen. The media file is stored on a USB 
flash drive or SD card connected to the HMI. Click the Preview tab to load the media file and view the file. If 
the file plays in the Preview tab, it will play in the simulator and the HMI. The media player supports the 
following formats: avi, flv, mov, mp3, mp4, mpg/mpeg, wav, wmv.  

 Not all models support the Media Player. 

The Media Player provides two options for playback control: manual and automatic. Automatic video 
playback begins playing a video immediately when the window containing the media player object is 
displayed. To enable Automatic playback in the Media Player Object’s Properties window, un-check the 
Enable option under the Control address section. 

 

 

To enable manual video control in the Media Player Object’s Properties window, check the Enable box 
under the Control address section. Enabling the control address provides control for functions such as play, 
pause, stop, seek, zoom, and volume adjustment. These control functions are managed by setting the 
parameter 1 and 2 register values and writing the command value to the command register. The Media 
Player control address defines a series of registers used to manipulate the various video playback control 
functions. 
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The command register address is defined on the General tab in the Media Player Object’s Properties 
window. The subsequent register addresses contain additional parameters and video playback information 
as indicated below. 

Enable: When enabled, the Control address and subsequent registers controls  the operation of the Media 
Player. When disabled, video playback will begin automatically when the window opens with the first video in 
the designated folder. 

Command (Command + 0): This register controls the operation of the Media Player (see table below for 
command options). 

Parameter 1 (Command + 1): Used in conjunction with the Command +0 register (see table below). 

Parameter 2 (Command + 2): Not currently used. 

Status (Command + 3): Indicates the status or errors. 
Bit 0 = File open 
Bit 1 = File playing 
Bit 8 = Command error 
Bit 9 = File format or loading error 
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File index (Command + 4): Contains the index number of the file being played. The HMI will write the file 
index value to this register when the video begins.  
When multiple media files are available, name them with the following format: 
n_NAME, where n is an integer starting at 1. 

Start time (Command + 5): Contains the time index (seconds) at which to start the file (default is 0). 

End time (Command + 6): Contains the time index (seconds) at which to end the file (default is the run time 
of the file). 

Update video playing time: When checked, the Media Player will write the elapsed time of the media file 
into the Playing time register (Command + 7). 

Update period: Defines how often the Media Player writes the elapsed time of the media file into the Playing 
time register (1-60 seconds). 

Ext. device: Determines which external device contains the media files to be played, SD card, USB 1, or USB 
2. (USB 1 is the first USB device connected to the HMI and USB 2 is the second USB device connected.) 

Folder name: Specifies the folder on the USB device where the media file(s) reside. The root folder is not 
allowed and only one level is supported. For example, an entry of “video” specifies the folder “video” on the 
USB or SD device, and is allowed. An entry of “video\files” specifies the folder “files” under the folder “video,” 
and is not allowed. 

  The folder name cannot be empty and cannot contain the following characters: / \ : * ? “ < > |. 

Auto repeat: When checked, the selected media file will restart after it has finished playing. If multiple files 
are present, all the files will be repeated (for example, [video 1] > [video 2] > … [video n] > [video 1] > etc.). 

Background: Sets the background color of the Media Player, visible if the media being played does not 
completely fill the Media Player’s outline. 

Media Player Commands 

Command Parameter 1 Parameter 2 Function 

1 0, 1, 2, … 0 
Plays the file indicated by Parameter 1, where 0 is the 
first file in the specified folder, 1 is the second file, etc. 
Files are sorted in numerical and alphabetical order. 

2 0 0 Play the previous file. Files are sorted in numerical 
and alphabetical order. 

3 0 0 Play the next file. Files are sorted in numerical and 
alphabetical order. 

4 0 0 Play / Pause toggle. 
5 0 0 Stop playing and close the file. 

6 1 to n-1 0 
Start playing the file at the point specified by 
Parameter 1, where n is the length of the file in 
seconds. 

7 1 to n-1 0 
Jump ahead to the point in the file specified by 
Parameter 1, where n is the length of the file in 
seconds. 

8 1 to n-1 0 
Jump back to the point in the file specified by 
Parameter 1, where n is the length of the file in 
seconds. 

9 0-128 0 Volume level. 

10 0-16 0 
Zoom level. 0 causes the video to fit the display 
object size; non-zero values adjust the magnification 
in 25% increments: 1=25%, 2=50%,…16=400%. 
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Click the Preview tab to load the media file and view the file. If the file plays in the Preview tab, it will play in 
the simulator and in the HMI. 

 

Video In  

The Video In object can display analog video on the HMI5121P and HMI5150P.  USB video can be 
displayed on the HMI5070P/5121P/5150P, and the HMI5121XL/5150XL/5097XL/5097NXL/5097DXL. Analog 
and USB video have different capabilities. 
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Analog Video 

 

 

One of two video input channels can be selected either in the program or dynamically using a PLC register. 
The composite video inputs can be configured to accept NTSC or PAL video formats. A capture function and 
a control function can be enabled that allows the value in a PLC register to control and capture images of the 
video input. 
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Recommended Format and Resolution 

 100% (1:1) 50% (1:2) 

NTSC 720 x 480 360 x 240 

PAL 720 x 576 360 x 288 
 

A capture function allows capturing video images and storing them as *.jpg files on a USB flash drive or SD 
card. The video capture is triggered by a PLC or local bit (OFF > ON) and can be configured to capture video 
once per second for a period of time defined by the Record time. The time Before and time After define the 
time period (up to 10 seconds each) before and after the trigger during which the video capture takes place. 
A buffer memory stores 10 seconds of captured video when the capture function is enabled. The capture 
function will work even if the video is in Pause mode.  

The file format for captured video before and after is: 
YYYYMMDDhhmmss.jpg 

The file format for captured video at the moment the capture was triggered is: 
YYYYMMDDhhmmss@.jpg 

USB Video 

Video is captured from an external USB camera. The size of the object at runtime may not be the same as 
what was configured. The Video In (USB) object will resize based on the size of the image from the camera. 
On the HMI5070P, the maximum size of the object is 340x240 pixels. On the HMI5121P/5150P and 
HMI5121XL/5150XL, the maximum size is 640x480. The object must be at least 50 pixels from the bottom 
right corner of the window it is placed on. If the camera is unplugged, the display will go blank. When the 
camera is re-connected, the display can be restored by using the Control Address, by switching screens, or 
by restarting the HMI. 

When using a USB camera, the capture function can only capture the current moment; it does not have 
buffering capability. The captured video is saved to SD card only. The file format for captured video is: 
YYYYMMDDhhmmss.png 

OS versions that support USB camera: 

Model OS Version (or later) 

HMI5070P 20140116 

HMI5121P/5150P 20140701 

HMI5121XL/5150XL/5097XL/5097NXL/5097DXL 20140624 

RMI5001 20140807 
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A control function can be enabled that allows the value in a PLC register to control the video input. For 
example, if the Control address is set to LW-n, where is any LW address, the designated and subsequent 
addresses will execute the following commands: 

Address Value Command 

LW-n 

0 

1 

2 

3 
 

4 
 

Stop displaying image 

Open channel 1 and display the image on HMI 

Open channel 2 and display the image on HMI 

Open channel 1 but don’t display the image on HMI  
(capture function operable) 

Open channel 2 but don’t display the image on HMI  
(capture function operable) 

LW-n + 1 1 Pause/resume the video (register resets to 0 after command 
is executed) 

LW-n + 2 * 1-100 Adjust the contrast ratio (analog video only) 

LW-n + 3 * 1-100 Adjust the brightness (analog video only) 

 
* Display adjustment must be selected. 

  If the Control function is not enabled, use the Input channel field to select the channel to play. 
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Bar Graph  

The Bar Graph Object is used to display register data in a bar graph display. It can be configured to have 
alarm indicators using different colors on the bar graph to provide a warning when the value in the register is 
approaching a maximum or minimum allowable value. 

Meter Display  

The Meter Display is used to display register data in an angular position on an analog-style meter. The scale 
(tick marks) can be adjusted around the circumference of the meter and the pointer style can be changed. 
Scale values can be assigned to the tick marks by assigning a span range (e.g., 0-100).  

It can be configured to have alarm indicators using different color bars around the inside of the meter to 
provide a warning when the value in the register is approaching a maximum or minimum allowable value. 

Pie Chart  

The Pie Chart object can display data from up to 16 consecutive registers as a pie chart. The Pie Chart is 
divided into segments to illustrate the numerical proportion of the values in the designated channels’ 
addresses. The Pie Chart can display actual values on each slice, percentage, or none. 
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Angle: The Angle dialog box allows you to determine the start and stop point in degrees (0-359) of the data 
in the Pie Chart or if it is displayed as a full circle. You can also select whether the data is displayed in a 
clockwise direction or counterclockwise. 

 

Hole: Use this slider control to adjust the diameter of the center hole in the Pie Chart. 

No. of channels: Select from two to 16 channels to display in the Pie Chart. 

Border color: Use this color palette to choose the color of the border around the Pie Chart. This is also used 
to determine the color of the segment lines within the chart. 

Style: Select None to have no label on the segments of the Pie Chart. With Value selected, the actual 
values contained in the registers is displayed on each segment. You can select the Font, Size and number 
of digits Right of decimal point. With Percentage selected, the percentage of each segment with respect to 
all of the channels is displayed. 

Read address: Select the first address to be displayed. This is for channel 1. The next consecutive address 
will be channel 2 and so on, up to 16 channels. 

Channel: Select each channel and adjust the Text color, Background color, Pattern color, and Pattern 
style individually for each channel. 

 The Pie Chart object is not available for the RMI5010. 

Dynamic Scale  

The Dynamic Scale object allows the user to create a vertical, horizontal, or circular scale with dynamic or 
fixed high and low limits. The interior tick mark values are then interpolated based on the number of tick 
marks, the number of displayed digits, and the high and low values. Click the Dynamic Scale icon on 
the toolbar or select Dynamic Scale from the objects menu to create the object. 
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General Tab  

 

Style – From the drop down menu select Circular, Horizontal, or Vertical to choose the style of scale. 

Angle – For Circular scales click the Angle button to open the Degree dialog shown. 

Direction – Sets the direction for the scale as either 
Clockwise or Counterclockwise. 

Degree – Start sets the value for the starting point of the 
scale in degrees. When Full Circle is unchecked End 
sets the value for the ending point of the scale in degrees. 

 

 

Tick Mark  

For Horizontal and Vertical scales the length of the individual tick marks is dictated by the size of the object. 
To make the tick marks smaller or larger change the size of the object. For the Circular scale the radius of 
the circle, and the length of the major and minor tick marks are adjustable with sliders. 

Color – sets the color of the tick marks 
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Main Scale – sets the number of tick marks for the primary scale. These will have numbers on them. 

Sub scale – sets the number of tick marks for the minor scale. These do not have numbers on them. 

Scale Label – Circular 

 

Use scale label – When checked the scale will include numeric labels on the main tick marks. 

Font, Color, and Size – These adjust the appearance of the scale labels.  

Right decimal Pt: - This sets how many digits appear after the decimal point on the scale labels. 

Radius – This adjusts the position of the scale labels relative to the total scale radius. 
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Scale Label – Horizontal/Vertical 

  

Use scale label – When checked the scale will include numeric labels on the main tick marks. 

Font, Color, and Size – These adjust the appearance of the scale labels.  

Left decimal Pt: - This sets how many digits appear before the decimal point on the scale labels. 

Right decimal Pt: - This sets how many digits appear after the decimal point on the scale labels. 

Position – This sets the position for the scale labels. Right/left for horizontal, and top/bottom for vertical. 

Dynamic Limits – When unchecked the Top and Bottom (maximum and minimum) scale values are 
specified here. When dynamic limits is checked the max. and min. values for the scale are read from the 
specified register and the next address. 
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Data Block Display  

The Data Block Display Object is used to draw line graphs of the data contained in consecutive registers (up 
to 1024 consecutive registers). In addition, up to 12 individual sets of data can be displayed in the Data 
Block Display. The line graphs can display data in any supported format, but the data in each graph must be 
of the same format. 

The Y-axis scaling is configured on the General tab with the Minimum and Maximum Limit fields (this 
defines the bottom and the top of the Data Block Display and should contain the range of data values). The 
X-axis scaling is configured on the Display Area tab in the Data Samples field (this defines the number of 
data samples to plot on a single screen). 

The Control address specifies the address to use to control the selected channel (data set). Each channel 
has its own Control Word address. 

XY Plot  

The XY Plot Object is used to plot one series of values against another series of values on a line graph. 

The direction of the plot is defined in the Direction field as follows: 

Direction Result 

Right The origin is at the lower left. The X-axis moves to the right, the Y-axis moves up. 

Left The origin is at the lower right. The X-axis moves to the left, the Y-axis moves up. 

Up The origin is at the lower left. The X-axis moves up, the Y-axis moves to the right. 

Down The origin is at the upper left. The X-axis moves down, the Y-axis moves to the right. 

 

The No. of channels field specifies the number of datasets to plot (up to 16 channels). 

The Control Address specifies the address to use to control how the XY Plot operates. The following values 
can be written to the Control Address to control the plot: 

The No. of data address field is automatically assigned to the next consecutive address after the Control 
Address. It must be loaded with the number of pairs of X-Y data to plot. This value must be set before a 
trigger value is written to the Control Address. Up to 1023 data points can be plotted per channel. 

The Read address field is the starting address of the data to plot. Each channel has its own Read address. 
Normally, the X and Y data are read from two consecutive addresses beginning with the Read address. To 
have the XY Plot use separate addresses for X and Y data, check the Separated address for X and Y data 
checkbox. Separating the X and Y data addresses also allows the X and Y data to have different formats. 
The first Read address field defines the X-axis data and the second Read address field defines the Y-axis 
data. 

The X-axis and Y-axis scaling is configured in the Limits section on the General tab. The Low and High 
limits define the left-to-right range and the bottom-to-top range for the X-axis and Y-axis respectively. 

If Dynamic limits is checked, the limits are read from registers. 

The appearance of the plot is configured on the Display Area tab, including the frame and background color 
of the display, and the color and width of the plot line. The Maker area lets you configure how the data for 
each channel is plotted: 
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Line: The data is plotted as a Line graph, with squares plotted at each data point. 
Point: The data is plotted as squares at each data point. 
X-axis projection: The data is plotted as a line graph (no squares). The plot is filled along the X-axis. 
Y-axis projection: The data is plotted as a line graph (no squares) with the X and Y data transposed. The 
plot is filled along the Y-axis. 

The Reference line section lets you configure up to four horizontal lines that can be drawn across the plot. 
Each line can be enabled separately, and can have a unique color and position. The position specified for 
each line is relative to the values entered in the Low Limit and High Limit fields. If the Limit from PLC box 
is checked, the reference lines are referenced to the values entered in the specified register addresses (low 
limit = value in register address; high limit = value in register address + 1). 

Recipe View  

The Recipe View is used to display recipe data on the HMI screen. The recipes are created on the Recipe 
tab in the System Parameters and the data is stored in the recipe database file (*.db). Recipe data cannot be 
edited in the Recipe View table. However, Numeric Input objects can be used to enter or change recipe data 
by selecting the Recipe Device Type in the address field and selecting the Recipe and Item to be edited. See 
“Chapter 16 – Recipes” for more information. 

Picture View  

Displays images stored on an attached SD or USB storage device.  This includes screen images captured by 
the HMI, and stills captured from the video input(s). Supported picture formats include *.jpg, *.bmp, *.gif, and 
*.png. The file name must contain ASCII characters only; Unicode characters are not supported. 

Picture files are displayed in numerical and alphabetical order. In order to have the files displayed in a 
particular order, add an alphabetical prefix to the file name. For example: 
A_name 
B_name 
C_name 
… 
AA_name 
AB_name 
AC_name 
etc. 

Dynamic Drawing  

The Dynamic Drawing object enables drawing a shape in a specified region on the HMI screen. The shapes 
supported are line, rectangle, circle, or dot. The style, color, and pattern can be adjusted with the Attribute 
Addresses. When a value is written to the specified Attribute Address (AA-0, Shape) the shape specified by 
AA-0 is drawn into the drawing area with the attributes specified by the remaining attribute addresses (AA-1 
to AA-8) 
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General Tab 

 

The Clear Address specifies the register address used to clear all the contents in the drawing area. When 
this bit is set to 1 everything in the drawing space is erased. 

The Attribute Address specifies the register of the first attribute, shape. There are nine attributes in total. 
They are stored in the specified register and the next eight sequential registers. The following tables gives 
the location and effect of different attribute settings. 
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The value of attribute address +2 (AA+2) determines either the line style or pattern mode depending on 
which shape (AA+0) and style (AA+1) are chosen according the following table. 
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Color Tab 

 

The color tab allows the user to specify which colors are assigned to the attribute values in inner color 
(AA+3) and pattern color (AA+4). The nine colors shown are the default values. These can be removed 
using Delete and additional colors can be added from the color palette using New. 

On the Profile Tab the user can modify the position and size of the drawing area placed on the HMI window. 

Data Sampling  

The Data Sampling Object is used to create Data Logs. A Data Log gathers data that can be saved as 
History files to the HMIs internal memory, or to a compact flash, SD card, or USB drive (depending on the 
model). That data can then be displayed in a Trend Display or History Data Display in real-time or historical. 
The data can then be displayed in a Trend Display in real-time, and data files from previous days can also be 
displayed in History mode. The History Data Display can also display historical data in a table format. 

The data files can also be transferred to a PC and saved in *.csv or *.xls format using the EasyConverter 
application (included with EZwarePlus). 

Note: Every 60 seconds, the HMI checks to see if the size of the updated data file exceeds 4000 bytes. If so, 
the data file is written to non-volatile memory. 

Sampling can be configured to occur periodically (Time-based) with sampling intervals ranging from 0.1 
second to 120 minutes, or it can be triggered by the state of a bit (Trigger-based). The Read address 
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defines the starting address of the data samples and the Data Record area allows you to configure how 
many consecutive registers to sample. Up to 40 Data Sampling objects can be created. 

The High Priority option enables the HMI to place a higher priority updating a Data Sampling object than 
objects displayed on the HMI screen. This helps to ensure that the sampling time interval is met. Note that 
enabling the High Priority option on many Data Sampling objects may slow down the update rate for other 
objects. 

The Data Format button opens a dialog to configure the format of a data log record. A record is a single line 
or group of lines of data. Different data formats can be used within the same record. When multiple items are 
configured in the same record, consecutive addresses are used beginning with the address specified in the 
Read address. The number of registers is determined by the number of items defined in the Data Format 
list and the size of each item (i.e., 16-bit or 32-bit). The first item is read from the specified Read address, 
the next item is read from the address after the Read Address, etc. 

Note: When creating a Data Sample for use with a multi-pen Trend Object, use the Data Format button to 
configure the data for each of the trend's pens. Each additional item in the Data Format list will use the next 
consecutive address from the specified Read Address. 

Clear real-time data address: when the specified bit goes into the selected condition, the Real-Time Trend 
display associated with this Data Sample will be cleared. Logged data will not be affected. 
(Not supported in the RMI5010.) 

Hold address: when the specified bit goes into the selected condition, data collection will pause. Data 
collection will resume when the bit goes back its original condition. 

Save to HMI memory: when checked, historical data will be saved in HMI internal memory. 

Save to SD card: when checked, historical data will be saved in the SD card inserted into the HMI. 

Save to USB disk: when checked, historical data will be saved in the USB device inserted into the HMI. 

  To save historical data, one of the Save to options must be selected. Only one of the three Save to 
options can be selected. Some HMI units support either USB or SD, but not both. 

  The RMI5010 has Sync. To SD card and Sync. To USB disk options. When the sampled data reaches 
10,000 records, the sampled data is automatically saved to the selected external device and the earliest 
1000 records are deleted from RMI5010 memory. The sampled data can be sync’d manually by enabling the 
Control address and writing a ‘2’ to the Control register. 

Each File Consists of all Records of a Day: One data file is created for each day. The data file has a file 
name of the form yyyymmdd.dtl, where yyyy is the four-digit year; mm is the two-digit month (01 for January, 
12 for December); dd is the two digit date. A new file is created at midnight. This is the default setup. 
(Not supported in the RMI5010.) 

Customized File Handling: When this mode is selected, a dialog is available that allows the user to specify 
the name of the log file, as well as when a new file is created. The file name supports 2- and 4-digit year, 
month, day, year, hour, minute, and second. In addition, static text may be embedded in the name. A new 
file can be created either when a user-specified bit changes state, or when the log file reaches a preset 
number of records. 
(Not supported in the RMI5010.) 

Folder Name: Specify the name of the folder in which the log files will be stored on the selected Save To 
device. 

File name example: shows the format of the log file name. 
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Preservation limit: select the number of days of data to keep. Data outside this limit will be deleted. 

Trend Display  

The Trend Display Object is used to display real-time or historical data collected by the Data Sample Object 
on a line graph. Up to 20 channels can be displayed on the graph with data collected from consecutive 
addresses, and with different colors assigned to each channel (pen).  

The Y-axis scaling is configured on the Channel tab with the Zero and Span fields (this defines the bottom 
and the top of the Trend Display and should contain the range of values in the data sample). The X-axis 
scaling is configured on the General tab with the Distance between data samples section. There are two 
options: Pixel (number of pixels between samples – Millimeter in the RMI5010) and Time (sets the width of 
the entire Trend Display in seconds).  Setting the x-axis scaling to a register allows the width of the trend to 
be adjusted on-the-fly.   

When using the RMI5010, the x-axis is not adjustable.  The display device (RMI5090 or tablet) supports 
’pinch and zoom’ functionality. 

In Real-time mode, data is displayed on the graph as it is generated. In History mode, data is plotted from 
data log files saved in memory. A new data log file is created each day and can be displayed in the Trend 
Display by changing the value in the History Control register. When the value in the History Control register 
is 0, the data for today is displayed on the trend. When the value is 1, the data from yesterday is displayed, 
etc. 

  For the RMI5010, the Trend Display combines Real-time and History modes. You can select the range of 
data to display by touching the icon in the upper-right corner of the Trend Display to open the Option 
window. When using an iPad or smartphone, swipe your finger left and right on the Trend Display to view 
older or newer data. Use two fingers to zoom in and out on the Trend Display’s data. 

See “Chapter 12 – Creating Data Sampling Objects and Trend Displays” for more information. 

Circular Trend Display  

Configuration of the Circular Trend Display is very similar to the Trend Display. It monitors data in single or 
multiple PLC registers and plots the data on a circular graph (polar coordinate system) where the 
circumference represents time (angular coordinate) and the radius represents the range of data (radial 
coordinate). 

The Zoom in/out register enlarges and reduces the magnification of the object on the HMI screen. The 
maximum size is 10 times larger. If a larger number is entered, it will remain at 10x. When magnified, use the 
scroll controls to navigate around the Circular Trend Display. 

  The Circular Trend Display is not supported in the RMI5010. 

History Data Display  

The History Data Display Object is used to display historical data collected by the Data Sample Object in a 
table format. Up to 16 channels of data can be displayed from consecutive addresses, and can be any mix of 
data types (e.g., 16-bit unsigned, 16-bit signed, 32-bit float, etc.). 

Note: The History files section in the Data Sampling Object must have a box checked (e.g., Save to HMI 
memory) and a Folder name defined in order for the data files to be stored and displayed in the History 
Data Display. 
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The History Control register is used to select the historical data file to display. When the value in the History 
Control register is 0, the data for today is displayed in the table. When the value is 1, the data from yesterday 
is displayed, etc. 

Event (Alarm) Log  

The Event (Alarm) Log Object is used to configure alarms and events. Select one of the History files 
checkboxes to save alarm/event files in HMI memory or to an SD card or USB flash drive. This is used when 
an Event Display is configured for History mode. The Preservation limit lets you limit the number of history 
files to save. A new file is created each day with the filename EL_yyyymmdd.evt where yyyy=year, 
mm=month, and dd=day. For example, the file for June 12, 2010 would be EL_20100612.evt. 

  The RMI5010 has Sync. To SD card and Sync. To USB disk options. When the Event Log data reaches 
10,000 records, the data is automatically saved to the selected external device and the earliest 1000 records 
are deleted from RMI5010 memory. The Event Log data can be sync’d manually by enabling the Control 
address and writing a ‘2’ to the Control register. 

Click the New button to create a new alarm/event. An alarm/event can be triggered by a bit or a word. The 
Notification field can be configured to set or clear a bit when the alarm is triggered. The Follow option 
resets the Notification bit automatically when the alarm/event has returned to its normal state. 

The Message tab allows you to enter a message that will appear in the Alarm Bar, Alarm Display, or Event 
Display when the alarm/event is triggered. The Write value for Event Display object is used to enter a 
window number that is written to the Write address configured in the Event Display object. This window 
number is used by an Indirect Window configured to popup when an alarm/event is acknowledged. 

For HMI5000 models with the audio line-out option, a sound can be played when the alarm/event is 
triggered. Click the Enable button and select a sound from the Sound Library. 

The WATCH addresses can be used to display the data in up to four registers in messages. Click the 
Syntax button to see how to configure the message to display the data. 

See “Chapter 13 – Capturing Alarms and Events” for more information. 

Alarm Bar  

The Alarm Bar Object is used to display alarms detected by the Alarm (Event) Log Object. It displays the 
alarm message for each current alarm in a single horizontal scrolling line across the Alarm Bar’s display. 
Only the most recent alarm appears in the Alarm Bar. 

Alarm Display  

The Alarm Display Object is used to display alarms detected by the Alarm (Event) Log Object. It displays the 
alarm message for each alarm in a table format arranged in chronological order. All current alarms are 
displayed in the Alarm Display and are removed from the list once the alarm condition is cleared. 

An Alarm Acknowledge function can be enabled, which provides a Write address for the Alarm Display. 
Each alarm/event can be acknowledged by touching the message in the Alarm Display. A different color can 
be assigned for the Acknowledge status. 

An Indirect Window can be configured to popup when the alarm/event is acknowledged to provide additional 
information to the operator on how to proceed. The Indirect Window should be placed on the same window 
as the Alarm Display. The window number is configured in the Alarm (Event) Log’s Message tab (Write 
value for Event Display object) and is written into the Write address assigned in the Event Display. 



Chapter 6 – Using EZwarePlus  108 

 

EZwarePlus Programming Manual   108 

   

Event Display  

The Event Display Object is used to display alarms or events monitored by the Alarm (Event) Log Object. 
Events can be displayed in Real-time or History mode. In Real-time mode, each alarm/event can be 
acknowledged by touching the alarm/event in the Event Display. Different colors can be assigned for the 
Acknowledge and Return To Normal statuses.  

  For the RMI5010, the Event Display combines Real-time and History modes. You can select the range of 
events to display by touching the icon in the upper-right corner of the Event Display to open the Option 
window. When using an iPad or smartphone, swipe your finger up and down on the Trend Display to view 
older or newer data. 

An Indirect Window can be configured to popup when the alarm/event is acknowledged to provide additional 
information to the operator on how to proceed. The Indirect Window should be placed on the same window 
as the Event Display. The window number is configured in the Alarm (Event) Log’s Message tab (Write 
value for Event Display object) and is written into the Write address assigned in the Event Display. 

In History mode, alarm/events from previous days can be displayed. The Write address changes to 
History Control address, and the value in the History Control register determines which historical data is 
displayed. When the value in the History Control register is 0, the data for today is displayed in the Event 
Display. When the value is 1, the data from yesterday is displayed, when the value is 2, the data from two 
days ago is displayed, etc. Use the Option List configured for “Source of item data: Dates of historical data” 
to select the day by date. 

Check Enable reading multiple histories to display events from more than one day at a time. There are 
two modes:  

With Number of days selected, the value entered in the History control register determines the 
starting day (most recent, where 0 = today) and the value in the History control register + 1 
determines the number of days of data to display (including the starting day). If three days are 
selected, but only two event files are included within the three day period, only two event files will be 
displayed. 

With Index of the last history selected, the value entered in the History control register determines 
the starting day (most recent, where 0 = today) and the value in the History control register + 1 is the 
number of event files to display. This setting is not dependent on the date and the Event Display will 
display the designated number of event files from most recent to oldest. 

  The Event Display can display up to 4MB of historical data. If the combined file size of the 
selected historical data exceeds 4MB, the most recent data is displayed and the oldest data beyond 
4MB is not displayed. 

Select Enable event management to control which events to display or hide, and allow users to delete 
selected events. 

Data Transfer (Trigger-based)  

The Data Transfer (Trigger-based) Object is used to transfer word-based data from the specified Source 
address(es) to the specified Destination address(es). This can be used to transfer data from one device to 
another. 

The Source and Destination address fields define the starting addresses, and the No. of words field 
specifies how many consecutive addresses are transferred. The data transfer can be triggered by touch 
(Touch trigger mode) or by an external or internal bit (External trigger mode). 
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Backup  

The Backup Object is used to copy recipe files (*.rcp or *.db), event log files (*.evt), data log files (*.dtl or 
*.db), and operation log files (*.db) from the HMIs internal memory to a USB flash drive, SD card, or a PC 
running EasyPrinter connected via Ethernet. If the e-Mail function is enabled in the System Parameters, files 
can be emailed to a list of recipients with the Backup object. 

  The L Series do not support SD cards. 

  Since the event log files and data log files in an RMI5010 can be sync’d to a USB flash drive or SD card, 
email is the only option available for backing up these files with the RMI5010. 
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When Historical event log or Historical data sampling is selected, the historical event logs or data logs 
can be saved in their native file formats (*.evt or *.dtl respectively) or in *.csv format. When Comma 
Separated Values (*.csv) is selected, you can choose whether or not to include a Byte Order Mark (BOM) 
to the file header (used to signal the order of bytes in a text file) and whether or not to Include time 
information in the data log file. If include time information is selected you also have the option to include 
millisecond (ms) information. 

The event log file contains five columns; Event, Category, Date, Time, Message. The Event column 
indicates the type of event as follows: 

 

0 = Event is triggered 
1 = Event is acknowledged 
2 = Event returned to normal 

  Use EasyConverter to open an event log file (*.evt), data log file (*.dlt), or SQLite database file (*.db; 
RMI5010). 

The range of history files can be selected and the backup can be triggered by touch (Touch trigger mode), 
by an external or internal bit (External trigger (bit)), or by an external or internal word (External trigger 
(word)). 

When External trigger (word) is selected for the Trigger Mode, the following registers control the Backup, 
allowing the operator to define what files are backed up: 
Trigger address: When the value changes from 0 to 1, the backup is triggered. When the backup is 
complete, the Trigger address is automatically reset to 0. 
Trigger address + 1: Defines the start day for the backup. 
Trigger address + 2: Defines the range of days to backup (maximum 90 days). 

When the backup process starts, local bit LB-9039 is set. When the backup is complete, local bit LB-9039 is 
reset. 

The Advance tab provides the option of adding a 5-digit serial number to the name of the file being backed 
up, with a range of 00000 – 65535. 
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The value contained in the Source register is appended to the backup filename, after the date code but 
before the file extension. The 5-digit serial number is padded out to five digits with leading zeros if the 
number is below 10000. Select Remove old files after backup to delete old history files after backup. 

  The native *.dtl or *.evt Storage format must be selected in order to enable the serial number option. 

  If the Remote printer/backup server is selected for the Backup position, the option to Remove old files 
after backup is disabled.  
(Use HMI Remote Printer/Backup Server must be enabled on the Printer/Backup Server tab in the System 
Parameters in order for this backup option to be available.) 

  The Advance tab is not available for the RMI5010. 

If e-Mail is selected for the Backup position, click on the e-Mail tab to configure the recipients of the email 
as well as the Subject line and message. 



Chapter 6 – Using EZwarePlus  112 

 

EZwarePlus Programming Manual   112 

   

 

Select Add .txt extension to the filename to skip the anti-virus detection if the intended recipient’s email 
server blocks the file attachment. 

Timer  

The Timer Object is used to control an output bit based on the state of an input bit and a measurement bit 
that is controlled by a preset time. There are five different configurations or modes for the timer including On 
Delay, Off Delay, Pulse, Accumulated On Delay, and Accumulated Off Delay. 

When placed on a base window, the timer object is active only when that window is showing on the HMI. 
When placed on the Common Window (Window 4), the timer object is active at all times, regardless of which 
window is displayed on the HMI. 

  With the RMI5010, the Timer Object runs in the background and is active at all times. 
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PLC Control  

The PLC Control Object is used to perform a number of background tasks. Click the New button to set up a 
control object. Click Type of control to open a drop-down box with the following options: 

Change Window 

This causes the HMI to close the currently-displayed Base Window, and display the Base Window whose 
number is in the specified Trigger address. 

The Change Window action occurs only when the HMI detects a change in the value of the specified Trigger 
Address. After the window is changed, the HMI will write the number of the newly-displayed window to 
(Trigger Address +1). 

Note: Several options are available in the Attribute section.  

Active only when designated window opened: This option removes the global feature of the PLC Control 
Object so the trigger address is only monitored by the HMI when the selected window is open. It also 
changes how the PLC Control Object handles an unchanged trigger address. By default the PLC Control 
Object is always monitoring the trigger address and only looks for a change in the data to call a new base 
window. When a designated window is selected, the PLC Control Object checks the trigger address each 
time the designated window is opened and will change to the screen in the trigger address regardless of 
whether it has changed.  

Turn on Back Light: This overrides the screen saver option in the HMI and turns on the backlight when the 
PLC object calls a new screen.  

Clear Data after window changed: This option clears the trigger address back to 0 when the window is 
changed. This allows the PLC Control Object to call the same window again in the future. Since the PLC 
Control Object is looking for a change in the trigger address, leaving the last selected window number in the 
trigger address would prevent the PLC Control Object from calling that same window again. If Active only 
when designated window is also selected the trigger address will be read each time that the designated 
window is opened, so clearing the data is necessary to prevent the PLC Control Object from triggering each 
time the designated window is selected. 

Use window no. offset: This option allows the user to designate a numeric offset to the selected window 
number. For example, if the PLC writes a 20 to the trigger address and the offset is set at -2, then window 18 
(20-2) would be called on the HMI. 

Write data to PLC (current base window) 

When the HMI initializes, and when the Base Window changes (for any reason), the number of the new Base 
Window is written to the PLC Register specified by the Trigger address. 

General PLC Control 

Executes a data transfer of up to 32 words from the HMI to the PLC or from the PLC to the HMI when the 
value in the Trigger Address is set to a valid operation code. After the operation is complete, the HMI sets 
the value in the Trigger address to 0. A total of four values are needed to configure the General PLC Control 
attribute. 

Note: The HMI will transfer data to/from the Device Type specified by the Trigger address. 

It is recommended that the data in (Trigger Addr + 1), (Trigger Addr +2), and (Trigger Addr +3) be set before 
writing the Operation Code to (Trigger Addr). 

mk:@MSITStore:C:%5CMapleSystems%5CEZ5000%5CEasyBuilder5000.CHM::/BASE_WINDOW.htm
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(General PLC Control is not supported in the RMI5010.) 

Backlight Control (Write Back) 

Allows the PLC to control the HMI’s backlight via the bit specified in the Trigger address. Once the requested 
operation has been performed, the HMI will reset the bit. 

Note: The PLC Control Object may be configured with two Backlight Control (Write Back) items, with 
different bits for the On and Off control. The backlight can then be controlled directly from the PLC. 

(Backlight Control (Write Back) is not supported in the RMI5010.) 

Backlight Control 

Operates the same as the Backlight Control (Write back) attribute described above, but the HMI will not reset 
the bit specified in the Trigger address. 
(Not supported in the RMI5010.) 

Sound Control 

Plays the selected sound when the bit specified by the Trigger address matches the trigger mode conditions. 
(Not supported in the RMI5010.) 

Execute Macro Program 

Executes the designated macro when triggered by the bit specified in the Trigger address. 
Note: Only available when a macro has been created in the project. 

Screen Hardcopy 

Prints the specified window when the bit specified by the Trigger address matches the trigger mode 
conditions. The Source window for print option provides the following selections: 

Current base window: When the trigger occurs, the window currently displayed on the HMI is printed. 
Window no. from register: When the trigger occurs, the window number is read from the specified register; 
the window is displayed and printed. 
Designate window no.: The window is selected from a list during project development. When the trigger 
occurs, this pre-selected window is displayed and printed. 

The Printer field allows you to select the destination for the screen hardcopy: a printer attached to the HMI, 
an SD or USB device, or the Remote Printer Server. If an SD or USB device is selected, the file is saved as 
a JPEG image, named as <yymmdd>_nnnn, where nnnn is a four-digit serial number. If the Customized 
File Handling option is checked, the Settings button appears and allows customization of the file name and 
the folder in which the file is stored. 

(Screen Hardcopy is not supported in the RMI5010.) 

Data Transfer (Time-based)  

The Data Transfer (Time-based) Object is used to transfer bit-based or word-based data from the specified 
Source address(es) to the specified Destination address(es) at periodic intervals. The interval is adjustable 
from 0.5 to 25.5 seconds, in 0.1 second steps. 

The Address type selects whether the data transferred is word or bit, and the No. of word/No. of bit field 
specifies how many consecutive addresses are transferred. The Source and Destination address fields 
define the starting addresses.  
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Note: When transferring bits, bits can only be transferred to the local HMI’s internal memory. It is not 
possible to transfer bits to a remote HMI or another PLC. 

System Message  

The System Message is used to customize the content of system-generated messages. 

Confirmation required: Message that is displayed when confirmation of an operation is required. 
Deny write-command: Message that is displayed when the HMI Monitor Mode is turned ON with LB-9196. 
Allow write-command: Message that is displayed when the HMI Monitor Mode is turned OFF with LB-9196. 

Scheduler  

The Scheduler is used to change a bit or a word based on a time schedule. Each scheduled action can have 
a start time and an end time. Up to 32 items can be entered in the Scheduler list. 

Power-ON start/end action: Determines the action to perform when the HMI is turned ON.  
When checked: If the HMI is turned ON within the scheduled time range, the start action is performed 
immediately. If the HMI is turned ON outside of the scheduled time range, the end action is performed 
immediately (if enabled). 
When unchecked: If the HMI is turned ON within the scheduled time range but after the start time, the start 
action is not performed but the end action is performed (if enabled). If the HMI is turned ON outside of the 
scheduled time range, no action is performed. 

Action modes include Bit ON, Bit OFF, or Word write. 
Bit ON: Start action sets the Action address bit. End action clears the Action address bit. 
Bit OFF: Start action clears the Action address bit. End action sets the Action address bit. 
Word write value settings – Constant: Start action writes the Start value into the Action address 
register. End action writes the End value into the Action address register. 
Word write value settings – Address: Start action writes the value stored in the designated register into 
the Action address register. End action writes the value stored in the designated register+1 into the Action 
address register. 

Note: The end action is only available when Enable termination action is checked on the Time Set tab. 

Click the Time Set tab to configure the start and end times for the scheduled action. When Constant is 
selected, the action is configured to occur on the specified days at the specified times. Multiple days can be 
selected. If the start and end times need to span several days, select the Setting on individual day 
checkbox. 

When Address is selected, the start and end times are determined by values in 11 consecutive registers 
beginning with the designated Time setting address. 

Operation Log  

The Operation Log records inputs by operators.  When security is enabled, the Operation Log can track 
which operator made which inputs.  Refer to “Chapter 17 – Operation Log” for details. 

(Not supported in the RMI5010.) 

File Browser  

The File Browser displays folders, CSV files only, or all files within the selected folder on an SD card or USB 
disk. When different folders are selected, the file list updates for that folder. Some objects can use the 
selected file. 
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General tab 

Folder Path Address: When enabled, the selected folder is represented as ASCII text in the specified 
series of registers. If a path is entered into the specified address, the File Browser will update to show the 
contents of that path. If selected, Full (folder + file name) Address should not be selected. 

File Name Address: When enabled, the selected file is represented as ASCII text in the specified series of 
registers. If a file name is entered into the specified address, the File Browser will select that file if it exists. If 
selected, Full (folder + file name) Address should not be selected. 

Full (folder + file name) Address: When enabled, the selected path and file are represented as ASCII text 
in the specified series of registers. If a path and file name are entered into the specified address, the File 
Browser will select that file if it exists. If selected, Folder Path Address and File Name Address should not 
be selected. 

(The File Browser is not supported in the RMI5010.) 

Outline tab 

File Position: select whether the File Browser should reference the SD device or the USB device. The 
available selections will vary with the HMI in use. 

File Type: select whether the File Browser should show CSV files only, or all files. 

Background: select the color of the background of the object. 

Color: select the color of the object’s border. 

Recipe Import/Export  

The Recipe Import/Export object allows recipe data to be exported to a comma-separated variable file, or 
imported from a comma-separated file. Multiple import/export items can be configured, so that different 
recipe tables can be used with different locations on SD and USB storage devices. The Recipe Import/Export 
object does not require placement on a window. 

New: create a new import/export item (see below). 

Delete: delete the selected import/export item. 

Settings: edit the selected import/export item (see below). 

When the New or Settings button is clicked, a configuration dialog is displayed. 

File Position: Select whether the CSV file is located on an SD or USB device. Some HMI units support only 
the USB device. 

Recipe: select which recipe table is to be imported or exported. The recipe table must already exist in the 
HMI recipe database. 

Control address: specify a PLC or HMI local address to manage the import/export. 
The following values are supported:  
1: Import 
2: Export, but do not overwrite an existing file 
3: Export, and allow overwrite an existing file 

The HMI will reset the register to 0 when the operation is finished. Additionally, the two consecutive 
addresses after the specified address have functionality: 
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[Control Address + 1]: Status, 0=Idle, 1=Busy 
[Control Address + 2]: Result, 1=Success, any other value is an error.  Please refer to the EZwarePlus Help 
system for the meaning of specific values. 

File name address: specify a PLC or HMI local address to contain an ASCII data string representing the 
CSV file name.  

Include folder path: if checked, the path of the file will also be included in the string, and the Folder path 
setting will not be available. 

Folder path address: if Include folder path is not checked, specify a PLC or HMI local address to contain 
an ASCII data string representing the CSV folder name.  

(The Recipe Import/Export is not supported in the RMI5010.) 

Drawing Tools  

Includes Line, Arbitrary Line, Link Line, Arc, Ellipse/Circle, Pie, Rectangle, Polygon, Scale, Text, Picture, 
Shape. 

Refer to the Help file for instructions in using each individual drawing tool (Help > Parts List > By Function > 
Drawing Objects). 

Database Server  

The database server object enables the HMI to connect to a MySQL database server on a PC to send 
sampled data or event logs to the MySQL database. 

Click the Database Server icon  on the toolbar, or select Objects –> Database Server, to open the 
Database Server dialog and create a new server object. 

 

Click New to create a new server object. This opens 
the Database Server object. Click Settings to 
modify the settings of an existing server object. 
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General Tab 

IP – Enter the IP address of the database. 

Port – Enter the port number of the database. 

Username – Enter the username for connecting the database. The maximum is 32 words. 

Password – Enter the password for connecting the database. The maximum is 32 words. 

Database Name – Enter the name of the database for collecting historical data.  

Address Tab 

Status Address  

LW-n: Displays the connection status of the Database Server. 

Value Description 

0 Not attempting to connect to database 

1 Failed to connect to database 

2 Connection succeeded 

  

 

LW-n+1: Error indicator 
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Value Description 

0 No error 

1 or more An error occured 

Control Address 

 LW-n: Controls the operation of the database server. 

Value Description 

0 Ready 

1 Start 

2 Stop 

3 Update 

  

LW-n+1: Sets the IP address of the database. 

LW-n+5: Sets the port number of the database. 

LW-n+6: Sets the username for connecting the database. 

LW-n+22: Sets the password for connecting the database. 

LW-n+38: Sets the name of the database. 

If sampled data is successfully synchronized to the SQL database, three tables will be generated in the 
database. The sampled data is saved in the *_data table. 

 

When synchronizing event logs the following three tables will be generated in the database. The event log is 
saved in the *_event table. 

 

If the content of the data sampling/event log is changed, such as data format or event message, please 
delete the tables listed above before backing up the database. 

 

 

 

Data Sampling Object 
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When configuring a Data Sampling Object that will be backed up to the SQL database check Enable in the 
Sync to Database section and select the Database to back up to. 

 

Event (Alarm) Log 

When configuring the Event (Alarm) Log to be backed up to an SQL database, first check the History files 
Enable check box then check Enable the Sync to Database Enable checkbox and select the Database to 
back up to. 

 

Managing Projects 
Like most Windows™ application software, EZwarePlus will open, save, close, and print files using the 
standard windows format. 

File Menu 

To create a new project   

1. On the File menu, click New or click the New icon in the Standard toolbar. The EZwarePlus dialog 
box appears. 
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2. Select the HMI model that you intend to use with your project and whether you want to use the HMI 
in Landscape or Portrait mode. Select the Use template checkbox to open the project with the 
default template for your selected model. 

3. Click OK. The System Parameter Settings window opens next. Refer to the Help menu “How Do I… 
Set Up a PLC or Controller in EZware?” to configure the devices in the Device List. You may also 
jump ahead to System Parameter Settings. Click OK to accept the settings. 

To open an existing project:   

1. On the File menu, click Open or click the Open icon in the Standard toolbar. The Open dialog box 
appears. 

2. Click on the project file you intend to open. 

3. Click Open. The main screen of EZwarePlus appears with the initial screen of the project displayed. 

To close a project: 

1. On the File menu, click Close. 

2. If changes have been made to the project file, EZwarePlus will ask you if you would like to save the 
project. Then the main screen of EZwarePlus will remain but with no work area displayed. You must 
now use the Open or New commands to edit a project. 

To save an existing project:   

1. On the File menu, click Save or click the Save icon in the Standard toolbar. 

2. If the project already has a name, then the project will automatically be saved. If this is a new 
project, then the Save As dialog box appears. 

3. Enter a file name and then click Save. 

4. The main screen of EZwarePlus reappears. 

To save a project using the compress feature: 

The compress feature allows you to save a project in compressed format so that the project data takes less 
space on your hard drive. This utility also will save the graphics libraries associated with the project into the 
compressed file. This facilitates sending a copy of the project to another person who has EZwarePlus in 
order to open and download the project into an HMI. It is also the best way to archive and backup your 
projects when you have completed them. 
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  The compress feature doesn’t save the fonts used in the project. It is best to use common Windows True 
Type fonts (or the HMI True Type fonts) in your project so that if it is opened on another computer, 
EZwarePlus will have access to the same fonts. 

1. From the Tools menu, select Compress/Uncompress.... The Compress/Uncompress Project 
dialog box appears. 

 

2. In the Compress box under Source Name, select the project (*.emtp) file that you wish to compress. 
The file must have a *.emtp or *.cmtp extension. 
 

3. Click Compressing… to begin. The utility will compress the project file and all related graphics 
libraries into a single file with a *.ecmp extension. 

To extract a compressed project file: 

1. From the Tools menu, select Compress/Uncompress.... The Compress/Uncompress Project 
dialog box appears. 

2. In the Uncompress box under Source Name, select the project (*.ecmp or *.ccmp) file that you wish 
to uncompress. 

3. Click Uncompressing… to begin. The utility will extract the project file (*.emtp or *.cmtp) and all 
graphics libraries from the compressed file. 

Note: It is a good idea to back up your Library folder before uncompressing a *.cmp/*.ecmp/*.ccmp file 
because the uncompress utility will overwrite any existing library files with the same name. You also have the 
option not to overwrite existing files, and in most cases this is okay unless the project being uncompressed 
uses modified libraries with the same names as the standard libraries in the Library folder. 

To exit EZwarePlus:   

On the File menu, click Exit or click on the standard windows Close icon in the upper right corner. 
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Display Options 
A number of toolbars are available in EZwarePlus that provide quick access to tools and functions in the 
software. 

View Menu 
Select the toolbars that you want to display in EZwarePlus under the View menu. These toolbars can be 
moved around within the EZwarePlus window by clicking and dragging on the left edge of the toolbar. 

Standard Toolbar:  

 

Includes New, Open, and Save project; Cut, Copy, Paste, Undo, Redo, Print, About, Help, Find/Replace, 
Redraw, Grid, Snap, Display Common Window, Display Underlay Window. 

Project Toolbar: 

 

Includes Compile, On-line Simulation, Off-line Simulation, Download, Build data for USB disk or CF/SD card 
download, Reboot HMI, Data/Event Log Converter, Address Viewer, Easy Watch, Administrator Tool, Recipe 
Database Editor, cMT Viewer. 

Library Toolbar: 

 

Includes Save Objects to Shape Library, Call up Shape Library, Call up Picture Library,  Save to Group 
Library, Call up Group Library, Sound Library Manager, Label Library Manager, Address Tag Library 
Manager, Macro, Recipe Records. 

Text Toolbar: 

 

Includes Font Name, Font Size, Big Font, Small Font, Label Position Tracking, Left Alignment, Center 
Alignment, Right Alignment, Italic, Text Color, Underline, Language (L1, L2, L3, L4). 

Edit Toolbar: 

 

Includes Top Layer, Bottom Layer, Previous Layer, Next Layer, Vertical Center in Window, Horizontal Center 
in Window, Nudge Up, Nudge Down, Nudge Left, Nudge Right, Decrease Height, Increase Height, Decrease 
Width, Increase Width, Align Left, Align Horizontal Center, Align Right, Align Top, Align Vertical Center, Align 
Bottom,  

 

Space Evenly Across (Horizontally), Space Evenly Down (Vertically), Make Same Width, Make Same 
Height, Make Same Size, Make Same Color, Flip Vertical, Flip Horizontal, Rotate, Pinned, Group, Ungroup, 
Go to destination window, Next Object, Zoom (%). 

State Toolbar: 
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Select the state to view multistate objects in the development window. The objects will appear on the window 
as they would in the selected state. 

Draw Toolbar: 

 

Includes Select, Properties, Line, Free Line, Linked Line, Arc, Ellipse/Circle, Pie, Rectangle, Polygon, Scale, 
Text, Picture, Shape. 

PLC Toolbar: 

 

Includes System Parameter Settings, Font Management, PLC Control, Data Transfer (Global), Event (Alarm) 
Log, Data Sampling, System Message, Schedule, Operation Log, Operation Log Printing. 

Object 1 Toolbar: 

 

Includes Bit Lamp, Word Lamp, Set Bit, Set Word, Combo Button, Toggle Switch, Multi-State Switch, Option 
List, Slider, Numeric, ASCII, QR Code, Function Key, Timer, Flow Block, Date/Time, Picture View, File 
Browser, Recipe Import/Export. 

Object 2 Toolbar: 

 

Includes Indirect Window, Direct Window, Moving Shape, Animation, Bar Graph, Meter Display, Pie Chart, 
Trend Display, Circular Trend Display, History Data Display, Data Block Display, XY Plot, Recipe View, 
Operation Log View, Alarm Bar, Alarm Display, Event Display, Data Transfer (Trigger-based), Backup, 
Media Player, Video In. 

Window Tree, Address Grid, Web Bar: 

EZwarePlus provides a Window Tree that can be used to easily maneuver among windows of a project. It 
also allows you to select any object that is on the window that is currently displayed. 

To display/hide the Window Tree: 

1. On the View Menu, click Window Tree. 

2. When the Window Tree, Address Grid, and Web Bar are enabled in the View menu, you can select 
which view is on top by clicking on the tabs at the bottom of the side bar. 
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3. At the top of the Window Tree,  
there is a drop-down box that  
allows you to select either Object  
List or Window Preview.  
The Window Preview displays  
thumbnail views of each of the  
windows in the project.  

 

 

 

 

 

 

 

 

4. The Object List combines a list of all of the windows in a project, and all of the objects on each 
window, into a single tree. Notice that the tree displays the title for each window next to the window 
number. This makes it easy to determine the windows that have been created for a project. An 
asterisk (*) next to a window indicates that the window is currently open. 



Chapter 6 – Using EZwarePlus  126 

 

EZwarePlus Programming Manual   126 

   

  

5. To display an open window, click on the window number in the Window Tree. To display a window 
that is not yet open, double-click on the window number. This will automatically open the window 
and display it.  

6. To change any settings or close an open window, click on the window number to select it. Then 
right-click anywhere inside the Window Treebar to display a popup dialog box. Select Close to close 
the window or Setting to change any of the window settings. 

7. Finally, to create a new window click on any window number that is not currently used. Then, right-
click inside the Window Tree and select New. 

Using the Window Tree to change object attributes: 

1. On the Window Tree, click the small plus sign [+] adjacent to any window number. The tree will 
expand to list the objects on that window, as shown: 
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2. The Object ID of each object will be listed. For example, WC_0 is Direct Window #0, TS_0 is Toggle 
Switch #0, etc. 

3. To highlight a particular object on the screen, click on the Object ID in the list. This allows the quick 
selection of a particular object, especially on crowded screens or screens where objects may be 
overlapping. 

4. To display the object’s attribute dialog box, double-click the Object ID in the Window Tree. 

Zoom: 

To zoom in on the selected window: 

1. Use the zoom pull-down menu in the Edit Toolbar. Zoom levels range from 50% to 200% in 25% 
increments. 

2. On the View menu, select Zoom Level. Zoom levels range from 50% to 200% in 25% increments. 

3. Use the Zoom In and Zoom Out selections to zoom in and out in steps of 25% increments. 
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Option Menu 
Grid/Snap  

One display option is to have the work area covered with grid lines. These grid markings can be helpful when 
trying to align objects that are created on the work area. If Grid Display is selected, you can adjust the 
dimensions of the grid points on the window. 

Turning the Grid on and off: 

1. On the Option menu, click Grid/Snap. 

2. Click the Display box or click the Grid icon in the Standard toolbar to turn the grid on and off. 

 If you still don’t see the grid after you have enabled it, make sure that the color of the grid doesn’t match 
the background color of the window currently displayed. 

Changing the grid size and color: 

1. On the Option menu, click Grid/Snap. 

2. Select the X spacing and Y spacing for grid size. 

 

 Spacing is measured in pixels.  

3. Select the Grid color in the drop-down menu.  

If you enable the Grid on the work area, you may also take advantage of a useful feature called Snap. The 
Snap option causes all objects placed into the work area to fall along the boundaries set by the grid lines. 
The Snap option can help provide a more ordered appearance to graphics objects. 

Using the snap option: 

1. The Grid option must be enabled. 

2. On the Option menu, click Grid/Snap. The Grid/Snap Settings dialog box appears. 

3. Click the Snap checkbox. 

4. Click OK. 
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Finally, you will find that you can move objects by selecting them with the mouse cursor and dragging them 
to a new location. However, you may find it difficult to select an object without accidentally moving it just a 
little. At times this may be frustrating, so you may wish to disable the move feature using the mouse and only 
move an object by changing its X and Y position parameters in the Profile tab of the object’s attributes box. 
This is the intent of the Fix all objects feature. 

To enable the fix all objects command: 

1. On the Option menu, click Grid/Snap. The Grid/Snap Settings dialog box appears. 

2. Click the Fix all objects checkbox. 

3. Click OK. Movement by mouse cursor is now disabled. 

Preferences 

Display Object ID: 

Every time you create a new object in EZwarePlus, an Object ID tag is assigned to the new object. This is 
done for several reasons: 

• Object ID tags are required by EZwarePlus to differentiate each object created. 
• If an error occurs during the compile process, EZwarePlus can refer to the window and object ID to 

indicate the object that is causing problems. 

To enable/disable displaying Object ID tags: 

1. On the Option menu, click Preferences. The Preferences dialog box appears. 
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2. Click the Display Object ID checkbox to display ID tags. This will cause the Object ID number to 
appear on each object in the project for easy identification. 
  The Object ID will not appear on the object when the project is downloaded to an HMI. 

3. Select the Font size and Text color for the ID tags. 

4. Click OK.  

The Preferences dialog also has the following options: 

Display Object Address: When selected, the address that is assigned to objects in EZwarePlus will 
appear on each object in the project. If more than one address is assigned to some of the objects, 
you can select how many of the addresses will appear on the object with The number of displayed 
addresses option. 

Display Common Window objects on Base Windows: When unchecked, objects on the Common 
Window will not appear on base windows in the EZwarePlus development screens. Objects on the 
Common Window will always appear on the base windows when the project is downloaded to the 
HMI. Check this to enable viewing the Common Window objects on the base windows in the 
development screens.  

Display Underlay Window objects on Base Windows: When unchecked, objects on Underlay 
Windows assigned in the base window’s settings will not appear in the EZwarePlus development 
screens. Objects on the assigned Underlay Windows will always appear on the base windows when 
the project is downloaded to the HMI. Check this to enable viewing the Underlay Window objects on 
the base windows in the development screens. 

Using Function key to make shape library object: Allows shapes to be placed inside the area 
defined by a Function Key before being imported into a Shape library. This allows a shape to occupy 
any position inside a shape library cell. See “Help > How Do I…Add a New Shape or Picture into the 
Libraries?” for more information. 

Automatically save and compile the project when download and simulate: This option causes 
EZwarePlus to automatically save and compile the project when a simulation is started or prior to 
commencing a download to the HMI. 

Generate backup of project file before save: This option causes EZwarePlus to automatically 
save a backup of the project when saving changes. Up to three backup projects will be saved with 
the extensions *.bak1, *.bak2, and *.bak3. 

Automatically make used pictures and shapes into the project library: When selecting a picture 
or shape to represent an object on the object’s Shape tab, the picture or shape is simply linked to 
the project from the selected library file. Selecting this option will place the picture or shape onto the 
Project tab in the Picture Manager or Shape Manager. Once it is placed on the Project tab, the 
picture or shape is stored in the project file (*.emtp or *.cmtp). 
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Save AutoRecover information: When checked, EZware will automatically save the project at the specified 
time interval (3 to 10 minutes). A backup file is not created. If the Generate Backup option is checked, a 
backup is only created when File > Save is selected. 

Basic Editing Commands 

Edit menu 

Using the Undo    and Redo    commands: 

1. The Undo command is used to cancel the last command or action that you made. 

From the Edit menu, click Undo or click the Undo icon from the Standard Toolbar. You can also 
press CTRL+Z. The deleted text box reappears. 

2. The Redo command is used to cancel the Undo command. 

Using the Cut     , Copy    , and Paste    commands: 

1. These commands are all selected from the Edit menu. 

2. Select the graphics object or objects you wish to cut or copy. 

3. Click Cut to copy and remove the graphics object(s) from the work area or click Copy to copy the 
graphics object(s). 

4. Objects cut or copied from one window can be pasted into other windows. Once the object has been 
selected and cut or copied, open another window, then paste the object into that window. 

5. The pasted object appears highlighted in the work area of the new window. 

6. Move the object by clicking on the highlighted area and dragging it to the desired position. 

Using the Multi-Copy command: 

The Multi-Copy command is used to make multiple copies of a single object on a screen. This is most useful 
when creating new keyboards or data tables. In addition to copying the object, this command will 
automatically assign new memory addresses to each object. 

1. Select the object you wish to copy. 

2. From the Edit menu, select Multi. Copy.... The Multi. Copy dialog box appears (see on following 
page). 
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3. Modify the settings according to your requirements. 

4. Click OK. The main screen of EZwarePlus is redisplayed with the Multi. Copy command executed. 

Multiple objects can be created according to these parameters: 

Pitch vs. Interval: This setting affects how EZwarePlus places the copies of an object on the screen 
relative to each other. The Pitch setting will interpret the X Distance setting as the distance from the 
left side of an object to the left side of the next object and the Y Distance setting as the distance from 
the top of one object to the top of another object. 

The Interval setting will interpret the X Distance setting as the distance from the right side of one 
object to the left side of the next object. The Y Distance setting is the distance from the bottom of 
one object to the top of the next object. 

X, Horizontal Distance and Y, Vertical Distance: These settings determine the spacing (in pixels) 
between objects. 

Quantity X and Quantity Y: These settings determine the number of copies to be made along the X 
axis (horizontal) and the Y axis (vertical). 

Left to right and Top to bottom: When Left to right is selected, objects are created and addressed 
in the X-axis first and then in the Y-axis. When Top to bottom is selected, objects are created and 
addressed in the Y-axis first and then in the X-axis. 

Adjust Distance: This is the offset used when assigning a new address to each new copy. For 
example, if 1 is selected, then EZwarePlus will add one to the address for each new copy made. 

Delete 

To delete a graphics object(s): 

1. Select the object or objects you wish to delete. 

2. Press the DELETE key or from the Edit menu, click Delete. 

  You can restore the deleted object by using the Undo command. 
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Find/Replace Address 

The Find/Replace option offers a quick way to determine if a particular address has been used in the project.  

    

Select either the Local HMI or the PLC being used at the top of the Find/Replace window and enter either 
the Bit address or Word address you wish to find. Click the Find button and a list of objects that use the 
selected address will appear at the bottom of the Find/Replace dialog, along with the Object ID and the 
window number. Use the Replace With field and the Replace or Replace All buttons to replace one or more 
of the selected addresses with a different address. 

Click the Range option to find addresses used within a range of addresses. You can replace all the selected 
addresses with a different address, or click the Shift option to replace the addresses with relative addresses 
beginning with the address in the Replace With field. 
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Go to destination window 

If you select a Function Key in the project that is configured to change windows, selecting this option will 
open the destination window assigned to the Function Key. 

Include in Operation Log 

If the Operation Log function has been enabled in the project, use this option to quickly enable a selected 
object in the Operation Log settings. See “Chapter 17 – Operation Log” for more information. 

Layer 

Graphics objects can be overlaid upon each other. When ‘layered,’ the graphics object on the topmost layer 
will be completely seen. How much of the other graphics objects are seen depends on what is on top of 
them. The following layer commands help to position the overlaid objects exactly how you want them. 

Top Layer:  Brings the selected object to the top layer. 

Bottom Layer:  Send the selected object to the bottom layer. 

Previous Layer:  Moves the selected object to the previous layer. 

Next Layer:  Moves the selected object to the next layer. 
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Normally, an object that is controlled by a PLC Register (i.e., Animation and Moving Shape) is brought to the 
Top Layer when the value in the PLC Register changes. This behavior can be changed by the Object 
Layout option on the General tab of the System Parameters dialog. A setting of Control sets the behavior 
as outlined above. A setting of Nature (default setting) results in the object remaining at the layer assigned 
during development. 

  The Object Layout setting is global and affects all PLC-controlled objects in the application. 

Center in Window 

Use this option to center selected objects either vertically  or horizontally  in the window. 

Nudge 

Nudging is used to fine-tune the placement of objects in the work area of EZwarePlus. Using the nudge 
feature on a selected object will move that object in the specified direction either by one pixel or by the grid 
setting amount. 

Use the nudge up  , down  , left  , and right   commands (Edit > Nudge or the Nudge 
icons in the Edit toolbar) to move objects on the window. This function is duplicated with the arrow keys on 
the keyboard. 

Resize 

The resize option allows you to increase or decrease the width and height of a selected object in one pixel 
increments. 

Other methods for resizing a graphics object: 

1. Select the object to be resized. 

2. To resize the object, move the mouse cursor over one of the small blue squares on the perimeter of 
the object. The cursor changes to a double-arrow icon to indicate that it is in resizing mode. 

3. Click and drag the mouse to resize the object. 

4. Objects can also be resized by changing the width and height attributes in the Profile tab of the 
Attributes dialog box. 
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Align 

The alignment option can be used to quickly align two or more objects. Aligning justifies objects to the 
desired position of the last-selected object. The last selected object will have "handles" of a different color 
than the other selected objects.  

Use the align left  , align right  , align top  , align bottom  , horizontal center  , and 

vertical center  commands (Edit > Align or the Align icons in the Edit toolbar) to clean up the alignment 
of objects on the window. 

Make Same Size 

This feature is handy if you want to quickly make two or more objects the same size. Objects are sized to the 
size of the last-selected object. The last-selected object will have "handles" of a different color than the other 
selected objects. This is most often used when you are trying to overlap objects that must be the same size. 

To make objects the same width: 

1. Select the objects you wish to make the same width.  

2. From the Edit menu, select Make Same Size, then Width or click the “Make Same Width” icon  
from the Edit toolbar. 

To make objects the same height: 

1. Select the objects you wish to make the same height. 

2. From the Edit menu, select Make Same Size, then Height or click the “Make Same Height” icon  
from the Edit toolbar. 

To make objects the same size: 

1. Select the objects you wish to make the same size. 

2. From the Edit menu, select Make Same Size, then Both or click the “Make Same Size” icon  
from the Edit toolbar. 

Make Same Color 

This feature can be used to make two or more drawn objects the same color. 

To make objects the same color: 

1. Select the objects that you wish to make the same color. The group of objects selected will be 
changed to the color of the last of the objects selected.  
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2. From the Edit menu, select Make Same Color. The selected objects will all change to the same 
color as the last selected object. For example, if green and orange objects are selected and orange 
is the last object selected, all the objects will change to orange after executing the command. 

 

Flip/Rotate 

These options allow you to quickly flip or rotate an object in a new direction. 

  The Flip/Rotate function only works on objects created with the Draw tools in EZwarePlus. 

To flip objects vertically: 

1. Select the object you wish to flip vertically. 

2. From the Edit menu, select Flip/Rotate > Flip Vertical or click the “Flip Vertical” icon  from the 
Edit toolbar. 

To flip objects horizontally: 

1. Select the object you wish to flip horizontally. 

2. From the Edit menu, select Flip/Rotate > Flip Horizontal or click the “Flip Horizontal” icon  from 
the Edit toolbar. 

To rotate objects: 

1. Select the object you wish to rotate. 

2. From the Edit menu, select Flip/Rotate > Rotate 90 Degrees or click the “Rotate” icon  from the 
Edit toolbar. 

Space Evenly 

This option allows you to space multiple objects evenly among each other. 

To space objects horizontally: 

1. Select all the objects you wish to space horizontally. 
2. From the Edit menu, select Space Evenly > Space Evenly Across or click the “Space Evenly 

Across” icon  from the Edit toolbar. 

To space objects vertically: 

1. Select all the objects you wish to space vertically. 
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2. From the Edit menu, select Space Evenly > Space Evenly Down or click the “Space Evenly Down” 

icon  from the Edit toolbar. 

Pinned 

Each object’s position and size can be locked by using the Pinned option. When the object is locked, its 
position and size cannot be changed. 

To lock an object: 

1. Select the object to be locked. 

2. From the Edit menu, select Pinned or click the “Pinned” icon  from the Edit toolbar. 

3. To unlock the object, deselect Pinned from the Edit menu or click the “Pinned” icon  once again in 
the Edit toolbar. 

4. Objects can also be locked by selecting the Pinned option in the Profile tab of the Attributes dialog 
box. 
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Group 

When creating graphics on a window, you may create a complex graphic that is actually composed of 
several simpler objects grouped together. Grouping objects together makes it easier to move or copy 
multiple objects at the same time. 

To group objects: 

1. Select the objects to be grouped. 

2. From the Edit > Group menu, click Group or click the “Group” icon  from the Edit toolbar. 

3. All objects within the group can now be copied, deleted, or moved by clicking on the group. 

To ungroup objects: 

1. Select the objects to be ungrouped. 

2. From the Edit > Group menu, click UnGroup or click the “Ungroup” icon  from the Edit toolbar. 

3. All objects within the group can now be copied, deleted, or moved separately. 

Window Process 

Select Close Window to close the currently open window in EZwarePlus. If there is only one window open, 
then selecting this option will close the project. 

The Window Copy option allows you to copy an entire window from one location to another, either within a 
project or from one project to another. 

Using the Window Copy command: 

The Window Copy command is used to copy a window from an existing project into the project that you are 
currently editing. This feature reduces time spent creating new projects since you can now use windows that 
you created for other similar projects. 

1. From the Edit menu, select Window Process and click Window Copy.... The Window Copy dialog 
box appears.  
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2. In the Source project box, specify the path to the project that contains the window screen(s) you 

wish to copy. Use the Browse... button  to navigate to the project if you are unsure of the 
location or name of the project file. 

3. In the Source boxes, enter the numbers of the window screen(s) you wish to copy. They must be 
consecutive windows. If you are only copying one window, put the same window number in both 
boxes. 

4. In the Destination box, select the number of the window in the current project that you wish to copy 
the selected window(s) to. If multiple windows are selected, they will be copied into consecutive 
windows beginning with the one designated in the Destination window. 

5. There are checkboxes for PLC control, Event (Alarm) log, Schedule, Data transfer, and Data 
sampling. The selected options will also be copied into the current project. 

Click OK to complete the process. 

Select All Objects 

Use this option to select all the objects on the currently open window. 

Select Next Object 

This option can be used to easily select an object that is underneath another object on the screen. To use 
this option, you must first select the overlapping object. 

To select next object: 

1. On the Edit Menu, click Select Next Object or click on the “Select Next Object” icon  on the 
Edit Toolbar. You can also click and drag across the multiple objects to select them and then right-
click on the top-most object on the screen. This will display a menu with a list of the overlapping 
objects. Select the object that you wish to access and click the Settings button to open the 
Attributes. 

2. Once the object you are trying to access is selected, you can proceed to modify its attributes or 
delete it. 

Select 

To select a graphics object: 

1. On the Edit Menu, click Select or click the “mouse cursor” icon  in the Draw Toolbar. 

2. Click on the graphics object. This causes the text box to be selected, with small square blocks 
around the edges indicating the boundaries of the object. Deselect the object by clicking somewhere 
else in the work area.  

3. When a graphics object is selected, it can then be modified, copied, deleted, or moved to a new 
location. 

To select multiple graphics objects: 

1. On the Edit Menu, click Select or click the “mouse cursor” icon  in the Draw Toolbar. 
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2. Click and hold down the left mouse button at the upper left corner of the graphics objects you wish to 
highlight. 

3. Drag the mouse cursor to the lower right corner of the highlighted objects. Notice that a rectangle is 
formed as you do this.  

4. Release the mouse button. The rectangle outline changes to small blue square blocks around the 
perimeter of the objects selected. Now multiple objects are selected. 

  If you do not completely enclose a graphics object you wish to highlight, then it will not be selected. 

5. Alternatively, you may select objects by holding down the CTRL key while selecting each object until 
all objects are selected. 

6. When several graphics objects are selected, they can easily be moved, deleted or copied together. 

Change Object Attributes 

To change attributes of a graphics object: 

1. Select the object to be changed, then select Change Object Attributes from the Edit menu. You 
can also double-click the object. 

2. The object’s attribute dialog box is displayed. Object Attributes defines what the object is or how it 
behaves, (i.e., size, position, color, etc.). Click OK to accept any changes made or Cancel to cancel 
any changes. 

To view object attributes of multiple graphics objects on a window: 

1. There will be times when you may want to quickly determine what PLC data registers are tied to 
which objects in a window. This can easily be done using the Change Object Attributes command. 

2. On the Edit menu, click Select all objects. 

3. From the Edit menu, click Change Object Attributes. The Object Attribute dialog box is displayed. 
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4. All of the objects that use PLC data registers or the internal memory of the HMI are listed in this 
dialog box according to their Object ID tag. Alongside each ID tag is the PLC or HMI memory 
identifier. 

Font Management 

The Font Management option is used to copy the font files used in the project to a specified location or to 
globally select a font that is used in the project and replace it with a different font. 

 

 

The Font Management window displays a list of the currently used fonts in the project. 

To copy the fonts to a specified location: 

1. Click the Copy Files To… button and navigate to the directory where you wish to save the fonts. All 
the fonts in the list will be copied to the specified location. 

To replace a font with a different font: 

1. Select the currently used font in the list that you want to replace. 

2. The selected font will appear in the Find what field at the bottom of the window. 

3. Click the down-pointing arrow in the Replace with field and select the font you want to use to 
replace the selected currently used font. 

4. Click the Replace button to complete the action. Everywhere the initial currently used font was used 
in the project will be replaced with the new font. 
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There is also a Font Management button at the bottom of the Compile window that opens the Font 
Management dialog. 

 

 

System Parameter Settings 
The final section of this chapter shows all the settings or parameters that can be configured using 
EZwarePlus. From the Edit menu, select System Parameters. The System Parameter Settings dialog box 
appears. The dialog box has eleven tabs: Device, Model, General, System Setting, Security, Font, Extended 
Memory, Printer/Backup Server (not available for the RMI5010), Time Synchronization, e-Mail, and Recipes. 

P Series/L Series/RMI5001 

 

 

RMI5010 
  Some of the System Parameter Settings windows are different for the RMI5010 and are identified when 
necessary. 
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Device tab settings: 
Local HMI: 
The Local HMI device is automatically created when starting a new project and the model is selected. 

1. With the Local HMI selected in the Device list, click the Security button below it to open the Device 
Properties window for the Local HMI. The PLC radio button and the Location option are greyed out 
and cannot be changed. 

  The following options are not available for the RMI5010. 

2. LW protection: When Prohibit remote-write operation of remote HMI or MODBUS client is 
checked, remote HMI(s) are prevented from writing to the range of Local Word addresses specified 
in the LW range boxes.  

3. RW protection: When Prohibit remote-write operation of remote HMI or MODBUS client is 
checked, remote HMI(s) are prevented from writing to the range of Recipe Word addresses specified 
in the RW range boxes.  
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4. Data Security: Opens the Data Security window. Click the Add button to add items to the list. 
 

 
 
Description: Enter text to describe the data being secured. 
 
Address Mode: Select either Word (LW) or Bit (LB). 
 
     When Word is selected, enter the Min. value and Max. value that can be entered in the 
 specified register. 

 
When Bit is selected, you can select Set ON only or Set OFF only. This can be used to 
latch the specified bit ON or OFF. 

 
Disable remote-write operation: When selected, a remote HMI is prohibited from writing to the 
specified register or bit. 
 
Used only in remote-write operation: When selected, the Data Security Settings only apply to a 
remote HMI writing to the specified register or bit, not the local HMI. 
 
Use min. value when write value is less than min. value: When selected, if a value less than the 
specified minimum value is entered, it will default to the minimum value. 
 
Use max. value when write value is more than max. value: When selected, if a value greater 
than the specified maximum value is entered, it will default to the maximum value. 
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Notification: When enabled, the designated bit will turn ON (with Set ON selected) or turn OFF 
(with Set OFF selected) when an attempt is made to write to the specified address in violation of the 
Data Security Settings. 

Local PLC: 

1. Click the New… button. The Device Properties dialog appears. 

 

 

  You can “export” a project created for one PLC brand to a different PLC brand by loading the 
project file into EZwarePlus, then entering a different PLC type in this box. EZwarePlus will go 
through your entire project and attempt to change each reference to PLC data registers to a logical 
selection for the new PLC protocol; however, we strongly recommend that you review these changes 
to ensure that they are satisfactory. 

2. Make sure the PLC button is selected. 

3. There are two choices for Location – either Local or Remote. Select Local if the HMI will be 
connected directly to the PLC. Select Remote if the HMI will be connected to the PLC through 
another HMI.  
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For the RMI5010, see step 3a next. 

If Remote is selected, click the Settings button and select whether the HMI-to-HMI connection will 
be via Ethernet or a serial COM port. 

 

 

Ethernet: Enter the IP address of the Local HMI (the HMI that is connected directly to the PLC with 
Location: Local selected). Enter the TCP/IP port assigned to the Local HMI (default is port 8000 – 
located in the System Parameter Settings on the Model tab). 

COM port: You must use the Master-Slave protocol in the Local HMI in order to make the HMI-to-
HMI connection.  

Configuring the Local HMI: Add the Master-Slave Server protocol to the Device list of the Local HMI. 

 

In this example, since the Local HMI is already using COM 1 to connect to the PLC using the 
Modbus RTU Master protocol, the Master-Slave Server is assigned to COM 3. The Remote HMI will 
connect to COM 3 on the Local HMI serially. 

Configuring the Remote HMI: Add the same PLC driver in the Device list as the Local HMI and 
select Remote for the location. Set the PLC I/F to match the Interface setting of the Master-Slave 
Server in the Local HMI (in this case, RS485 2W). 
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Click the Settings button next to Location: Remote and select COM port. 

Click the Settings button in the COM section and set the Baud rate, Data bits, Parity, and Stop bits 
to match the settings of the Master-Slave Server configuration in the Local HMI project. 

 

In this example, the Remote HMI is configured to communicate on COM 1, so COM 1 on the 
Remote HMI is connected to COM 3 on the Local HMI. 
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3a.  For the RMI5010, the Remote HMI and Remote PLC are configured differently. The Local HMI 
can only have a Local PLC assigned to it. The Local/Remote option is greyed out. 

  

To add a remote HMI and remote PLC, click the New HMI button and enter the IP address of the 
remote HMI in the IP Address Settings window. Click OK. 
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 Then click the New PLC button and add the Remote PLC.  

  

 Click OK. 
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4. Click the PLC type drop-down box and select the appropriate driver for your PLC type. 

 

 

5. There are five selections for PLC I/F: 
RS-232 /RS-485 2W / RS-485 4W / Ethernet / USB 
Choose the PLC interface appropriate for your PLC model. 

6. Select the PLC station number for your PLC if appropriate (see Controller information Sheet for your 
PLC) and then click Settings… The COM Port Settings dialog appears. 

 

7. Select the appropriate COM port. This is the COM port used by the HMI. 
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8. Select Baud rate, Data bits, Parity and Stop bits. Use Maple Systems’ Controller Information 
Sheets or the PLC manufacturer’s operations manual for information on the communications 
parameters required by the PLC. These parameters must match the PLC settings.  

Timeout adjusts the amount of time (in seconds) it takes for the PLC no response message to 
popup when communication is lost or disrupted between the HMI and PLC. 

Turn around delay adjusts the amount of time (in milliseconds) that the HMI waits after receiving a 
reply before sending the next request. 

Send ACK delay and the Parameter 1-3 settings are optional depending on the PLC type. Refer to 
the Controller Information Sheet for the PLC selected. 

9. The number of resending commands sets the maximum number of retries the HMI will attempt to 
establish communication when communication is lost. When “0” is selected, the HMI will continue to 
retry indefinitely. 

10. Click OK. 

11. PLC default station no.: Defines the station number or unit ID number of the PLC, if applicable 
(e.g., Modbus station number). 

12. Default station no. use station no. variable: Enables using a Local Word (where LW10000-
LW10015 corresponds to var0-var15) to define the station number. By using the var syntax in the 
address field (e.g., var0#100), the station number can be changed at runtime by changing the value 
in the corresponding Local Word. 

13. Use broadcast command: When enabled, causes the HMI to not expect a response from the 
station number specified by the Broadcast station no. field. 

14. Interval of block pack (words): Determines how many words are read from the PLC in one 
communication cycle. For more information on this feature, select Help> Help Topics in 
EZwarePlus and select Miscellaneous > Optimizing the Update Rate With PLC Block Pack.  

15. Max. read-command size (words): The maximum data size to be read from a device at one time. 
 The Interval of block pack (words) setting must be less than this setting. 

16. Max. write-command size (words): The maximum data size to be written to a device at one time. 

17. Click OK. 
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Model tab settings: 

 

1. HMI model: Select the HMI model that you are programming. 

2. HMI station no.: When multiple HMIs are used, this selects the unique network address of the HMI. 
See Controller Information Sheet for more information. 

3. Port No: Assign a TCP/IP port so that another HMI can access the HMI through this port. For more 
information, select Help > Help Topics > How Do I…Setup TCP Port Forwarding With the HMI. 

4. Support cMT communication protocol: When selected, the HMI supports a remote connection 
from an RMI5010. The remote HMI port number in the RMI5010 project (under Support 
iE/XE/eMT/mTV HMI communication protocol) must match the Port No. entered here. 
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RMI5010 System Parameter Settings Model Tab 

 

  The remaining options do not apply to the RMI5010. 

5. Clock Source: Select internal HMI RTC or External Device. 
HMI RTC uses the internal real-time clock in the HMI. 
External Device points to a PLC register to obtain real-time clock data. When the HMI first starts up, 
it will read the RTC data from six consecutive 16-bit registers in the PLC, starting at the specified 
register. The RTC data must be provided in the following order: 

Address = Seconds (0-59) 
Address+1 = Minutes (0-59) 
Address+2 = Hours (0-23) 
Address+3 = Day of Month (0-31) 
Address+4 = Month (1-12) 
Address+5 = Year (4 digits) 

  To update the RTC more frequently, use a Data Transfer object. In the Source address section, select 
the address in the external device that holds the first of the RTC values (seconds).  

In the Destination address section, select the Local HMI system tag LW-9017 (local second). 

In the Attribute section, enter a 6 into the No. of word: field. 

 



Chapter 6 – Using EZwarePlus  155 

 

EZwarePlus Programming Manual   155 

   

 

6. Printer Type: Select type of printer to be connected locally to the HMIs serial port or USB port.  
Printers are not supported on the RMI series. 

7. Scroll bar: select the size and appearance of the scroll bar(s) on certain display objects. The scroll 
bars appear automatically as needed. 

8. Pass through (Virtual COM port): select the Port Number to use in Pass-Through mode. The same 
setting needs to be made in the Utility Manager when Pass-Through is selected. 

Auto Resizing Using the Model Tab 

This tab can be used to automatically resize your project when changing to another HMI model with a 
different size touchscreen. The project and all objects and graphics will be proportionately resized 
automatically. 

To auto resize your project using the Model tab in the System Parameters dialog: 

1. In the Model tab, select a different display size from the HMI model drop-down box and click OK. 

2. The Resize popup windows/objects dialog appears. 

 

3. Check all the resize options and then click OK. The project will automatically resize. 
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General tab settings: 

 

1. Fast selection button: The Attribute: drop-down enables or disables the fast selection button, 
which is used to open the Fast Selection window (window number 3). The Fast Selection window is 
used as a menu window to quickly access other windows in the project with Function Keys.The Fast 
Selection button, when enabled, is accessible from every other window.  

The Settings button sets the look of the button including shape and color. The Position drop-down 
sets the fast selection button on either the lower left or lower right portion of the display. When 
checked, the Hide button when HMI starts option causes the fast select button to be hidden when 
the HMI starts. Use Local Bit 9014 to control the Fast Select button. Clear the bit to show the button 
and set the bit to hide it. 

  Place an invisible Set Bit object assigned to LB-9013 over the Fast Selection window (Window 3) 
to automatically close the Fast Selection window when a Function Key button is pressed on the 
window. 



Chapter 6 – Using EZwarePlus  157 

 

EZwarePlus Programming Manual   157 

   

  Fast Selection is not supported in the RMI5010. 

2. Screen Saver: The Back light saver sets the number of minutes (none-255) of inactivity after which 
the backlight is turned off. If the value None is selected, then the back light saver is disabled. 

  The backlight is re-triggered when the screen is touched or when an alarm occurs (if the Enable 
back light when alarm occurs option is selected). 

Screen Saver sets the number of minutes (none-255) of inactivity after which the screen saver is 
activated. If the value None is selected, then the screen saver is disabled. 

Saver window no. designates the window that will be used as the screen saver. 

  Use the Backlight Saver to extend the life of the backlight in the HMI. 
Use the Screen Saver to have the HMI return to a Main Menu screen after a designated number of 
minutes of inactivity. 

3. Options: The Startup window no. selects the window number that will be displayed every time the 
HMI is started up. Window 10 is the default startup window. 

The Common window option determines if objects in the common window (window 4) are placed 
above or below the base window. 

The Object layout option determines the layout and display of objects by selecting either Control 
mode or Nature mode. 

  Normally, an object that is controlled by a PLC Register (i.e., Animation or Moving Shape) is 
brought to the Top Layer when the value in the PLC Register changes. This behavior can be 
changed by the Object layout option. A setting of Control sets the behavior as outlined above. A 
setting of Nature (default setting) will result in the object remaining at the layer assigned during 
development. 

The RW_A enabled checkbox enables an extra 64K of recipe storage memory. 

4. Event: When the Use LW9450-9455 as time tags of event logs box is checked, the Time/Date 
stamp for items in the Event Display will be taken from Local Words LW9450-9455. You can select 
the data format of the Time/Date stamp – BCD (binary-coded decimal) or BIN (16-bit signed 
decimal). 
If unchecked, the Time/Date stamp is taken from the selected clock (HMI RTC or External). 

Extra No of events: The default maximum number of events that can be displayed in the Event 
Display is 1000. To display more events, enter the additional number of events you would like to 
display, up to 10,000. 

5. Keyboard: Lists the windows that have been configured as keyboards.  

Add: Opens a window list from which you can select an additional window to be available as a 
project keyboard. 

Delete: Deletes the selected keyboard from the list. 

The Caret color drop-down allows you to set the color of the cursor in the Numeric Input object 
when the keyboard is activated 

The Select color drop-down allows you to set the highlight color in the Numeric Input object when 
the keyboard is activated. 
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External keyboard layout (LW-9199): Select the style of keyboard that is connected to the USB 
port on the HMI, QWERTY(0) or AZERTY(1). Local Word LW-9199 can also be used to make the 
selection (0 = QWERTY; 1 = AZERTY). 

6. Project protection: When checked, the HMI will compare the value in the Project key field to the 
32-bit unsigned value stored in HMI Local Words LW9046 and LW9047. If the value is different, the 
HMI will not run the project. 

  The Fast Selection button and keyboard option are not supported in the RMI5010. 

System Setting tab settings: 
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1. Startup language after redownloading the project: Select the language that the HMI is to use 
when restarting after a download. 

2. Execute init. MACRO when power on: When checked, the HMI will execute the selected macro on 
startup. Available only when one or more macros exist in the project. 

3. Auto logout: When checked, the HMI will automatically log out of security if no touchscreen activity 
is detected during the specified interval. The time interval can range from 1 -256 minutes. 

4. Hide system setting bar: When checked, the HMI will not display the button in the lower-right 
corner that displays the System Setting toolbar. Local Bit LB-9020 can be used to control the button. 
Set the bit to show the button and clear the bit to hide the button. Local Bit LB-9062 will cause the 
System Setting dialog window to open when set. 

5. Hide mouse cursor: When checked, the HMI will not display the mouse cursor. Local Bit LB-9018 
can be used to control the mouse cursor. Set the bit to hide the cursor and clear the bit to show the 
cursor. 

6. Sound Control: Controls how the buzzer operates when pressing buttons.  
 
  The Sound option must be enabled on the Security tab in the object’s properties. 
 
With each touch on a button, a sound is emitted – causes the HMI to produce a beep when a button 
is pressed. 
 
With each operation from a button, a sound is emitted – when the minimum press time is activated 
on a button, enabling this option will cause the HMI to produce a beep when the operation is actually 
performed, as determined by the minimum press time, rather than when the button is initially pressed. 

7. Disable buzzer: When checked, the HMI will not sound the buzzer (beep) when the screen is 
touched. Local Bit LB-9019 can also be used to control the buzzer. Set the bit to disable the buzzer 
and clear the bit to enable the buzzer. 

8. Prohibit remote HMI connecting to this machine: When checked, the HMI will not allow 
connections from a remote HMI. Local Bit LB-9044 can also be used to control remote connections. 
Set the bit to disallow remote connections, clear the bit to allow remote connections. 

 This setting controls whether or not other HMIs can connect to this HMI. It does not affect how this 
HMI connects to other HMIs. 

9. Disable upload function (effective after rebooting HMI): When checked, prevents the project 
from being uploaded from the HMI (sets LB-9033 ON). Reports “error: uploading 
/mt8000/001/mt8000.” 

  The Disable upload function can also be selected in the Compile window. 

10. Prohibit password remote-read operation: When checked, a remote HMI cannot read from the 
local words containing the VNC password (LW-9530 to LW9537) and User password (LW-9500 to 
LW-9522) data (sets LB-9053 ON). 

11. Prohibit password remote-write operation: When checked, a remote HMI cannot write to the local 
words containing the VNC password (LW-9530 to LW9537) and User password (LW-9500 to LW-
9522) data (sets LB-9054 ON). 

12. Use a disconnection icon on relative objects when PLC communication fails: When checked, 
any object that cannot be resolved due to communication loss will be displayed with a special icon: 
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13. VNC server: Check Password from project to use the password entered in the adjacent 
Password box for a VNC client to use to connect to the HMI’s internal VNC server. When not 
checked, use the VNC password entered in the HMI’s System Settings VNC Server Setting tab.  

 The VNC Server Password is stored in Local Words LW-9530 to LW-9537. 

14. VNC Server: Check Password free to allow VNC Client(s)  to connect to the HMI without requiring 
a password. 
 
 This setting is also controlled by Local Bit LB-12089. 
 

15. VNC Server: Check Monitor Mode to allow VNC Client(s) to connect to the HMI, but not allow the 
client(s) to change any data.  

 This setting is also controlled by Local Bit LB-12088. 

16.  EasyAccess server: Check Login EasyAccess server to enable EasyAccess in the HMI. See 
Technical Note 5082, “Using EasyAccess” for more information. 

  Several of these options are not supported in the RMI5010. 

Security tab settings:  
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The Security tab is used to set up a table of users, user levels (access classes), and passwords.  

General mode 

When General mode is selected, up to 12 users can be individually enabled, and each has a unique 
password and combination of any six access classes (A-F). Only numbers are allowed for passwords. When 
an object is created, it can be assigned an access class. When that object is activated (for example, a button 
is touched), the HMI compares the access classes allowed for the currently logged-in user to the access 
class specified for the object. If the access class of the object is within the classes allowed, the object’s 
action is executed. 

The access class for an object is configured in the User restriction section of the Security tab for that 
object. So, for example, if you wish to set the access class for a set bit object, click on the Security tab of 
that object’s properties dialog, as shown below: 

 

The object can be configured to handle insufficient security in one of two ways: 

• The object can be hidden while security is not sufficient (Make invisible while protected). 
• The HMI can display the message on Window 7 – Password Restriction  

(Display warning message if access denied). 

There are a number of local HMI addresses that can be used with the security features. 
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Address Description Data Type Notes 

LB-9050 Reset security level to 0  
(no security) Boolean Set momentarily to trigger. 

Also serves as user logout. 

LB-9060 Invalid password Boolean 
Set by the HMI when an invalid 
password is entered. Must be 
explicitly reset. 

LB-9061 Load new passwords Boolean Loads new passwords as defined 
by LW-9500-9523 

LW-9219 User level 16-bit 
unsigned 

Set to 1-12. Determines which 
password is used. 

LW-9220 Password 32-bit 
unsigned 

Enter password into this address to 
change the security level 

LW-9222 Current access classes 16-bit binary 
Indicates the Access Classes 
currently allowed. Bit 0 indicates 
Class A; Bit 5 indicates Class F. 

LW-9500,  
LW-9501 New password, user 1 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9502,  
LW-9503 New password, user 2 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9504,  
LW-9505 New password, user 3 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9506,  
LW-9507 New password, user 4 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9508,  
LW-9509 New password, user 5 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9510,  
LW-9511 New password, user 6 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9512,  
LW-9513 New password, user 7 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9514,  
LW-9515 New password, user 8 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9516,  
LW-9517 New password, user 9 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9518,  
LW-9519 New password, user 10 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9520,  
LW-9521 New password, user 11 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

LW-9522,  
LW-9523 New password, user 12 32-bit 

unsigned 
Loaded into security system when 
LB-9061 is set momentarily 

 
To log out a user, use a Set Bit Object to momentarily set bit LB-9050. 

Enhanced security mode 

When Enhanced security mode is selected, each user can be assigned up to twelve access classes (A-L). 
Passwords and User Names can be alphanumeric, which are stored in local memory as assigned by the 
Control address. One user is reserved as an administrator, which has complete access. The Option List 
object can be configured to display the User Names, providing a quick way to select a user to log-in. 
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In addition, up to 127 more user accounts can be added using the Administrator Tools. See “Chapter 14 – 
Security” for more information about Enhanced security mode and “Chapter 15 – Administrator Tools” for 
more information on adding more user accounts with a USB flash drive or SD card. 

  The RMI5010 only has Enhanced security mode available. 

Project password (MTP file): Select this option to set a password in order to prevent unauthorized users 
from opening and editing a project. The correct password must be entered in order to open the password-
protected project. 

Font tab settings: 

 

Determines the fonts available for non-ASCII strings. If a non-ASCII character set or double-byte character 
set is used (e.g., simplified Chinese, Japanese, Korean, etc.) but not listed in the Fonts for non-ASCII 
strings table, EZwarePlus will select a font from the list to substitute for it automatically. To add a Windows 
TrueType font that is on your computer, click Add... and select the font from the drop-down menu that 
appears, and click OK. 
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Line spacing: Select the spacing between lines of text, with a range of 0 (closest) to 6 (widest). 

Select Support Arabic, Persian, Hebrew, and Thai, …alphabets to correctly display these characters. 

 For an RMI5010 project, this tab lists the Windows fonts and the corresponding fonts displayed on an i-
Pad and the RMI5090 touchscreen. 
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Extended Memory tab settings: 

 

The Extended Memory tab is used to configure the extended memory for saving data to an SD card or USB 
flash drive. There are 10 files that can be configured for saving data, em0.emi through em9.emi. Each 
extended memory location can be accessed using the Device Type setting in an object’s properties. There is 
no address limitation for the extended memory other than the size of the SD card or USB drive connected to 
the HMI. The HMI will assume 16-bit data registers for unused addresses, so if address 100 is used for 
em0.emi, the memory storage must have at least 200 bytes of available memory. 

 Extended memory files (*.emi) can be edited and converted to *.csv file format using the Recipe/Extended 
Memory Editor, which can be opened with Utility Manager. 
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Printer/Backup Server tab settings: 

 

1. Check the Use Remote Printer/Backup Server checkbox to enable the HMI to print to a printer 
connected to a PC on the network or backup files to a PC on the network. 

 The EasyPrinter utility (included with EZwarePlus and accessible through Utility Manager) must 
be running on the PC with the network printer connected. 

2. In the Output settings section, select page layout (horizontal or vertical), print area size, and 
margins. 

3. In the Communications settings section, set the settings for the PC hosting the printer. 

  The Printer/Backup Server tab is not available in the RMI5010.  
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Time Synchronization and Daylight Savings Time settings: 

 

Select Enable time synchronization via NTP (Network Time Protocol) server to synchronize the HMI 
time with an NTP server. 

Execute time synchronization when HMI starts: Synchronizes the HMI time with the NTP server when the 
HMI starts. 

Server response time has been adjusted in accordance with DST: Check this box if the NTP server 
automatically adjusts to daylight savings time.  
 When this option is selected, the option “Automatically set daylight saving time (DST)” is deselected. 

HMI time zone: Select the time zone of the HMI relative to UTC time (Coordinated Universal Time; also 
called Greenwich Mean Time or GMT). 

Server response time: Select the time zone of the NTP server relative to UTC time. 
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Network time server: There are four Network time server fields available to configure. You can enter the IP 
address or the domain name of the NTP server(s). If the synchronization with server 1 fails, the HMI will try 
to synchronize with server 2, and so on. If the HMI is unable to synchronize with any of the NTP servers, the 
system bit LB-12055 will turn ON to indicate that time synchronization failed. 

Update interval: Determines the frequency with which the HMI attempts to synchronize with the NTP server. 
The range is 10 seconds to 86400 seconds (24 hours). 

Automatically set daylight saving time (DST): This option is available if the Server response time has 
been adjusted in accordance with DST is NOT selected.  

The Start and End fields allow you to choose when Daylight Savings Time begins and when it ends. The 
clock will move forward at the Start time and will move back at the End time. 

Daylight bias determines the time offset that will be used when DST starts and ends (usually 1:00 hour). 

E-Mail tab settings: 
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The e-Mail tab is used to enable and configure the email feature in EZwarePlus. Alarms can be configured to 
automatically send an email to a list of recipients when the alarm occurs and when the alarm is cleared. In 
addition, a screenshot of the HMI’s screen can be attached to the email. An email can also be sent when a 
Backup object is activated to send history files, recipe files, or the operation log to a list of recipients. 

Enable e-Mail function: Check this box to enable the emailing feature. 

Use existing contact settings on HMI: Email SMTP settings and contacts can be imported to the HMI from 
a USB flash drive using the Administrator Tools. When this box is checked, emails will be sent using the 
settings in the HMI. 

SMTP settings: SMTP (Simple Mail Transfer Protocol) is an internet standard for sending email across IP 
networks. Contact your IT or LAN administration staff for specific information on entering the SMTP settings. 

 Server: Enter the SMTP server address for your particular email provider. 

 Port: Enter the port number used by the email server for SMTP communications. 

User name: Enter the user name that the email account requires (usually the email address). 

Password: Enter the password associated with the email account. 

Confirm Password: Enter the password again. It must match the first password entry. 

Log on using Secure Password Authentication (SPA): Check this box if your email server 
requires Secure Password Authentication. 

Use the following type of encrypted connection: Check this box if your email server requires TLS 
or SSL encryption. 

Sender information: Configures how the sender (HMI) will appear to the recipients. 

Name: Check “Use HMI name” to use the name assigned to the HMI in the System Parameters 
Device List. If unchecked, a name can be assigned in the field below. 

 Mail address: This is the “From” email address as it will appear in the email that is sent. 

Open contact settings: Click here to open the Contacts dialog box, which is used to enter email addresses 
and create groups of recipients. Up to 16 groups can be created with a different list of recipients for each 
group. 

 



Chapter 6 – Using EZwarePlus  170 

 

EZwarePlus Programming Manual   170 

   

Add: Add a new email address to the Contacts list. 

Remove: Remove an email address from the Contacts list. 

Left and Right Arrows  : Add or remove a selected contact in the left side of the window to or 
from the selected group in the right side of the window. 

Export: Export the Contact List and Group Lists in a CSV file format. The list can then be backed up 
or edited to add more contacts. 

Import: Import a CSV file containing the Contact List and Group Lists for a project. 

See “Chapter 13 – Capturing Alarms and Events” for more information on using alarms and events 
to trigger an email from the HMI. 

 

Recipes tab settings: 
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There are two methods for creating and storing recipes in EZwarePlus. One method uses the RW memory in 
the HMI to store data and LW-9000 to index (jump) from one recipe to another. The data can be entered 
manually using Numeric Input objects or imported as a *.rcp file from the Recipe Editor. 

Another method stores the data in a database file (*.db) in the HMI. The recipe format (definition) is created 
in the Recipe tab of the System Parameters and the data is entered manually in Offline or Online Simulation 
mode using the Recipe View object and Numeric Input objects, or edited directly in the database file using 
the Recipe Database Editor (Tools > Recipe Database Editor). 

Click the “Add New Recipe” button  to create a new recipe. There are six parameters to define for the 
recipe records in a new recipe. 

1. Item name: Provides a name for the recipe record, usually an alphanumeric name, occupied by the 
first column when displayed in the Recipe View object. 

2. Data type: Defines the type of data that is used for each element in the recipe record (i.e., ASCII, 
16-bit unsigned, 32-bit float, etc.). 

3. Size: Defines the number of words for each element in the recipe record. Adjustable only for the 
ASCII, Unicode, and High/Low Reversed data types. All other data types set this field automatically. 

4. Display width: Defines the width of the data to be displayed in number of characters. This includes 
the sign, decimal point, and all digits to the left and right of the decimal point. For example, -1.34 
would require a Display width of 5, while 1.3 would require 3. 

5. Decimal Pt.: Defines the number of digits to the right of the decimal point. 

6. Alignment: Defines how the data will be aligned in the Recipe View cell (Align left, Align center, 
Align right). 

Click the New button to add items (data fields) to the recipe after the selected item. Each new item adds a 
column to the recipe when viewed in the Recipe View object. 

Click the Settings button to edit the parameters for the selected item in the Recipes Item Information popup 
window.  

 

The parameters can also be edited directly in the item list in the Recipes tab. 

Click the Delete button to delete the selected item from the list. 
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Click the Up/Down arrow buttons on the right side of the Recipes tab to move the selected item up and down 
in the list. 

Click Export definition file of recipes to save the recipe definitions in a *.rdef file. This can be imported into 
the Recipe Database Editor for adding data to the recipe. 

See “Chapter 16 – Recipes” for more information about using recipes in EZwarePlus. 

Cellular Data Network tab settings: 

 

The Cellular Data Network tab is used to setup the cellular network connection for the HMI. Network data 
settings will be different between different network providers and hardware manufacturers, please refer to 
documentation from your hardware manufacturer and service provider for network settings. 

RMI 5010 

Attaching a 3G/4G USB dongle to the USB port enables the RMI5010 to connect to the 3G/4G network 
through the device.  

If Use existing settings on HMI is checked the cellular data settings currently in the HMI will be used. When 
no specific settings are required, set PIN code to “0000,” APN to “internet,” and leave Username, 
Password, and Dial Number blank. 



Chapter 6 – Using EZwarePlus  173 

 

EZwarePlus Programming Manual   173 

   

Registers: 

• LW-11297: (16 words) : PIN code of SIM card (cellular network) 
• LW-11313: (16 words) : APN - Access Point Name (cellular network) 
• LW-11329: (16 words) : username (cellular network) 
• LW-11345: (16 words) : password (cellular network) 
• LW-11361: (16 words) : dial number (cellular network) 
• LW-11377: (16bit) : stop (set 0)/start (set 1) connection (cellular network) 
• LW-11378: (16bit) : last error code (0:success, 1:incorrect PIN code, 2:no SIM, 3:no device, 4:puk 

locked, 5:other) (cellular network) 
• LW-11379: (16bit) : connection status (0:no device, 1:disconnect, 2:connecting, 3:connected) 

(cellular network) 

HMI or RMI5001Connecting an Android mobile phone to the HMI with a USB cable enables the HMI to share 
the network connection of the mobile phone.  

On the Android mobile phone enable USB tethering. 

 

Registers: 

• LW-11380: (16bit) : stop (set 0)/start (set 1) connection (USB tethering) 
• LW-11381: (16bit) : connection status (0:no device, 1:disconnected, 2:connected, 3:fail, 4:OS not 

supported, 5:HMI not supported) (USB tethering) 

Reboot HMI 
EZwarePlus can automatically reboot the HMI after download. 

To enable automatic reboot of HMI after download: 

1. From the Tools menu, select Download. The Download dialog box is displayed. 

2. Check the Reboot HMI after download checkbox. 

3. Click OK. 

To manually reboot HMI: 

1. From the Tools menu, select Reboot HMI. 
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2. Select Ethernet or USB cable. 

3. You can reset the recipe, recipe database, event log, and data sampling by selecting the 
corresponding checkbox. 

4. Click Reboot HMI. 

Save and Compile the Project 
EZwarePlus can automatically save and compile the project when downloading or simulating. 

To enable automatic save and compile: 

1. From the Option menu, select Function Property. The Function Property dialog box is displayed. 

2. Check the Automatic save and compile when download and simulate checkbox. 

3. Click OK to exit the Function Property dialog box. 

EZware-500 Project Translation Utility 
EZwarePlus has a translation utility that will convert projects created in EasyBuilder-500 into a project format 
that can be read and modified using the EZwarePlus software. Below is a brief description of how to use this 
utility (for more information, download Technical Note 5102 on this subject from Maple Systems’ website): 

To convert a *.eob (EasyBuilder-500 compiled project) into a *.emtp (EZwarePlus project), it is necessary to 
use the Translation utility in EasyBuilder-5000 first and then transfer the translated project to EZwarePlus: 

1. Open EasyBuilder-5000. 

2. From the Tools menu, click Translate HMI500 Project: 

 

3. Click the Browse… button for the HMI500 EOB file and select the EasyBuilder-500 project file you 
wish to convert. 
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4. By default, the converted file is automatically placed into the same directory. To modify the name of 
the file or location, click the Browse… button for the HMI5000 project file. 

5. Default font: All text objects in theEasyBuilder-500 project file use a proprietary fixed font. When 
converting to an EasyBuilder-5000 project, these text objects are converted to TrueType fonts. Use 
this section to specify which TrueType fonts you wish to use. 

  The EZware-500 configuration software uses proprietary fonts that must be replaced with a Windows 
TrueType font. EZware-5000 installs three TrueType fonts into the Windows > Fonts folder that closely 
resemble the fonts used in EZware-500 (HMI 500 16p, HMI 500 24p, HMI 500 8p). Select Use HMI500 
ASCII font files to use these fonts. If you choose to use another Windows TrueType font (by unchecking 
Use HMI500 ASCII font files), additional ‘tweaking’ may be required after you have converted your project. 
We recommend using Calibri if you have this font available on your computer. Otherwise, another san serif 
font like Helvetica should work. 

You can allow EasyBuilder-5000 to automatically adjust the font size for you by selecting Use the most 
suitable font size automatically. If you uncheck this box, you can click on the Font Size Table button, 
which allows you to customize the transition size of the fonts from EasyBuilder-500 to EasyBuilder-5000 
projects. This gives you maximum flexibility in deciding which font and which sizes you would like to use. For 
the Calibri font, we recommend those items as shown in the table on the next page. 

 

6. Delete “Direct Window” objects which are triggered with LB9060~9069, 9080, 9081, (HMI5000-
series use a new mechanism to manage keyboards.): Check this box to delete any Direct Windows 
objects in the EasyBuilder-500 project file that are triggered by the internal local memory bits 
LB9060-LB9069, LB9080-LB9081. 

 In EasyBuilder-500, these local memory bits allowed a popup window to appear in the display 
based upon touching any Numeric Input or ASCII Input object located in a particular area of the 
screen. This feature is not available in EZwarePlus. By default, this option is checked. 

7. Click the Translate button to begin conversion of the file. When done, you will see text in the 
comments field that indicates if the conversion is successful. 
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8. Click the Exit button to go back to the main screen of EasyBuilder-5000. Open the converted file as 
you would normally open any EasyBuilder-5000 project file. 

 Due to some incompatibilities between the EZware-500 software and the EasyBuilder-5000 software, you 
should check each screen and test operation after conversion to make sure that your HMI works to your 
satisfaction. 

 The Shape Library and Picture Library file formats in EZwarePlus are different than those used in 
EasyBuilder-500. When a project is translated, EasyBuilder-5000 creates new libraries with the same file 
name as the translated project containing the shapes and pictures (bitmaps) from the original EasyBuilder-
500 project. For example, if a 500 Series project is translated and saved with the filename 
“PumpStation4.mtp,” a Shape Library is created with the name “PumpStation4_0.plb” and a Picture Library is 
created with the name “PumpStation4_0.flb” and saved into the EZware-5000 Library folder 
(C:\MapleSystems\EZ5000\library).  

9. Depending on the HMI model you have to replace the HMI500 Series, you may need to select a new 
model in the System Parameters > Model tab that corresponds to the screen size of the HMI5000 
Series you are converting to. Use the following table to match the target HMI (the HMI5000 Series 
that you have) with the model you should select in EasyBuilder-5000. 

Target HMI Screen Resolution EasyBuilder-5000 Model 

HMI5043L 480x282 HMI5043N/T 

HMI5070P/L/DL/R; 5100L 800x480 HMI5070NH/TH 

HMI5121P/XL; HMI5150P/XL; 5097XL/NXL 1024x768 HI5150X 

RMI5001 1280x720 HMI5150X (closest fit) 

RMI5010 1024x748 
HMI5150X (closest fit) 
(not all features will 
convert) 

 

10. Once you have selected the corresponding model in the Model tab, click OK. A popup window will 
appear with options for resizing windows and objects in the project. 
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There are four options for resizing the project. Select Resize pop-up windows and Resize objects 
under General windows. If you want the keypads to be resized appropriately for the new screen size, 
select Resize keyboard windows and Resize function key objects under Keyboard windows. 

11. Click OK and the windows will automatically resize to the selected model’s screen resolution.  
Save the project. 
 

12. Compress the file by opening the Compress utility (Tools > Compress/Uncompress) and clicking the 
Compressing button. 
 

 
 

13. This creates a new file with the same name as the project but with a *.cmp extension. The compress 
utility bundles the project file (*.mtp) with the library files that are linked to the project. 
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14. Copy the compressed file (*.cmp) into the EZwarePlus project folder 
(C:\MapleSystems\EZPlus\Project). Open EZwarePlus and run the Uncompress utility (Tools > 
Compress/Uncompress). 
 

 
 
This extracts the *.emtp project file and the library files and places them in the Project folder and 
Library folder, respectively. 
 

15. Open the project in EZwarePlus and select the appropriate model in the System Parameters > 
Model tab. 
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Chapter 7 – Creating Windows 
This section shows how to create and use windows in EZwarePlus.  

Window Fundamentals 
An operator interface terminal wouldn’t be very useful if all of the information to be displayed could only be 
placed onto one screen. Therefore, most HMIs have multiple screens that you can use to display information. 
The Maple Systems HMI5000P/L are capable of storing up to 1999 windows (actual limit is determined by 
memory requirements of each screen), giving you maximum flexibility in designing your operator interface. We 
prefer to call these screens ‘windows’ because they have several features not normally associated with 
screens: 

• Windows can be created in any size. You can make the window full-sized so that it fits the 
entire area of the HMI display or you can create a window that partially covers the display. 

• Windows can be overlaid on top of each other. All data on each window displayed is updated 
continuously regardless of whether or not it is covered up by another window. 

• Windows can be moved around the HMI display to allow portions of other windows to come 
into view. 

The HMI5000 Series has four basic types of windows available for use: Base windows, a Common window, 
System Message window, and a Fast Selection window. Base windows are the windows that you will most 
often use. The Common window and Fast Selection window are two windows reserved for special functions. 
System Message windows are reserved for custom messages from the controller. By the end of this chapter, 
you will be able to create these windows and use the many features available to them. 

Opening and Closing a Window 
To view the contents of a window in EZwarePlus, it must first be opened. When you create or open an existing 
project file, only the initial window is opened. To view any other windows that have already been created, you 
must first open the window. This can be done using the Window Tree (see “Chapter 6 – Using EZwarePlus > 
Display Options”) or by performing the following: 

To open a window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 
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2. Click on the Window you wish to open. Then click Open.  
 You can also open the window by double-clicking the window. 

3. The Open Window dialog box closes and the opened window is displayed in the EZwarePlus work 
area. 

The Open Window dialog box lists all of the windows currently created for the project. An asterisk next to a 
Window indicates that the window has already been opened. Each window is listed with the Window name 
and size. The window name is the name that you assign to the window when it is created. The window size is 
shown for quick reference. Finally, you will notice that the Open Window dialog box is also used to create a 
new window or change any of the settings for a window.  

By default, when a window is opened it will replace any window that was displayed in the work area of 
EZwarePlus. To switch between open windows, click the Window menu and select from the list of windows 
currently open. You can also cascade (select Window-Cascade) or tile (select Window-Tile) the open 
windows to see the windows at the same time. 

EZwarePlus requires more resources from your computer every time you open another window. When many 
windows are open, the performance of the computer may be affected. Therefore, you may wish to close some 
of the windows until you need to edit them. 

To close a window: 

1. You will notice three small icons located in the upper right hand corner of each window: the minimize 
icon  , the maximize icon  , and the close icon  . To close a window, click the close icon 
associated with that window. These icons show in the window if minimized. Otherwise, the icons are 
located on the rightmost end of the menu bar of EZwarePlus. 

2. There is a close icon on each window tab as well, located just above the work area. 

Creating a New Window 
Whenever you create a new project, several windows have already been created by EZwarePlus. Windows 5, 
6, 7, and 10 are created by default. You must have the “Use template” option checked when creating the 
project to create the other windows listed below. 

#3: Fast Selection – The window controlled by the Fast Sel button that appears on every window (when 
enabled in the System Parameters > General tab). This allows you to quickly jump to commonly accessed 
windows or objects by placing Function Keys on the Fast Selection window. 

#4: Common Window – A window that displays graphics (such as a company logo) or objects that are always 
on every screen of the display. The common window runs below every other window that is being displayed 
on the HMI. 

#5: PLC Response – This is the window that is displayed when the HMI loses communications with the PLC. 

#6: HMI Connection – This is the window that is displayed with the HMI loses communications with a remotely 
connected HMI. 

#7: Password Restriction – This is a window that is displayed when access is attempted on a protected object 
without the proper password. 

#8: Storage Space Insufficient – This is a window that is displayed when the available memory in the HMI, 
USB Flash drive, or SD card is running low.  

#10: Startup Window – The window that displays whenever the HMI is started up. The Startup window can be 
redefined in the System Parameter Settings, on the General tab. 



Chapter 7 – Creating Windows  181 

 

EZwarePlus Programming Manual   181 

   

#50-65: Various Keypads– A selection of different style keypads to use for numeric or alphanumeric entry 
including Integer, Hex, Floating, and ASCII. 

The remaining windows are available to be created as you desire for your project. In order to create new 
windows, the following steps must be performed. 

To create a new window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

 

2. Click New… The Select Window Style dialog box appears. 

 

3. Click Base Window. If the Fast Selection and Common Window buttons appear grayed out, then it is 
because those windows have already been created. The Window Setting dialog box appears. 
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4. Modify the window parameters, then click OK. The Open Window dialog box reappears. 

5. If you wish to open the window you just created, click on the window and click Open. Otherwise, click 
Exit to return to the main screen of EZwarePlus. 

6. An alternate method of creating a new window is to right-click on an unused window number in the 
Windows Object List and select New. The Window Settings dialog opens. 

Window Settings 
Let’s look more closely at the parameters you can change when creating a new window. 

  When a window is initially created, the window settings can be edited to make changes. To change the 
window settings, highlight the desired window in the Open Window dialog and click on the Settings... button. 
Alternately, right-click on the desired window in the Window Tree > Object List and select Settings. 

Window Name 
The Name is a description box used to help you identify what the window is used for without having to actually 
open the window and look at the contents. Up to 50 characters can be entered into this field with space 
characters allowed. 

Window Number 
Although 1999 windows are available on the HMI5000P/L Series, two are specifically reserved for the 
Common Window and the Fast Selection window and several are reserved for internal use. Therefore, you 
can assign #10-1999 to any window you create. When you initially create a window, EZwarePlus will 
automatically assign the lowest available number to the window. However, once you create the window you 
can go back into the Window Settings and reassign it to any number within the allowed range. In this manner, 
you can group windows together that may share some common traits. 

Size of Window 
You can vary the size of a new window to create full screen or popup windows. Popup windows are most 
often used to display data that does not need to be on the HMI display all of the time. For example, you might 
want to configure an instructional message in a popup window that can be moved aside or closed when not 
needed. The message can be triggered to pop up when needed or appear with a keypress.  

Window Frame 
The Window Settings dialog provides the option of having a frame around any window that you create. You 
can create a frame from 0-16 pixels wide in any of the EZwarePlus 65K available colors. 

Window Background 
You can also select a different background color for each window created. The default setting is black. 

To select a different background color: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

2. Click on the window that you wish to change the background color. Click Settings. The Window 
Setting dialog box appears. 

3. In the Background section, check the Filled box. 

4. Click the pull-down arrow of the Color box. The Color dialog box appears. 
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5. Select from one of the basic colors or add new colors from the customized list of colors. To create a 
customized color, click on the Custom button at the bottom of the Color dialog box.. 

6. The color table dialog box appears allowing you to select or modify one of the colors available. 

7. Click OK in the Color dialog box to go back to the Window Setting dialog box. Click Close to return to 
the EZwarePlus main screen. 

Instead of using a solid background color, you can select a pattern that is displayed in the background of a 
window. 

To select a background pattern: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

2. Click on the window that you wish to change the background pattern. Click Settings. The Window 
Setting dialog box appears. 

3. In the Background section, check the Filled box. Select a background color as described above. 

4. Click the pull-down arrow of the Pattern box and select a pattern, then click OK.  

5. Click the pull-down arrow of the Pattern color box and select a color. 
 To use the background pattern, the color selected for Pattern color must be different then the color 
selected for the Background color. 

6. Once a pattern color is selected, click OK in the Color dialog box to go back to the Window Setting 
dialog box. 

7. Click Close to return to the EZwarePlus main screen. 

Underlay Windows 
An Underlay Window is a Base Window that is displayed at the same time as the Base Window that calls it. 
Each full-size Base Window can display up to three underlay windows. A popup window cannot display any 
underlay windows. There may be times when it is desirable to place the same information on multiple (but not 
all) windows. Underlay windows provide a means to accomplish that without the overhead of a Direct or 
Indirect Window, and without using the Common Window (which makes the information visible on all 
windows). Underlay windows also eliminate the need to actually place the same objects on multiple windows, 
which increases the memory required for the project. Each base window can display up to three underlay 
windows, which are called Bottom, Middle, and Top. 

How to Display Underlay Windows 
When you have common objects to display on multiple screens, use the underlay window feature to store 
these on underlay windows attached to a base window. This decreases the amount of memory required for 
the project. The base window “calls” the underlay window. Each full-size base window can display up to three 
underlay windows, which are called Bottom, Middle, and Top. Objects on the underlay windows cannot be 
edited from the base window on which they are displayed. 

  It may be desirable to use Underlay Windows but temporarily hide them when developing the project. 

The  button on the Standard Toolbar toggles the visibility of objects on Underlay Windows. You can also 
toggle the Underlay Window visibility in the Preferences window under the Option menu . 

  A popup window cannot display any underlay windows. 
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To assign underlay windows to a base window, you must first create the underlay windows. Underlay windows 
are created the same way base windows are created. Then you can assign the underlay windows to the base 
window. 

To assign underlay windows to a base window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

2. Highlight the base window you wish to use. 

3. Click the Settings… button. The Window Setting dialog box appears. 

4. Click the pull-down list box for each Underlay window selection to assign the underlay window 
screens to the base window. 

5. Click OK. Click Close on the Window Setting dialog box. 

Rules That Apply to Underlay Windows 

• Only the objects of an underlay window are displayed on the base window. All background 
information about the underlay window (i.e. background color, frame color and size, etc.) are 
not displayed on the base window. 

• Active objects can be ‘overlaid’ on top of each other over two or more underlay windows. For 
example, a Set Bit object that is configured to set an HMI local bit LB0 is located at X=20, 
Y=50 for Underlay Window #1. Another Set Bit object that controls LB1 is placed on Underlay 
Window #2 at the same location. When the Base Window displays these two windows, both 
objects will be active so that when they are pressed both LB0 and LB1 will be set. 

• Static objects may be overlaid using underlay windows. However, any static object that is on 
the Base Window has the highest precedence and will be displayed over any static objects 
that are on the underlay windows. Active objects have higher precedence over static objects. 

• Popup windows cannot display underlay windows. 

• Underlay windows are always positioned from the top left corner of the screen. Any position 
settings you make when creating the underlay window are ignored when the window is 
displayed by a Base Window as an underlay window. 

For more information and an example of how to use underlay windows, consult the EZwarePlus Help files. 

Popup Window Start Position 
This is the starting position that the window goes to when it is initially called onto the HMI screen as a popup 
window. The X and Y positions refer to the pixel location of the HMI display at which the upper left-hand 
corner of the window is to be displayed. 

The default setting is X=0 and Y=0 which is the upper left-hand corner of the HMI display. The X-axis refers to 
the horizontal location and the Y-axis refers to the vertical location.  

Monopoly Feature 
The monopoly feature is used to ‘monopolize’ all touchscreen action that can occur on the HMI screen. For 
instance, suppose the HMI display is currently showing a full screen window with several objects. If a popup 
window is displayed that does not have the monopoly feature enabled, the HMI operator is able to press and 
activate any objects on the popup window or the full screen window since objects on both screens are active. 
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If another popup window is displayed that does have the monopoly feature enabled, then the objects on the 
full screen window will not respond when pressed. 

Please note that the monopoly feature only disables touchscreen objects on the full screen window. Objects 
on other popup windows can still be activated. 

The monopoly feature can be used to display a popup window with some action that the HMI operator must 
perform before being allowed to do some other action on the HMI. For example, you might construct a dialog 
box that asks the HMI operator if some step in the control process has been performed. The dialog box would 
have Yes and No function key options which, with the monopoly feature enabled, the HMI operator must press 
before continuing. 

Macro 
Macros can be executed when a window opens, closes, or while it is open. 

 

 The Macro options do not appear unless a macro has been created in the project. 

The options are: 

1. Open: runs once when window opens. 

2. Cycle: runs once every 500 milliseconds while window is open. 

3. Close: runs once when window closes. 

Notes: 

1. The macro options work on base windows, popup windows, direct windows, indirect windows, and 
windows called from PLC control objects. 

2. For indirect windows, the open and close macros are both executed when the window is changed. 

3. The monopoly feature does not prevent the macro from being executed. 

Deleting a Window 
Before any window can be deleted from a project, the window must be closed. To close a window, see the 
section earlier in this chapter on opening and closing windows. 

To delete a window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 
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2. Highlight the window that you wish to delete. 

3. Click the Delete button. A dialog box appears asking if you want to delete this window. 

4. Click Yes. The dialog box disappears and the selected window is deleted. 

5. Click Close in the Open Window dialog box to go back to the EZwarePlus main screen. 

  If the Delete button does not appear when the window is highlighted, this means that this is a Window that 
can't be deleted. Typically, if you are unable to delete a window, it is because it is one of the predefined 
windows discussed earlier in this chapter or the window is still open. 

  Windows can also be deleted by right-clicking on the window in the Windows Object list and selecting 
Delete. The window must be closed before it can be deleted. 

Using Base Windows 
Of the four types of windows, base windows are the most commonly used. A base window is used to create a 
full screen window or a popup (partially sized) window. Popup windows can also be moved about on the HMI 
display and can overlap each other. The number of objects that can be placed onto each base window is 
limited only by the total amount of memory available within the HMI. 

How to Display Base Windows 
Base windows can be displayed on the HMI screen by using a function key to display the window or by using 
the PLC to call up the window. 

Using a Function Key 
The Function Key Object is a graphic touch object that is placed onto a window to perform an action. Function 
keys have many purposes, but two actions that a function key can perform are: 
•  Calling a full screen window 
•  Calling a popup window 

Calling a full screen window 

If a function key object is created to call a full screen window, the window that is displayed replaces the base 
window currently displayed and closes any popups that were opened with the Close this popup window 
when parent window is closed option selected. 

To call a full screen window using a function key object: 

1. From the Objects menu, select Function Key. The New Function Key Object dialog box appears. 

2. In the General tab, click the Change full-screen window option button. 

3. In the same section, enter the Window No. you want to call. 

4. Select the Shape tab, click the Use shape or Use picture checkbox, and then click the Shape 
Library button or Picture Library button. Select the shape or bitmap you wish to use to represent the 
function key and click OK. 

5. Select the Label tab and check Use label and create a label for the function key. 

6. Click OK to return to the main screen of EZwarePlus. 

7. Place the function key object where you want it on the window you are editing. You must select a 
window that is full size when using the Change Window function. 
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Calling a popup window 

If a function key object is created to call a popup window, the window that is displayed is generally overlaid 
over all other windows that are on display. Think of calling a popup window as opening another active window 
for display. 

To call a popup window using a function key object: 

1. From the Objects menu, select Function Key. The New Function Key Object dialog box appears. 

2. In the General Tab, check the Display popup window option button. Note that the Close this 
popup window when parent window is closed checkbox will cause the popup to close 
automatically whenever the base window changes. 

3. In the same section, enter the Window No. you want to call. 

4. Select the Shape tab, click the Use shape or Use picture checkbox, and then click the Shape 
Library button or Picture Library button. Select the shape or bitmap you wish to use to represent the 
function key and click OK. 

5. Select the Label tab and check Use label and create a label for the function key. 

6. Click OK to return to the main screen of EZwarePlus. 

7. Place the function key object where you want it on the window you are editing. You must select a 
window that is less than full size when using the Popup Window function. 

To display a full screen or popup window, press the touchscreen where the function key object is located. The 
window displays in the location on the HMI display as determined by the X and Y position in the Window 
Settings box for that window. 

Using the PLC 
Three objects are used by the PLC to call or display a base window. The PLC Control Object is used by the 
PLC to display full screen windows. The Direct and Indirect Window Objects are used by the PLC to display 
popup windows. 

The PLC Control Object 

The PLC can display a full screen window by using the PLC Control Object. This object allows the HMI to 
continuously scan a PLC register to display a full screen window, which corresponds to the number in the PLC 
register. 

Once the HMI displays a window that is requested by the PLC Control Object, the HMI will automatically write 
the number of the requested window to the next consecutive register. For example, if you assign a Modbus 
holding register 4x10 to a PLC Control Object/Change Window and the number 3 is placed into this register, 
then the HMI will display Window #3. Finally, it will put the number 3 into 4x11. This allows the PLC to confirm 
that the window has been properly displayed by the HMI. 

You can create as many PLC Control Objects as you need -- each object is universal and is not dependent 
upon which HMI window is currently on display. 
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To call a full screen window using the PLC Control object: 

1. From the Objects menu, select PLC Control. The PLC Control Object dialog box appears. 

 

2. Click New.... The PLC Control dialog appears. 

 

3. Select Change window from the Type of control drop-down box in the Attribute section. 
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4. Click the Setting… button in the Trigger address section and select the Device type and Address 
for the actual PLC address you wish to monitor. 

  The HMI will write the number of the newly-displayed window to the next consecutive address 
after the address specified in this step. 

5. Select the format from the drop-down menu (e.g., 16-bit or 32-bit unsigned, signed or BCD). 

6. Click OK to return to the PLC Control dialog box. Click OK again to return to the PLC Control Object 
dialog box. 

7. You will see a new entry that lists the PLC address that is monitored by the HMI. 

The PLC must only enter window numbers that represent full-size windows when using the PLC Control 
Object function. If the PLC writes the number of a popup window or a non-defined window to the thrigger 
address, then no action will be taken. 

 See “Chapter 6 – Using EZwarePlus > EZwarePlus Features > Objects Summary > PLC Control “for more 
information about the Change Window feature.  

The Direct and Indirect Window Objects 

If you want the PLC to call up a popup window that is to be overlaid on top of other windows already open, 
then there are two methods used to do this: 
•  Direct Window Object 
•  Indirect Window Object 

  Unlike the PLC Control Object, the Direct and Indirect Window Objects are only active for the windows into 
which they are placed.  Place the Direct or Indirect Window on the Common Window if you want it to be active 
regardless of which window is open in the HMI. 

Both the Direct and Indirect Windows can be configured to display a Title Bar.  When the application is 
running (in the HMI or simulator), the Title Bar can be grabbed (or clicked) and used to move the window 
around the screen. 

The Direct Window Object is used to display a popup window using a PLC bit. The HMI continuously reads 
the value of the PLC bit, as long as the window containing the Direct or Indirect Window object is active, to 
determine its state. If the trigger state is detected, then the designated popup window is displayed within the 
frame of the Direct Window Object.. 

The Indirect Window Object is used to display a popup window using a PLC data register. Similar to the PLC 
Control Object, the HMI continuously monitors the selected PLC data register. It will display any popup 
window that corresponds to the number placed into the PLC data register by the PLC.  If the Window Offset 
feature is checked, the displayed window will be the window whose number is the sum of the value in the 
register and the selected offset value. 

The PLC must reference a window that is less than full size when using the Direct Window and Indirect 
Window objects. 

To call a popup window using the Direct Window Object: 

1. From the Objects menu, select Direct Window. The New Direct Window Object dialog box appears. 
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2. Select the trigger state in the Trigger drop-down box (ON or OFF). 

3. Click the Settings… button in the Read address section and select the PLC address according to 
Device type selected from the drop-down menu and then enter the address. Click OK to close the 
Address window. 

4. Select the Window No. you want to call from the drop-down menu under the Attribute heading. 

5. Select the Style of the popup window, With title bar or No title bar. Enabling the title bar allows the 
user to grab the window and move it around the display. 

6. Click OK to return to the main screen of EZwarePlus. The mouse cursor will have a square object that 
represents the size of the popup window. 

7. Place the Direct Window object where you want the popup window to appear. 

  The Direct Window object should be the same size as the popup window it is calling. You can 
resize the object after you have placed it by clicking on the object and dragging on the sizing handles 
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or selecting the Profile tab in the Direct Window Object’s Properties window and adjusting the Width 
and Height settings. 

To call a popup window using the Indirect Window Object: 

1. From the Objects menu, select Indirect Window. The New Indirect Window Object dialog box 
appears. 

 

2. Select Click the Setting… button in the Read address section and select the PLC address according 
to Device type selected from the drop-down menu and then enter the address. 

3. Leave the Attribute set to No title bar.  Using a Title Bar allows the window to be moved around the 
screen. 

4. Leave Use window no offset and Auto adjust window size unchecked. 

5. Click OK to return to the main screen of EZwarePlus. The mouse cursor will have a square object that 
represents the size of the popup window. 
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6. Place the Indirect Window object where you want the popup window to appear. 

  The Indirect Window object should be the same size as the popup window it is calling. You can 
resize the object after you have placed it by clicking on the object and dragging on the sizing handles 
or selecting the Profile tab in the Indirect Window Object’s Properties window and adjusting the 
Width and Height settings. 

Tips and Suggestions 

Having trouble deciding which method to use to display a base window? Here are some suggestions: 

• If you want to clear the HMI display of all open windows and display a new full screen window, then use the 
PLC Control Object function or select the Change Window option in the Function Key Object. The PLC Control 
Object is global (meaning it does not matter which windows are currently on display), so the HMI will always 
monitor the PLC address that you have selected. The Function Key Object can be made local to one or more 
windows by placing the object on only those windows. It can also be made global (meaning the HMI operator 
can always change to this window no matter which window is currently displayed), by placing the Function 
Key Object on the Common Window or the Fast Selection Window. 

• If you want to display a popup window on one particular full screen window, then try using the Popup 
Window option in the Function Key Object. This is particularly useful if you want the HMI operator to control 
the ability to display the popup window. If you want the PLC to determine when to display the popup window, 
then use the Direct Window object. 

• If you want to display a popup window that can be shown on any full screen window, then try using the 
Popup Window option in the Function Key Object. You should place the Function Key Object on the Common 
Window or in the Fast Selection Window. This will allow the HMI operator access to that popup window 
regardless of which full screen window is displayed. If you want to display the popup window only when some 
condition in the PLC has occurred, then use the Direct Window object on the Common Window. 

• If you want to display one of many possible popup windows on any full screen window, then try using the 
Indirect Window object on the Common Window. You can then let the PLC determine which popup window 
should be displayed or you can create several Set Word objects to allow the HMI operator to select which 
window to look at. 

Returning to a previous window 

You can configure a function key to display the full-sized base window that was on the HMI screen before the 
currently shown window. 

Create a function key to return to previous window: 

1. From the Objects menu, select Function Key. The New Function Key Object dialog box is displayed. 

2. Select the Return to previous window option button. 

3. Configure the rest of the function key, and then click OK. 

4. Place the function key object onto the full-sized base screen. 

 Placing a Return to previous window function key onto a popup window will not work. 

Using a function key to close a window 

You can configure a function key to close any popup window that is currently displayed on the HMI screen, 
and was called by a function key. 

Create a function key to close a window: 
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1. From the Objects menu, select Function Key. The New Function Key Object dialog box is displayed. 

2. Select the Close window option button. 

3. Configure the rest of the function key, and then click OK. 

4. Place the function key object onto the popup window. 

 Placing a Close window function key onto a full-size base screen will not work. To close a direct window, 
turn off the controlling bit. To close an indirect window, write a 0 to the controlling register. 

Using the Common Window 
Your project might require that some data be displayed on the HMI screen at all times, regardless of which 
window(s) are displayed. For example, you may want to display a company logo on the HMI screen at all 
times, or you may want to display some critical data or an alarm message which should be seen no matter 
what windows are displayed. 

Using base windows to display this information requires that you configure every full screen base window with 
the same graphics object. The common window however, is a predefined window in the HMI that you can 
enable to display this information. When created, the common window always operates in the background as 
a full screen window that overlays any full screen base window displayed. 

  It may be desirable to use the Common Window but temporarily hide it when developing the project. 

The  button on the Standard Toolbar toggles the visibility of objects on the Common Window. 

Whenever you create a new project, the common window (Window #4) is automatically created. 

To access the common window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears (see on 
following page). 
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2. Highlight Window #4, Common Window and click Settings. The Window Setting dialog box appears. 

 

3. As you can see, some of the parameters for a common window are disabled and cannot be changed. 
Window #4 is always reserved for the Common Window. Although the Background settings are active, 
none of these settings affects the operation of the common window. 

4. Click OK. The Open Window dialog box reappears with the Common Window selected. 

5. If you wish to open the common window, click Open. Otherwise, click Close to return to the main 
screen of EZwarePlus. 

Displaying the common window above/below the base window 
This setting resolves the conflict that can occur if a graphics object on the common window occupies the same 
space on the HMI display as a graphics object on a base window. Using the Above base window attribute 
forces the graphics object on the common window to cover the base window graphics object. Using Below 
base window has the opposite effect. 

   

Base Window Common Window 
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When Above base window is set, the result is: 

 

When Below base window is set, the result is: 

 

To set the Above/Below base window option for a common window: 

1. From the Edit menu, select System Parameters. The System Parameter Settings dialog box 
appears. 

2. Select the General tab. In the Options section next to Common window, select either Above base 
window or Below base window. 

3. Click OK to return to the main screen of EZwarePlus. 

  Active graphics objects (objects that display information or graphics according to a data value in a PLC 
register or coil) take precedence over passive graphics objects (objects such as circles, lines, rectangles, 
etc.). Therefore, a Set Word Object on a base window will cover a Rectangle Object on a common window 
that occupies the same space even with the Above base screen attribute enabled. 

Changing the Active Common Window 
Although only one common window can be on the HMI display at one time, you do have the ability to create 
multiple common windows by using base windows as common windows. Then, with the help of a Function 
Key object (using the Change common window checkbox), the HMI operator can change the active common 
window. 

The ability to change the common window adds more flexibility to your project should you need it. For 
example, you may have a series of full screen windows which all need a keypad for entry. Another series of 
full screen windows may require a common alarm message. By changing the common window with each 
series of windows, you can customize each common window to contain only the graphics objects that are 
needed. 
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To change the active common window: 

1. Create a new project. The Common Window (Window 4) is automatically created. 

2. Create a base window that is full screen. This will be used as another common window. 

  Note that when a base window is used as a common window, the Start Pos:, Style, Frame, and 
Background settings are ignored by the HMI. For this example, let’s use Window #30 as the alternate 
common window. 

3. Create another full screen base window that can be displayed along with the common windows, (such 
as a startup window). Let’s use Window #10, the initial window, for our example. 

4. On Window #10, create a Function Key object that is used to change the common window. From the 
Objects menu, click Function Key. The New Function Key Object dialog box appears. 

5. On the General tab, select the Change common window option button. 

6. In the same section, select 30 from the Window no. drop-down menu. 

7. Click the Shape tab. Click Use Shape... and then click on the Shape Library… button. Select Shape 
#1 from the button1 library. Click OK to return to the Create Function Key Object dialog box. 

8. Click the Label tab. Click the Use label checkbox. 

9. For our example, type CCW (meaning Change Common Window) into the Content box. Click OK to 
exit the Create Function Key Object dialog box and go back to the EZwarePlus main screen. 

10. Place the new Function Key object somewhere on Window #10. 

Below is an illustration of what the default common window, Window#30 (alternate common window), and 
Window#10 (startup window) might look like: 

 

     Default Common Window #4   Alternate Common Window #30   Initial Window #10 



Chapter 7 – Creating Windows  197 

 

EZwarePlus Programming Manual   197 

   

When the HMI initializes, it displays the startup screen (Window #10) and the default common window. 

 

To change common windows, we press the CCW function key that has been configured to change the 
common window to Window #30. 

 

Window #30 remains the common window until another function key object is pressed that changes the 
common window or until the HMI is reset. 

Using the Fast Selection Window 
In the last section, you read that common windows are great for displaying information that should be 
displayed all the time, regardless of which base windows are active. You may also create projects that require 
a window that is always accessible (like a common window) but not always displayed. For example, you may 
want a numeric keypad available for any data entry; however, a keypad takes precious space on the HMI 
display. Ideally it should appear on screen only when a key was pressed and then, by pressing another (or the 
same) key, the keypad should disappear. 

This is essentially the purpose of the Fast Selection window. The Fast Selection window can also be used as 
a menu key that allows the HMI operator to rapidly switch screens. 
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Whenever a new project is created, the fast selection window (Window #3) is automatically created (except 
when Portrait mode is selected; you can create a Fast Selection window using the Window > Open Window 
> New… > Fast Selection command). 

To open a fast selection window: 

1. From the Window menu, select Open Window. The Open Window dialog box appears. 

 

2. Highlight the Fast Selection Window and click Settings. The Window Setting dialog box appears. 

 

3. The Name: and Window No.: are reserved to identify the Fast Selection window. The other 
parameters can be modified, (see the Window Settings section earlier in this chapter for more 
information). Notice that the default size is Width = 100 and Height = 450. The default was selected to 
create a ‘sidebar’ that contains function keys to display other windows on the HMI5070P. The 
example below illustrates how the Fast Selection Window can be used for this purpose. 

4. Press OK. The Open Window dialog box reappears with the Fast Selection window selected. 

5. If you wish to open the fast selection window, click Open. Otherwise, click Close to return to the main 
screen of EZwarePlus. 
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Using the Fast Selection Button 
The fast selection button is used to display the Fast Selection window.  
Pressing the button again causes the Fast Selection window to close. 

Creating the Fast Selection Button 

The fast selection button must be activated in the System Parameters > General tab in order  
to have it display on the HMI. When enabled, the fast selection button is always  
visible on the screen. 

 

  You can use the following system bits to control the Fast Selection button and window: 

LB-9013: Fast Select window control (hide when ON, show when OFF) 
LB-9014: Fast Select button control (hide when ON, show when OFF) 
LB-9015: Fast Select window and button control (hide when ON, show when OFF) 

For example, place an invisible Set Bit object over the entire Fast Select window assigned to LB-9013 and 
configured to Set ON. This will cause the window to close automatically once a selection is made on the 
window. 

To display the fast selection button: 

1. Select Edit > System Parameters. The System Parameters Setting Dialog  
appears. Select the General tab. 
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2. In the Fast selection button section, select Enable from the Attribute drop-down menu. 

3. Select either Right or Left from the Position drop-down menu to select whether the button will 
appear in the right-lower corner or left-lower corner of the screen. 

4. Click Settings... Click the Use shape checkbox, and then click the Shape Library… button. 

5. Select a shape for your fast selection button and click OK. 

6. Click OK. 

  The Fast Selection window can only call full screen windows, not popup windows. Therefore, you cannot 
use Function Key Objects configured to Display popup window in Fast Selection windows. 
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System Message Windows 
EZwarePlus has five windows designated as System Message windows. These windows have been pre-
configured with automated messages and a function key to close the window, so no changes are necessary, 
though you may customize them for your own application if desired. 

 You must select the “Use template” option when you create your project in EZwarePlus in order for these 
windows to become available. 

Window #5 is designated as the PLC Response window that pops up automatically when the HMI loses 
communications with the PLC. 

 

Window #6 is designated as the HMI Response window, which will pop up automatically if the HMI loses 
communications with another HMI that is remotely connected. 

 

Window #7 is designated as the Password Restriction window, which will pop up when access is attempted 
on a protected object without the proper password. The Display warning message if access denied 
checkbox must be enabled in the Security tab > User restriction section of the object. 

 

Window #8 is designated as the Storage Space Insufficient window, which will pop up when the available 
memory in the HMI, USB Flash drive, or SD card is running low. The following Reserved Local Bits indicate 
insufficient memory conditions: 

LB-9035 HMI free space insufficient alarm (when ON) 

LB-9036 SD Card free space insufficient alarm (when ON) 

LB-9037 USB free space insufficient alarm (when ON) 
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The amount of available memory is indicated by the following Reserved Local Words: 

LW-9072 HMI free space available in KB (32-bit) 

LW-9074 SD Card free space available in KB (32-bit) 

LW-9076 USB free space available in KB (32-bit) 

 

  The default trigger value for the insufficient memory warning is stored in LW-9070 (in MB). This is a “read-
only” register and cannot be modified.  

Window #9 is designated as the Backup window, which will pop up when the Backup object has been 
triggered to copy files from the HMI to an external memory location such as an SD card or USB flash drive. 

  This window pops up in a Direct Window located on the Common Window (window 4), triggered by 
System Bit LB-9039, which turns ON when a backup is in process. When the backup is complete, the bit turns 
OFF and the Direct Window closes. 
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Chapter 8 – Using the Shape Manager, Picture Manager, and 
Group Library 
 
EZwarePlus provides a number of Shape Libraries (*.plb), Picture Libraries (*.flb), and Group Libraries 
(*.glb) with images that can be used to represent objects on the screen (Bit Lamps, Toggle Switches, etc.). 
These are stored in the Library folder in the EZPlus folder (C:\MapleSystems\EZPlus\library). These shapes 
and pictures can be linked to the EZwarePlus project (Library tab) or they can be stored in the project file 
itself (Project tab). In either case, the shapes and pictures are embedded in the compiled file (*.exob or 
*.cxob) that is downloaded to the HMI/RMI. 

If the shapes and pictures are linked to the project using the Library tab in the Shape or Picture Manager, 
use the Compress utility under the Tools menu in EZwarePlus to transfer the project from one computer to 
another. The compressed file (*.ecmp or *.ccmp) contains the project file and the library files that are linked 
to the project. Uncompress the file on the destination computer to load the project and library files into the 
appropriate folders on the computer. 

If the shapes and pictures are stored on the Project tab in the Shape or Picture Manager, then they are 
saved in the project file (*.emtp or *.cmtp) and the project can be transferred from one computer to another 
and retain the shapes and pictures. 

  Saving the shapes and pictures to the Project tab will increase the file size of the EZwarePlus project. 

Shape Manager 
Shapes are vector graphics constructed of lines, curves, or polygons. You can create new shapes using the 
drawing tools under the Draw menu.  

An individual shape can have more than one state (up to 256 states).  

 

To open the Shape Manager, click on the Library menu and select Shape > Call up library. 
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Library Tab 

The drop-down list at the top of the Library tab shows the currently open library files in the project. 

 

  There are four system libraries (System Frame, System Button, System Lamp, and System Pipe) that 
are unique and behave differently from the other library files. They can be used to quickly assign a two-state 
shape to an object, having a different color for each state by using the Inner and Frame color palettes. Note 
that the system libraries cannot be modified by adding additional states and they cannot be unattached from 
a project. 

New library   

Click the New library button to open an existing library or create a new one. To create a new, empty library, 
enter a new file name and click Open. Up to 40 library files can be open in a single project.  
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  When adding modified or new shapes, it is best to create a new shape library rather than modify a 
standard library that is included in EZwarePlus. This will avoid accidentally overwriting a modified standard 
library file when upgrading EZwarePlus. 

Unattach library   

Closes an open library in the project. EZwarePlus will warn you if the library is being used in the project. 

Rename shape   

Click to rename the shape in the selected library. 

Copy to project   

Copies the selected shape to the Project tab. Shapes that are copied to the Project tab are saved in the 
project file rather than linked to the library file. Up to 1000 shapes can be added to the Project tab. 

  Shapes in the System Libraries cannot be copied to the Project tab. 

Background 

Selects the background color for the shapes in the selected library. The color is only displayed in the Shape 
Manager dialog box and is not displayed when placing the object on the screen. 
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Place 

Copies the selected shape to the currently open window in the project. This is useful for modifying a shape 
and importing it back into the Shape library. 

Up/Down   

Move the shape’s selected state to the previous or next state in the list. 

Copy   

Copy the current state of the selected shape to the clipboard. 

Paste   

Paste the shape from the clipboard to the selected shape (adds it to the next state after the selected state). 

Insert Transparent State   

Inserts a blank state after the selected state. 

Delete 

Deletes the selected state of the shape. 

Clean 

Deletes all the states of the selected shape. 

OK 

Confirms saving the edited shape. 

Cancel 

Cancels the editing event. 

Help 

Opens the Help file for the Shape Manager. 
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Creating a New Shape Library 
 
This describes how to create a new Shape Library and add a shape with two states into the library. 

1. Click the New library button  and enter the name of the new Shape Library in the File name 
field of the Open window. 

 

2. Click Open and a dialog box opens to confirm creating a new library file. 

 

 

3. Click Yes and a new empty library is opened (called Two_state in this example). 
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4. Click OK to close the new library. To add a new shape to the library, use the drawing tools under 
the Draw menu to create a new shape on a window in the EZwarePlus project.  

  Alternately, you can select a shape from an existing library and use the Place button to copy it to 
the currently open window in the project. You can then edit its shape and color.  

With the entire shape selected, click on the Library menu and select Shape > Save to library. 

5. Select the new library in the Shape Manager and click the Save button to save the shape into state 
0 of shape 0. 

 

6. Click OK to close the library.  
To create a second state, edit the shape and color of the new shape on the EZwarePlus window. 
With the entire shape selected, click on the Library menu and select Shape > Save to library. 
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7. Select the new library in the Shape Manager and click the Save button to save the shape into state 
1 of shape 0. 

 

8. Repeat for as many states as required for your application (up to 256 states). 

Picture Manager 
Pictures are bitmap graphics constructed of individual pixels. Supported picture formats include .bmp, .jpg, 
.gif, .dpd, .svg, and .png. 

An individual picture can have more than one state (up to 256 states).  

 

To open the Picture Manager, click on the Library menu and select Picture > Call up library. 
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Library Tab 

The drop-down list at the top of the Library tab shows the currently open library files in the project. 

 

New library   

Click the New library button to open an existing library or create a new one. To create a new, empty library, 
enter a new file name and click Open. Up to 40 library files can be open in a single project.  

  When adding modified or new pictures, it is best to create a new picture library rather than modify a 
standard library that is included in EZwarePlus. This will avoid accidentally overwriting a modified standard 
library file when upgrading EZwarePlus. 

Unattach library   

Closes an open library in the project. EZwarePlus will warn you if the library is being used in the project. 

Rename shape   

Click to rename the picture in the selected library. 

Copy to project   

Copies the selected picture to the Project tab. Pictures that are copied to the Project tab are saved in the 
project file. Up to 1000 pictures can be added to the Project tab. 

Background 

Selects the background color for the pictures in the selected library. The color is only displayed in the 
Picture Manager dialog box and is not displayed when placing the object on the screen. 
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Export 

Exports the selected picture to a directory on the PC. This is useful for modifying a picture in an external 
graphics program and importing it back into the Picture library. 

 

Modify 

Imports a picture from a directory on the PC and replaces the selected picture in the library. 

Up/Down   

Move the picture’s selected state to the previous or next state in the list. 

Copy   

Copy the current state of the selected picture to the clipboard. 

Paste   

Paste the picture from the clipboard to the selected picture (adds it to the next state after the selected state). 

Insert Transparent State   

Inserts a blank state after the selected state. 
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Delete 

Deletes the selected state of the picture. 

Clean 

Deletes all the states of the selected picture. 

OK 

Confirms saving the edited picture. 

Cancel 

Cancels the editing event. 

Help 

Opens the Help file for the Picture Manager. 

Creating a New Picture Library 
 
This describes how to create a new Picture Library and add a picture with two states into the library. 

1. Click the New library button  and enter the name of the new Picture Library in the File name 
field of the Open window. 
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2. Click Open and a dialog box opens to confirm creating a new library file. 
 

 
 

3. Click Yes and a new empty library is opened (called Two_state in this example). 

 

 

4. To add a new picture to the library, click the New button and navigate to the picture you wish to 
bring in to the Picture library.  

5. Click Open and the Picture Editor opens. 
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When the Enable Transparent Color option is checked you can select which color the HMI will 
treat as transparent. This is a useful feature when adding multiple images together or placing 
dynamic graphs onto pictures so that the graph can show through. 

Click OK to save the picture into state 0 of picture 0. 

  Alternately, you can export a picture from an existing library and import it into a new library. 
Open the library that contains the picture you want to use, select the picture, and click the Export 
button. The Export button can also be used to export an image and edit it in a graphics editing 
program before importing it back into EZwarePlus. 
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6. To add a second state to the picture, click New and select a second picture to add to the Two_state 
library. Follow the instructions in steps 4 and 5 above, and click OK to save the picture into state 1 
of picture 0. 

 

7. Use the Modify button to replace the currently selected state of the picture with another image file 
on the PC. 

8. Repeat for as many states as required for your application (up to 256 states). 

Group Library 
The Group Library is used to store grouped objects in a library file. Individual objects in the grouped object 
may have multiple states, but each group in the Group Library has only one state. 

1. To open the Group Library, click on the Library menu and select Group > Call up library. 
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2. The drop-down list under Library name shows the currently open Group library files in the project. 

 

3. To open an existing library, click on the Select Lib. … button. Select the Group library file from the 
EZPlus/library folder you wish to use and click Open. 

4. To create a new library, click on the New Lib. … button, enter the name of the library and click OK. 

5. To add a new group to the library, group the objects that you want to include using the Group 
option under the Edit menu. With the grouped object selected, click on the Library menu and select 
Group > Save to library. 

6. Select the new Group library and the Group no. where you want to save the grouped object and 
click OK. 

7. To place an object from the Group library on a window in your EZwarePlus project, open the Group 
library containing the object, click the Place button, and it will appear in the upper-left corner of the 
currently open window. 

Chapter 9 – Creating and Using the Label Library, String Table, 
and Address Tag Library 
 
EZwarePlus includes the ability to create and use a Label Library, String Table, and Tag Address Library.  

The Label Library is a database of text labels. Once created, the label database provides a method for 
assigning labels to individual objects from the Label Library. The Label text may also be represented in up 
to eight languages, each selectable for display. 

The String Table is similar to the Label Library but has extended features such as the ability to create 
different sets (sections) of text and dynamically change the text being displayed. 

The Tag Address Library is a database of HMI and PLC register addresses. Once created, the tag database 
provides a method for assigning addresses to individual objects from the Tag Address Library. 

Creating the Label Library 
The Label library is a database of text Labels, for use with objects utilizing text labels descriptive of their 
status or condition. Each label can consist of multiple unique text strings (determined by the maximum 
number of states available per label), displayable in up to 24 separate languages. 

  The number of states for each label is determined by the number of languages selected. 
1 language = 256 states 
2 languages = 256 states 
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4 languages = 192 states 
8 languages = 96 states 
16 languages = 48 states 
24 languages = 32 states 

To create a label text database library: 

1. From the Library menu, click Label..., or click the Label Library Manager icon from the Library 
toolbar. The Label Library dialog box appears. 

 

2. Create a label by clicking the New... button to display the Label dialog. 

 

3. Enter the Label name for the label, and how many states the new label requires. For example, a 
label titled “Start” requires 2 states to represent separate conditions, where condition one status is 
“START” and condition two is “STOP.” 

4. Click the OK button, and the new label is added to the database. The Name will appear in a 
selectable listing of available Labels for use with objects that support text field labeling. 
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5. The new label is still selected. Click the Settings… button to display the Label Tag Content dialog. 
In the State No. list pull-down box, select the state that the text is representing. 

 

6. In each Language box, as needed, enter the text representing that state in each language. 

7. If further text labeling is required to represent conditions or status in additional states, while still in 
the Settings... mode for Label Content Settings, select the state requiring text labeling. Enter the 
text in the Language boxes as above. 

 There is no inter-language conversion or translation capability. Entries must be made using the 
correct wording for the language designated, to display as entered. 

8. Continue to add state descriptive text labeling as required. 

9. When all text has been entered for all states desired, click OK. The Label is now contained in the 
Label Library and displayed when the Library is opened. View text labels for the various states of 
each label in the Library by selecting the State to display in the pull down box. 

10. Once a label text has been created and you wish to change the number of states, you may do so by 
double-clicking on the desired label text. On the Label Tag Content dialog box, click the Change No 
of States... button, and then enter the No. of states desired for the label. 

Setting Different Fonts for Different Languages 
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If you would like to use different fonts for different languages, for instance, if the language you are using 
requires special characters or Unicode fonts, you can select a different font for each language using the 
label library. 

To set a different font for each language: 

1. From the Library menu, click Label..., or click the Label Library Manager icon from the Library 
toolbar. The Label Library dialog box appears.  

2. Select the Font tab. 

 

3. Select the font for each language from the drop-down menu. Note that the fonts must be available 
to you in your Windows > Fonts folder. 

4. Click OK. 

Importing and Exporting the Label Library 
This feature allows you to save the labels from the label library into a .lbl file format. Once saved, the file 
can be loaded into another project. 

To save the label library: 

1. Click on Save Label File... The open dialog box appears. 

2. Enter the name of the file and where you wish to save the data. 

3. Click Open. 

To load the label library from an existing .lbl file: 

1. Click Load Label File... The Open dialog box appears. 

2. Browse for the .lbl file that contains the labels. 

3. Click Open. 

 The .lbl file format cannot be edited. 

The label library can also be imported and exported using an Excel (*.xls) file format or comma-separated 
variable (*.csv) file format. These formats are very useful if you need to make several changes to the 
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database. When creating a new project, it is easier and faster to create and edit labels in Excel or as *.csv 
files. 

To export the label library: 

1. Click Export EXCEL File… The Open dialog box appears. 

2. Enter the name of the file and where you wish to save the data. 

3. Select the type of file; *.xls or *.csv. 

4. Click Open. 

To import the label library: 

1. Click Import EXCEL File…. 

2. The Language count dialog box appears. Select the number of languages (1-8) you wish to use in 
the Label Library. Click OK. 

 

3. The Open dialog box appears. 

4. Select the type of file; *.xls or *.csv. 

5. Browse for the file that contains the labels. 

6. Click Open. 

 

Using the Label Library 
Once entries have been made to the Label Library, they can be used with any object that supports text field 
labeling. 

1. Select an object that supports text field labeling as required. On the Label tab for the object’s 
Attributes, check the Use label library checkbox. The Label Index list will be enabled, containing all 
of the labels in the database. 

2. Select the applicable label from the Label tag drop-down menu. The label will display on the object, 
representative for states and languages as entered in the Label Library dialog. 

3. Once created with Labels assigned, objects can be viewed displaying the various text labeling in 
each of the states detailed, in each of the languages utilized. To view, on EZwarePlus State and 
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Test Toolbars, select the state and language for objects displayed on the window. The object’s text 
labeling display will change according to the state and language selected for viewing. 

4. To use the multiple language feature of the Label Library to display object labels in languages other 
than the default language (Language 0), the function must be enabled. Enable the multiple 
language capability as detailed below. 

Using Languages with the Label Library 
The HMI5000 Series supports up to 24 languages for use with the Label Library text labeling. In order to use 
the multiple language feature, a label configured in multiple languages must be created and stored in the 
Label Library, as detailed above. The language displayed is selected through Internal Local Word Control, 
LW-9134. 

1. Text Labels in any of up to 24 languages can be displayed, as configured in the Label Library. In 
LW-9134, a value of 0 enables Language 1 as configured in the Label Library, a value of 1 enables 
Language 2, a value of 2 enables Language 3, and a value of 3 enables Language 4, etc. 

2. The appropriate value must be written to LW-9134 to enable a designated language to display. For 
example, a series of set word objects writing a value to LW-9134 could be placed on a setup 
screen. Each set word might be labeled with the Language to be enabled, and the appropriate value 
addressed to LW-9134. If Set Word #0 enables English and English is the configured Language 1 in 
the Label Library, pressing the English Set Word Object writing a 0 to LW-9134 will enable label text 
to display in English. If Set Word #1 enables French and French is the configured Language 2 in the 
Label Library, pressing the French Set Word object writing a 1 to LW-9134 will enable text to display 
in French. Continue for all languages configured in the Label Library. 

 

 

 

 

 

 LW-9134 is the System Tag Language Mode. 

Note: Although up to 24 languages can be created in the Label Library, only eight languages can be 
selected and used in a project at one time. 

 

Creating and Using the String Table 
The String Table is a database of text strings, which can be assigned to a Text object or an event/alarm 
message in the Event/Alarm Log. The String Table allows you to create multiple sections or sets of text that 
can be assigned to individual Text objects and Event/Alarm messages. In addition, it is not limited to a 
certain number of states based on the number of languages selected (like the Label Library), so you can 
create more than 256 text strings if required for your application. 

To create a String Table Library:  

1. From the Library menu, click String Table..., or click the String Table Manager button from the 
Library toolbar. The String Table dialog appears. 
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2. Create a new table by clicking the New Section button. Enter a name for the new table in the 
Description field. Multiple sections can be created, each with its own set of text strings. 

3. Click the New button to create a new text string. A text string can be created for one or more 
languages. The number of languages is determined by the settings in the Label Library and the 
language displayed is determined by the language mode system register LW-9134 (see “Using 
Languages with the Label Library in the previous section). 

4. Additional text strings can be added by clicking the New button again.  
 

 
5. Text can be entered directly in the String Table dialog window or by clicking the Settings button for 

the selected string to open the Content Settings window. 
  The font for each language for the text string is determined by the font setting in the Label 
Library. The font size is determined by the individual text object or Event/Alarm message setting. 
  A carriage return can be entered in the text string from the Content Settings window to create 
multiple lines of text for a single text string. 
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6. Once a String Table is created, it can be assigned to a Text object or an Event/Alarm message. 
Select “Use string table” to enable the String Table for the text. 
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7. Select which string section you wish to use in the Section drop-down. The individual string can be 
selected in the String ID section. The string can be selected dynamically by selecting Dynamic in 
the String ID section. The assigned register is used to select the string displayed by its ID number. 
The value written to the register will display the corresponding string in the text object or 
Event/Alarm message. 

Importing and Exporting the String Table Library 
This feature allows you to save the strings from the String Table library into a CSV file format or XLS file 
format. Once saved, the file can be loaded into another project. 

To save the String Table library: 

1. Click on Export CSV File or Export EXCEL File. The Save As dialog box appears. 

2. Enter the name of the file (File name) and where you wish to save the data. 

3. Click Save. 
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To load the String Table library from an existing CSV or XLS file: 

4. Click Import CSV File or Import EXCEL File. The Open dialog box appears. 

5. Browse for the CSV or XLS file that contains the String Table. 

6. Click Open. 

The label library can also be imported and exported using an Excel (*.xls) file format or comma-separated 
variable (*.csv) file format. These formats are very useful if you need to make several changes to the 
database. When creating a new project, it is easier and faster to create and edit labels in Excel or as *.csv 
files. 

Creating and Using the Tag Library 
The Tag Library is a database of register addresses, with each tag representing a single address. 
EZwarePlus gives you the option of using either Customized or System tags. Customized tags are tags that 
you build yourself. System tags are predefined tags that allow access to certain built-in functions and 
settings (see “Appendix A – Reserved Local Memory” for more information). You can select whether you 
will be using customized or system tags in the Address Tag Library dialog. The Tag listing does not 
contain display information, as display attributes are set when the individual object using the Tag listing is 
created. 

To create a Tag Database Library:  

4. From the Library menu, click Address..., or click the Address Tag Library Manager button from the 
Library toolbar. The Address Tag Library dialog appears. 

 

 

5. To create a new Tag listing, click the New… button to display the Tag dialog. 
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6. Enter the new Tag name. Tag names may be up to 100 characters, any character. 

7. Select the PLC name: as configured in the Device Table from the drop-down menu. 

8. Select the Address type (Bit or Word).  If Word is selected, an additional Data format option will 
be displayed.  When the tag is assigned to an object, the data format of that object will be preset to 
the data format selected for the tag. 

9. Select the Device type from the drop-down menu. 

10. Enter the Register Address. 

11. Conversion (Use macro): This provides the option of converting the data format of the data being 
displayed and of using a macro to scale the value when reading and writing values for the selected 
tag address. The macros must be stored in the Macro Function Library as a subroutine. Only macro 
subroutines with the same data format as the address tag can be selected. 

12. Click OK. 

13. Make additional entries to the database by repeating the procedure. 

To delete a tag: 
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1. Open the Tag Library as directed above. 

2. Select the tag to delete. 

3. Click the Delete button. 

To modify a tag: 

1. Open the Tag Library as directed above. 

2. Select the tag to edit. 

3. Click the Settings... button. 

4. Edit as applicable and then click OK. 

Importing and Exporting the Tag Library 
This feature allows tags from the tag library to be imported and exported into a comma-separated variable 
(*.csv) file format or Excel (*.xls) file format. These formats are very useful if you need to make several 
changes to the database; or, if creating a new project, it is easier and faster to create and edit the tags in a 
.csv or .xls file. 

  The *.tgl file format from previous versions of EZwarePlus is no longer supported. 

To export the tag library to a .csv file or .xls file: 

1. Click Export CSV or Export EXCEL. The Open dialog box appears. 

2. Enter the name of the file where you wish to save the data. 

3. Click Open. 
  If the Use UTF-8 format to export CSV file option is selected, the .csv file will be exported in 
UTF-8 (character encoding) format. Otherwise, it will be exported in ANSI format. 

To import the tag library from a .csv file or .xls file: 

1. Click Import CSV or Import EXCEL. The open dialog box appears. 

2. Brows for the CSV or XLS file containing the tags. 

3. Click Open. 

Using the Tag Library 
Once the Tag Database has been created, individual objects can use the Library to assign a Tag to the 
object, referenced to the PLC register address. 

1. On addressable objects, once the Tag Database has been created, a User-defined tag checkbox is 
available. This box is not available if no tags have been configured in the Database Library. 
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2. Check User-defined tag checkbox. The Device Type list will be filled with a list of available tags. 
Objects addressable as Register-type objects will display Tags configured as Word; Objects 
addressable as Bit-type objects will display Tags configured as Bit. 

 

3. Select the desired Tag from the Device Type list to address the Object to the referenced Register 
Address. 
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Chapter 10 – Creating and Using Keypads 
 
The HMI operator must have a keypad available to enter new data when using the Numeric Input Object or 
the ASCII Input Object. EZwarePlus includes group libraries that contain sample keypads to be placed onto 
a window screen. You can also create your own custom keypads. This chapter focuses on how to create 
keypads, display them on the window screen, and use them for entering data into PLC registers. 

How to Create a Keypad 
Any keypad that you create is actually composed of keys using the Function Key Object. The Function Key 
Object can create alphanumeric keys as well as control keys, (i.e., Delete, Enter, Clear, etc.) 

To create a Function Key Object:  

1. From the Objects menu, click Button > Function Key or click the Function Key icon in the Object 1 
toolbar. The New Function Key Object dialog box appears. 

 

2. Use the Description: box to enter a title for the Function Key part. A description is not necessary 
but does help you identify the purpose of the part. 

3. In the ASCII/UNICODE mode section, there are seven control key options. Control keys are used 
during data entry to perform a specific function. 
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Function Description 

[ENTER] 
Configures the Function Key as an Enter key. When pressed, it will write the 
alphanumeric characters entered into a Numeric Input Object or ASCII Input Object to 
the target PLC register. 

[BACK 
SPACE] 

Configures the Function Key as a Delete key. When pressed, it will delete the 
alphanumeric character to the left of the cursor in the Numeric Input object. 

[CLEAR] 
Configures the Function Key as a Clear key. When pressed, it will clear the data 
displayed in the Numeric Input Object or ASCII Input Object. Note: this key does not 
clear the actual target PLC register until the Enter key is pressed. 

[ESC] Configures the Function Key as an Escape key. When pressed, it will exit the editing 
mode. 

[Delete] Configures the Function Key as a Delete key. When pressed, it will delete the 
alphanumeric character to the right of the cursor in the Numeric Input object. 

[Left] Configures the Function Key as a Left Arrow key. Moves the cursor in the Numeric 
Input object to the left one space. 

[Right] Configures the Function Key as a Right Arrow key. Moves the cursor in the Numeric 
Input object to the right one space. 

 

4. Just below the four control key options, is the ASCII/UNICODE checkbox. Select this when you want 
to configure the Function Key to enter an alphanumeric character. When this checkbox is selected, 
the character box is activated. Use this box to enter the ASCII character you want to use. 

5. Click the Shape tab to select either a shape or bitmap to represent the Function Key.  

6. Click the Label tab to display the Label for the Function Key. Click the Use label checkbox to use a 
label. 

7. Click OK. The New Function Key Object dialog closes and the main screen of EZwarePlus appears 
with the cursor tied to a rectangular outline of the part you just created at the upper left corner of the 
screen. Move the part to the desired location on the window and click the mouse to place it. 

8. Once the part is placed onto the window, you can adjust the location of the label inside the part by 
clicking once on the label. This will highlight the entire object. Now click on the label again. Now only 
the label is highlighted, allowing you to move it without moving the part.  

9. Create a Function Key for each number, Enter, Back Space, Clear, and Escape key. 

10. Add a display to the keypad by selecting Objects > Numeric/ASCII > ASCII Display. Configure the 
ASCII Display with a Read Address of LW-9150, and six words (No. of words). Place the ASCII 
Display above the Function Keys to complete the keypad. 

To create a custom keypad, group all of the keypad objects together on a window. You can then save the 
keypad to a group library for later use in other projects. Several predefined keypads are included with 
EZwarePlus. To use these keypads, click Library > Group > Call up Library in EZwarePlus and access the 
keypad library. 

Alternately, you can create a custom keypad in a graphics program such as Paint and import it into the 
Picture Library. Place the picture on a window using the Draw > Picture tool, and overlay the Function Keys 
and ASCII Display on top of the picture. The computer.flb library has some keypad pictures you can use 
(picture no. 35 and 36). 

  Once a new keypad is created, it must be added to the Keyboard list in the System Parameters > 
General tab. 
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Displaying and Using a Keypad 
Let’s go through a sample project that uses one of the predefined keypads included in EZwarePlus to enter 
values in a Numeric Input Object and an ASCII Input Object. This example will show you how to place these 
objects on a window screen, and then use the keypad to edit the data registers. 

To create a sample keypad entry screen: 

1. Start a New project file in EZwarePlus. 

2. From the Objects menu, select Numeric. The New Numeric Input Object properties box appears. 

3. Create a Numeric Input Object with the following parameters: 

Tab Section Parameter Value 

General 

Description  Numeric Input Object 

Read Address 

PLC Name: Local HMI 

Device Type: LW 

Address: 0 

Data Entry 
Keyboard 
(Select Use a popup 
keypad) 

Window No. 60: ASCII Middle 

Popup position Lower, right-hand 
column 

Numeric Format 
Display Data Format 16-bit signed 

Number of Digits Left of Decimal Pt. 5 

 

Note: In the Numeric Object Properties – Numeric Format tab in the Display section you can 
select how many digits before and after the decimal place, and the data format. These settings will 
determine the allowable values that can be entered by the Numeric Object. The user can also 
further restrict the allowable inputs on the same Numeric Format tab under the Limits section. If 
the operator tries to input a value outside of the allowable range the register will retain its current 
value. 

4. From the Objects menu, select ASCII. The New ASCII Object properties box appears. 

5. Create an ASCII Input Object with the following parameters: 

Tab Section Parameter Value 

General 

Description  ASCII Input Object 

Read Address 

PLC Name: Local HMI 

Device Type: LW 

Address: 1 

No. of words: 12 

Data Entry 
Keyboard 
(Select Use a popup 
keypad) 

Window No. 60. ASCII Middle 

Popup position Lower, right-hand 
column 
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Note: In the ASCII Object Properties – General tab, in the Read Address section select Settings 
to input the desired register address and the size of the reserved storage (No. of words). Each 16-
bit word can contain two ASCII characters.  

6. Create two text boxes; one to identify the Numeric Input register, and one to label the ASCII Input 
register. Place the text boxes and the Numeric Input and ASCII Input objects near the top of the 
window. 

Editing data registers using a keypad: 

1. Save and compile the new project, then test the operation of the keypad by either running in 
Simulation mode or by downloading the project to the HMI. 

2. The following screen will appear: 

 

 

 

 

 

3. Change the value of the Numeric Input register. Touch the Numeric Input Object to activate the edit 
mode. The keypad will pop up. 

4. Using the keypad, enter digits 1, 2, 3, 4, and 5. As you enter the digits, each one should appear in 
the Numeric Input Object box. 

5. Press the Backspace key to delete digit 5. 

6. Try pressing any of the alpha characters (A-Z). Notice that alpha characters are not accepted into a 
Numeric Input Object register. 

7. Press the Clear key. Notice that the entire register is cleared to 0. 

8. Enter digits 5, 4, 3, 2, 1, and then press the Enter key. The keypad closes but the value was not 
accepted. This indicates that the value entered is out-of-range. Touch the numeric input object 
again. Press the Clear key and enter 32767. Press the Enter key. Notice that this value is accepted 
and blinking stops. 

9. Touch the Numeric Input Object register again to activate editing mode. Enter five more digits then 
press the Esc key. Notice that the entry is cancelled and the previous number 32767 is restored. 

10. Change the value of the ASCII Input register. Touch the ASCII Input Object to activate the edit 
mode. 

11. Using the keypad, enter the character string “HELLO WORLD”. As you enter the characters, each 
one should appear in the ASCII Input Object box. Press the Enter key to send the characters to the 
HMI internal data register. 

The above example uses a popup keypad that can be moved onscreen by touching the title bar and 
dragging it around. You can create a fixed keypad without a title bar by selecting Hide title bar in the 
Numeric Input or ASCII Input object’s Data Entry tab. 
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To create a fixed keypad on a window instead of using a popup keypad or Direct Window: 

1. In the above sample project, create a new Numeric Input Object and deselect Use popup keypad 
on the Data Entry tab. Click OK to close the Properties window. 

2. Copy your custom keypad into the window, or open Window 50 and copy the keypad over to 
Window 10. 

3. You must click or touch the Numeric Input Object first to activate it, enter a number using the 
keypad, and then press Enter on the keypad to write the value to the register. 
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Chapter 11 – Bar Graphs and Meters 
 
This chapter focuses on two special graphic objects, which can be used to display PLC data registers. 
You’ve learned how to use shapes and bitmaps to represent the data in PLC registers as states. You’ve also 
learned how to use alphanumeric data fields to display the contents of PLC registers as either numbers or 
ASCII characters. We now introduce two more options to display the data in PLC registers: Bar Graphs and 
Meter Display. In Chapter 12 we will introduce the Trend Display, another method of displaying data in PLC 
registers. 

Creating Bar Graphs 
The Bar Graph Object is used to represent the data in a 16-bit or 32-bit PLC register as a bar graph. You can 
configure the bar graph to move up, down, right, or left. The bar graph can be configured with any base 
number that represents 0 level and any span range. You can create the bar graph with an alarm low and 
high setting to indicate to the HMI operator that an underflow/overflow alarm condition exists. In addition, you 
can set the alarm low and high limits to be controlled by two additional PLC registers so that the low and high 
limits are variable. Bar graphs can even be constructed with a shape or bitmap overlaying the bar graph to 
create flow tanks, temperature gauges, etc. 

To create a Bar Graph Object:  

1. From the Objects menu, click Bar Graph, or click the Bar Graph icon in the Object 2 toolbar. The 
New Bar Graph Object dialog box appears. 
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2. Use the Comment: box to enter a title for the Bar Graph object. A comment/description is not 
necessary but does help you identify the purpose of the part. 

3. Click the Setting… button in the Read address frame. Select the device type from the drop-down 
menu, and then indicate the PLC register address. Select the data format. 

4. Click on the Outline tab to display the outline form. 

 

 
 

5. Under Type select either Bar or Circular 
 

6. In the Attribute section, select how the Graph is to operate. 

Bar Type 
Function Option Description 

  Mode 

Normal The bar starts at one end of the object, and moves to the other end. 

Offset The bar starts at some non-zero point defined by the Origin, and moves 
through the origin as the value changes. 

  Min.  The PLC Register values corresponding to an unfilled bargraph. 

  Origin  The starting point of the bar when the Type is set to Offset. 

  Direction 
Up The bargraph starts at the bottom of the object, and moves up as it fills. 

Down The bargraph starts at the top of the object, and moves down as it fills. 
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Right The bargraph starts at the left of the object, and moves right as it fills. 

Left The bargraph starts at the right of the object, and moves left as it fills. 

Max.  The PLC Register values corresponding to a completely filled bargraph. 

Bar Width 
Ratio (%)  The percent of the object’s width that the bar occupies. 

 
Circular Type 

 

Function Option Description 

   Mode 
Normal The bar starts at one end of the object, and moves to the other end. 

Offset Circular bar graph does not support Offset Mode 

Min.  The PLC Register values corresponding to an unfilled graph. 

Angle 

Clicking the Angle menu button opens the Degree dialog, shown below. 

Clockwise The graph starts at the Start angle and moves clockwise as it fills. 

Counter-
clockwise The graph starts at the Start angle and moves counter-clockwise as it fills. 

Full Circle When checked the graph will fill 360°. 

Start The starting point of the graph in degrees. 

End If Full Circle is unchecked this sets the end point of the graph in degrees. 

Max.  The PLC Register values corresponding to a completely filled graph. 

Hole Radius 
(%)  

 
The ratio of the radius of the center hole to the outer radius of the graph. 

 
 

 
 

7. The Bar color/style determines the appearance of the Bar Graph. 
 

Function Description 

Frame Set the color of the outside of the bar graph. 

Bar Set the color of the filled part of the bar. 

Background Set the color of the unfilled part of the bar. 

Bar Style Set the pattern of the filled part of the bar. 
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8. Set up the Target indicator. This selects the color of the filled part of the bar when it reaches a 
preset value. 

Function Description 

Enable When checked, the Target Indicator is active. 

Color Set the color to change the bar when the value is equal to the Target Value. 
Target 
Value 

The value at which to change the color of the bar. 

Tolerance Set a tolerance for the Target Value. When the value is less than or greater than the 
Target Value by this value, the bar will remain in the selected color. 

 
9. Select the Alarm indicators colors.  

Function Description 

Low Limit The value at which the bar will change to the Low Color. 

Low Color The color to change the bar when the value reaches the Low Limit. 

High Limit The value at which the bar will change to the High Color. 

High Color The color to change the bar when the value reaches the High Limit. 
 

10. Set up Dynamic target/alarm/zero (span) address. When checked, this option allows certain alarm 
limits to be read from the PLC / Controller. The Target value, Low limit, and High limit fields are 
disabled. When Dynamic zero/span is checked, the Min. and Max. (and Origin in offset mode) 
fields are disabled. Data is read from the PLC as follows: 

Specified Address Low Limit 

Specified Address + 1 High Limit 

Specified Address + 2 Target Value 

Specified Address + 3 Min. Value 

Specified Address + 4 Max. Value 

Specified Address + 5 Origin Value 

 

11. Once the part is placed onto the window, you can adjust the attributes of the Bar Graph by double-
clicking on the part. 

Creating Meter Displays 
The Meter Display Object is used to represent the data in a 16-bit or 32-bit PLC register as a scaled meter. 
The meter can be easily customized to the look that you want. The Meter Display can be configured with any 
base number that represents 0 level and any span range. 

To create a Meter Display Object:  
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1. From the Objects menu, click Meter Display, or click the Meter Display icon in the Object 2 toolbar. 
The New Display Meter Object dialog box appears. 

 

 

2. Use the Comment: box to enter a title for the Meter Display object. A comment/description is not 
necessary but does help you identify the purpose of the part. 

3. Click the Setting… button in the Read address frame. Select the Device type from the drop-down 
menu, and then specify the PLC register address. Select the data format. 

4. Click the Outline tab. This is where you will configure all of the attributes of your meter. 
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5. In the Degree section, you can select the range of your meter, where the range is 0 to 360. The 
Start degree 0 is at 12:00. Below are four examples of start and end degrees for different meters: 

 

 Note that meters can have any start and end degree between 0 and 360. 

6. The Background section allows you to select background options for the meter. The following 
illustrations show how your meter will appear with different options checked: 
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7. The Tick marks section allows you to configure the length, scale and sub-scale of the tick marks. 

8. In the Pointer section, select arm style, color, length, and width. 

9. The Pin point section allows you to adjust the style and size of the pinpoint. See the illustration 
above to see the pinpoint (the center of the meter). 

10. Select the Limits tab. In this section, you can configure a scale that goes on the face of the meter 
that shows by a color indication when high and low limits have been exceeded. If you look at the 
above examples, you will see this is represented on the face of the meter as a red, yellow and green 
strip.  
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11. In the Value section, select the Min. and Max. values. These are the PLC register values that 
represent the zero and full-scale deflection of the meter’s arm. 

12. In the Range limits section, click the enable check box to enable the limits. Select the colors for low, 
mid and high. Select the width, in pixels, of the color band. The values from zero to low limit will be 
on the 'low' color band; values from low limit to high limit will be on the 'mid' color band; and values 
greater than high limit will be on the 'high' color band. 

13. Select the Low limit and High limit. These are the values used for the range limit color bands. Click 
the Dynamic limits check box to allow PLC registers to determine the low and high limits. The low 
limit is the specified register, and the high limit is the next consecutive register. 

14. The Scale label section allows you to enable labeling on the “main scale tick marks” inside the 
meter. You can select the font, color, size, and number of digits to the right of decimal point. 

15. If you'd like a background shape to appear with your meter, click the Shape tab and select a shape. 

16. Click OK. The meter appears on the work area of EZwarePlus. Click to drag and place your meter 
on your work area. If you need to reconfigure any of the properties, deselect the meter and then 
double click on it and the properties dialog box will reappear. 
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Chapter 12 – Data Sampling, Trend Displays, and History Data 
Displays 

Creating Data Sampling Objects and Trend Displays 
Data Sampling objects can be used to log historical data. Once data is historically logged, it can be saved to 
the HMI's internal memory, or to an external memory source such as USB, an SD card, or backed up to a 
PC. 

The Trend Display Object is used to display the sampled data in single or consecutive PLC registers and plot 
this data on a time graph. You can display a maximum of 64 channels with varying pen colors to distinguish 
the channels. Data can be displayed in Real-time mode or in History mode, which provide the option of 
displaying previous days’ data. Finally, a hold feature allows you to ‘freeze’ the graph, and a Watch line 
allows you to display the data at a particular point in time. 

In order to create a Trend Display object, you must first create one or more Data Sampling objects from 
which to display the trends. Up to 40 Data Sampling objects may be created. 

To create a data sampling object: 

1. From the Objects menu, select Data Logging > Data Sampling. 

2. The Data Sampling Object Dialog appears. 
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3. Click New… to create a new data sampling object. 
These steps are for the P and L series.  For the RMI series, the configuration is slightly different – 
see below. 

 

4. Comment: Enter a name for the object. This isn't necessary, but will help in later identification of the 
Data Sampling object when configuring the Trend Display. 

5. Sampling Mode: This can be either Time-based or Trigger-based. With Time-based selected, the 
sampling interval can range from 0.1 seconds to 120 minutes. With Trigger-based selected, a PLC 
bit-address can be configured to trigger each sample. The Mode can be OFF > ON, ON > OFF, or 
OFF <-> ON (toggle). 

The High Priority option enables the HMI to place a higher priority updating a Data Sampling object 
than objects displayed on the HMI screen. This helps to ensure that the sampling time interval is 
met. Note that enabling the High Priority option on many Data Sampling objects may slow down the 
update rate for other objects. 

6. The Read address is the PLC register being sampled. Click the Setting… button to select the 
Device Type and Address for the Data Sampling Object. 

7. Max data records (real-time mode): Sets the maximum number of records to display in the Trend 
Display (Real-time mode), up to 86,400 (1 sample/sec * 24 hr). If Auto. stop is selected, data 
sampling automatically stops when the number of records in Max data records has been reached. 
Otherwise, the existing logged data will continue to be recorded in the data log file beyond the 
number of records (samples) configured in the Max data records field. 
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8. Click the Data Format... button to configure the format of each logged item. The Data Format dialog 
appears.  

 

9. Click New... to call the Data Format configuration dialog. 

 

10. Enter a description for the data format in the Comment field and then select the Data type. Click OK 
to return to the Data Format dialog and then Exit to return to the Data Sampling Object.  

 Note: You must have at least one Data type configured in the Data Format list. If you want to 
display multiple channels in a Trend Display, you must configure multiple Data types in the Data 
Format list, one for each channel. The Data Sampling Object will sample data in consecutive 
registers starting with the register configured in the Read address of the Data Sampling Object, with 
the number of consecutive registers determined by the number of Data types in the Data Format list. 

11. Click the Enable check box in the Clear real-time data address section if you would like the data 
samples to be cleared when the bit is momentarily set. If enabled, specify the Mode (OFF -> ON or 
ON -> OFF), PLC address and device type. 

  The PLC name should be selected at the top of the dialog box. 

12. Click the Enable check box in the Hold address section if you would like to pause the data sampling 
as long as the specified bit is set. If enabled, specify the Mode (ON or OFF), PLC address and 
device type. 

13. In order to display history data files in a Trend Display or History Data Display, the sampled data 
must be saved to memory. Select the type of memory to which you would like to save the data files, 
and then specify the folder in which the data will be saved. The Preservation limit option allows you 
to specify the number of days of data files to save before they are deleted from memory.  
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  Normally, the HMI creates a new data file every 24 hours at midnight (00:00), with a filename 
corresponding to the current day (YYYYMMDD.dtl). Select Each file consists of all records of a day for 
this option. 

EZwarePlus provides an option for Customized file handling. Select this option and click on the Settings 
button to customize when a new data log file is created and how it is named. 

 

File Creation: Select Automatic mode to create a new file each time the file name changes. The format of 
the file name is specified in the File name section. Select Trigger mode to create a new file based on the 
Trigger method option. 

Trigger method: When Trigger mode is selected for the File creation, these settings determine when a 
new data log file is created. Select Limit by number of data records to set the maximum number of records 
to be contained in a file. When the number of records exceeds this value, a new file will be created. Select 
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Register status to create a new file when a bit changes state. Enable Set OFF after triggered to return the 
bit to its original state after the new file is created. 

  If both options are selected, either condition will result in a new data log file. 

File name: Use the buttons to construct the structure of the data log file name. As buttons are clicked, the 
file name structure will appear in the Format box. The Example box will update with the actual file name, 
based on the current time and date of the PC. If Automatic mode is selected, a change in any of the 
selected file name fields will result in a new file being created. 

If Dynamic format is selected, specify the starting address and number of words of ASCII data containing 
the file name in a string. Any valid string can be used, except for the illegal characters noted below. 

If multiple data log files are going to be created in the same day, be sure to construct a file name format that 
will be unique for each capture. Otherwise, a new file may overwrite an existing file. For example, instead of 
using the default format of %Y%m%d, use %Y%m%d_%H%M%S. This will name the file 
<year><month><day>_<hour><minute><second>. 

  These characters cannot be used in a file name: 
/ \ : * ? < > | 

14. Click OK.  

15. Follow steps 2-13 to create additional Data Sampling Objects. 

16. Click Exit to exit the Data Sampling Object. 

To create a data sampling object with the RMI5010: 

Configuration is very similar to the steps outlined above. There are two differences: 

 

1. The value in the Control address manages data logged by the Data Sample: 
Write ‘1’ to clear the data from the RMI memory. 
Write ‘2’ to write the data to the SD or USB device. 
Write ‘3’ to write the data to the SD or USB device, then clear the RMI memory. 
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2. History files can be automatically synchronized to an SD card or USB flash drive. If selected, the 
RMI will automatically save the logged data to the specified device when 10,000 records have been 
saved. The oldest 1,000 records will then be deleted from storage in the RMI. If data already exists 
on the SD or USB device, the new data will be appended to the existing data. 
 
  The RMI will always delete the oldest 1,000 records from HMI memory when 10,000 records 
have been saved, whether a Synchronize option has been selected or not. 

To create a Trend Display Object:  

1. From the Objects menu, select Data Logging > Trend Display, or click the Trend Display icon in 
the Object 2 toolbar. The New Trend Display Object dialog box appears. 

 A Data Sampling Object must be configured before you can create a Trend Display. 

 

 

2. In the Data Sampling Object Index, select the data sampling object from the drop-down menu 
whose data is to be displayed. 

3. For Trend type, select whether the data showing will be historical data or real-time data. 
  When Real-time is selected, the Trend Display reads data stored in RAM memory, so it can only 
display data since the HMI was powered up. When History is selected, the Trend Display reads data 

Trend type: Real-time Trend type: History 
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from the data log file (*.dtl) in memory. History mode can display data in real-time as well (select the 
Refresh data automatically option), but has the additional capability of displaying data from 
previous days using the History control register. 

4. The Distance between data samples option allows you to configure how the data is displayed in 
the X-axis on the Trend Display. When Pixel is selected, enter the number of pixels between data 
samples in the Distance field. When Time is selected, enter the number of seconds from left to right 
on the X-axis in the Distance field. To allow the distance between data samples to be adjusted at 
runtime, click the dynamic distance between data samples checkbox.  Select the register used to 
control this value. This creates a ‘zoom in’ feature on the trend, adjustable by the user. 

5. Check the Enable checkbox in the Hold control section (Real-time mode only) if you'd like the trend 
to pause when a specified bit is set, and then configure the PLC address and device type. 

6. Configure the History control section (History mode only) to designate a register used to select the 
data log file to display in the Trend Display Object. 

  The Option List (Objects menu > Button > Option List) can be used to select the data log file to 
display in the History Trend Display by its date. Select Dates of historical data for the Source of 
item data attribute in the Option list tab and assign the Option List Monitor address to the same 
register as the History Control register in the History Trend Display. 

7. Click the Enable checkbox in the Watch line section if you'd like to place a watch line on the trend 
that writes the value at that point to a specific register or registers, and then configure the PLC 
address and device type. If the selected Data Sampling Object is sampling two or more consecutive 
registers, the watch line will reserve the same number of consecutive registers as the number of 
registers being sampled, beginning with the specified register. 
 

8. Use the Time Stamp Output to monitor the elapsed time where the Watch Line crosses the X-axis. 
The specified register contains a 32-bit value representing the number of seconds from the start of 
the trend to the current location of the Watch Line. The next register contains a 32-bit value 
representing the time elapsed since the trend started. If the Trend tab Relative Time mode setting is 
enabled, the value is expressed as: 
[(Hour * 3600) + (Minute * 60) + Seconds]. 
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9. Click on the Trend tab to display the Trend dialog box. 
 

 

10. Select the Frame color and the Background color for the trend from the drop-down menus. 
 

11. Check the Show scroll controls checkbox to enable the left and right scroll controls on the Trend 
Display. 

12. Check the Transparent checkbox to allow the Trend Display to be transparent. This allows you to 
overlay two Trend Displays, one on top of the other, and see the channels in both displays. By 
stacking Trend Displays, you can show data from non-consecutive registers on one display. 
Note: The scroll controls are not linked when stacking Trend Displays. 

13. Check the Enable checkbox in the Grid section if you would like the trend to display a grid. The Y-
axis determines the number of divisions from bottom to top. The X-axis interval: second(s) 
determines the number of divisions from left to right. For example, if the X-axis is configured for time 
= 100 seconds, setting the X-axis interval to 10 seconds creates 10 divisions from left to right on 
the Trend Display. 

14. Check the Time scale Enable checkbox (only visible when the X-axis time range is set to Time) to 
display a time stamp at each division along the X-axis. Select the Format (HH:MM or HH:MM:SS) 
and the Font, Size, and Color. 
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15. Check the Relative time mode box to display the horizontal axis as elapsed time rather than time-
of-day. 

16. Check the Time and Date checkboxes in the Time/Date section to display the current time and date 
in the upper-left corner of the Trend Display, and then select the format in which you'd like the time 
and date displayed. 

17. Click on the Channel tab to display the Channel dialog box. 

 

18. In the Data sampling object section, select the channels you want to display by clicking the 
checkboxes under Display. Select the pen properties for the selected channel in the Channel 
section.  

19. Next, select the value at which the pen will be at the bottom of the display (Min.) and where the pen 
will be at the top of the display (Max.). If Dynamic limits is selected, the Min. and Max. values are 
read from the designated register and the next consecutive register, respectively.  
Note: These parameters are set independently for each channel. 

20. The Channel visibility control allows individual trend lines to be shown or hidden at runtime. Each 
bit of the word in the specified register corresponds to a channel in the Trend Display. Bit 0 
corresponds to Channel 0, bit 1 to Channel 1, etc. Bit 0 in the next consecutive register corresponds 
to Channel 16, etc. Channel visibility can be configured to show the trend line when the 
corresponding bit is ON or OFF. 
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21. Click on the Y Scale tab to display the Y Scale dialog box. 

 

22. In the Data sampling object section, the Display column indicates whether the channel has been 
selected to display in the Channel tab (True). The Y scale column is used to select whether that 
channel’s scaling is used as the Main Axis, the Aux Axis, or None (not displayed). The Main Axis 
appears to the immediate left of the Trend Display’s Y-axis, while the Aux Axes appear further to the 
left of the Trend Display. Only one channel can be assigned to the Main Axis. 

23. In the Scale font section, you can select the attributes of the font to use for the Y-axis scale. 

24. Enable Dynamic Y-scale visibility to dynamically show or hide the Y-scaling for each channel. If 
the control address is LW-300, then the first channel’s Y-axis scale is controlled by LW_Bit-30000, 
the second channel is controlled by LW_Bit-30001, etc. 

25. Enable Dynamic main axis to dynamically change which channel is on the Main axis (closest to the 
Y-axis on the Trend Display). If the control address is LW-400, write a 1 into LW-400 for Channel 1 
to be the Main axis; write a 2 into LW-400 for Channel 2 to be the Main axis, etc. 

26. Click on the Security tab to enable User restriction to control the visibility of the Trend Display. 

27. Click the Shape tab to configure a different frame style or color for the display, if desired. 

Not available 
with the 
RMI5010 



Chapter 12 – Data Sampling, Trend Displays, and History Data Displays 252 

 

EZwarePlus Programming Manual   252 

   

28. Click OK and place the Trend Display on the EZwarePlus work area. If you'd like to reconfigure any 
of its properties, double-click on the trend to display the Trend Display Object's Properties Dialog. 
Click the Profile tab if you'd like to resize or re-position your trend using the Width/Height and X/Y 
position boxes instead of dragging and placing it in the work area. 

To create a Circular Display Object:  

1. From the Objects menu, select Data Logging > Circular Trend Display, or click the Circular Trend 
Display icon in the Object 2 toolbar. The New Circular Trend Display Object dialog box appears. 
  (This option is not available with the RMI5010.) 

 A Data Sampling Object must be configured before you can create a Circular Trend Display.  

 

2. In the Data Sampling Object Index, select the data sampling object from the drop-down menu 
whose data is to be displayed. 

3. For Trend type, select whether the data showing will be historical data or real-time data. 
  When Real-time is selected, the Circular Trend Display reads data stored in RAM memory, so it 
can only display data since the HMI was powered up. When History is selected, the Circular Trend 
Display reads data from the data log file (*.dtl) in memory. History mode can display data in real-time 
as well (select the Refresh data automatically option), but has the additional capability of 
displaying data from previous days using the History control register. 
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  The Option List can be used to select the data log file to display in the History Circular Trend 
Display by its date. Select Dates of historical data for the Source of item data attribute in the 
Option list tab and assign the Option List Monitor address to the same register as the History 
Control register in the History Circular Trend Display. 

4. The Distance option allows you to configure how many hours of data is represented by the full 
circumference of the circle. To adjust the number of hours at runtime, click the dynamic time range 
checkbox.  Select the register used to control this value (range 1-24). 

The Start position setting determines the position from where to start drawing the trend curve. 

 

5. Check the Zoom in/out Enable checkbox to enlarge and reduce the magnification of the object on 
the HMI screen during runtime. The maximum size is 10 times larger. If a larger number is entered, it 
will remain at 10x. When magnified, use the scroll controls to navigate around the Circular Trend 
Display. 

6. Check the Enable checkbox in the Hold control section (Real-time mode only) if you'd like the trend 
to pause when a specified bit is set, and then configure the PLC address and device type. 

7. Configure the History control section (History mode only) to designate a register used to select the 
data log file to display in the Circular Trend Display Object. 
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  The Option List can be used to select the data log file to display in the History Trend Display by 
its date. Select Dates of historical data for the Source of item data attribute in the Option list tab 
and assign the Option List Monitor address to the same register as the History Control register in 
the History Trend Display. 

8. Click the Enable checkbox in the Watch line section if you'd like to place a watch line on the trend 
that writes the value at that point to a specific register or registers, and then configure the PLC 
address and device type. If the selected Data Sampling Object is sampling two or more consecutive 
registers, the watch line will reserve the same number of consecutive registers as the number of 
registers being sampled, beginning with the specified register. 

9. Use the Time Stamp Output to monitor the elapsed time at the point of the Watch Line. The 
specified register contains a 32-bit value representing the number of seconds from the start of the 
trend to the current location of the Watch Line. The next register contains a 32-bit value representing 
the time elapsed since the trend started. 

10. Click on the Trend tab to display the Trend dialog box. 
 

 

11. Select the Frame color and the Background color for the trend from the drop-down menus. 
 

12. Check the Show scroll controls checkbox to enable the left and right scroll controls on the Circular 
Trend Display. These are used to view data earlier than the time specified in the Distance field. 
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13. Check the Enable checkbox in the Grid section if you would like the trend to display a grid. The Y-
axis division(s) determines the number of divisions from center to outer circumference. The Font 
size sets the size of the font for the Time scale or Channel scale. 

Check the Time scale Enable checkbox to display a time stamp at each scale division around the 
circumference. When the Distance (time length) is 2-24 hours, the scale division is one hour. When 
the Distance is set to 1 hour, the scale division is 15 minutes. 

Check the Channel scale Enable checkbox to display the value at each Y-axis division. The color of 
the font that labels the channel scale corresponds to the setting of the trend curve for each channel. 

14. Check the Time and Date checkboxes in the Time/Date section to display the current time and date 
in the upper-left corner of the Trend Display, and then select the format in which you'd like the time 
and date displayed. The Color bar selects the color of the text for the time and date. 

15. Click on the Channel tab to display the Channel dialog box. 
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16. In the Data sampling object section, select the channels you want to display by clicking the 
checkboxes under Display. Select the pen properties for the selected channel in the Channel 
section.  

17. Next, select the value at which the pen will be at the center of the display (Min.) and where the pen 
will be at the outside circumference of the display (Max.). 

18. The Channel visibility control allows individual trend lines to be shown or hidden at runtime. Each 
bit of the word in the specified register corresponds to a channel in the Trend Display. Bit 0 
corresponds to Channel 0, bit 1 to Channel 1, etc. Bit 0 in the next consecutive register corresponds 
to Channel 16, etc. Channel visibility can be configured to show the trend line when the 
corresponding bit is ON or OFF. 

19. Click the Shape tab to configure a different frame style or color for the display, if desired. 

20. Click OK and place the Circular Trend Display on the EZwarePlus work area. If you'd like to 
reconfigure any of its properties, double-click on the trend to display the Circular Trend Display 
Object's Properties Dialog. Click the Profile tab if you'd like to resize or re-position your trend using 
the Width/Height and X/Y position boxes instead of dragging and placing it in the work area. 

History Data Display 
The History Data Display shows data captured by the Data Sampling object. 

Data is displayed in tabular format with the option to show the time and date of when data was captured. A 
control register is used to determine which historical data record is displayed (i.e., most recent, yesterday, 
two days ago, etc.) based upon date of capture. 

 

The HMI reads from the Data Sampling Object data log file (*.dtl) immediately after the screen that contains 
the History Data Display object is displayed.  
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 The data is only read and updated whenever the screen is first displayed. Data recorded to the data log 
file (*.dtl) after the History Data Display object is shown will not appear on the History Data Display object 
until the screen is refreshed (closed, then opened again). A maximum of 64 channels can be displayed. 

To create a History Data Display Object: 

1. From the Objects menu, select Data Logging > History Data Display, or click the History Data 
Display icon in the Object 2 toolbar. The New History Data Display dialog box appears: 

 

2. Data Sampling Object index: Select from drop-down list which data file to use. Data files are 
created using the Data Sampling object. 

3. Refresh data automatically: When selected, the History Data Display will update in real-time when 
displaying data from the current day. 

4. Grid: Displays grid lines on the data table.  
a. Enable: Check to enable grid lines. 
b. Color: Select color used for grid lines. 
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c. Column Interval: Enter the number of pixels that separate each column of data. 

5. Profile color: Determines the color of the background of the object. 
a. Transparent: Enable if you do not want a background color or frame to appear. 
b. Frame: Color for the perimeter frame. 
c. Background: Color for the background of the object. 

6. Text: Select the font and size for all text that appears. 
a. Font: Select the True type font for the text. 
b. Size: Select the size of the font. 

7. Time: Enable to display the time when the data was captured by the Data Sampling object.  
a. Style: Select from HH:MM:SS, HH:MM, DD:HH:MM, or HH. 
b. Color: Determines the color used to display the time. 

8. Date: Enable to display the date when the data was captured by the Data Sampling object.  
a. Style: Select from MM/DD/YY, DD/MM/YY, DD.MM.YY or YY/MM/DD. 
b. Color: Determines the color used to display the date. 
c. Move column [Date] to the front of column [Time]: By default, the Time appears before 

the Date in the display. Select this option to display the Date before the Time. 

9. Sequence no: Enable to display a sequence number of when the data was captured by the Data 
Sampling object.  

a. Color: Determines the color used to display the sequence number. 

10. Time ascending or Time descending: Determines the order in which the data is displayed. 

11. History Control: Use to select the target PLC or internal HMI register that is used to determine 
which data log file is displayed. 

For example, suppose we have data log files that were recorded during a four day period- 
20090615.dtl (June 15th), 20090616.dtl (June 16th), 20090617.dtl (June 17th), and 20090618.dtl 
(June 18th). 

We choose to use internal HMI memory address LW100 for the History Control address. If the value 
in LW100 = 0, then the History Data Display object will display the most recent data log record- in 
this example, 20090618.dtl (June 18th). If the value in LW100 = 1, then 20090617.dtl (June 17th) is 
displayed, and so on. 

Note: The Option List can be used to select the data log file to display in the History Data Display by 
its date. Select Dates of historical data for the Source of item data attribute in the Option list tab 
and assign the Option List Monitor address to the same register as the History Control register in 
the History Data Display. 

 



Chapter 12 – Data Sampling, Trend Displays, and History Data Displays 259 

 

EZwarePlus Programming Manual   259 

   

Data Format tab: Used to configure how the data appears for each column: 

 

1. Channel: Channels are configured in groups of eight (maximum of 64 channels). Use this pull-down 
box to select each group. 

2. Channel #0-63 (description in parentheses tells you what format is used for that data variable). 

3. Display checkbox: Check to enable viewing that data variable. 

4. Left of decimal Pt.: Determines the number of digits that can be displayed to the left of the decimal 
point. 

5. Right of decimal Pt.: Determines the number of digits that can be displayed to the right of the 
decimal point. 
 If 0, then no decimal point is displayed. 

6. Alignment: Options are center, right, and left justified. 
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7. Leading zero: Check to display leading zeroes 

8. Color: Select the color used to display the data. 

Title tab: Used to configure a title bar or legend at the top of the data columns: 

 

1. Use title: Check to use the Title bar option. 

2. Title background: Determines color of background on title bar.  
a. Transparent: Check to remove background color. 
b. Color: Select from drop-down color box. 

3. Title name: Default name of each column. 

4. Title: Name assigned to appear at the top of each column. This is assigned in the Data Sampling 
Object > Data Format list. It can be changed by directly entering a new title or by clicking the 
Settings button at the bottom for the selected channel. 
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5. Label library: None = not used, Used = Label Library used instead of direct text entry. To assign a 
Label Tag, highlight the channel you wish to modify and click on the Setting… button.  

  For more information on using Label Libraries, see “Chapter 9 – Creating and Using the Tag   
Library and Label Library”. 

6. Label tag: Blank = not used, or the particular name of the label tag used.  

Shape tab: Use to configure the frame and background color of the display. 
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Chapter 13 – Capturing Alarms and Events 
 
This chapter looks at how the HMI5000 Series uses alarms and events. 

Using Alarm/Events 
EZwarePlus has four parts that are used to perform alarm/event functions: the Event (Alarm) Log object, the 
Alarm Display object, the Alarm Bar object, and the Event Display object. The Event (Alarm) Log object 
monitors alarm/event conditions and alerts the Alarm Display object, the Alarm Bar object, and the Event 
Display object when an alarm/event condition occurs. Use the Alarm Display object if you want to display a 
scrollable list of all alarm/events that are active. Use the Alarm Bar object to display all active alarm/events 
on a single horizontally scrolling line (like a marquee). Use the Event Display object to display all 
alarm/events and their status (active alarm/events, acknowledged alarm/events, returned to normal 
alarm/events), 

Note: Alarms and events are handled in the same way by EZwarePlus, so reference will be made to alarms 
only rather than alarm/events for the remainder of this chapter, except for reference to the Event (Alarm) 
Log. 

Monitoring Alarms with the Event (Alarm) Log 
The Event (Alarm) Log continuously monitors PLC coils and registers to determine if an alarm condition has 
occurred. Once an alarm is active, the Event (Alarm) Log directs a string of characters associated with that 
alarm to the Alarm Display object, the Alarm Bar object, and the Event Display object for display on the HMI 
screen. 

To create an Event (Alarm) Log:  

1. From the Objects menu, select Alarm > Event (Alarm) Log, or click the Event (Alarm) Log icon in 
the PLC toolbar. The Event (Alarm) Log dialog box appears. 
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Check Enable back light when alarm occurs to turn on the HMI backlight when an alarm is detect. 
To have the HMI save historical alarm data, check one of the locations under History files. No historical 
data will be retained without one of these options selected. 
The Preservation limit determines how long historical data is saved before being overwritten with new data. 
Under Print, select the information to be printed to the connected printer. If no printer has been configured in 
the project, the Print option will not be available. 

For the RMI5010, the configuration options are slightly different: 
 

 

To save historical data, the Enable box in the History files section must be checked, and at least one of the 
Sync to SD card or Sync to USB disk must be selected.  If not checked, no historical data will be saved. 
 
If enabled, the Control Address allows the application to save historical data on demand: 
Write ‘1’ to clear the data from the RMI memory. 
Write ‘2’ to write the data to the SD or USB device. 
Write ‘3’ to write the data to the SD or USB device, then clear the RMI memory. 
 
If not enabled, the RMI will automatically save the data to the selected destination when 10,000 records have 
been logged.  At that point, the oldest 1,000 records will be deleted from RMI storage. 
 
The RMI will store a maximum of 10,000 records.  Even if History files is not enabled, the most recent 1,000 
records will be deleted when 10,000 records have been stored.  If History files is not enabled, those 1,000 
records cannot be recovered. 
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2. Click the New... button. The Event (Alarm) Log Properties dialog appears. 

 

3. On the General tab, set the Category for the alarm. The Alarm Bar, Alarm Display, and Event 
Display can filter the alarms based on the category selected (range 0-255). 

4. Select a Priority level from the drop-down menu (Low, Middle, High, Emergency). The alarms are 
sorted by priority in the Alarm Bar and the Alarm Display with the highest priority shown on top (or 
first, in the case of the Alarm Bar). 

5. When the History files option is selected in the Event (Alarm) Log dialog box, the Save to history 
option provides independent control for saving an individual alarm to the history files. 

6. Select either Bit or Word from the Address type drop-down menu. 

7. Delay time for event monitoring when HMI resets: Provides an option for specifying a time 
interval for the HMI to wait after it starts up before it begins to monitor the alarm. 

8. Click Setting… and select the PLC name, device type and read address, as well as the numeric 
format in the Read address section. 

9. Click the Enable checkbox in the Notification section to have a specific bit set or cleared when the 
alarm condition is reached. If the Follow checkbox is not checked, the Notification bit will stay ON 
after the alarm condition is cleared. Select the Follow option to automatically turn OFF the 
notification bit when the alarm condition is cleared. 

10. Set the Condition to trigger the alarm (depends on Word or Bit selected for Address type). 
  When Word is selected, the Trigger value can be preset or dynamic. Selecting Dynamic 
condition value assigns the next consecutive address after the Read address to contain the Trigger 
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value. Select Read/Condition use different addresses to select a different address for the Trigger 
value. The data at the specified address must have the same format as the Read address. 

11. Click the Message tab to display the Message dialog. 

 

12. Enter the message to display when the alarm or event is triggered in the Content box. If you would 
like to configure the message in different languages, click Label and follow the instructions in 
“Chapter 9 - Creating and Using the Tag Library and Label Library.” Select the Font and Color to 
use for the message being displayed. 

13. In the Acknowledge value field, enter the window number to display once the alarm or event is 
acknowledged. This value is entered into the register configured in the Event Display’s Write 
address on the General tab. 

14. Click the Enable checkbox in the Sound section to have the HMI play a sound when the alarm is 
triggered (for models with audio output connector only). Click the Sound Library... button to select a 
sound from the sound libraries. If no sound is selected, the default sound is a beep. Click Play to 
preview the sound. 

15. Click the Enable continuous beep until acknowledged or recovered to have the HMI emit a beep 
periodically until the alarm condition is acknowledged or cleared. Select the Time delay of 
continuous beep in seconds to set the amount of time between beeps (1 – 255 seconds). 
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16. If a local printer has been enabled in the System Parameters > Model tab, you can send the alarm 
message to a printer. Click the On trigger box to print when the alarm is triggered, and Return to 
normal box to print when the alarm condition has been resolved. 

17. Multi-watch: The values of up to 8 data registers can be displayed in an Alarm/Event Message. 
Select the number of registers to be displayed. Click the Syntax… button to display a dialog 
explaining the syntax of embedding watch registers in an Alarm/Event Message. 

18. Click the e-Mail tab to display the e-Mail dialog. 

  The e-Mail tab is not visible unless e-Mail has been enabled in the System Parameters > e-Mail tab. 

 

19. Select Send when event triggered to send an email when the event/alarm is triggered, and select 
Send when event cleared to send an email when the event/alarm is cleared. The settings for Send 
when event triggered and Send when event cleared can be set independently by selecting one or 
the other at the top of the e-Mail dialog. 

20. Under Recipients, select the e-Mail Group you wish to send the email to. You can send the e-Mail to 
multiple groups under the category of To, Cc, and Bcc. 

Select As recipients of triggered mail settings to send the event cleared e-Mail to the same 
recipients as the event triggered e-Mail. If unchecked, the event cleared e-Mail can be sent to 
different recipients. 

 

Send when event cleared 
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  E-Mail Groups are configured in the System Parameters > e-Mail tab. 

21. Under Subject, select Use event content as subject to use the event/alarm message that appears 
in the Alarm Display in the subject line of the e-Mail. If unchecked, enter a custom subject line 
message. 

22. Under Message, enter the Opening message and the Ending message for the e-Mail. Check Use 
label library if the messages are already preconfigured in the Label Library, or click the Label 
Library button to enter the messages directly in the Label Library. 

23. Under Attach, select Contains a screenshot of window to include a screenshot of the alarm 
window with the e-Mail. This only available for the event triggered e-Mail. 

Click the Occurrence tab. When Read and reset address is enabled, the HMI will record the 
number of times that the alarm was triggered in the designated address. The value can be 
overwritten by the user and it will continue counting from the new value. This would allow the user to 
reset the counter or continue the count from a user defined number. 

 

24. Click OK to return to the Alarm (Event) Log dialog. You may select a location to save History files by 
selecting one of the check boxes. You may also configure additional Event (Alarm) Log items here. If 
a printer has been enabled in the System Parameters > Model tab, you can choose the items to 
include in the printed message when an alarm triggers a print command (configured on the alarm’s 
Message tab).  

25. Click Exit when you are finished. 

Displaying Alarms using the Alarm Display Object 
Though the Event (Alarm) Log object continuously monitors the PLC for alarms, it cannot display the alarms 
without the Alarm Display object, the Alarm Bar object, or the Event Display object. The Alarm Display object 
takes the alarm strings sent to it from the Event (Alarm) Log object and displays them on a window screen as 
a list. The list contains all of the active alarms occurring with the most recently activated alarm, and highest 
priority, at the top of the list.  

To create an Alarm Display Object:  

1. From the Objects menu, click Alarm > Alarm Display or click the Alarm Display icon in the Object 2 
toolbar. The New Alarm Display Object dialog box appears. 
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2. Enable acknowledge function: Select this to enable the acknowledge feature for the Alarm 
Display. Use the acknowledge function to open an Indirect Window with instructions for the operator 
about what to do to remedy the alarm condition. 

The Acknowledge address is the register where the alarm or event writes the window number to 
open an Indirect Window when the operator touches the Alarm Display to acknowledge the alarm or 
event. This is configured in the Event (Alarm) Log on the Message tab (Acknowledge value for 
Event/Alarm Display object).  

Scrolling control address: Enable this option to allow dynamic control of the Alarm Display’s 
scrolling feature. The value in the designated address determines the number of lines the Alarm 
Display will be scrolled down (0 = first line). 

  For the RMI5010, press and hold the alarm in the Alarm Display to acknowledge the alarm. 
Drag a finger on the Alarm Display to scroll. 

3. Click the Alarm tab to configure the parameters for the Alarm Display. 
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4. Include categories: To include all categories, set this at 0 to 0. 

5. Acknowledge style: Select either Click or Double click for the acknowledge style. 

6. Select the Frame and Background colors from the drop-down menus. Select Transparent for no 
frame or background. 

7. Select Grid Enable to include a grid in the Alarm Display. 

8. Select the sort order in which the alarms will appear, either Time ascending or Time descending. 

9. Check the Event trigger date, Event trigger time, Event message and Occurrence count 
checkboxes to include them in the Alarm Display. Use the Display order list to arrange the order in 
which the selected event information is displayed. 

10. Select the format for how the date and time is displayed in the Date: and Time: drop-down boxes. 

11. Click the Shape tab to configure a background shape, if you'd like one. 
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12. Click the Font tab to configure the size of the font. 

13. Click OK and click in the work area of EZwarePlus to place the Alarm Display. Drag it to place it in 
the desired location. 

Displaying Alarms using the Alarm Bar Object 
The Alarm Bar Object displays alarms scrolling horizontally along a single line. The alarm bar continuously 
scrolls each alarm until the alarm is no longer active. If more than one alarm is active, the Alarm Bar Object 
appends each alarm to the string of characters scrolled. This part can be used on window screens where 
space is very limited. It also allows you to display long alarm text strings that are too long to be shown in the 
Alarm Display Object. 

To create an Alarm Bar Object:  

1. From the Objects menu, click Alarm > Alarm Bar or click the Alarm Bar icon in the Object 2 toolbar. 
The New Alarm Bar Object dialog box appears. 

 

2. Include categories: To include all categories, set this at 0 to 0. 

3. Select Scroll speed from the drop-down menu to adjust the speed at which the message scrolls 
across the alarm bar (1 = slowest; 10 = fastest). 

4. Select the Frame and Background colors from the drop-down menus. Select Transparent for no 
frame or background. 

5. Select the sort order in which the alarms will appear, either Time ascending or Time descending. 
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6. Check the Event trigger date, Event trigger time, and Event message checkboxes to include 
them in the Alarm Bar. Use the Display order list to arrange the order in which the selected event 
information is displayed. 

7. Select the format for how the date and time is displayed in the Date: and Time: drop-down boxes. 

8. Click the Shape tab to configure a background shape, if you'd like one. 

9. Click the Font tab to configure the size of the font. 

10. Click OK and click in the work area of EZwarePlus to place the Alarm Bar. Drag it to place it in the 
desired location. 

Displaying Alarms Using the Event Display Object 
The Event Display Object takes the event strings sent to it from the Event (Alarm) Log Object and displays 
them on a window screen as a list. The list contains all of the events that have occurred with the most 
recently triggered event at the top of the list. You do not have to display the entire list of events on a window 
screen. You can limit the viewable events to a ‘scrollable window’ that displays a given number of lines. An 
acknowledge feature allows the HMI operator to touch an event recorded in the event list to display a popup 
window. The popup window can then be used to display further instructions to the HMI operator or to perform 
some operation. 

To create an Event Display Object:  

1. From the Objects menu, click Alarm > Event Display or click the Event Display icon in the Object 2 
toolbar. The New Event Display Object dialog box appears. 

 

History Mode 
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2. Use the Comment: box to enter a title for the Event Display object. A comment is not necessary but 
does help identify the purpose of the part. 

3. Select either Real-time or History as the mode for the events to be displayed. 
In Real-time mode, the Acknowledge address is the register where the alarm or event writes the 
window number to open an Indirect Window. 
In History mode, the History control address is the register used to select the history file to display, 
where 0 displays the most recent events, 1 displays yesterday’s events, 2 displays the events from 
two days ago, etc. Select Enable reading multiple histories to display more than one history file at 
a time. 

  When Real-time is selected, the Event Display reads data stored in RAM memory, so it can only 
display data since the HMI was powered up. When History is selected, the Event Display reads data 
from the event log file (*.evt) in memory. History mode can display data in real-time as well, but has 
the additional capability of displaying data from previous days using the History control register. 

4. Select Enable event management to configure a register to control the events that are displayed 
(see “Chapter 6 – Using EZwarePlus > EZwarePlus Features > Objects Summary > Event Display” 
for more information). 

  The RMI5010 displays all events and updates in real-time. Touch the filter icon in the upper-right 
corner of the Event Display to set the start and end dates for displaying events. 

 

5. Scrolling control address: Enable this option to allow dynamic control of the Event Display’s 
scrolling feature. The value in the designated address determines the number of lines the Event 
Display will be scrolled down (0 = first line). (Not available for the RMI5010.) 
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6. Click on the Event Display tab to display the Event Display dialog. 

 

7. Include categories: To include all categories, set this at 0 to 0. 

8. Select Click or Double-click in the Acknowledge style drop-down menu to acknowledge an event 
with a single or double touch. Then select the maximum number of events to display in the Event 
Display (applies to Real-time mode only). The valid range is 10-1000. (Not available for the 
RMI5010.) 

9. Select colors for Background, Frame, Select box, Acknowledge, and Return to normal. 

10. Select Grid Enable to include a grid in the Alarm Display. 

11. Select the order in which events will be sorted, Time ascending or Time descending. 

12. Check the Sequence no. check box to add a unique serial number to each event. Select the Event 
trigger date and Event trigger time to have the date and time the event is triggered added to each 
event. Select Acknowledge time and Return to normal time to have those times added to each 
event, and select Event message to include the message defined for the alarm/event appear in the 
display. Select Occurrence count to display the number of times that the alarm was triggered 
throughout the day (not available for the RMI5010). 

13. Use the Display order list to arrange the order in which the selected event information is displayed, 
and select the format for how the date and time is displayed in the Date: and Time: drop-down 
boxes. 

14. Click the Shape tab to configure a background shape (if desired). Click the Font tab to configure the 
size of the font. 
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15. Click the Empty Warning tab to enable displaying a message in the Event Display when there are no 
events or alarms displayed. 

 
16. Click OK and click in the work area of EZwarePlus to place the Event Display. Drag it to place it in 

the desired location. Click and drag the corners to resize it. 

 

Event Display 
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Chapter 14 – Security 
The security feature in EZwarePlus allows you to create up to 12 users with individual passwords and 
assign different access levels to each user. Access to windows and even individual objects can be secured 
so only individuals logged in with the correct access levels can operate certain functions. 

System Parameter Settings Security tab 
The security feature is enabled in the System Parameters. Open the System Parameter Settings (Edit > 
System Parameters) and click on the Security tab. Check the Enable box for each user you want to 
configure with security access. Enter a password for each user and check the boxes for the access level 
assigned to each user. 

 

 

Note: There is no priority in assigning access levels. For example, access level F doesn’t automatically 
provide access to levels A-E. In many cases, you will want higher security levels to include access to lower 
security levels. In the screen shot above, Users 1 – 6 are assigned increasingly higher security levels, with 
each security level including access to the security levels below it. 
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There are two security modes in EZwarePlus, General mode and Enhanced Security mode. General 
mode operates the same as the security feature in EasyBuilder-5000, so projects created in EasyBuilder-
5000 will default to the General mode when opened in EZwarePlus. Enhanced Security mode provides 
additional features and user account management for improved security and runtime editing of user accounts. 

General Mode 
When General mode is selected (not available for the RMI5010), up to 12 users can be individually 
enabled, and each has a unique password and combination of any six access classes (A-F). Only numbers 
are allowed for passwords. When an object is created, it can be assigned an access class. When that object 
is activated (for example, a button is touched), the HMI compares the access classes allowed for the 
currently logged-in user to the access class specified for the object. If the access class of the object is within 
the classes allowed, the object’s action is executed. 

In order for a user to login, they must first enter their user number into reserved local word LW-9219. Then 
they must enter their password into reserved local word LW-9220 (32-bit unsigned). 

There are several other reserved local words and bits that can add functionality to your security implementation. 

Reserved Local Memory Function 

LW-9219 Enter user number 

LW-9220 Enter user password 

LW9222 
Displays the access levels assigned to the currently 
logged-in user in binary format (16-bit binary) 
Bit 0: A, Bit 1: B, Bit 2: C, Bit 3: D, Bit 4: E, Bit 5: F 

LW9500-LW9523 (32-bit unsigned) Stores user passwords 1-12 

LB9050 Logs out user and resets password to zero when bit is 
set (HMI resets bit to zero) 

LB9060 Indicates when an invalid password has been entered 
(bit resets to zero when valid password is entered) 

LB9061 Set to update user passwords when changed locally  
(LW9500-LW9523) Use momentary style 

 

Refer to the Security Sample Project on our website to see how to employ the above reserved local memory 
bits and registers in a security implementation: 

http://www.maplesystems.com > Support Center > Sample Projects > HMI5000 Series > Sample Prj: Security 

 

http://www.maplesystems.com/


Chapter 14 – Security  277 

 

EZwarePlus Programming Manual   277 

   

Enhanced Security Mode 
When Enhanced security mode is selected, up to 11 users can be enabled along with a default 
Administrator. Each user can be assigned up to twelve access classes (A-L). The Administrator has full 
access (all access classes). Passwords and User Names can be alphanumeric, and the currently logged-in 
user’s password and user name are stored in local memory as assigned by the Control address (see below 
for a description of the Control address). The Option List object can be configured to display the User 
Names, providing a quick way to select a user to log-in. 

 

 

Use existing user accounts on HMI: User accounts can be created and stored on a USB flash drive or SD 
card using the Administrator Tools and imported into the HMI via a Function Key. Check the Use existing 
user accounts on HMI checkbox to use the user accounts already stored in the HMI. This disables the user 
selection capability in the Security tab. 

When Use existing user accounts on HMI is unchecked, you can enable users by selecting the Enable 
checkbox for each user. Enter the User name and Password, and select the access classes for each user. 
User names and passwords can be alphanumeric and up to 16 characters long. Passwords are case 
sensitive. 
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Selecting Secret user will hide the User name from being displayed in the Option List. The User name 
would then have to be manually entered to log in that user. (Note: The Option List does have a Secret User 
override.)  

The access classes can be assigned descriptions, which appear in the Object class drop-down when 
enabling the User restriction on an object’s Security tab. 

 

Administrator: The administrator’s user name is admin by default and cannot be changed. Enter the 
administrator’s password and select Secret user to hide the admin user name in the Option List. 

Control Address: The control address defines the area of memory containing the control registers and user 
account data. This reserves 20 consecutive registers beginning with the register designated in the Control 
address area. The addresses are allocated as follows: 

Address Length (Words) Description 

Control Address 1 Command (see below) 

Control Address + 1 1 Command result (see below) 

Control Address + 2 1 Selected Item Index (used with the Option List 
object) 

Control Address + 3 1 Privilege (bit 0 = Class A; bit 1 = Class B; bit 2 = 
Class C; etc. 

Control Address + 4 8 User Account Name 

Control Address + 12 8 Password 
 

Command 
(Control 
Address)1 

Function 

1 Log in with current name (Control Address + 4) and password (Control Address 
+ 12). 

2 Log in with current index from the Option List (Control Address + 2). 

3 Log out. 

4 Change password of currently logged-in user account. The new password must 
be written to Control Address + 12 prior to execution. 

5 Add a new permanent user account, with the new name in Control Address + 4 
and password in Control Address + 12. 



Chapter 14 – Security  279 

 

EZwarePlus Programming Manual   279 

   

6 

Add a new temporary user account, with the new name in Control Address + 4, 
password in Control Address + 12, privilege in Control Address + 3, and duration 
of account in minutes in Control Address + 2. If duration is 0, the new temporary 
account will be active until the next HMI power cycle. 

Note: All temporary accounts are deleted when power is removed from the HMI. 

7 Delete user account by name selected in Control Address + 4.  
Note: The currently logged-in user account cannot be deleted. 

8 Delete user account by Option List index (Control Address + 2). 
Note: The currently logged-in user account cannot be deleted. 

9 
Change the privilege level of the selected user account by name (Control 
Address + 4). The new privilege value must be entered in Control Address + 3 
prior to execution. 

10 
Change the privilege level of the selected user account by Option List index 
(Control Address + 2). The new privilege value must be entered in Control 
Address + 3 prior to execution. 

11 
Change the password of the selected user account by name (Control Address + 
4).  The new password must be entered in Control Address + 12 prior to 
execution. 

12 
Change the password of the selected user account by Option List index (Control 
Address + 2).  The new password must be entered in Control Address + 12 prior 
to execution. 

13 Read user account privilege by account name in Control Address + 4. Result is 
returned in Control Address + 3. 

14 Read user account privilege by Option List index in Control Address + 2. Result 
is returned in Control Address + 3. 

 

1Note: The Control Address is reset to 0 when the command is completed. 

Result 
(Control Address + 1) Description 

1 Success 

2 Command error 

4 Account already exists (when adding a new account) 

8 Account does not exist 

16 Password error 

32 Current command cannot be executed 

64 Invalid account name 

128 Invalid account password 

256 The imported data is invalid 

512 Not within the effective time limit (when using the USB Security Key to log in) 
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To log in from a keypad: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User 
Name. 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the 
Password. 

3. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 1. 

4. When the project is run, enter the User Name and Password, then touch the Set Word object. 

To log in from an Option List: 

1. Create an Option List with User account selected for the Source of item data. Configure the 
Monitor Address as ([Control Address] + 2). 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the 
Password. 

3. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 2. 

4. When the project is run, choose the desired User Name from the Option List, enter the Password, 
Then touch the Set Word object. 

To add a permanent user at runtime: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User 
Name. 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the 
Password. 

3. Create 12 Toggle Switch objects, addressed to ([Control Address] + 3), bits 00 to 12. 

4. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 5. 

5. When the project is run, enter the User Name and Password, set the appropriate bits for the Access 
Class privileges, then touch the Set Word object. 

To add a temporary user at runtime: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User 
Name. 

2. Create an ASCII Input object, addressed to ([Control Address] + 12), length 8 words, for the 
Password. 

3. Create a Numeric Input object, addressed to ([Control Address] + 2), 1 word, 16-bit Signed, for the 
Duration. 

4. Create 12 Toggle Switch objects, addressed to ([Control Address] + 3), bits 00 to 12. 

5. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 6. 

6. When the project is run, enter the User Name, Password, and Duration, set the appropriate bits for 
the Access Class privileges, then touch the Set Word object. 

Note: All temporary accounts are deleted when power is removed from the HMI. 
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To delete a user by name: 

1. Create an ASCII Input object, addressed to ([Control Address] + 4), length 8 words, for the User 
Name. 

2. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 7. 

3. When the project is run, enter the User Name, then touch the Set Word object. 

To delete a user by Option List: 

1. Create an Option List with User account selected for the Source of item data. Configure the 
Monitor Address as ([Control Address] + 2). 

2. Create a Set Word object, addressed to (Control Address), configured to write a constant value of 8. 

3. When the project is run, select the desired User Name from the Option List, then touch the Set 
Word object. 

Project password (EMTP file): When enabled, the project file is password protected and requires entering 
the designated password in order to open the project file (EMTP) in EZwarePlus. 

Execute auto. Login/logout when insert an USB key into the HMI: When enabled, a user can log in by 
inserting a USB flash drive configured with log in information (see “Chapter 15 – Administrator Tools – USB 
Security Key” for more information). 

The Status address reflects the status of the log in: 
0 = No action 
1 = Log in successful 
4 = Log in failed 
8 = Log out successful 
16 = Log out failed 

  Execute auto. Login/logout when insert an USB key into HMI is not supported in the RMI5010. 

Object Security 
Many objects in EZwarePlus can be secured using the Security tab in the object’s properties window. For 
example, a Function Key can be secured so that only user’s with a specified access class can operate the 
Function Key and open a particular window. 

User Restriction 
The User restriction area is where the security class for the object is set. 
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Once an Object class is selected in the User restriction area, three options become available. With no option 
checked, the object simply will not operate when touched unless a user with the correct access class is 
logged in. 

Disable protection permanently after initial activation: This option removes the user restriction from the 
object once the object has been activated by a user with the correct access class, even after that user logs 
out. The protection is disabled until the HMI is rebooted. 

Display warning message if access denied: This option causes the message in Window 7 (Password 
Restriction) to popup when a user with an incorrect access class attempts to activate the object. 

 

Make invisible while protected: This option causes the object to be invisible on the screen until a user with 
the correct access class is logged in. 
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Safety Control 
The Safety control area is used to prevent an operator from activating a button or switch by accidentally 
touching it. 

 

Min. press time (sec): This sets the minimum amount of time in seconds that the object needs to be 
pressed in order to activate it. 
 This option is not available when Display confirmation request is enabled. 

Display confirmation request: When enabled, the HMI will display a confirmation window before executing 
the action. The message in the confirmation window is configured in Message 0 of the System Message 
object (Objects > System Message). 

Max. waiting time (sec): This sets the maximum amount of time in seconds that the confirmation window 
stays on the screen. If the time expires, the confirmation window closes and the action is not executed. 
 This option is available only if Display confirmation request is enabled. 

Interlock 
The interlock feature uses the state of a bit to enable or disable the action of the object. When Interlock is 
enabled, the following options are available: 

 

Hide when disabled: When this box is checked, the object is invisible on the screen until the designated bit 
is in the enable state. 

            

Disabled    Enabled 

Grayed label when disabled: When this box is checked, the object’s label is grayed out until the 
designated bit is in the enable state. 

                 

Disabled    Enabled 
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Enable when Bit is ON/Enable when Bit is OFF: Choose the state of the designated bit that will enable 
the action of the object. 

Sound 
Enable the Sound option to play a sound when the object is activated.  

 

The default sound is the HMI’s beep. For models equipped with an audio output jack, you can select other 
sounds from the sound libraries to play when the object is activated. 

Auto logout 
There is an Auto logout feature in the System Parameters on the System Setting tab (Edit menu > System 
Parameters > System Setting tab). 

 

 

When this feature is enabled, you can select the number of minutes of inactivity before the HMI will 
automatically logout the user. This avoids a situation where a user logs in and forgets to log out before 
leaving the HMI (use LB-9050 to manually logout a user). 

Additional Security Features 

Project Password (EMTP file) 
Enable the Project Password in the System Parameter settings (Edit > System Parameters > Security 
tab). This secures a project and prevents it from being modified without the proper password. When the 
Project Password is enabled, you must enter the correct password in order to open the project in 
EZwarePlus. 
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Project Protection 
Enable Project Protection in the System Parameter settings (Edit > System Parameters > General tab). 
Use the Project Protection feature to set a unique password (Project key) in the project that will cause the 
project to run only on specific HMIs that have a matching password (HMI key). 

 

 

 

A developer can set the HMI key in the reserved local memory of the HMI (LW9046 configured for 32-bit 
unsigned numeric format). This value is stored in non-volatile memory, and once it is set, the value is hidden 
and cannot be read using a numeric display. In this way, only HMIs with the correct HMI key will be able to 
run the project. If the Project key does not match the HMI key, local bit LB9046 is set and the driver is 
disabled and will not communicate with the PLC. 
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 The HMI must be rebooted in order for the HMI key setting to take effect. 

Disable Upload Function 
Activate the Disable Upload Function in the System Parameter settings (Edit > System Parameters > 
System Setting tab). Alternately, you can set LB9033 in the local reserved memory of the HMI to disable the 
upload function and prevent a project from being uploaded from the HMI. 

 

 The HMI must be rebooted after downloading the project in order for the Disable Upload Function to take 
effect. 

This function can also be enabled in the Compile window (not available for the RMI5010). 

 

EXOB Password 
A project (*.emtp) must be compiled (*.exob) before it can be downloaded to an HMI. When compiling a 
project, you have the option to change the default password (111111) to a unique number. 
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You must enter the correct password before you can decompile the file and open it in EZwarePlus or you 
will get a decompiling error. 
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Decompiling Prohibited 
Click the Decompilation is prohibited checkbox in the Compiling window to prevent the compiled project 
from being decompiled. 

 

  Once a project is compiled with the Decompilation is prohibited option checked, it cannot be 
decompiled. There is no “backdoor” password to override it. 

System Passwords 
The System Setup Toolbar in the HMI has the option of changing several passwords from their default 
setting of 111111 to another number. 

Open the System Setup Toolbar and click the System Settings icon. 

 

A dialog will be displayed requesting the Local password. The default password is 111111.  

 

  You may have to move windows around a bit to gain access to the virtual keyboard. You may also have 
to click inside the password field again.  
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Once the correct password has been entered, the System Settings dialog is displayed. Click on the Security 
tab to display the security settings dialog. Here, you can select and modify your system passwords.  

 

To change a system password, the new password must be entered, and then entered again to confirm. As 
the password is entered into the confirm field, an indicator will show if the two passwords match.  

 

Local Password: The password required to enter local setup on the HMI. 
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Upload Password: The password required to upload data from the HMI to a PC or memory module. 

 

Upload to a PC using Utility Manager 

 

Upload to a USB Flash or SD Card 
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Download Password: The password required to download data to the HMI from a PC or memory module. 

 

Download from a PC to an HMI 

 

Download from a USB Flash or SD Card 
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Upload (History) Password: The password required to upload history files from the HMI to a memory 
module. 

 

Upload to a USB Flash or SD Card 
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Chapter 15 – Administrator Tools 
The Administrator Tools is a separate utility that allows storing data to a USB flash drive or SD card for 
specific functions including User Accounts, USB Security Key, e-Mail SMTP Server Settings, and e-Mail 
Contacts. The stored data can then be loaded into an HMI. 

To open the Administrator Tools, click Tools > Administrator Tools in EZwarePlus. 

User Accounts 

 

  The project in the HMI must have Enhanced Security mode selected in the System Parameters > 
Security tab for the User Accounts data to be implemented in the HMI. 

Selecting User Accounts allows creating and saving new user accounts to the HMI during runtime, without 
having to change the project in EZwarePlus and download it to the HMI. Use the Add button to create new 
user accounts. Up to 127 new accounts can be added in this way. Check the Effective Time: Restrict the 
using terms checkbox to put a time limit on when the data can be uploaded to the HMI. If not checked, the 
data can be uploaded at any time. Once the data is uploaded, the account data is stored in the HMI until 
power is removed.  

Click the Export button to save the User Accounts in a EUA (EZware User Accounts)  file. Click the Import 
button to import a list of User Accounts from a EUA file. 

Select Save to USB to save the User Account data to the USB flash drive or SD card.  Navigate to the USB 
flash drive or SD card connected to your PC and click Create. 
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To upload the data to the HMI, you must have a Function Key configured to import the user data. 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the 
Settings button. Select Import user accounts under Function mode. Select the Data position (SD card or 
USB disk) and the Account import mode (Overwrite or Append). Select Delete file after importing user 
accounts to delete the file from the SD card or USB flash drive after importing the data to the HMI. Click OK 
and select an appropriate shape and label for the Function Key. Pressing the Function Key on the HMI 
during runtime will import the User Account data from the USB flash drive or SD card connected to the HMI. 

  For the RMI5010, new User Accounts can be added in the Configuration Page > Enhanced Security tab. 
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USB Security Key 

 

  The project in the HMI must have Enhanced Security mode selected in the System Parameters > 
Security tab for the USB Security Key data to be implemented in the HMI. 

Selecting USB Security Key allows a user to log-in automatically by pressing a Function Key that is 
configured to Use [USB Security Key] to Login. Enter the User name and Password of the user account. 
The User name and Password must match an existing account in the HMI. Check the Effective Time: 
Restrict the using terms checkbox to put a time limit on when the USB Security Key data can be used. 

Select Save to USB to save the USB Security Key data to the USB flash drive or SD card.  Navigate to the 
USB flash drive or SD card connected to your PC and click Create. 
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To log-in the user, you must have a Function Key configured to Use [USB Security Key] to Login. 

 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the 
Settings button. Select Use [USB Security Key] to Login under Function mode. Select the Data position 
(SD card or USB disk). Click OK and select an appropriate shape and label for the Function Key. Pressing 
the Function Key on the HMI during runtime will log-in the designated user account on the USB flash drive or 
SD card connected to the HMI. 

  This option is not supported in the RMI5010. 
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e-Mail SMTP Server Settings 

 

Selecting e-Mail SMTP Server Settings allows the e-Mail server settings to be changed in the HMI during 
runtime without having to change the project in EZwarePlus and download it to the HMI. Enter the SMTP 
Server settings that you want to import into the HMI. 

Select Save to USB to save the e-Mail SMTP Server Settings data to the USB flash drive or SD card.  
Navigate to the USB flash drive or SD card connected to your PC and click Create. 
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To update the HMI, you must have a Function Key configured to Import e-mail settings and contacts. 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the 
Settings button. Select Import e-Mail settings and contacts under Function mode. Select the Data 
position (SD card or USB disk). Click OK and select an appropriate shape and label for the Function Key. 
Pressing the Function Key on the HMI during runtime will import the new e-mail SMTP settings to the HMI. 

  This option is not supported in the RMI5010. 
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e-Mail Contacts 

 

Selecting e-Mail Contacts allows the e-Mail contacts in the HMI to be changed without having to change the 
project in EZwarePlus and download it to the HMI. 

Click the Add button to add a Contact Name and Mail Address to the list of contacts. Up to 256 contacts can 
be created. 

Select the No. of groups to use for the assigned e-Mail recipients. Up to 16 groups can be created. 

Select a group under Current group to add contacts to the group. Select the contact under Contacts and 
click the right-arrow button to add that contact to the selected group. 

Click the Export button to save the e-Mail Contacts in a CSV file. Click the Import button to import a list of e-
Mail Contacts from a CSV file. 

Select Save to USB to save the e-Mail Contact data to the USB flash drive or SD card. Navigate to the USB 
flash drive or SD card connected to your PC and click Create. 
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To update the HMI, you must have a Function Key configured to Import e-mail settings and contacts. 

 

In the Function Key object’s properties, select Import user data/Use [USB Security Key] and click the 
Settings button. Select Import e-mail settings and contacts under Function mode. Select the Data 
position (SD card or USB disk). Click OK and select an appropriate shape and label for the Function Key. 
Pressing the Function Key on the HMI during runtime will import the new e-mail contacts to the HMI. 

  This option is not supported in the RMI5010
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Chapter 16 – Recipes 
EZwarePlus supports creating and using recipes in the HMI5000P/L and RMI Series. EZwarePlus supports 
the RW/RW_A mechanism from the EZware5000 software. This allows projects created in EasyBuilder-5000 
to be opened in EZwarePlus without having to modify the recipe structure. 

EZwarePlus also supports a new method of creating and using recipes, which stores the recipe data in the 
EMTP/EXOB file itself or creates a separate recipe database file that can be uploaded or downloaded to the 
HMI using the Utility Manager. 

This chapter will focus on the new method of creating and using recipes. Please refer to the EZwarePlus 
Help file for information on creating and using recipes with the RW memory in the HMI and the 
Recipe/Extended Memory Editor (Help > Help Topics > How Do I…Use Recipes?). 

Creating a Recipe 
Recipes are created in the Recipes tab of the System Parameters in EZwarePlus (Edit > System 
Parameters > Recipes tab).  
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Click the “Add new recipe” button  to create a new recipe in the Recipes list. 

Click the New button to add an item to the recipe. An item represents an ingredient or variable in the recipe 
that may change from one recipe record to another. Each item has the following parameters that can be 
configured independently. 

Item name: This is the name that appears at the top of the column in the Recipe View that describes the 
particular ingredient or variable for each item in the recipe.  Usually, this is alphanumeric. 

Data type: If the data in the column is alphanumeric, choose ASCII as the data type. If the data is numerical, 
you can select from a variety of numeric formats (16-bit signed or unsigned, 32-bit signed or unsigned, 32-bit 
float, etc.). 

Size: Choose how many characters wide the column requires. 

Decimal Pt.: Determines how many digits to the right of the decimal point is displayed. 

Alignment: Align left, center, or right. 

Once the recipe format has been configured, you can select Export definition file of recipes to save the 
recipe format in a recipe definition file (*.rdef). This is imported by the Recipe Database Editor for editing 
recipes and saving as a recipe database file (*.db) (see “Adding and Editing Data in a Recipe in the Recipe 
Database Editor” below). Otherwise, the recipe can be edited using the Recipe Records Library, which 
reads the recipe formats directly from the System Parameters > Recipes tab. 

Adding and Editing Data in a Recipe in EZwarePlus 
Open the Recipe Records Library (Library > Recipe Records) to edit the recipe data in EZwarePlus. 

 

The recipe formats that were created in the System Parameters > Recipes tab will appear in the Recipes list 
on the left side of the Recipe Records dialog. Select a recipe in the Recipes list to edit the data. The Item 
names that were created for the recipe in the System Parameters appear along the top of the Recipe 
Records dialog. 
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Click the Add button to add records to the recipe. Enter the data for each column. In this example, the first 
column is the name of the recipe record and subsequent columns represent the ingredients used, with the 
data entered representing the amount of each ingredient. 

You can use the up/down arrow buttons to move a selected recipe record up and down in the list. When all 
the recipe records have been created and the data entered, click the OK button to close the Recipe Records 
dialog. 

When changes have been made, a popup window will ask if you want to apply the changes to the recipe 
database. If you select Yes, the recipe database file will be updated with the changes. This is stored as 
recipe.db in the EZPlus > HMI_memory > Recipe folder. If you select No, the database file will not be 
updated but the data is stored in the MTP file (and the XOB file when compiled). 

 
 

Adding and Editing Data in a Recipe in the Recipe Database Editor 
The Recipe Database Editor can be used to enter data in a recipe. To open the Recipe Database Editor, 
click on the Tools menu in EZwarePlus and select Recipe Database Editor. 
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Click the Import button to import a recipe definition file (*.rdef saved from the System Parameters > Recipes 
tab) or a recipe database file (*.db).  

The recipe definition file contains the structure of the recipe, but no recipe data. The Item names that were 
created for the recipe in the System Parameters > Recipes tab appear along the top of the Recipe Database 
Editor. 

 

The recipe database file contains both the structure and the data. This file is created when the project is run 
in the Online or Offline Simulator. The file is located in the HMI_memory > recipe folder 
(C:\MapleSystems\EZPlus\HMI_memory\recipe). The *.db file can also be uploaded from the HMI using the 
Utility Manager (see “Chapter 6 – Using EZwarePlus” for information on the Utility Manager). 
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Click the Add button to add records to the recipe. Enter the data for each column. In this example, the first 
column is the name of the recipe record and subsequent columns represent the ingredients used, with the 
data entered representing the amount of each ingredient. 

You can use the up/down arrow buttons to move a selected recipe record up and down in the list. When all 
the recipe records have been created and the data entered, click the Export button to save the recipe 
database file (*.db). 

If a recipe database file has already been created (for example, by saving it from the Recipe Records dialog), 
it can be opened in the Recipe Database Editor, edited, and saved.  

Important: Once the data has been edited in the Recipe Database Editor and saved to the database file, you 
must download the database file (*.db) to the HMI using Utility Manager. The database file is not included in 
the XOB file that is downloaded to the HMI and any changes are not reflected in the Recipe Records Library. 

Adding and Editing Data in the Recipe Database File in the HMI 
You can view the recipe data on the HMI screen using the Recipe View object. You cannot edit the recipe 
data in the Recipe View object directly. However, you can select individual recipe records within the Recipe 
View and display and edit the data using Numeric and ASCII Input objects. 

 

Create a new Numeric Input or ASCII Input object and select Recipe for the Device type. 

  A recipe must be created in the System Parameters > Recipes tab for the Recipe Device type to be 
available. 
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Select the individual item in the Address field. If the item is ASCII, it will only be available in the ASCII Input 
object. If the item is numeric, it will only be available in the Numeric Input object. 

 

When a recipe record is selected (highlighted) in the Recipe View object on the HMI or when running the 
Simulator, the data for the selected recipe record will appear in the various ASCII and Numeric Input objects 
on the screen. 

There are four additional choices in the Address field for the Recipe Device type in a Numeric Input object. 

Selection: This displays the zero-based index of the selected record. Writing a value into this field will set 
the Recipe View to that record. 

Count: Displays the number of records in the selected recipe. 

Command: Performs an action on the recipe based on the value entered. 

1. Add a new record. The selected record is duplicated and added to the end of the list where it can be 
edited. 

2. Update the selected record with new data. 
3. Delete the selected record. 

Result: Displays the result of the action performed with the Command field. 

1. Success 
2. The selected record does not exist. 
3. Unknown command. 
4. The recipe has reached the limit of 10,000 records. No new records can be added. 
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In this example, the selected record is highlighted in yellow (Tea_25ml). The Recipe Record Number in the 
upper-left corner is displaying the index number of the selected record in the list, counting from “0.” Entering 
a different number in this Numeric Input will cause the corresponding recipe record to be highlighted. 

The Recipe Tag section displays the selected record’s name with an ASCII Input object and the item data 
with Numeric Input objects.  

Clicking the New button writes a “1” to the Recipe Command register and creates a new recipe record at the 
end of the list. When data is changed in the selected record using the Numeric Input objects, clicking the 
Update button writes a “2” to the Recipe Command register and updates the recipe database file in the HMI 
and updates the Recipe View. Clicking the Delete button writes a “3” to the Recipe Command register and 
deletes the selected record. 

Upload/Download Recipe Data Using Utility Manager 
The recipe data can be uploaded from and downloaded to the HMI using the Utility Manager. 

 



Chapter 16 – Recipes  308 

 

EZwarePlus Programming Manual   308 

   

Import/Export Recipe Data Using CSV Files 
The Recipe Import/Export object along with the File Browser object can be used to create a convenient way 
of loading and retrieving recipe data. 

Create a Recipe Import/Export object (Objects menu > Recipe Import/Export). Click New. 

1. File Position: select where the CSV file will reside, the SD or USB device. 
2. Control Address: specify a register to control the import/export. 
3. File Name Address: select a starting address and size for a string containing the name and path of 

the CSV file. Check the Include Folder Path box to have the file name and path in the same string. 
Otherwise, specify the string locations and sizes for the name and path. 

Create a File Browser object (Objects menu > File Browser). 

1. If using Include Folder Path above, check the Full (folder + file name) address box, and set the 
address and size to the same as the Import/Export object. Otherwise, check the Folder path 
address and File name address boxes, and set the addresses as specified for the Import/Export 
object above. 

2. On the Outline tab, set the File Position to the same SD or USB as the Import/Export object. 
3. Set the File Type to CSV. 

Create Control buttons. 

1. Create ASCII objects for each address used in the File Browser, for the file name and/or path. 
2. Create Set Word objects, addressed to the Import/Export Object’s Control Address. 

Write a 1 to import a file; 
Write a 2 to export a file without overwriting; 
Write a 3 to export a file and allow overwriting. 

3. Monitor [Control Address+1] for the status: 0=idle, 1=busy. 
4. Monitor [Control Address+2] for the result: 1= success; any other value is an error.  Please refer to 

EZwarePlus Help for a list of error codes. 

 

CSV File Format 

The first line of the file must contain the field names as defined in the Recipe. The remaining lines contain 
the data, where each line is a single record. The HMI will import data formatted with each item contained 
within double-quotation marks (space between each field), or without double-quotation marks (no space). 

With double-quotation marks and space: 

"item", "coffee", "tea", "coco", "sugar", "cream", "water" 
"Cappuccino_25ml", "5", "0", "0", "2", "3", "15" 
"Cappuccino_50ml", "10", "0", "0", "4", "6", "30" 
"Tea_25ml", "0", "5", "0", "2", "3", "15" 
"Tea_50ml", "0", "10", "0", "4", "6", "30" 
"Latte_25ml", "6", "0", "0", "1", "2", "15" 
"Latte_50ml", "12", "0", "0", "2", "4", "30" 
"Coco_25ml", "0", "0", "6", "1", "2", "15" 
"Coco_50ml", "0", "0", "12", "2", "4", "30" 
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Without double-quotation marks and no space: 

item,coffee,tea,coco,sugar,cream,water 
Cappuccino_25ml,5,0,0,2,3,15 
Cappuccino_50ml,10,0,0,4,6,30 
Tea_25ml,0,5,0,2,3,15 
Tea_50ml,0,10,0,4,6,30 
Latte_25ml,6,0,0,1,2,15 
Latte_50ml,12,0,0,2,4,30 
Coco_25ml,0,0,6,1,2,15 
Coco_50ml,0,0,12,2,4,30 
 

Upload / Download Recipe Data To/From the PLC 
The Upload from PLC and Download to PLC buttons are Data Transfer (Trigger-based) objects that 
transfer the recipe data to and from the PLC. For Download to PLC, select the recipe in the Source 
address and select the PLC in the Destination address (this is the beginning address where the recipe 
data will be written). 
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Important: When the recipe data has been edited in the Simulator, the changes are stored in the database 
file on the PC (EZPlus > HMI_memory > Recipe > recipe.db). This database file must be downloaded to the 
HMI using Utility Manager in order for the HMI to reflect the changes made in the recipe.  

When the recipe data is edited in the HMI, the changes are stored in the database file in the HMI. The 
database file must be uploaded from the HMI using Utility Manager and stored in the Recipe folder on the PC 
in order for the EZwarePlus project to reflect the changes made in the recipe. The changes are reflected in 
the Recipe View object when running the Simulator but not in the Recipe Records Library.
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Chapter 17 – Operation Log 
The Operation Log is a mechanism that records operator actions to an SQLite database file. Only user-
triggered actions can be logged, such as a Set Bit, Function Key, Numeric Input, etc. The Operation Log 
consists of two parts – Configuration and View. 

  The RMI Series does not support the Operation Log. 

Configuration Settings 
Click the  button or, from the Objects menu, select Operation Log, Operation Log Settings. 

 

The text in the Comment column is recorded in the log, along with date/time, value, and certain other 
information.  The Comment text is the same text as that which appears as the Comment in the object’s 
Properties dialog. 
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1. Check the Enable Operation Log Function checkbox. The object list displays all objects available 
for recording in the Operation log. Use the filter button  to select the type of object(s) that appear 
in the list. 

2. Check the Enable box for each object to be recorded. Click the Select All / Discard All buttons to 
select or deselect all objects shown in the list. 

3. Use the Storage Settings section to determine how much data is stored in HMI internal memory, 
and when to archive data to an SD or USB device. 

Maximum Record No. in HMI Memory Select the maximum number of records to store in 
HMI memory. This memory is shared with Data 
Sampling and Alarm/Event logging. This is not the 
maximum amount of data to log. 

External Devices for 
Synchronization/Backup 

Select whether to archive to an SD or USB 
device. 

Behavior when HMI Space is Insufficient Stop Saving Operation Log: No more data is 
saved, and no archiving is done. 

Synchronize to External Device: The data is 
archived to the SD or USB device. If previous data 
exists on the SD/USB device, the new data is 
merged with the existing data. If there is sufficient 
storage space in the HMI, half of the data in the 
log is erased to make room for more data. If there 
is insufficient storage space in the HMI, all of the 
data in the log is erased. 

Note: If the specified SD or USB device does not 
exist, old data is erased from the log to make 
room for new data. 

Control Address Specifies the first of two addresses that allow 
commands to be sent to the Operation Log: 

[Specified Address] : Command 

1 – Clear all records 
2 – Copy all records to the USB device 
3 - Copy all records to the SD device. 
4 - Copy all records to the USB device, and clear 
all records from the log. 
5 - Copy all records to the SD device, and clear all 
records from the log. 

[Specified Address + 1] : Result 

0 – Processing the command 
1 – Command Successful 
2- The device does not exist 
3 -The records does not exist 
4 – Unknown error. 
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View Settings 
The Operation Log View displays data recorded by the Operation Log object in a spreadsheet-like format. 
The Operation Log View will display data from the current database file, plus any data archived to the SD or 
USB device.  Click the  button or, from the Objects menu, select Operation Log, Operation Log View. 

General Tab 

The General tab sets up the basic appearance of the Operation Log View. 

 

1. Comment: Enter a text description of the object (optional). 

2. Title: Specify how the title of the object is to appear. The title is the header that appears above each 
column in the view. Click the Transparent checkbox to have the background of the title be the same 
as the color of the window. If the Transparent box is unchecked, select a background color for the 
title. The foreground color of the title text is the same as that selected for the data. 
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3. Profile: Specify the background color of the view. If the Transparent box is checked, the background 
color is the same as the color of the window. If the Transparent box is unchecked, select a 
background color for the view 

4. Grid: Check the Enable box to display gridlines on the view. If checked, specify a color for the 
gridlines. 

5. Selection Control: Specify a highlight color for the selected row. 

6. Font: Specify a Color, Style, and Size for the font used in the view. The title row and data rows all 
use the same font. 

Title Tab 

The Title tab sets up which fields are displayed in the Operation Log View. 

 

1. In the top section, enter the text to display in the Title row for each field. The default text is the field 
name. If a label database exists in the EZware project, the Label Library checkbox may be checked 
and a Label Tag may be selected. The Label Library and Label Tag columns are visible only if a 
label database exists in the EZwarePlus project. 

2. Sort: Select whether the view is to sort the data in Ascending or Descending chronological order. 
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3. Order & Characters: Specify which database fields are to be displayed, the character length of 
each field, and the order in which to display the contents of each field. In the Display Order box, click 
on a field name and use the up/down buttons to change its position. The field at the top of the list is 
displayed left-most in the view. 

4. Date/Time: Select the format in which to display the Date and Time. 

 

  



Chapter 18 – EasyDiagnoser and Easy Watch  316 

 

EZwarePlus Programming Manual   316 

   

Chapter 18 – EasyDiagnoser and Easy Watch 
EasyDiagnoser is a diagnostic utility that monitors the read and write commands between the HMI and the 
PLC and indicates when an error occurs in the communication. 

EasyWatch provides a method of displaying and editing registers in the HMI and PLC in a tabular format. An 
existing macro in an HMI can also be triggered with EasyWatch for troubleshooting and debugging 
purposes. 

  EasyDiagnoser and EasyWatch require an Ethernet connection between the PC and HMI. Therefore, 
these utilities are not compatible with the HMI5070NL. 

Both EasyDiagnoser and EasyWatch can be started from the Utility Manager. First select the product series 
from the top left corner of the dialog.  Then Select Analysis & Testing from the menu on the left. The 
EasyDiagnoser and EasyWatch options will be displayed. 

(Not available for the RMI5010 Series.) 
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EasyDiagnoser 
 

Enter the IP address of the HMI that you want to monitor. 

 

EasyDiagnoser will open and attempt to connect to the HMI through the Ethernet port on the PC. The Logger 
window will display “Connection established with the target HMI” when the connection is made. 
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Main Window 
The main window in EasyDiagnoser is where you set the parameters for monitoring the communications and 
see the results. 

To begin monitoring communications: 

 

1. From the Command drop-down list, select whether to monitor Read and Write commands, Read 
commands only, or Write commands only. The default is Read + Write commands. 

2. In the Device drop-down list, select which device to monitor. Local HMI will always be an option, 
along with the other controllers and protocols configured in the HMI project. The default is All. 

3. If Device is set to something other than All, a unique Station Number can be selected. If enabled, 
EasyDiagnoser will monitor communications to the controller with the specified station number only. 

4. Select which Address Type to monitor. If All is selected, communications to every address used in 
the project will be monitored. The drop-down list will present every available address type, based on 
the selection in the Device drop-down list. The default is All. This option is available only when the 
Device selection is something other than All. 

5. If Address Type is set to something other than All, a range of addresses to monitor can be selected. 
If enabled, communications are monitored only for the selected Address Type and Range. 

6. Click the Capture button to start monitoring communications. Click the Capture button again to 
stop. 

Interpreting the Communication Status: 

• Each line in the table represents a data read or write command. 

• Any line in red indicates a communications error. The Error column indicates the type of error (see 
below). 
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• The No column is a sequential number for that read or write command. 

• The Cmd column is R for Read, W for Write. 

• The PID column is the Package ID number for the Polling Package containing the object’s address. 
Look for that number in the Package ID column in the Polling Packages window to see the details 
for that Polling Package. Double-clicking an object in the Polling Package window will highlight the 
object in the HMI or simulator. 

• The St. column represents the Station Number of the PLC that the Polling Package is associated 
with. 

• The Index column represents the index of the Polling Package. 

• The Address / Length column indicates the starting address of the Polling Package, and how many 
addresses are in the Polling Package. 

• The Time column indicates how long the HMI took to respond to the request (in milliseconds). 

• The Error column indicates if any errors occurred. 
 0  = No Error 
 1  = Time Out 
 2  = Fail 
12 = Ignore 

Polling Packages 

 

The Package ID column lists the numbers assigned to each Polling Package. The number in parenthesis 
represents the number of objects contained in the Polling Package. Click on the “+” in front of the Polling 
Package to see the objects within it. Double-click on an object to highlight it in the HMI or Simulator. 

 

Highlighted object on the HMI screen 
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The Device column lists which device the Polling Package is assigned to, either Local HMI or the PLC 
device name.  

The Station column lists the Station Number assigned to the Device (if applicable). When the objects within 
a Polling Package are displayed, it shows the window number where the object is located. 

The Index column shows the Index number assigned to the Polling Package. When the objects within a 
Polling Package are displayed, it shows the Object ID assigned to the individual objects by EasyDiagnoser. 
These can be viewed on the HMI or Simulator by selecting Show Object ID (HMI) under the Options menu. 

The Address / Length column lists the addresses assigned to the Polling Packages and the length of each 
address in words. 

Devices 

 

Shows the devices that the HMI is communicating with, including the Local HMI. 

Output 

 

The Output window displays messages generated with the macro TRACE command. The macro TRACE 
command uses a syntax like the c printf statement to display text and values in EasyDiagnoser. The macro 
ID number and the line in the macro where the TRACE command resides is shown in brackets. This 
example was generated with the following command: 
TRACE (“Value is %d”, value) 
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Logger 

 

The Logger window show events that occur in EasyDiagnoser. 

  EasyDiagnoser does not support monitoring PLCs using the tag import feature such as Siemens S7-
1200 and Allen-Bradley CompactLogix/ControlLogix – Free Tags. 

 

EasyWatch 
EasyWatch is a utility that allows you to display and edit registers in the HMI and PLC in a spreadsheet-style 
format. It also provides a method of triggering an existing macro in the HMI for troubleshooting and 
debugging purposes. 

Open EasyWatch from the Tools menu (Tools > EasyWatch). You can also open it from the Project 
Toolbar by clicking on the EasyWatch icon. 

 

The first step in creating an EasyWatch project is to add one or more HMIs to the HMI Manager list.  
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To add an HMI to the project: 

1. Open the HMI Manager by clicking on the Objects menu and selecting HMI Manager, or by clicking 
on the HMI Manager icon in the toolbar. 

 

  

2. Click the Add button. Enter the IP address and Port No. of the HMI. The IP address of the HMI is 
configured in the System Settings window in the HMI. The Port No. is configured in the EZwarePlus 
project’s System Parameters > Model tab. 

 

Check Use Local HMI to connect to an Online or Offline Simulator running on the PC. It will appear 
as Local Host in the HMI Manager list. Click OK to add the HMI to the HMI Manager list. 

3. Repeat to add more HMIs to the list. Click Exit when completed. 
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The next step is to add address monitors in the EasyWatch window to view registers in an HMI and PLC. 

To add a Monitor object to the project: 

1. Open the Monitor Settings window by clicking on the Objects menu and selecting Add Object > 
Add Monitor, or by clicking on the Add New Address Monitor icon in the toolbar. 

2. Enter a name for the Monitor object or use the default. 

 

3. Uncheck the Read only checkbox if you want to modify the value in the register using EasyWatch. 

4. Select the HMI to connect through. All of the HMIs configured in the HMI Manager are available in 
the drop-down list. 
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5. Select the PLC to monitor. If you want to monitor a register in the HMI, select HMI5000 Series HMI. 
If you want to monitor a register in a PLC connected to the HMI, select the PLC type from the drop-
down list and enter the appropriate communication settings. 

 

6. Select the Address you wish to monitor and the appropriate Address Type. 

7. Select the Update Cycle. This determines how often the monitor is updated in EasyWatch, with a 
range from 500 ms to 5000 ms. 

8. Click OK and repeat for each register you want to monitor. 

 

You can create multiple pages in EasyWatch. Click the “+” tab at the top of EasyWatch to create additional 
pages. Double-click on the tab name to rename it. In this example, three pages have been created to 
monitor a Modbus TCP device, the local HMI, and a Simulator running on the PC. 
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To begin monitoring data: 

1. Select one or more monitor objects in the list (hold the shift key to select multiple objects) and click 
the Run button in the toolbar. The status indicator for each selected monitor object will change from 
Stop to Connected and the Value column will display a number or state. 
If the red Address Error is displayed under the Status column, check the communication settings, 
address syntax, and physical connection to the device. 

 

To add a Macro object to the project: 

1. Open the Macro Settings window by clicking on the Objects menu and selecting Add Object > Add 
Macro, or by clicking on the Add New Macro icon in the toolbar. 

2. Enter a name for the Macro object or use the default. 

 

3. Select the HMI on which the macro resides. 
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4. Select the Macro Type by clicking the Active Type button. 

Direct Active: The selected macro object is triggered by a button in EasyWatch. An Active button 
appears in the Value column, which is used to trigger the macro object manually. 
 

Cycle Active: The selected macro object is triggered periodically. Click the Active Type button 
again to select the time period to wait before running the macro object again (range is 1 – 255 
seconds).  

5. Select the macro to run by selecting the Macro ID number. Each macro in the HMI project has a 
unique ID number to identify it in addition to the name of the macro. Select the Macro ID number 
and click the Add button to add it to the list of macros. More than one macro can be run sequentially 
by adding them to the list. 

6. Select the Sleep button and Sleep Time to insert a delay between each macro (range 500 ms to 
5000 ms). 

7. Click the Up and Down buttons to move an item up and down in the list. 

8. Click OK when finished. 

 

9. For macro objects configured for Cycle Active, select the macro object and click the Run button  
in the toolbar to start running the macro object periodically. For macro objects configured for Direct 
Active, click the Active button to run the macro object once. 

An EasyWatch project can be saved by clicking File > Save As at the top of EasyWatch. The project is 
saved with a *.EWT extension, which allows it to be opened again at any time. 
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Chapter 19 – Using the Modbus Gateway 
The Modbus Gateway allows any ModbusTCP Master to request HMI data using standard Modbus 
commands.  The HMI uses the ModbusRTU/TCP Slave protocol to pass Modbus requests to any non-tag-
based PLC or controller connected to the HMI, or the HMIs internal storage. 

  Tag-based PLCs are those that use named tags instead of addresses, such Allen Bradley Compact and 
Control Logix , Siemens S7-1200, and BACnet. 

For example, the Modbus Gateway would allow a SCADA system to obtain data from a device that is not 
supported by the SCADA system, but is supported by the HMI.  The Modbus Gateway also allows serial-
connected devices access to the SCADA system. 

The Modbus Gateway support the following Modbus function codes (decimal): 

Code Definition 

1 Read Coil Status 

2 Read Input Status 

3 Read Holding Registers 

4 Read Input Registers 

5 Force Single Coil 

6 Preset Single Register 

15 Force Multiple Coils (LB addresses in the HMI only, not compatible with bits in a PLC) 

16 Preset Multiple Registers 

 

HMI Local Word LW-9288 indicates Modbus communication errors: 

Value Error 

0 No error 

1 Attempt to read/write an undefined register 

2 Illegal Data Value 

3 Bad Command Format 

4 Attempt to write to a Read-only register 

5 Attempt to read from a Write-only register 

6 Timeout 

7 Invalid Function Code 

 

  



Appendix A – Reserved Local Memory  328 

 

EZwarePlus Programming Manual   328 

   

Configuring the Modbus Gateway 
1. Configure the PLC to which Modbus registers will be mapped.  Refer to the System Parameter 

Settings section at the end of Chapter 6. 

2. On the Model tab of the System Parameter dialog, change the HMI Station Number to the Modbus 
Unit Number desired for the HMI. 

3. Change the Port Number to the port used by the ModbusTCP Master.  Typically, port 502 is used. 

 

 
 

Add the Modbus RTU/TCP Slave protocol to the project, and set the PLC I/F to Ethernet. Refer to the 
System Parameter Settings section at the end of Chapter 6. 

1. Check the Enable checkbox in the MODBUS TCP/IP Gateway section. 
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This example will show how to use the Modbus Gateway to obtain data from an Animatics Smartmotor. 

1. Click the Address Mapping Tables button. 

 

By default, Modbus registers are mapped to HMI local storage. These should be deleted to create a new 
Modbus address mapping table. 

2. Click the Delete button to remove the selected entry. 

3. Click the Add button to map a Modbus register. 
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In this example, Modbus registers are being mapped to array elements in an Animatics Smartmotor 
controller. 
 
Description: Enter a text description for this mapping. 
Device Type: Select whether the mapped data is a Bit or Word address. 
Mode: Configure the access privileges. 
MODBUS address: Specify the Modbus address. 
Mapped PLC address: Specify the PLC and address to which the Modbus address will be mapped.  In this 
example, Modbus registers are being mapped to the AL[] array in the Animatics Smartmotor. 
Table size: Specify how many words or bits are to be mapped.  The table starts with the addresses 
configured above.  In this example, 10 Modbus addresses are being mapped. 
Conversion: AB -> BA swaps the byte order during the mapping, ABCD -> CDAB swaps the word order. 

4. Click the OK button. 

5. Repeat for each address type to be mapped. 

 

Configuring the ModbusTCP Master 
The ModbusTCP Master must be configured to communicate with the HMI. 

In general, there will be a one-to-one matching of the Modbus address and the address mapped in the PLC.  
If 32-bit types are used on one side, and 16-bit types are used on the other, addresses may be skipped. 

When the ModbusTCP Master requests data, the HMI will send the request to the mapped device, and return 
the data to the ModbusTCP Master.  In the Animatics example, when the ModbusTCP Master requests 
register 4x1, the HMI will request the data from Animatics register ArrayAL[0], and return the data to the 
ModbusTCP Master. 
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Chapter 20 - Configuring the MQTT Protocol 
The MQTT protocol is a new addition to EZwarePlus in v5.03.02. This protocol is a lightweight protocol used 
for the IIoT (Industrial Internet of Things).  

The MQTT protocol works between clients and a broker (server) on a publish/subscribe basis.  

• The HMI can host the MQTT broker (server) on the HMI hardware 
• The HMI client capabilities only allow the HMI to publish tags to a broker  
• The HMI does not have the ability to subscribe to a tag 
• Tags can be published when the value changes (poll by exception) or on a time base 
• Authentication is available through Username and Password 
• The QoS (Quality of Service) is fixed at QoS2 
• Compressed messages are compressed/uncompressed through Zlib compression algorithms 

The MQTT configuration dialog is found in the Objects menu of EZwarePlus. To configure the MQTT 
protocol, first click on the settings button; this will display the dialog box used to target the IP address of the 
MQTT broker.  

To host the MQTT broker on the HMI, click on the Localhost checkbox. When this is done, the HMI publishes 
tags to a broker hosted locally on the HMI. Other clients can publish data to a broker hosted on a separate 
HMI, and the broker can publish the data out to subscribers. 

1. Set the IP address for the MQTT broker  
2. The port number is generally set to 1883 
3. Set the Registration ID 
4. Set the Username and Password if Authentication is used 
5. Enter a Keep Alive Time to keep the HMI connected to the broker for a period of time if no messages 

are received by the HMI 

The address tab allows the programmer the ability to configure the register that is used for the HMI to MQTT 
broker connection status, and the control address at the bottom of the window can be enabled to gain access 
to items like the IP address, Port number and other settings from the General tab through registers of the 
HMI. 

Once the server address has been configured, the topics (the name used for tags or registers in MQTT) can 
be configured by clicking on the New button on the MQTT dialog box. 

The MQTT Topic configuration dialog appears. The nickname is used for the programmer to easily identify 
what data is included in this topic. The topic name follows the format xxxxx/xxxxxx/xxxxxx/xxxxxx. For 
instance, the programmer may call a topic HMI1/Processing/Oven/Temperature. There are no limitations to 
the naming convention, but you can find best practices for MQTT topic naming here: 
http://www.hivemq.com/blog/mqtt-essentials-part-5-mqtt-topics-best-practices  

Topics can be configured to send the data on a time-base (resent on a timed interval) or trigger-based 
(message is automatically sent when content changes).  

The Compressed Transmission selection compresses the message payload with the Zlib compression 
library. 

The Retain Message selection: if the publisher disconnects with the broker and reconnects, the latest data 
will be automatically published to the broker. 

http://www.hivemq.com/blog/mqtt-essentials-part-5-mqtt-topics-best-practices
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Appendix A – Reserved Local Memory 
EZwarePlus reserves some Local Words (LW) and Local Bits (LB) in the HMI for system use. These can be 
accessed with objects in EZwarePlus by selecting the System Tag checkbox in the Address window. 

 

They can also be accessed from the Tag Library by selecting the System tags radio button. 
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A categorized, expandable list of the System Tags can be viewed by checking the Classification checkbox. 

 

 

Following is a list of the current system tags in EZwarePlus. As new versions of EZwarePlus are released, 
these may change. You can export a list of the System Tags by selecting the Export EXCEL button in the 
Tag Library with the System Tags selected. 

Reserved Local Bits 

LB-9000 : initialized as ON 
LB-9001 : initialized as ON 
LB-9002 : initialized as ON 
LB-9003 : initialized as ON 
LB-9004 : initialized as ON 
LB-9005 : initialized as ON 
LB-9006 : initialized as ON 
LB-9007 : initialized as ON 
LB-9008 : initialized as ON 
LB-9009 : initialized as ON 
LB-9010 : data download indicator 
LB-9011 : data upload indicator 
LB-9012 : data download/upload indicator 
LB-9013 : FS window control (hide when ON,  show when OFF) 
LB-9014 : FS button control (hide when ON,  show when OFF) 
LB-9015 : FS window/button control (hide when ON,  show when OFF) 
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Reserved Local Bits 

LB-9016 : status is on when a client connects to this HMI 
LB-9017 : disable write-back in PLC control's [change window] 
LB-9018 : disable mouse cursor (set ON) 
LB-9019 : disable/enable buzzer 
LB-9020 : show (set ON)/ hide (set OFF) system setting bar 
LB-9021 : reset current event log (set ON) 
LB-9022 : delete the earliest event log file on HMI memory (set ON) 
LB-9023 : delete all event log files on HMI memory (set ON) 
LB-9024 : refresh event log information on HMI memory (set ON) 
LB-9025 : delete the earliest data sampling file on HMI memory (set ON) 
LB-9026 : delete all data sampling files on HMI memory (set ON) 
LB-9027 : refresh data sampling information on HMI memory (set ON) 
LB-9028 : reset all recipe data (set ON) 
LB-9029 : save all recipe data to machine (set ON) 
LB-9030 : update COM 1 communication parameters (set ON) 
LB-9031 : update COM 2 communication parameters (set ON) 
LB-9032 : update COM 3 communication parameters (set ON) 
LB-9033 : disable(when on)/enable (when off) HMI upload function 
LB-9034 : save event/data sampling to HMI, USB disk, SD card (set ON) 
LB-9035 : HMI free space insufficiency alarm (when ON) 
LB-9036 : SD card free space insufficiency alarm (when ON) 
LB-9037 : USB disk free space insufficiency alarm (when ON) 
LB-9039 : status of file backup activity (backup in process if ON) 
LB-9040 : backlight up (set ON) 
LB-9041 : backlight down (set ON) 
LB-9042 : acknowledge all alarm events (set ON) 
LB-9043 : unacknowledged events exist (when ON) 
LB-9044 : disable remote control (when ON) 
LB-9045 : memory-map communication fails (when ON) 
LB-9046 : project key is different from HMI key (when ON) 
LB-9047 : reboot HMI (set ON when LB9048 is on) 
LB-9048 : reboot-HMI protection 
LB-9049 : enable (set ON)/disable (set OFF) watch dog 
LB-9050 : user logout 
LB-9051 : disconnect (set OFF)/connect (set ON) EasyAccess server  
LB-9052 : status of connecting to EasyAccess server 
LB-9053 : prohibit password remote-read operation (when ON) 
LB-9054 : prohibit password remote-write operation (when ON) 
LB-9055 : MODBUS server (COM 1) receives a request (when ON) 
LB-9056 : MODBUS server (COM 2) receives a request (when ON) 
LB-9057 : MODBUS server (COM 3) receives a request (when ON) 
LB-9058 : MODBUS server (ethernet) receives a request (when ON) 
LB-9059 : disable macro TRACE function (when ON) 
LB-9060 : password error 
LB-9061 : update password (set ON) 
LB-9062 : open hardware setting dialog (set ON) 
LB-9063 : disable(set ON)/enable(set OFF) popuping information dialog while finding an USB 

 



Appendix A – Reserved Local Memory  335 

 

EZwarePlus Programming Manual   335 

   

Reserved Local Bits 

LB-9064 : enable USB barcode device (disable keyboard) (when ON) 
LB-9065 : disable/enable COM 1 broadcast station no. 
LB-9066 : disable/enable COM 2 broadcast station no. 
LB-9067 : disable/enable COM 3 broadcast station no. 
LB-9068 : auto. connection for remote HMI 1 (when ON) 
LB-9069 : auto. connection for remote HMI 2 (when ON) 
LB-9070 : auto. connection for remote HMI 3 (when ON) 
LB-9071 : auto. connection for remote HMI 4 (when ON) 
LB-9072 : auto. connection for remote HMI 5 (when ON) 
LB-9073 : auto. connection for remote HMI 6 (when ON) 
LB-9074 : auto. connection for remote HMI 7 (when ON) 
LB-9075 : auto. connection for remote HMI 8 (when ON) 
LB-9099 : auto. connection for remote HMI 32 (when ON) 
LB-9100 : remote HMI 1 status (set on to retry connection) 
LB-9101 : remote HMI 2 status (set on to retry connection) 
LB-9102 : remote HMI 3 status (set on to retry connection) 
LB-9103 : remote HMI 4 status (set on to retry connection) 
LB-9104 : remote HMI 5 status (set on to retry connection) 
LB-9105 : remote HMI 6 status (set on to retry connection) 
LB-9106 : remote HMI 7 status (set on to retry connection) 
LB-9107 : remote HMI 8 status (set on to retry connection) 
LB-9148 : remote HMI 49 status (set on to retry connection) 
LB-9149 : forced to reconnect remote HMI when IP changed on-line (set ON) 
LB-9150 : auto. connection for PLC 1 (COM 1) (when ON) 
LB-9151 : auto. connection for PLC 2 (COM 2) (when ON) 
LB-9152 : auto. connection for PLC 3 (COM 3) (when ON) 
LB-9153 : auto. connection for PLC 4 (ethernet) (when ON) 
LB-9154 : auto. connection for PLC 5 (ethernet) (when ON) 
LB-9155 : auto. connection for PLC 6 (ethernet) (when ON) 
LB-9156 : auto. connection for PLC 7 (ethernet) (when ON) 
LB-9157 : auto. connection for PLC 8 (ethernet) (when ON) 
LB-9158 : auto. connection for PLC 9 (ethernet) (when ON) 
LB-9189 : auto. connection for PLC 40 (ethernet) (when ON) 
LB-9190 : auto. connection for PLC (USB) (when ON) 
LB-9191 : PLC status (USB), set on to retry connection 
LB-9192 : disable USB PLC's "PLC No Response" dialog (when ON) 
LB-9196 : local HMI supports monitor function only (when ON) 
LB-9197 : support monitor function only for remote HMIs (when ON) 
LB-9198 : disable local HMI to trigger a macro (when ON) 
LB-9199 : disable remote HMI to trigger a macro (when ON) 
LB-9200 : PLC 1 status (SN0, COM 1), set on to retry connection 
LB-9201 : PLC 1 status (SN1, COM 1), set on to retry connection 
LB-9202 : PLC 1 status (SN2, COM 1), set on to retry connection 
LB-9203 : PLC 1 status (SN3, COM 1), set on to retry connection 
LB-9204 : PLC 1 status (SN4, COM 1), set on to retry connection 
LB-9205 : PLC 1 status (SN5, COM 1), set on to retry connection 
LB-9206 : PLC 1 status (SN6, COM 1), set on to retry connection 
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Reserved Local Bits 

LB-9207 : PLC 1 status (SN7, COM 1), set on to retry connection 
LB-9455 : PLC 1 status (SN255, COM1), set on to retry connection 
LB-9460 : EM0's storage device (SD card) does not exist (when ON) 
LB-9461 : EM1's storage device (SD card) does not exist (when ON) 
LB-9462 : EM2's storage device (SD card) does not exist (when ON) 
LB-9463 : EM3's storage device (SD card) does not exist (when ON) 
LB-9464 : EM4's storage device (SD card) does not exist (when ON) 
LB-9465 : EM5's storage device (SD card) does not exist (when ON) 
LB-9466 : EM6's storage device (SD card) does not exist (when ON) 
LB-9467 : EM7's storage device (SD card) does not exist (when ON) 
LB-9468 : EM8's storage device (SD card) does not exist (when ON) 
LB-9469 : EM9's storage device (SD card) does not exist (when ON) 
LB-9470 : EM0's storage device (USB disk) does not exist (when ON) 
LB-9471 : EM1's storage device (USB disk) does not exist (when ON) 
LB-9472 : EM2's storage device (USB disk) does not exist (when ON) 
LB-9473 : EM3's storage device (USB disk) does not exist (when ON) 
LB-9474 : EM4's storage device (USB disk) does not exist (when ON) 
LB-9475 : EM5's storage device (USB disk) does not exist (when ON) 
LB-9476 : EM6's storage device (USB disk) does not exist (when ON) 
LB-9477 : EM7's storage device (USB disk) does not exist (when ON) 
LB-9478 : EM8's storage device (USB disk) does not exist (when ON) 
LB-9479 : EM9's storage device (USB disk) does not exist (when ON) 
LB-9500 : PLC 2 status (SN0, COM 2), set on to retry connection 
LB-9501 : PLC 2 status (SN1, COM 2), set on to retry connection 
LB-9502 : PLC 2 status (SN2, COM 2), set on to retry connection 
LB-9503 : PLC 2 status (SN3, COM 2), set on to retry connection 
LB-9504 : PLC 2 status (SN4, COM 2), set on to retry connection 
LB-9505 : PLC 2 status (SN5, COM 2), set on to retry connection 
LB-9506 : PLC 2 status (SN6, COM 2), set on to retry connection 
LB-9507 : PLC 2 status (SN7, COM 2), set on to retry connection 
LB-9755 : PLC 2 status (SN255, COM2), set on to retry connection 
LB-9800 : PLC 3 status (SN0, COM 3), set on to retry connection 
LB-9801 : PLC 3 status (SN1, COM 3), set on to retry connection 
LB-9802 : PLC 3 status (SN2, COM 3), set on to retry connection 
LB-9803 : PLC 3 status (SN3, COM 3), set on to retry connection 
LB-9804 : PLC 3 status (SN4, COM 3), set on to retry connection 
LB-9805 : PLC 3 status (SN5, COM 3), set on to retry connection 
LB-9806 : PLC 3 status (SN6, COM 3), set on to retry connection 
LB-9807 : PLC 3 status (SN7, COM 3), set on to retry connection 
LB-10055 : PLC 3 status (SN255, COM3), set on to retry connection 
LB-10069 : forced to reconnect remote printer/backup server when IP changed on-line (set ON) 
LB-10070 : forced to reconnect PLC 4 (ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10071 : forced to reconnect PLC 5 (ethernet) when IP or system parameters changed on-line 
(set ON) 

LB-10072 : forced to reconnect PLC 6 (ethernet) when IP or system parameters changed on-line 
(set ON) 
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Reserved Local Bits 

LB-10073 : forced to reconnect PLC 7 (ethernet) when IP or system parameters changed on-line 
(set ON) 
LB-10074 : forced to reconnect PLC 8 (ethernet) when IP or system parameters changed on-line 

  LB-10075 : forced to reconnect PLC 9 (ethernet) when IP or system parameters changed on-line 
  LB-10099 : forced to reconnect PLC 33 (ethernet) when IP or system parameters changed on-
   LB-10100 : PLC 4 status (ethernet), set on to retry connection 

LB-10400 : PLC 5 status (ethernet), set on to retry connection 
LB-10700 : PLC 6 status (ethernet), set on to retry connection 
LB-11000 : PLC 7 status (ethernet), set on to retry connection 
LB-11300 : PLC 8 status (ethernet), set on to retry connection 
LB-11600 : PLC 9 status (ethernet), set on to retry connection 
LB-11900 : PLC 10 status (ethernet), set on to retry connection 
LB-11901 : PLC 11 status (ethernet), set on to retry connection 
LB-11902 : PLC 12 status (ethernet), set on to retry connection 
LB-11903 : PLC 13 status (ethernet), set on to retry connection 
LB-11904 : PLC 14 status (ethernet), set on to retry connection 
LB-11905 : PLC 15 status (ethernet), set on to retry connection 
LB-11906 : PLC 16 status (ethernet), set on to retry connection 
LB-11939 : PLC 49 status (ethernet), set on to retry connection 
LB-11940 : delete the earliest event log file on SD card (set ON) 
LB-11941 : delete all event log files on SD card (set ON) 
LB-11942 : refresh event log information on SD card (set ON) 
LB-11943 : delete the earliest event log file on USB disk (set ON) 
LB-11944 : delete all event log files on USB disk (set ON) 
LB-11945 : refresh event log information on USB disk (set ON) 
LB-11949 : delete the earliest data sampling file on SD card (set ON) 
LB-11950 : delete all data sampling files on SD card (set ON) 
LB-11951 : refresh data sampling information on SD card (set ON) 
LB-11952 : delete the earliest data sampling file on USB disk (set ON) 
LB-11953 : delete all data sampling files on USB disk (set ON) 
LB-11954 : refresh data sampling information on USB disk (set ON) 
LB-11958 : time setting error (when ON) 
LB-11959 : LED indicator control 
LB-11960 : disable PLC 1's "PLC No Response" dialog (when ON) 
LB-11961 : disable PLC 2's "PLC No Response" dialog (when ON) 
LB-11962 : disable PLC 3's "PLC No Response" dialog (when ON) 
LB-11963 : disable PLC 4's "PLC No Response" dialog (when ON) 
LB-11964 : disable PLC 5's "PLC No Response" dialog (when ON) 
LB-11965 : disable PLC 6's "PLC No Response" dialog (when ON) 
LB-11966 : disable PLC 7's "PLC No Response" dialog (when ON) 
LB-11967 : disable PLC 8's "PLC No Response" dialog (when ON) 
LB-12023 : disable PLC 64's "PLC No Response" dialog (when ON) 
LB-12030 : COM 1 status (OFF : normal, ON : open failed) 
LB-12031 : COM 2 status (OFF : normal, ON : open failed) 
LB-12032 : COM 3 status (OFF : normal, ON : open failed) 
LB-12033 : COM 4 status (OFF : normal, ON : open failed) 
LB-12034 : COM 5 status (OFF : normal, ON : open failed) 
LB-12035 : COM 6 status (OFF : normal, ON : open failed) 
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LB-12036 : COM 7 status (OFF : normal, ON : open failed) 
LB-12037 : COM 8 status (OFF : normal, ON : open failed) 
LB-12038 : COM 9 status (OFF : normal, ON : open failed) 
LB-12040 : remote printer/backup server disconnection alarm (when ON) 
LB-12041 : refresh HMI IP (LW-9129~9132) (set ON) 
LB-12042 : open/close [System information] dialog (set ON/set OFF) 
LB-12048 : USB disk status (exists when ON) 
LB-12050 : SD card status (exists when ON) 
LB-12051 : buzzer status (active when ON) 
LB-12052 : MODBUS server status (disabled when ON) 
LB-12053 : Failed to send an [Event Log] e-Mail (when ON) 
LB-12054 : Failed to send an [Backup Object] e-Mail (when ON) 
LB-12055 : failed to execute time synchronization (when ON) 
LB-12056 : the user touches an unauthorized object (when ON) 
LB-12080 : auto. connection for PLC (CAN Bus) (when ON) 
LB-12081 : PLC status (CAN Bus), set on to retry connection 
LB-12082 : disable CAN Bus device's "PLC No Response" dialog (when ON) 
LB-12088 : enable VNC monitor mode (when ON) 
LB-12089 : VNC password free (when ON) 
LB-12090 : a VNC client connecting to HMI (when ON)(OS version 20120621 or later supports 

 LB-12091 : disable auto-logout function when a VNC client connecting to HMI (when ON)(OS 
      LB-12092 : enable VNC (set ON), disable VNC (set OFF) 

LB-12093 : VNC connection mode (OFF : single connection, ON : multi. connection)(OS version 
    LB-12100 : pause CAN Bus device 1 communication (when ON) 

LB-12101 : pause CAN Bus device 2 communication (when ON) 
LB-12102 : pause CAN Bus device 3 communication (when ON) 
LB-12103 : pause CAN Bus device 4 communication (when ON) 
LB-12104 : pause CAN Bus device 5 communication (when ON) 
LB-12105 : pause CAN Bus device 6 communication (when ON) 
LB-12106 : pause CAN Bus device 7 communication (when ON) 
LB-12107 : pause CAN Bus device 8 communication (when ON) 
LB-12108 : pause CAN Bus device 9 communication (when ON) 
LB-12109 : pause CAN Bus device 10 communication (when ON) 
LB-12354 : pause CAN Bus device 255 communication (when ON) 
LB-12355 : daylight saving time period (when ON) 
 

Reserved Local Words 

LW-9002 (32bit-float) : input high limit 
LW-9004 (32bit-float) : input low limit 
LW-9006 (16bit) : connected client no.  
LW-9008 (32bit-float) : battery voltage 
LW-9010 (16bit-BCD) : local second 
LW-9011 (16bit-BCD) : local minute 
LW-9012 (16bit-BCD) : local hour 
LW-9013 (16bit-BCD) : local day 
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LW-9014 (16bit-BCD) : local month 
LW-9015 (16bit-BCD) : local year 
LW-9016 (16bit-BCD) : local week 
LW-9017 (16bit) : local second 
LW-9018 (16bit) : local minute 
LW-9019 (16bit) : local hour 
LW-9020 (16bit) : local day 
LW-9021 (16bit) : local month 
LW-9022 (16bit) : local year 
LW-9023 (16bit) : local week 
LW-9024 (16bit) : memory link system register 
LW-9025 (16bit) : CPU loading (x 100%) 
LW-9026 (16bit) : OS version (year) 
LW-9027 (16bit) : OS version (month) 
LW-9028 (16bit) : OS version (day) 
LW-9030 (32bit) : system time (unit : 0.1 second) 
LW-9032 (8 words) : folder name of backup history files to SD, USB memory 
LW-9040 (16bit) : backlight index 
LW-9041 (16bit) : touch status word (a user is touching the screen when bit 0's status is ON)) 
LW-9042 (16bit) : touch x position 
LW-9043 (16bit) : touch y position 
LW-9044 (16bit) : leave x position 
LW-9045 (16bit) : leave y position 
LW-9046 (32bit) : HMI key 
LW-9048 (16bit) : time (0 : AM, 1 : PM) 
LW-9049 (16bit) : local hour (12-hour format) 
LW-9050 (16bit) : current base window ID 
LW-9051 (16bit) : audio volume (0 ~100) 
LW-9052 (32bit-float) : the previous input value of the numeric input object 
LW-9060 (16bit) : no. of event log files on HMI memory 
LW-9061 (32bit) : size of event log files on HMI memory 
LW-9063 (16bit) : no. of data sampling files on HMI memory 
LW-9064 (32bit) : size of data sampling files on HMI memory 
LW-9070 (16bit) : free space insufficiency warning (Mega bytes) 
LW-9071 (16bit) : reserved free space size (Mega bytes) 
LW-9072 (32bit) : HMI current free space (K bytes) 
LW-9074 (32bit) : SD current free space (K bytes) 
LW-9076 (32bit) : USB disk current free space (K bytes) 
LW-9080 (16bit) : backlight saver time (unit : minute) 
LW-9081 (16bit) : screen saver time (unit : minute) 
LW-9082 (16bit) : auto logout time (unit : minute, 0 : disable the function) 
LW-9100 (14 words) : project name 
LW-9116 (32bit) : project size in bytes 
LW-9118 (32bit) : project size in K bytes 
LW-9120 (32bit) : EZwarePlus version 
LW-9122 (16bit) : project compiled date [year] 
LW-9123 (16bit) : project compiled date [month] 
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LW-9124 (16bit) : project compiled date [day] 
LW-9125 (16bit) : HMI ethernet gateway 0 (machine used only) 
LW-9126 (16bit) : HMI ethernet gateway 1 (machine used only) 
LW-9127 (16bit) : HMI ethernet gateway 2 (machine used only) 
LW-9128 (16bit) : HMI ethernet gateway 3 (machine used only) 
LW-9129 (16bit) : HMI ethernet IP 0 (machine used only) 
LW-9130 (16bit) : HMI ethernet IP 1 (machine used only) 
LW-9131 (16bit) : HMI ethernet IP 2 (machine used only) 
LW-9132 (16bit) : HMI ethernet IP 3 (machine used only) 
LW-9133 (16bit) : ethernet port no. 
LW-9134 (16bit) : language mode 
LW-9135 (16bit) : media access control (MAC) address 0 
LW-9136 (16bit) : media access control (MAC) address 1 
LW-9137 (16bit) : media access control (MAC) address 2 
LW-9138 (16bit) : media access control (MAC) address 3 
LW-9139 (16bit) : media access control (MAC) address 4 
LW-9140 (16bit) : media access control (MAC) address 5 
LW-9141 (16bit) : HMI station no. 
LW-9150 (32 words) : keyboard's input data (ASCII) 
LW-9199 (16bit) : external keyboard layout : 0 (QWERTY), 1 (AZERTY) 
LW-9200 (16bit) : address index 0 
LW-9201 (16bit) : address index 1 
LW-9202 (16bit) : address index 2 
LW-9203 (16bit) : address index 3 
LW-9204 (16bit) : address index 4 
LW-9205 (16bit) : address index 5 
LW-9206 (16bit) : address index 6 
LW-9207 (16bit) : address index 7 
LW-9208 (16bit) : address index 8 
LW-9209 (16bit) : address index 9 
LW-9210 (16bit) : address index 10 
LW-9211 (16bit) : address index 11 
LW-9212 (16bit) : address index 12 
LW-9213 (16bit) : address index 13 
LW-9214 (16bit) : address index 14 
LW-9215 (16bit) : address index 15 
LW-9216 (16bit) : the result of importing e-Mail data 
LW-9219 (16bit) : user no. (1~12) 
LW-9220 (32bit) : password 
LW-9222 (16bit) : classes can be operated for current user (bit 0:A, bit 1:B,bit 2:C, ...) 
LW-9230 (32bit) : address index 16 
LW-9232 (32bit) : address index 17 
LW-9234 (32bit) : address index 18 
LW-9236 (32bit) : address index 19 
LW-9238 (32bit) : address index 20 
LW-9240 (32bit) : address index 21 
LW-9242 (32bit) : address index 22 
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LW-9244 (32bit) : address index 23 
LW-9246 (32bit) : address index 24 
LW-9248 (32bit) : address index 25 
LW-9250 (32bit) : address index 26 
LW-9252 (32bit) : address index 27 
LW-9254 (32bit) : address index 28 
LW-9256 (32bit) : address index 29 
LW-9258 (32bit) : address index 30 
LW-9260 (32bit) : address index 31 
LW-9270 (16bit) : request's function code - MODBUS server (COM 1) 
LW-9271 (16bit) : request's starting address - MODBUS server (COM 1) 
LW-9272 (16bit) : request's quantity of registers - MODBUS server (COM 1) 
LW-9275 (16bit) : request's function code - MODBUS server (COM 2) 
LW-9276 (16bit) : request's starting address - MODBUS server (COM 2) 
LW-9277 (16bit) : request's quantity of registers - MODBUS server (COM 2) 
LW-9280 (16bit) : request's function code - MODBUS server (COM 3) 
LW-9281 (16bit) : request's starting address - MODBUS server (COM 3) 
LW-9282 (16bit) : request's quantity of registers - MODBUS server (COM 3) 
LW-9285 (16bit) : request's function code - MODBUS server (ethernet) 
LW-9286 (16bit) : request's starting address - MODBUS server (ethernet) 
LW-9287 (16bit) : request's quantity of registers - MODBUS server (ethernet) 
LW-9288 (16bit) : last error code - MODBUS server (ethernet) 
LW-9300 (16bit) : driver ID of local PLC 1 
LW-9301 (16bit) : driver ID of local PLC 2 
LW-9302 (16bit) : driver ID of local PLC 3 
LW-9303 (16bit) : driver ID of local PLC 4 
LW-9331 (16bit) : driver ID of local PLC 32 
LW-9350 (16bit) : pending command no. in local HMI 
LW-9351 (16bit) : pending command no. in PLC 1 (COM 1) 
LW-9352 (16bit) : pending command no. in PLC 2 (COM 2) 
LW-9353 (16bit) : pending command no. in PLC 3 (COM 3) 
LW-9354 (16bit) : pending command no. in PLC 4 (ethernet) 
LW-9355 (16bit) : pending command no. in PLC 5 (ethernet) 
LW-9356 (16bit) : pending command no. in PLC 6 (ethernet) 
LW-9357 (16bit) : pending command no. in PLC 7 (ethernet) 
LW-9389 (16bit) : pending command no. in PLC 39 (ethernet) 
LW-9390 (16bit) : pending command no. in PLC (USB) 
LW-9392 (16bit) : pending command no. in PLC (CAN Bus) 
LW-9400 (16bit) : error code for PLC 1* (see Communication Error Codes next) 
LW-9401 (16bit) : error code for PLC 2* 
LW-9402 (16bit) : error code for PLC 3* 
LW-9403 (16bit) : error code for PLC 4* 
LW-9404 (16bit) : error code for PLC 5* 
LW-9405 (16bit) : error code for PLC 6* 
LW-9406 (16bit) : error code for PLC 7* 
LW-9407 (16bit) : error code for PLC 8* 
LW-9449 (16bit) : error code for PLC 50* 
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LW-9450 (16bit) : time tag of event log - second 
LW-9451 (16bit) : time tag of event log - minute 
LW-9452 (16bit) : time tag of event log - hour 
LW-9453 (16bit) : time tag of event log - day 
LW-9454 (16bit) : time tag of event log - month 
LW-9455 (16bit) : time tag of event log - year 
LW-9490 (16bit) : error code for USB PLC* 
LW-9491 (16bit):  error code for CANbus PLC* 
LW-9500 (32bit) : user 1's password 
LW-9502 (32bit) : user 2's password 
LW-9504 (32bit) : user 3's password 
LW-9506 (32bit) : user 4's password 
LW-9508 (32bit) : user 5's password 
LW-9510 (32bit) : user 6's password 
LW-9512 (32bit) : user 7's password 
LW-9514 (32bit) : user 8's password 
LW-9516 (32bit) : user 9's password 
LW-9518 (32bit) : user 10's password 
LW-9520 (32bit) : user 11's password 
LW-9522 (32bit) : user 12's password 
LW-9530 (8 words) : VNC server password 
LW-9540 (16bit) : reserved for caps lock 
LW-9541 (16bit) : MODBUS/ASCII server station no. (COM 1) 
LW-9542 (16bit) : MODBUS/ASCII server station no. (COM 2) 
LW-9543 (16bit) : MODBUS/ASCII server station no. (COM 3) 
LW-9544 (16bit) : MODBUS/ASCII server station no. (ethernet) 
LW-9550 (16bit) : COM 1 mode (0:RS232,1:RS485 2W,2:RS485 4W) 
LW-9551 (16bit) : COM 1 baud rate 

 LW-9552 (16bit) : COM 1 databits (7 : 7 bits, 8 : 8 bits) 
LW-9553 (16bit) : COM 1 parity (0:none, 1:even, 2:odd, 3:mark, 4:space) 
LW-9554 (16bit) : COM 1 stop bits (1 : 1 bit, 2 : 2 bits) 
LW-9555 (16bit) : COM 2 mode (0:RS232,1:RS485 2W,2:RS485 4W) 
LW-9556 (16bit) : COM 2 baud 

 LW-9557 (16bit) : COM 2 databits (7 : 7 bits, 8 : 8 bits) 
LW-9558 (16bit) : COM 2 parity (0:none, 1:even, 2:odd, 3:mark, 4:space) 
LW-9559 (16bit) : COM 2 stop bits (1 : 1 bit, 2 : 2 bits) 
LW-9560 (16bit) : COM 3 mode (0:RS232,1:RS485 2W) 
LW-9561 (16bit) : COM 3 baud rate 

 LW-9562 (16bit) : COM 3 databits (7 : 7 bits, 8 : 8 bits) 
LW-9563 (16bit) : COM 3 parity (0:none, 1:even, 2:odd, 3:mark, 4:space) 
LW-9564 (16bit) : COM 3 stop bits (1 : 1 bit, 2 : 2 bits) 
LW-9565 (16bit) : COM 1 broadcast station no. 
LW-9566 (16bit) : COM 2 broadcast station no. 
LW-9567 (16bit) : COM 3 broadcast station no. 
LW-9570 (32bit) : received data count (bytes) (COM 1 MODBUS server) 
LW-9572 (32bit) : received data count (bytes) (COM 2 MODBUS server) 
LW-9574 (32bit) : received data count (bytes) (COM 3 MODBUS server) 
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LW-9576 (32bit) : received data count (bytes) (Ethernet MODBUS server) 
LW-9600 (16bit) : PLC 4's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9601 (16bit) : PLC 4's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9602 (16bit) : PLC 4's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9603 (16bit) : PLC 4's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9604 (16bit) : PLC 4's port no. 
LW-9605 (16bit) : PLC 5's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9606 (16bit) : PLC 5's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9607 (16bit) : PLC 5's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9608 (16bit) : PLC 5's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9609 (16bit) : PLC 5's port no. 
LW-9610 (16bit) : PLC 6's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9611 (16bit) : PLC 6's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9612 (16bit) : PLC 6's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9613 (16bit) : PLC 6's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9614 (16bit) : PLC 6's port no. 
LW-9615 (16bit) : PLC 7's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9616 (16bit) : PLC 7's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9617 (16bit) : PLC 7's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9618 (16bit) : PLC 7's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9619 (16bit) : PLC 7's port no. 
LW-9620 (16bit) : PLC 8's (IP address = IP0:IP1:IP2:IP3) 
LW-9621 (16bit) : PLC 8's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9622 (16bit) : PLC 8's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9623 (16bit) : PLC 8's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9624 (16bit) : PLC 8's port no. 
LW-9625 (16bit) : PLC 9's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9626 (16bit) : PLC 9's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9627 (16bit) : PLC 9's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9628 (16bit) : PLC 9's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9629 (16bit) : PLC 9's port no. 
LW-9765 (16bit) : PLC 37's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9766 (16bit) : PLC 37's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9767 (16bit) : PLC 37's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9768 (16bit) : PLC 37's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9769 (16bit) : PLC 37's port no. 
LW-9770 (16bit) : remote printer/backup server IP0 (IP0:IP1:IP2:IP3) 
LW-9771 (16bit) : remote printer/backup server IP1 (IP0:IP1:IP2:IP3) 
LW-9772 (16bit) : remote printer/backup server IP2 (IP0:IP1:IP2:IP3) 
LW-9773 (16bit) : remote printer/backup server IP3 (IP0:IP1:IP2:IP3) 
LW-9774 (6 words) : remote printer/backup server user name 
LW-9780 (6 words) : remote printer/backup server password 
LW-9800 (16bit) : remote HMI 1's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9801 (16bit) : remote HMI 1's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9802 (16bit) : remote HMI 1's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9803 (16bit) : remote HMI 1's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9804 (16bit) : remote HMI 1's port no. 
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LW-9805 (16bit) : remote HMI 2's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9806 (16bit) : remote HMI 2's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9807 (16bit) : remote HMI 2's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9808 (16bit) : remote HMI 2's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9809 (16bit) : remote HMI 2's port no. 
LW-9810 (16bit) : remote HMI 3's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9811 (16bit) : remote HMI 3's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9812 (16bit) : remote HMI 3's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9813 (16bit) : remote HMI 3's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9814 (16bit) : remote HMI 3's port no. 
LW-9815 (16bit) : remote HMI 4's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9816 (16bit) : remote HMI 4's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9817 (16bit) : remote HMI 4's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9818 (16bit) : remote HMI 4's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9819 (16bit) : remote HMI 4's port no. 
LW-9820 (16bit) : remote HMI 5's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9821 (16bit) : remote HMI 5's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9822 (16bit) : remote HMI 5's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9823 (16bit) : remote HMI 5's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9824 (16bit) : remote HMI 5's port no. 
LW-9825 (16bit) : remote HMI 6's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9826 (16bit) : remote HMI 6's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9827 (16bit) : remote HMI 6's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9828 (16bit) : remote HMI 6's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9829 (16bit) : remote HMI 6's port no. 
LW-9830 (16bit) : remote HMI 7's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9831 (16bit) : remote HMI 7's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9832 (16bit) : remote HMI 7's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9833 (16bit) : remote HMI 7's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9834 (16bit) : remote HMI 7's port no. 
LW-9835 (16bit) : remote HMI 8's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9836 (16bit) : remote HMI 8's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9837 (16bit) : remote HMI 8's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9838 (16bit) : remote HMI 8's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9839 (16bit) : remote HMI 8's port no. 
LW-9895 (16bit) : remote HMI 20's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9896 (16bit) : remote HMI 20's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9897 (16bit) : remote HMI 20's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9898 (16bit) : remote HMI 20's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9899 (16bit) : remote HMI 20's port no. 
LW-9900 (16bit) : HMI run mode (0 : normal mode, 1~3 : test mode (COM 1~COM 3)) 
LW-9901 (16bit) : pass-through source COM port (1~3 : COM 1~COM 3) 
LW-9902 (16bit) : pass-through destination COM port (1~3 : COM 1~COM 3) 
LW-9903 (16bit) : pass-through control (0 : normal, 1 : pause, 2 : stop communications between 

      LW-9904 (16bit) : pass-through server port no. (2000~2100) 
LW-9905 (16bit) : remote HMI 21's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9906 (16bit) : remote HMI 21's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9907 (16bit) : remote HMI 21's IP2 (IP address = IP0:IP1:IP2:IP3) 
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LW-9908 (16bit) : remote HMI 21's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9909 (16bit) : remote HMI 21's port no. 
LW-9910 (16bit) : remote HMI 22's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9911 (16bit) : remote HMI 22's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9912 (16bit) : remote HMI 22's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9913 (16bit) : remote HMI 22's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9914 (16bit) : remote HMI 22's port no. 
LW-9915 (16bit) : remote HMI 23's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9916 (16bit) : remote HMI 23's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9917 (16bit) : remote HMI 23's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9918 (16bit) : remote HMI 23's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9919 (16bit) : remote HMI 23's port no. 
LW-9920 (16bit) : remote HMI 24's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9921 (16bit) : remote HMI 24's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9922 (16bit) : remote HMI 24's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9923 (16bit) : remote HMI 24's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9924 (16bit) : remote HMI 24's port no. 
LW-9925 (16bit) : remote HMI 25's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9926 (16bit) : remote HMI 25's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9927 (16bit) : remote HMI 25's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9928 (16bit) : remote HMI 25's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9929 (16bit) : remote HMI 25's port no. 
LW-9930 (16bit) : remote HMI 26's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9931 (16bit) : remote HMI 26's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9932 (16bit) : remote HMI 26's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9933 (16bit) : remote HMI 26's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9934 (16bit) : remote HMI 26's port no. 
LW-9935 (16bit) : remote HMI 27's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9936 (16bit) : remote HMI 27's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9937 (16bit) : remote HMI 27's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9938 (16bit) : remote HMI 27's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9939 (16bit) : remote HMI 27's port no. 
LW-9940 (16bit) : remote HMI 28's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9941 (16bit) : remote HMI 28's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9942 (16bit) : remote HMI 28's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9943 (16bit) : remote HMI 28's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9944 (16bit) : remote HMI 28's port no. 
LW-9945 (16bit) : remote HMI 29's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9946 (16bit) : remote HMI 29's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9947 (16bit) : remote HMI 29's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9948 (16bit) : remote HMI 29's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9949 (16bit) : remote HMI 29's port no. 
LW-9950 (16bit) : remote HMI 30's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9951 (16bit) : remote HMI 30's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9952 (16bit) : remote HMI 30's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9953 (16bit) : remote HMI 30's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9954 (16bit) : remote HMI 30's port no. 
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LW-9955 (16bit) : remote HMI 31's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9956 (16bit) : remote HMI 31's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9957 (16bit) : remote HMI 31's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9958 (16bit) : remote HMI 31's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9959 (16bit) : remote HMI 31's port no. 
LW-9960 (16bit) : remote HMI 32's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9961 (16bit) : remote HMI 32's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9962 (16bit) : remote HMI 32's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9963 (16bit) : remote HMI 32's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9964 (16bit) : remote HMI 32's port no. 
LW-9995 (16bit) : remote HMI 39's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-9996 (16bit) : remote HMI 39's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-9997 (16bit) : remote HMI 39's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-9998 (16bit) : remote HMI 39's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-9999 (16bit) : remote HMI 39's port no. 
LW-10000 (16bit) : var0 - station no variable (usage : var0#address) 
LW-10001 (16bit) : var1 - station no variable (usage : var1#address) 
LW-10002 (16bit) : var2 - station no variable (usage : var2#address) 
LW-10003 (16bit) : var3 - station no variable (usage : var3#address) 
LW-10004 (16bit) : var4 - station no variable (usage : var4#address) 
LW-10005 (16bit) : var5 - station no variable (usage : var5#address) 
LW-10006 (16bit) : var6 - station no variable (usage : var6#address) 
LW-10007 (16bit) : var7 - station no variable (usage : var7#address) 
LW-10008 (16bit) : var8 - station no variable (usage : var8#address) 
LW-10009 (16bit) : var9 - station no variable (usage : var9#address) 
LW-10010 (16bit) : var10 - station no variable (usage : var10#address) 
LW-10011 (16bit) : var11 - station no variable (usage : var11#address) 
LW-10012 (16bit) : var12 - station no variable (usage : var12#address) 
LW-10013 (16bit) : var13 - station no variable (usage : var13#address) 
LW-10014 (16bit) : var14 - station no variable (usage : var14#address) 
LW-10015 (16bit) : var15 - station no variable (usage : var15#address) 
LW-10050 (16bit) : IP0 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10051 (16bit) : IP1 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10052 (16bit) : IP2 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10053 (16bit) : IP3 of the HMI connecting to remote PLC 1 (IP address = IP0:IP1:IP2:IP3) 
LW-10054 (16bit) : port no. of the HMI connecting to remote PLC 1 
LW-10055 (16bit) : IP0 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10056 (16bit) : IP1 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10057 (16bit) : IP2 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10058 (16bit) : IP3 of the HMI connecting to remote PLC 2 (IP address = IP0:IP1:IP2:IP3) 
LW-10059 (16bit) : port no. of the HMI connecting to remote PLC 2 
LW-10060 (16bit) : IP0 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10061 (16bit) : IP1 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10062 (16bit) : IP2 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10063 (16bit) : IP3 of the HMI connecting to remote PLC 3 (IP address = IP0:IP1:IP2:IP3) 
LW-10064 (16bit) : port no. of the HMI connecting to remote PLC 3 
LW-10065 (16bit) : IP0 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
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LW-10066 (16bit) : IP1 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
LW-10067 (16bit) : IP2 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
LW-10068 (16bit) : IP3 of the HMI connecting to remote PLC 4 (IP address = IP0:IP1:IP2:IP3) 
LW-10069 (16bit) : port no. of the HMI connecting to remote PLC 4 
LW-10205 (16bit) : IP0 of the HMI connecting to remote PLC 32 (IP address = IP0:IP1:IP2:IP3) 
LW-10206 (16bit) : IP1 of the HMI connecting to remote PLC 32 (IP address = IP0:IP1:IP2:IP3) 
LW-10207 (16bit) : IP2 of the HMI connecting to remote PLC 32 (IP address = IP0:IP1:IP2:IP3) 
LW-10208 (16bit) : IP3 of the HMI connecting to remote PLC 32 (IP address = IP0:IP1:IP2:IP3) 
LW-10209 (16bit) : port no. of the HMI connecting to remote PLC 32 
LW-10300 (16bit) : remote PLC 1's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10301 (16bit) : remote PLC 1's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10302 (16bit) : remote PLC 1's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10303 (16bit) : remote PLC 1's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10304 (16bit) : remote PLC 1's port no. 
LW-10305 (16bit) : remote PLC 2's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10306 (16bit) : remote PLC 2's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10307 (16bit) : remote PLC 2's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10308 (16bit) : remote PLC 2's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10309 (16bit) : remote PLC 2's port no. 
LW-10310 (16bit) : remote PLC 3's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10311 (16bit) : remote PLC 3's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10312 (16bit) : remote PLC 3's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10313 (16bit) : remote PLC 3's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10314 (16bit) : remote PLC 3's port no. 
LW-10315 (16bit) : remote PLC 4's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10316 (16bit) : remote PLC 4's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10317 (16bit) : remote PLC 4's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10318 (16bit) : remote PLC 4's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10319 (16bit) : remote PLC 4's port no. 
LW-10455 (16bit) : remote PLC 32's IP0 (IP address = IP0:IP1:IP2:IP3) 
LW-10456 (16bit) : remote PLC 32's IP1 (IP address = IP0:IP1:IP2:IP3) 
LW-10457 (16bit) : remote PLC 32's IP2 (IP address = IP0:IP1:IP2:IP3) 
LW-10458 (16bit) : remote PLC 32's IP3 (IP address = IP0:IP1:IP2:IP3) 
LW-10459 (16bit) : remote PLC 32's port no. 
LW-10480 (16bit) : no. of event log files on SD card 
LW-10481 (32bit) : size of event log files on SD card 
LW-10483 (16bit) : no. of event log files on USB disk 
LW-10484 (32bit) : size of event log files on USB disk 
LW-10489 (16bit) : no. of data sampling files on SD card 
LW-10490 (32bit) : size of data sampling files on SD card 
LW-10492 (16bit) : no. of data sampling files on USB disk 
LW-10493 (32bit) : size of data sampling files on USB disk 
LW-10500 (16bit) : PLC 1 timeout (unit : 100ms) 
LW-10501 (16bit) : PLC 1 turn around delay (unit : ms) 
LW-10502 (16bit) : PLC 1 send ACK delay (unit : ms) 
LW-10503 (16bit) : PLC 1 parameter 1  
LW-10504 (16bit) : PLC 1 parameter 2 
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LW-10505 (16bit) : PLC 2 timeout (unit : 100ms) 
LW-10506 (16bit) : PLC 2 turn around delay (unit : ms) 
LW-10507 (16bit) : PLC 2 send ACK delay (unit : ms) 
LW-10508 (16bit) : PLC 2 parameter 1 
LW-10509 (16bit) : PLC 2 parameter 2 
LW-10510 (16bit) : PLC 3 timeout (unit : 100ms) 
LW-10511 (16bit) : PLC 3 turn around delay (unit : ms) 
LW-10512 (16bit) : PLC 3 send ACK delay (unit : ms) 
LW-10513 (16bit) : PLC 3 parameter 1 
LW-10514 (16bit) : PLC 3 parameter 2 
LW-10515 (16bit) : PLC 4 timeout (unit : 100ms) 
LW-10516 (16bit) : PLC 4 turn around delay (unit : ms) 
LW-10517 (16bit) : PLC 4 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10518 (16bit) : PLC 4 parameter 1 (SIEMENS S7/400 rack) 
LW-10519 (16bit) : PLC 4 parameter 2 (SIEMENS S7/400 CPU slot) 
LW-10520 (16bit) : PLC 5 timeout (unit : 100ms) 
LW-10521 (16bit) : PLC 5 turn around delay (unit : ms) 
LW-10522 (16bit) : PLC 5 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10523 (16bit) : PLC 5 parameter 1 (SIEMENS S7/400 rack) 
LW-10524 (16bit) : PLC 5 parameter 2 (SIEMENS S7/400 CPU slot) 
LW-10525 (16bit) : PLC 6 timeout (unit : 100ms) 
LW-10526 (16bit) : PLC 6 turn around delay (unit : ms) 
LW-10527 (16bit) : PLC 6 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10528 (16bit) : PLC 6 parameter 1 (SIEMENS S7/400 rack) 
LW-10529 (16bit) : PLC 6 parameter 2 (SIEMENS S7/400 CPU slot) 
LW-10530 (16bit) : PLC 7 timeout (unit : 100ms) 
LW-10531 (16bit) : PLC 7 turn around delay (unit : ms) 
LW-10532 (16bit) : PLC 7 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10533 (16bit) : PLC 7 parameter 1 (SIEMENS S7/400 rack) 
LW-10534 (16bit) : PLC 7 parameter 2 (SIEMENS S7/400 CPU slot) 
LW-10535 (16bit) : PLC 8 timeout (unit : 100ms) 
LW-10536 (16bit) : PLC 8 turn around delay (unit : ms) 
LW-10537 (16bit) : PLC 8 send ACK delay (unit : ms) (SIEMENS S7/400 Link type) 
LW-10538 (16bit) : PLC 8 parameter 1 (SIEMENS S7/400 rack) 
LW-10539 (16bit) : PLC 8 parameter 2 (SIEMENS S7/400 CPU slot) 
LW-10655 (16bit) : PLC 32 timeout (unit : 100ms) 
LW-10656 (16bit) : PLC 32 turn around delay (unit : ms) 
LW-10657 (16bit) : PLC 32 send ACK delay (unit : ms) 
LW-10658 (16bit) : PLC 32 parameter 1  
LW-10659 (16bit) : PLC 32 parameter 2 
LW-10700 (4 words) : DLT_645 operator (COM 1) 
LW-10704 (4 words) : DLT_645 password (COM 1) 
LW-10708 (6 words) : DLT_645 address (COM 1) 
LW-10715 (4 words) : DLT_645 operator (COM 2) 
LW-10719 (4 words) : DLT_645 password (COM 2) 
LW-10723 (6 words) : DLT_645 address (COM 2) 
LW-10730 (4 words) : DLT_645 operator (COM 3) 
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LW-10734 (4 words) : DLT_645 password (COM 3) 
LW-10738 (6 words) : DLT_645 address (COM 3) 
LW-10750 (16bit) : HMI ethernet netmask 0 (machine used only) 
LW-10751 (16bit) : HMI ethernet netmask 1 (machine used only) 
LW-10752 (16bit) : HMI ethernet netmask 2 (machine used only) 
LW-10753 (16bit) : HMI ethernet netmask 3 (machine used only) 
LW-10754 (8 words) : current user name 
LW-10804 (16bit) : HMI ethernet domain name system (DNS) server IP 0 (OS version 20131106 
or later supports only) 
LW-10805 (16bit) : HMI ethernet domain name system (DNS) server IP 1 (OS version 20131106 
or later supports only) 
LW-10806 (16bit) : HMI ethernet domain name system (DNS) server IP 2 (OS version 20131106 
or later supports only) 
LW-10807 (16bit) : HMI ethernet domain name system (DNS) server IP 3 (OS version 20131106 
or later supports only) 
LW-10812 (16bit) : obtain an IP address automatically (DHCP => 0 : off, 1 : on) 
LW-10814 (16bit) : connecting to a Weintek HMI (0:none, 1:connecting) 
LW-10815 (16bit) : link speed of ethernet 1 (0:failure, 10 (10M), 100 (100M), 1000 (1G)) 
LW-10816 (16bit) : link speed of ethernet 2 (0:failure, 10 (10M), 100 (100M), 1000 (1G)) 
LW-10820 (16bit) : disable (set 0)/enable (set 1) (EasyAccess 2.0) 
LW-10821 (5 words) : session ID (EasyAccess 2.0) 
LW-10826 (2 words) : password (EasyAccess 2.0) 
LW-10828 (16bit) : execution status (EasyAccess 2.0) 
LW-10829 (16bit) : the last error code (EasyAccess 2.0) 
LW-10850 (16bit) : disable/enable (0 : disable, 1 : normal, 2 : IP limited) (siemens pass-through) 
LW-10851 (16bit) : destination COM port (siemens pass-through) 
LW-10852 (16bit) : destination PLC station no. (siemens pass-through) 
LW-10853 (16bit) : communication protocol (0 : invalid, 1 : PPI, 2 : MPI) (siemens pass-through) 
LW-10854 (16bit) : IP0 of connecting client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10855 (16bit) : IP1 of connecting client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10856 (16bit) : IP2 of connecting client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10857 (16bit) : IP3 of connecting client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10858 (16bit) : IP0 of designated client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10859 (16bit) : IP1 of designated client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10860 (16bit) : IP2 of designated client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10861 (16bit) : IP3 of designated client (IP address = IP0:IP1:IP2:IP3) (siemens pass-through) 
LW-10862 (16bit) : connection status (0 : ready, 1 : client connecting) (siemens pass-through) 
LW-10863 (16bit) : execution status (0 : normal, 1 : error) (siemens pass-through) 
LW-10864 (16bit) : the last error code (siemens pass-through) 
LW-10884 (16 words) : HMI name 
LW-10900 (16bit) : macro 0 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10901 (16bit) : macro 1 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
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LW-10902 (16bit) : macro 2 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10903 (16bit) : macro 3 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10904 (16bit) : macro 4 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10905 (16bit) : macro 5 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10906 (16bit) : macro 6 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10907 (16bit) : macro 7 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10908 (16bit) : macro 8 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-10909 (16bit) : macro 9 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-11154 (16bit) : macro 254 status (0:ready, 3:executing, 5:waiting response, 9:waiting sync, 
17:delay) 
LW-11155 (32bit) : the total size of HMI memory (unit : KB) 
LW-11157 (32bit) : the free size of HMI memory (unit : KB) 
LW-11159 (16bit) : memory loading (x 100%) 
LW-11160 (16bit) : start time of USB security key - year 
LW-11161 (16bit) : start time of USB security key - month 
LW-11162 (16bit) : start time of USB security key - day 
LW-11163 (16bit) : start time of USB security key - hour 
LW-11164 (16bit) : start time of USB security key - minute 
LW-11165 (16bit) : expiration time of USB security key - year 
LW-11166 (16bit) : expiration time of USB security key - month 
LW-11167 (16bit) : expiration time of USB security key - day 
LW-11168 (16bit) : expiration time of USB security key - hour 
LW-11169 (16bit) : expiration time of USB security key - minute 
LW-11170 (16bit) : Proxy Disable/Enable (0:disable, 1:enable) (EasyAccess 2.0) 
LW-11171 (16bit) : Proxy Type (0:HTTP, 1:SOCKSv4, 2:SOCKSv5) (EasyAccess 2.0) 
LW-11172 (16bit) : Proxy Server IP0 (EasyAccess 2.0) 
LW-11173 (16bit) : Proxy Server IP1 (EasyAccess 2.0) 
LW-11174 (16bit) : Proxy Server IP2 (EasyAccess 2.0) 
LW-11175 (16bit) : Proxy Server IP3 (EasyAccess 2.0) 
LW-11176 (16bit) : Proxy Server Port (EasyAccess 2.0) 
LW-11177 (16bit) : Proxy authentication (0:disable, 1:enable) (EasyAccess 2.0) 
LW-11178 (16 words) : Proxy username (EasyAccess 2.0) 
LW-11194 (16 words) : Proxy password (EasyAccess 2.0) 
LW-11210 (20 words) : Hardware key (EasyAccess 2.0) 
LW-11260 (16bit) : enable/disable the daylight saving time (DST) (0:disable, 1:enable) 

 
LW-11261 (16bit) : hour of the DST bias 

 
LW-11262 (16bit) : minute of the DST bias 
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LW-11263 (16bit) : month of the year when DST starts 

 
LW-11264 (16bit) : week of the month when DST starts (1~5) 

 
LW-11265 (16bit) : day of the week when DST starts (0~ 6) 

 
LW-11266 (16bit) : hour of local time when DST starts 

 
LW-11267 (16bit) : minute of local time when DST starts 
LW-11268 (16bit) : month of the year when DST ends 
LW-11269 (16bit) : week of the month when DST ends (1~5) 
LW-11270 (16bit) : day of the week when DST ends (0~6) 
LW-11271 (16bit) : hour of local time when DST ends 
LW-11272 (16bit) : minute of local time when DST ends 
LW-11273 (16bit) : enable/disable time synchronization via NTP (Network Time Protocol) server 
(0 di bl  1 bl ) LW-11274 (16bit) : execute time synchronization when HMI starts (0:disable, 1:enable) 
LW-11275 (16bit) : server response time has been adjusted in accordance with DST (0:disable, 
1 bl ) LW-11276 (16bit) : HMI time zone (unit : minute) 
LW-11277 (16bit) : server response time (server time zone)  (unit : minute) 
LW-11278 (16bit) : IP 0 of network time server 1 (IP address = IP0:IP1:IP2:IP3) 
LW-11279 (16bit) : IP 1 of network time server 1 (IP address = IP0:IP1:IP2:IP3) 
LW-11280 (16bit) : IP 2 of network time server 1 (IP address = IP0:IP1:IP2:IP3) 
LW-11281 (16bit) : IP 3 of network time server 1 (IP address = IP0:IP1:IP2:IP3) 
LW-11282 (16bit) : IP 0 of network time server 2 (IP address = IP0:IP1:IP2:IP3) 
LW-11283 (16bit) : IP 1 of network time server 2 (IP address = IP0:IP1:IP2:IP3) 
LW-11284 (16bit) : IP 2 of network time server 2 (IP address = IP0:IP1:IP2:IP3) 
LW-11285 (16bit) : IP 3 of network time server 2 (IP address = IP0:IP1:IP2:IP3) 
LW-11286 (16bit) : IP 0 of network time server 3 (IP address = IP0:IP1:IP2:IP3) 
LW-11287 (16bit) : IP 1 of network time server 3 (IP address = IP0:IP1:IP2:IP3) 
LW-11288 (16bit) : IP 2 of network time server 3 (IP address = IP0:IP1:IP2:IP3) 
LW-11289 (16bit) : IP 3 of network time server 3 (IP address = IP0:IP1:IP2:IP3) 
LW-11290 (16bit) : IP 0 of network time server 4 (IP address = IP0:IP1:IP2:IP3) 
LW-11291 (16bit) : IP 1 of network time server 4 (IP address = IP0:IP1:IP2:IP3) 
LW-11292 (16bit) : IP 2 of network time server 4 (IP address = IP0:IP1:IP2:IP3) 
LW-11293 (16bit) : IP 3 of network time server 4 (IP address = IP0:IP1:IP2:IP3) 
LW-11294 (32bit) :  update interval (time synchronization interval) (10 ~ 86400, unit : second) 
LW-11296 (16bit) :  Location of EasyAccess 2.0 server (0 : Global, 1 : China) 
 

*Communication Error Codes (LW-9400 to LW-9449; LW-9490 to LW-9491) 

Error Code Cause of Communication Error 
0 Normal 
1 The device is busy and not yet ready to process a command. 
2 Communication error due to unexpected reason. 
3 The device does not exist. 
4 The device using the spec ified station number does not exist. 
5 Incorrect address format. 
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6 Read/Write unsupported address. 
7 The driver of the device does not exist. 
8 The COM port does not exist. 
9 Incorrect IP address or unable to connect to the device. 
10 Checksum error. 
11 Unidentified command. 
12 Ignore. 
20 The USB device is improperly connected. 
21 The CANbus device is improperlyconnected. 
22 No reply from the device. 
23 Insufficient data read from the device during timeout. 
24 The Conversion Tag used by the object does not exist or the content is incorrect. 
25 HMI is not accepting any commands from a remote HMI. 
251 Read/Write exceeding number of words from/to the register of the Modbus device. 
252 The Modbus device replies incorrect data format. 
253 Modbus device checksum error. 
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Appendix B – Index Registers 
EZwarePlus provides Index Registers for changing addresses during runtime. The Index Register feature 
allows an object’s read/write address to be changed on the HMI screen while the project is running. 

There are 32 Index Registers available (sixteen are 16-bit registers and sixteen are 32-bit registers). 

 

LW-9200 through LW-9215 are 16-bit Index Registers that correspond to INDEX 0-15. 
They have a maximum offset range of 65536 words (2^16). 

LW-9230 through LW-9260 are 32-bit Index Registers that correspond to INDEX 16-31. 
They have a maximum offset range of 4,294,967,296 words (2^32). 

To use an Index Register 

1. Next to the Read/Write address in an object’s properties window, click on the Settings button to 
open the Address window. 
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2. Select the Index register checkbox and select the Index register to be used (INDEX 0 through 
INDEX 31). 
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3. When using the Index Register for an object’s read/write address, the value in the Index Register is 
added to the designated read/write address. 

For example, if the designated read/write address of a Numeric object is LW-10 and a “5” is written to the 
Index Register, the Numeric object will read and write to LW-15 [R/W register address + Index Register 
value]. 

  Index Registers can also be used with bit addresses. However, adding a “1” to the Index Register will 
offset the bit address by 16. 

For example, if the designated read/write address of a Toggle Switch object is LB-10 and a “1” is written to 
the Index Register, the Toggle Switch will read and write to LB-26 [(R/W register address) + (Index Register 
value x 16)]. 
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Appendix C – Downloading a Project to the HMI from a USB 
Drive or SD Card 
A project can be loaded onto a USB flash drive or SD card and downloaded to an HMI. 

  This feature is not supported in the RMI5010. 

To download a project to the HMI from a USB drive or SD card: 
1. Open the project in EZwarePlus and compile the project (Tools > Compile).  

2. Select Build Data for USB Disk or CF Card Download from the Tools menu.  

3. In the USB Disk/CF Card/SD Card Data dialog box, under Select the folder to save download 
data: use the Browse button to select the location to save the project. Click Build.  When the 
process is complete, the message “Creating successful!" appears. Click OK and click Exit. 

 

 

4. A folder named mt8000ie (or emt3000, depending on the model) will be created on the root (main) 
directory of the USB flash drive or SD card. 

5. Remove the flash drive from your computer and connect it to the HMI. When a flash drive is inserted 
into the HMI5000 Series, the following dialog is displayed: 
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Download  Transfer data from the flash drive to the HMI. 

Upload  Transfer data from the HMI to the flash drive. 

Restart Project and Exit  Close the dialog and restart the HMI. 

 
Cancel  Close the dialog without transferring. 

 
Time Remaining 

The dialog will automatically close after 10 seconds if no selection is 
made; shows the time remaining. 

 
 

  The Download/Upload dialog box can be disabled. If it does not pop up when the USB flash drive or SD 
card is installed, open the System Settings in the HMI and enable it on the Misc 1 tab. 

  

When Download is selected, a dialog box appears requesting the Download password and what data to 
download. The default password is 111111. 
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Password Enter the Download password. 

Download Project Files 
When checked, the HMI checks the specified folder for project data 
and transfers it if it exists. 

 

Download History Files 
When checked, the HMI checks the specified folder for history data 
and transfers it if it exists (includes data log files, event log files, and 
recipe files). 

 
Clear History Files 

When checked, clears all history files in the HMI (includes data log 
files, event log files, and recipe files). 

 

 
 

If a USB flash drive is being used to download the project, select the folder under the usbdisk folder 
(disk_a_1) and then click OK. If an SD card is being used, select the folder under the pccard folder 
(SD_MMCO_1). If the project is in a folder on the USB drive or SD card, select the folder just above the 
mt8000ie or emt3000 folder. 

  Do not select the mt8000ie or emt3000 folder, but the folder just above the mt8000ie or emt3000 folder. 

                       

          USB flash drive            SD card 

Click OK to download the project from the USB drive or SD card to the HMI. When the download is 
complete, the HMI automatically reboots and runs the project.  

 The storage device can be left with the HMI as a backup should the project need to be downloaded 
to the HMI again. 
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Appendix D – Uploading a Project from the HMI to a USB Drive 
or SD Card 
A project can be uploaded from an HMI5000 Series to a USB flash drive or SD card and transferred to a PC. 

  This feature is not supported in the RMI5010. 

To upload a project from the HMI to a USB drive or SD card: 
1. Insert the USB flash drive in the HMI’s USB port or insert the SD card in the HMI’s SD card slot. The 

Download/Upload dialog box will appear. 

 

Download Transfer data from the flash drive to the HMI. 

Upload Transfer data from the HMI to the flash drive. 

Restart Project and Exit Close the dialog and restart the HMI. 

Cancel Close the dialog without transferring. 

 
Time Remaining 

The dialog will automatically close after 10 seconds if no selection is 
made; shows the time remaining. 

  

  The Download/Upload dialog box can be disabled. If it does not pop up when the USB flash drive or SD 
card is installed, open the System Settings in the HMI and enable it on the Misc 1 tab. 
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2. Select Upload and enter the upload password (the default password is 111111). 

  

Password Enter the Upload password. 

Upload project1 When checked, the HMI uploads the compiled project file from the 
HMI (*.exob). 

 Upload all project files When checked, the HMI uploads the compiled project file along with 
all the associated files (firmware, fonts, drivers). 

Upload history Files When checked, the HMI uploads history files (includes data log files, 
event log files, recipe files, and operation log files). 

  

1 Note: Older models do not have the “Upload project” option available. 

3. In the Pick a Directory window, select the location where you want the data to be stored.  
For a USB flash drive, touch the “+” sign in front of usbdisk and select disk_a_1. 
For an SD card, touch the “+” sign in front of pccard and select SD_MMCO_1. 
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  USB flash drive        SD card 

4. Click OK to upload the files from the HMI to the USB drive or SD card. When the upload is complete, 
the HMI automatically reboots and resumes operation.  

5. Remove the storage device from the HMI and connect it to a PC. 

6. If Upload project is selected, the compiled project file (*.exob) will be copied to the root directory of 
the USB flash drive or SD card. Using Windows Explorer, copy the file to the Project folder in the 
EZPlus folder (C:\MapleSystems\EZPlus\Project), open EZwarePlus and select the Decompile 
option under the Tools menu. The decompiler will create a new file with a *.emtp extension that can 
be opened in EZwarePlus. 

7. If Upload all project files is selected, a folder named mt8000ie (or emt3000, depending on the 
model) will be created by the HMI on the root directory of the USB flash drive or SD card. Using 
Windows Explorer, open the “001” folder in the mt8000ie or emt3000 folder on the USB flash drive or 
SD card. Add a .exob extension to the mt8000 file or emt3000 file and copy it to the Project folder in 
the EZPlus folder (C:\MapleSystems\EZPlus\Project). Open EZwarePlus and select the Decompile 
option under the Tools menu. The decompiler will create a new file with a *.emtp extension that can 
be opened in EZwarePlus. 

If Upload history files is selected, a folder named history will be created by the HMI on the root 
directory of the USB flash drive or SD card containing all the data log files, event log files, recipes, 
and operation log files from the HMI.  
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Appendix E – Transferring a Project from one HMI to another 
with a USB Drive or SD Card 
A project can uploaded to a USB flash drive or SD card from an HMI5000 series and downloaded to another 
HMI of the same type without requiring the EZware programming software. 

  This feature is not supported in the RMI5010. 

To transfer a project from one HMI to another with a USB drive or SD card: 
1. Insert the USB flash drive in the HMI’s USB port or insert the SD card in the SD card slot. The 

Download/Upload dialog box will appear. 

 

2. Select Upload. In the Upload Settings window, select Upload all project files and enter the Upload 
password (111111 is the default). 
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3. In the Pick a Directory window, select the location where you want the data to be stored.  
For an SD card: Touch the “+” sign in front of pccard, select SD_MMCO_1 and select OK. 

 

For a USB flash drive: Touch the “+” sign in front of usbdisk, select disk_a_1 and select OK. 

 

4. A folder named mt8000ie, mt8000xe, or emt8000 will be created by the HMI on the root (main) 
directory of the USB flash drive or SD card.  

5. Remove the storage device from the HMI and connect it to the second HMI.  

Note: Some models can have the same project downloaded to them. Here is a list of HMI5000 Series 
models programmed with EZwarePlus. Those listed on the same line can share the same project: 

HMI5043L/HMI5043LB 
HMI5070NL 
HMI5070NLv2 
HMI5070L/HMI5070LB/HMI5070R/HMI5100L 
HMI5070DL 
HMI5070P 
HMI5121P/HMI5150P 
HMI5121XL/HMI5150XL 
HMI5097NXL/HMI5097XL 
HMI5097DXL 
RMI5001 
RMI5010 
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6. The Download/Upload window will appear on the screen. 

 

7. Select Download and enter the Download password (111111 is the default). 

 

8. If a USB flash drive is being used to download the project, select the folder under the usbdisk folder 
(disk_a_1) and then click OK. If an SD card is being used, select the folder under the pccard folder 
(SD_MMCO_1).  

  Do not select the mt8000ie/mt8000xe/emt8000 folder, but the folder just above the 
mt8000ie/mt8000xe/emt8000 folder. 
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Appendix F – Accessing the FTP Server in an HMI 
This describes how to log-in to the FTP server on the RMI5000/HMI5000 Series in order to access data files, 
event files, recipe files, and operation log files stored in the internal memory or on an external memory card 
(USB flash drive or SD card). 

1. Determine the IP address of the HMI. You can find the IP address by opening the “System 
Information” window from the System Toolbar on the HMI. 

 

2. Make sure your computer is connected to the same local area network as the HMI. 
Note: If you are connecting the HMI directly to the Ethernet port on your computer, you must use an 
Ethernet crossover cable. If going through an Ethernet switch, you can use a straight-thru or 
crossover cable. 
 

From Windows Explorer: 

3. Enter the following address, using the IP address of the HMI: 
ftp://uploadhis:111111@192.168.1.50 

Note: 111111 is the default “Upload history” password. If the password is different in the HMI, use 
that password instead. 

 

4. Press “Enter” (or the right-arrow button).  
ftp://192.168.1.50 is shown in the address window for Windows XP (The Internet > 192.168.1.50 for 
Windows 7) and the data log, event log, recipe, operation log, pccard, and usbdisk folders appear in 
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the view pane. You can open each folder and copy-and-paste or drag the contents to your 
computer’s hard drive without interrupting the operation of the HMI. 

  

From Internet Explorer: 

5. Enter the following address, using the IP address of the HMI: 
ftp://uploadhis:111111@192.168.1.50 

6. Note: 111111 is the default “Upload history” password. If the password is different in the HMI, use 
that password instead. 

7. Press “Enter.” The data log, event log, recipe, operation log, pccard, and usbdisk folders appear in 
the view pane. 

 
 

8. Click on the folder names (Directory) to access the individual files. Click on a file name to download 
it to your computer. 
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